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The purpose of this document 
This document contains instructions on how to set up and use the enhancements implemented in the 
Aloha® Point-of-Sale (POS) v19.6 enhancement release. In some instances, we combine features 
together to better explain the new enhancements. When applicable, we include a scenario, how to 
configure the feature in the Back-of-House (BOH), how to use the feature in the Front-of-House (FOH), 
and references to other materials to fully implement the feature. This document is not intended to fully 
explain a particular function or other options available or surrounding the function. For your 
convenience, the material for each enhancement begins on a new page, so you can properly remove 
and distribute the material to the necessary recipients. This document does not guarantee the options 
are in the same location, nor that the functionality remains the same due to enhancements 
implemented in future versions of the affected products. 
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Aloha POS Software 

Tracking 
Number

Description

POS v19.6 

ALOHAP-01225 “Reporting loyalty overrides on BOH Audit report” on page 5

ALOHAP-01229 “Excluding empty checks from the calculation when performing punch edits” on 
page 7

ALOHAP-01248 “Preventing zero-priced open items from printing on kitchen chits” on page 8

ALOHAP-01249 “Combining customer voucher with guest check for EMV Moneris” on page 10

ALOHAP-01259 “Preventing multiple quick refunds of same closed check” on page 12

ALOHAP-01304 “Displaying a double zero button on tender screen” on page 14

ALOHAP-01305 “Preventing comp discounts on quick combos” on page 16

ALOHAP-01306 “Enhancing Customer Survey” on page 18

ALOHAP-01307 “Enhancing auto-clock out” on page 20

ALOHAP-01563 “Excluding items sold as non-taxable from discount distribution” on page 23

ALOHAP-03216 “Embedding a website address within a survey QR code” on page 28

ALOHAP-04244
ALOHAP-04246

“Configuring multiple PMS hosts” on page 30

ALOHAP-04799
ALOHAP-14664

“Printing the original check number on a quick refund check” on page 31

ALOHAP-05934 “Using the quantity button to modify like items” on page 33

ALOHAP-06726 “Creating a filter for undesired words in the FOH” on page 36

ALOHAP-07177 “Allowing the same employee to log in to multiple terminals” on page 40

ALOHAP-07731 “Adding more functions to a scripted button” on page 43

ALOHAP-08499 “Supporting fractional guest counts in custom FOH reports” on page 44

ALOHAP-09044
ALOHAP-13611

“Overriding occupational tax by order mode” on page 45

ALOHAP-12274
ALOHAP-14593

“Printing perpetual check counter when dispatching a driver” on page 47

ALOHAP-13132
ALOHAP-13959

“Supporting acknowledgments for declared cash tips from NBO” on page 50
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ALOHAP-16961
ALOHAP-19926

“Supporting three decimal place pricing” on page 53

ALOHAP-18278 “Supporting quick combos for fractional pizzas in Quick Service” on page 54

ALOHAP-19261 “Contributing to multiple tip-share pools” on page 55

ALOHAP-20672
ALOHAP-20674

“Merging split items” on page 63

ALOHAP-20678
ALOHAP-27495
ALOHAP-27830

“Saving different cards to the same tab or table” on page 70

ALOHAP-20686 “Changing percentage-based gratuities to a dollar amount” on page 81

ALOHAP-20692 “Tying a guest check to a party” on page 84

ALOHAP-21991 “Clocking out an employee that left mid-shift” on page 90

ALOHAP-25393 “Supporting group combos for fractional pizzas in Table Service” on page 94

ALOHAP-26161 “Configuring minimum guest count to force automatic gratuity by revenue center” on 
page 95

ALOHAP-27614 “Displaying employees assigned to cash drawers” on page 101

ALOHAP-27618 “Changing the font size of text on Change Due message box” on page 104

ALOHAP-29565 “Supporting Givex 24-digit gift card numbers” on page 107

WIT 094473 “Sending orders from two terminals to one serial display board” on page 108

WIT 177165 “Displaying text on manager approval screen for early break returns” on page 110

WIT 177173 “Using car images to recall orders to active guest check window” on page 111

WIT 178027 “Supporting charitable donations in Quick Service” on page 112

WIT 179700 “Supporting visual indicators for order modes” on page 113

WIT 185817 “Expanding customer survey access methods” on page 119

WIT 190419 “Displaying immediate USB PIN pad error message” on page 120

WIT 190442
WIT 190448
WIT 190453
WIT 193526

“Limiting interface employee access” on page 121

WIT 396085 “Refunding a check to original order mode” on page 122

Tracking 
Number

Description
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WIT 417956 “Migrating item costing to Item Cost function” on page 126

WIT 450214 “Running custom FOH report for multiple employees” on page 127

Electronic Draft Capture (EDC) 

NPSEDCA-58 “Supporting NPP Processor” on page 128

ORDERPOINT! 

“Enhancing ORDERPOINT!” on page 129

Tracking 
Number

Description
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Reporting loyalty overrides on BOH Audit report 

Restaurants using the Loyalty program can set up options to force manager approval. For example, if 
a card is not swiped or must be looked up, a prompt for manager approval appears. You can now 
include manager overrides for Loyalty transactions on the Back-of-House (BOH) Audit report.

To include manager overrides for Loyalty transactions on the BOH Audit report:

1. Select Reports > Aloha Point-of-Sale > Audits.
2. Select the date and click OK. The ‘Select Transactions to Audit’ dialog box appears.

3. Under ‘Other,’ select Loyalty Mgr Override.
4. Click View, Print, or Export to review the report.

Version Tracking Number Products Audience

POS v19.6 ALOHAP-01225
WIT 169757

Aloha Quick Service, Aloha Table Service Configuration Technician
End User

Figure 1  Select Transactions to Audit (TS)
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The entry includes the time, check ID, member name, and the manager who approved the override.

Figure 2  Audit Report Sample
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Excluding empty checks from the calculation when performing punch edits 

In POS v15.1, we introduced a new option called ‘Prevent editing shifts that do not align with sales’ to 
prevent you from editing a shift to a time that is earlier or later than the time stamp on sales 
transactions existing for that employee on that date. Now the system also excludes empty checks from 
the calculation when performing punch edits. For example, an empty check occurs when a bartender 
performs any function on the POS, such as clocking in or logging in to the system. Normally, this is 
not an issue; however, if the employee uses the wrong job code, or clocks in too early, the shift 
cannot be edited due to the empty check opened at the initial log in.  

Version Tracking Number Products Audience

POS v19.6 ALOHAP-01229
WIT 272956

Aloha Quick Service, Aloha Table Service Configuration Technician
End User

Note
You must select ‘Prevent editing shifts that do not align with sales’ under the ‘Clock In/Out’ group 
bar in the Labor group on the Store Settings tab in Maintenance > Business > Store to use this 
feature successfully.
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Preventing zero-priced open items from printing on kitchen chits 

Currently, you can prevent a zero-priced open item from printing on the guest check. You can now 
prevent zero-priced open items from printing on the kitchen chit. 

To define an item as an open item, access Maintenance > Menu > Items and:

● Create an item of the ‘Standard’ type and select ‘Ask for description’ under the ‘Settings’ group 
bar on the Item tab.

● Select the Pricing tab and select Ask for Price as the pricing method and type ‘0.00’ as the 
minimum price under the ‘Pricing options’ group bar.

● Select the Print tab and clear ‘Print on check when price is zero’ under the ‘Check printing’ group 
bar.

To prevent zero-priced open items from printing on kitchen chits:

1. Select Maintenance > Menu > Items.
2. Select the open item from the drop-down list.
3. Select the Print tab. 

Version Tracking Number Products Audience

POS v19.6 ALOHAP-01248 Aloha Quick Service, Aloha Table Service Configuration Technician
End User

Figure 3  Hide Price When Zero
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4. Under the ‘Chit printing’ group bar, select Hide price when zero to prevent zero-priced open 
items from printing on the kitchen chit.

Hide price when zero — Prevents zero-priced open items from printing on the kitchen chit. 
Documented Version: v19.3. Required Options: You must configure the open item in Mainte-
nance > Menu > Items as ‘Ask for description,’ ‘Ask for Price,’ ‘0.00’ as the minimum price, and 
clear ‘Print on check when price is zero’ to use this feature effectively.

5. Repeat this procedure if for any other open menu items. 
6. Click Save and exit the Items function. 
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Combining customer voucher with guest check for EMV Moneris 

Currently, there are two to three artifacts that print with each PIN pad payment for EMV Moneris: 

● One guest check
● One customer voucher (required)
● One merchant voucher

EMV Moneris stipulates very specific requirements for what must appear on guest checks and 
vouchers. One specific requirement states the store information header must appear on the guest 
check and all additional vouchers. This increases paper usage, and, in an effort to help restaurants 
conserve paper, you can now combine the information from the customer voucher and the guest 
check into one document.  

To combine the customer voucher and guest check into one document:

1. Select Maintenance > Business > Store.
2. Select the Store Settings tab.

Version Tracking Number Products Audience

POS v19.6 ALOHAP-01249
WIT 190415

Aloha Quick Service, Aloha Table Service Configuration Technician
End User

Figure 4  Guest Check Example
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3. Select the Credit Card group located at the bottom of the screen. 

4. Under ‘Voucher print settings’ group bar, select Print first voucher with guest check.

Print first voucher with guest check  — Combines the information for the customer voucher 
(first voucher that prints) with the guest check, reducing the amount of paper required for PIN 
pad payments only. Note: This option is for use with EMV Moneris only. Documented Version: 
v19.3.

5. Click Save and exit the Store function. 

Figure 5  Credit Card Group - Voucher Print Settings Group Bar 
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Preventing multiple quick refunds of same closed check 

Currently, you can refund a check using the Quick Refund button and copies the original check to a 
new check in ‘refund’ mode. You can now limit only one quick refund per closed check. Additionally, 
if the guest is a Loyalty member, any accrued or deducted points move from the original check to the 
quick refund check to retain an accurate status of the Loyalty account. 

To use this feature, you must have:

● An employee with the ability to perform a refund. Access Maintenance > Labor > Access Levels 
and select the refund types under the ‘Financial’ group bar.

● Non-cash tenders configured to allow refunds. Access Maintenance > Payments > Tenders and 
select ‘Can refund’ for each non-cash tender you allow to be refunded.

● The Quick Refund button on a FOH panel. Access Maintenance > Screen Designer > Quick 
Service Screen Designer and add the Quick Refund function button.

To prevent more than one quick refund per closed check:

1. Select Maintenance > Business > Store > Store Settings tab.
2. Select the Security group located at the bottom of the screen. 

Version Tracking Number Products Audience

POS v19.6 ALOHAP-01259 Aloha Quick Service Configuration Technician
End User
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3. Under the ‘Restrictions’ group bar, select Limit to one quick refund per closed check. 

Limit to one quick refund per closed check — Prevents employees from refunding a closed 
check multiple times using the Quick Refund function. Documented Version: v19.3. Related 
Requirements: You configure the Quick Refund button in Maintenance > Screen Designer > 
Quick Service Screen Designer.

4. Click Save and exit the Store function. 

Figure 6  Store Settings Tab - Security Group 
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Displaying a double zero button on tender screen 

In countries where rounding is prevalent, an employee must enter additional touches to tender the 
transaction. For example, a check rounds to $16.00. The employee must touch the one, six, and zero 
buttons, as well as another zero button to enter the amount. You can now add a double-zero to the 
check with a single button touch, increasing speed of service. 

To display a double zero button on the Tender screen: 

1. Select Maintenance > Business > Store.
2. Select the Store Settings tab.

Version Tracking Number Products Audience

POS v19.6 ALOHAP-1304 Aloha Quick Service, Aloha Table Service Configuration Technician
End User

Figure 7  Original Keypad (Left); Keypad with Double-Zero Button (Right)
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3. Select the User Interface group located at the bottom of the screen. 

4. Under the ‘Display’ group bar, select Display double zero button on tender screen to add a 
double zero button to the keypad that appears on the Tender screen, allowing you to add two 
zeros to the tender amount using a single button touch. 

Display double zero button on tender screen — Enables a double zero button to appear on 
the keypad that appears on the Tender screen, allowing you to add two zeros to the tender 
amount using a single button touch. Documented Version: v19.3.

5. Click Save and exit the Store function. 

Figure 8  User Interface Group - Display Group Bar
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Preventing comp discounts on quick combos  

Some restaurants discount quick combos to the lowest price possible, and do not want them 
discounted further using comps. You can now select a comp as ineligible for a quick combo. For 
example, a Hamburger quick combo is $7.77, and the restaurant does not want the quick combo 
discounted further by applying a comp.

To preventing comp discounts on quick combos: 

1. Select Maintenance > Payments > Promotions.
2. Select a promotion configured as a quick combo.
3. Select the Restrictions tab. 

4. Under the ‘Comp Restrictions’ group bar, select the comp, such as ‘Mngr Comp’ from ‘Included’ 
and click >> to move it to ‘Excluded.’

5. Repeat step 4 for any additional comps to disallow for the quick combo
6. Click Save.

Version Tracking Number Products Audience

POS v19.3 ALOHAP-01305 Aloha Quick Service Configuration Technician
End User

Figure 9  Promotions - Restrictions Tab
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7. Repeat this procedure for any other quick combo for which you want to exclude comp discounts. 
8. Exit the Promotions function. 

If an employee attempts to add an ineligible comp to the check, an error message appears: 

Figure 10  Error Message - Comp Cannot Be Applied At This Time
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Enhancing Customer Survey  

We enhanced the Customer Survey feature to allow you to define a set of conditions under which a 
guest can earn a reward for a campaign. We also added the ability to establish the survey printing 
frequency for all day parts. 

Defining conditions for printing customer surveys
The Campaign Rulebook feature allows you to define a set of conditions under which a guest can 
earn a reward for a campaign. The reward can be in the form of a printed voucher to be redeemed 
on their next visit to your restaurant, or an immediate reward, such as a free $5.00 gift card with the 
purchase of $50.00 in gift cards. Effective in POS v19.3, we expanded the Campaign Rulebook 
feature to allow you to also define a set of conditions under which a customer survey prints. For 
example, when a guest purchases a minimum of $10.00 from the Food category, the designated 
customer survey prints on their guest check. You can also stipulate that a specific comp or promo 
cannot be applied to the guest check for the customer survey to print.  

Configuring the survey printing frequency for all day parts
For ease of use, you can now configure the frequency for which to print a customer survey for all day 
parts instead of for each individual day part.  

Version Tracking Number Products Audience

POS v19.6
CFC v21.6

ALOHAP-01306
ALOHAP-04085

Aloha Quick Service, Aloha Table Service Configuration Technician
End User

Reference
Refer to the HKS304 Customer Survey Feature Focus Guide for more information.

Reference
Refer to the HKS324 Campaign Rulebook Feature Focus Guide for more information.

Tip
You must upgrade to Aloha Configuration Center or Aloha Manager 21.6 to configure the survey 
printing frequency for all day parts. 

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS304&actp=search&viewlocale=en_US
https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS324&actp=search&viewlocale=en_US
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To configure the survey printing frequency for all day parts:

1. Select Maintenance > Messaging > Survey. 
2. Click New to create a new survey or select an existing survey from the drop-down list. 

3. Under the ‘Day part/frequency setup’ group bar, select Configure All DayParts. 

Configure All DayParts — Allows you to set the same printing frequency for all day parts. Clear 
this option to set the frequency for each individual day part. Documented Version: POS v19.6. 
Related Options: 1) This option enables the ‘Frequency For All DayParts’ option. 2) Selecting 
this option hides ‘Day part 1’ through ‘Day part 4.’ 

4. Type the frequency to apply to all day parts in ‘Frequency For All DayParts.’ 

Frequency For All DayParts — Determines the frequency with which the survey prints for all 
day parts. For example, if you enter 5, the survey prints on every fifth guest check for all day 
parts. Documented Version: POS v19.6. Required Options: You must select ‘Configure All 
DayParts’ to enable this option. 

5. Click Save. 
6. Repeat this procedure for each survey needing to configure the frequency for all day parts. 
7. Exit the Survey function. 

Figure 11  Surveys Function
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Enhancing auto-clock out 

The Aloha POS system offers a feature that automatically clocks out any employee who is still clocked 
in at the time the End-of-Day (EOD) process runs. For example, if an employee checks out at 3:00 
p.m. but forgets to clock out at the end of the shift, the system automatically clocks the employee out 
when the EOD process runs at 11:00 p.m.; however, the system records the clock out time as 3:00 
p.m., same as checkout time for the employee. Using this logic, it is possible to under pay an 
employee who works beyond their checkout time. Effective in POS v19.3, the system provides two 
options for automatically clocking out an employee, using their checkout time (current functionality) 
or using the time at which the EOD runs. In keeping with the above scenario, when using the time at 
which the EOD runs, the system records the automatic clock out as 11:00 p.m.  

To configure auto-clock out to use the time at which EOD runs:

1. Select Maintenance > Business > Store.
2. Select the Store Settings tab. 

Version Tracking Number Products Audience

POS v19.6 ALOHAP-01307 Aloha Quick Service, Aloha Table Service Configuration Technician
End User

Important
Upon upgrade to POS v19.3, if 'Auto clock out at End of Day' is False (not selected), the drop-down 
selection for 'Auto-Clock Out time' is set to 'None.' If Auto clock out at End of Day' is True 
(selected), the drop-down selection for 'Auto-Clock Out time' is set to 'Checkout time,' in keeping 
with current functionality. No action is required on your part unless you want to change the feature 
to use the time at which the End-of-Day runs instead.
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3. Select the Labor group located at the bottom of the screen. 

4. Under the ‘Employee Settings’ group bar, select ‘End of day’ from the ‘Auto-Clock Out time’ 
drop-down list.

Auto-Clock Out time — Enables the system to automatically clock out any employee who forgets 
to clock out at the end of their shift and is still clocked in at the time the EOD occurs, based on 
your selection. You can choose to not use this feature, use the employee checkout time as the 
employee clock out time, or use the time at which the End-of-Day process runs as the employee 
clock out time. If an employee has not run a checkout, the system checks them out, and then 
clocks them out. For non-order entry employees, the system clocks them out at the time of EOD. It 
may be necessary to make pay adjustments no matter which method you choose. Documented 
Version: v19.3. Prior to v19.3, this option was called 'Auto clock out at End of Day.' Related 
Options: If you select 'End of day,' in 'Auto-Clock Out time,' along with '24-hour operation' 

Figure 12  Store - Store Settings - Labor Group 
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under the 'Day/Time' group bar in Maintenance > Business > Store > Store Settings tab > System 
group, the system clocks employees out at the time EOD runs, but does not clock them back in for 
the new business day.

None — Disables the auto-clock out feature. The system discards the shift times for employ-
ees who do not check out before the EOD runs, and the shift does not appear in edit 
punches. Related Options: If you select '24-hour operation,' under the 'Day/Time' group 
bar in Maintenance > Business > Store > Store Settings tab > System group, the system 
clocks employees out at the time EOD runs and then clocks them back in for the new business 
day.

Checkout time — Uses the employee checkout time as the employee clock out time. For 
example, if an employee checks out at 3:00 p.m. and the EOD process runs at 11:00 p.m., 
the system records the clock out time as 3:00 p.m., same as the checkout time for the 
employee. This may result in under-paying an employee and a pay adjustment may be 
required. 

End of day — Uses the time at which the EOD process runs as the employee clock out time. 
For example, if an employee checks out at 3:00 p.m. and the EOD process runs at 11:00 
p.m., the system records the clock out time as 11:00 p.m., the time at which the EOD process 
runs. This may result in over-paying an employee and a pay adjustment may be required. 

5. Click Save and exit the Store function.
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Excluding items sold as non-taxable from discount distribution 

A Goods and Services Tax (GST) is a percentage tax on the sale of goods and services; however, you 
can exempt certain items from the GST tax, as allowed. For example, when a guest who is dining in 
your restaurant purchases a bottled water as part of a quick combo, it is necessary to charge a GST 
tax on the bottled water. If, however, that same guest purchases the bottled water as part of a quick 
combo for carry-out, the bottled water is GST-exempt. 

It is common practice to group items together as one item, such as a quick combo, and charge a 
lower price for the grouped item than the sum total of each ala carte item included in the combo. 
When all items in the quick combo are subject to the GST tax, calculating and distributing the 
discount to the items on the check is straightforward, but when one of the items in the quick combo is 
exempt from the GST tax, the desire is for the system to exclude the price of the GST-exempt item 
when calculating and distributing the discount. You can now exclude GST-exempt items from the 
quick combo discount distribution. 

SCENARIO: You offer a quick combo and it contains a hamburger, French fries, and bottled water
as a drink choice. When you sell the quick combo for dine-in, the bottled water is subject to GST tax
and is included in the quick combo discount distribution; however, when you sell the quick combo
for carryout, the bottled water is exempt from GST tax and excluded from the discount distribution.
The following table shows the discount distribution for the quick combo when it is included in the dis-
count distribution vs. when it is not included.  

Version Tracking Number Products Audience

POS v19.6 ALOHAP-01563
WIT 418670

Aloha Quick Service Configuration Technician
End User

Figure 13  Scenario Table
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Configuring items sold as non-taxable from discount distribution
To exclude GST-exempt items from the quick combo discount distribution, you must:

● Configure the GST tax, if not already configured. (This document assumes your GST tax is already 
configured. How to configure a GST tax is outside the scope of this document.)

● Create a category of the General type and ensure you include all items that are taxable when you 
apply the order to a non-taxable order mode. 

● Designate the order modes from which you can sell items as non-taxable. 
● Configure each quick combo to exclude GST-exempt items from the discount distribution. 

To create a category of items that are taxable when you apply the order to a non-taxable 
order mode: 

1. Select Maintenance > Menu > Categories.
2. Click the ‘New’ drop-down list, select General, and click OK. 
3. Under the ‘Settings’ group bar, type a name, such as ‘Taxable Items,’ to identify the general 

category.
4. Select the Items tab. 
5. Select all items that are taxable when you apply an order to an order mode designated as 

non-taxable from the ‘Available’ list box and click >> to move the items to the ‘Included’ list box. 
6. Click Save and exit the Categories function.
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To designate an order mode as not subject to tax:

1. Select Maintenance > System Settings > Order Mode.
2. Select an order mode from which you can sell items as non-taxable. 

3. Under the ‘Tax selections’ group bar, select Non-taxable except and then select the category 
containing the items subject to tax from the ‘Category’ drop-down list. 

4. Click Save.
5. Repeat this procedure for each order mode from which you sell items as non-taxable.
6. Exit the Order Mode function. 

Excluding non-taxable items from discount distribution
You must configure each quick combo that offers an item that can be sold as non-taxable to exclude 
the item from the discount distribution when the right conditions are met. For example, you want to 
evenly distribute the discount across all items in the quick combo when they are all subject to the GST 
tax, but exclude the item from the discount distribution when you sell it tax-free. 

Figure 14  Order Mode - Order Mode Tab
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To exclude quick combo items sold as non-taxable from discount distribution: 

1. Select Maintenance > Payments > Promotions.
2. Select a quick combo from the drop-down list. 

3. Under the ‘Settings’ group bar, select If non-taxable exclude from discount to exclude the item 
from the discounted price calculations of a quick combo.

If non-taxable exclude from discount — Excludes the price of any item in the quick combo 
sold as non-taxable, when calculating the quick combo discount distribution for reporting pur-
poses. Documented Version: v19.3. Related Options: Selecting this option exposes ‘Apply 
indicator for tax free item.’ Related Requirements: Access Maintenance > System Settings > 
Order Mode and select ‘Non-taxable except’ under the ‘Tax selections’ group bar to designate an 
order mode as non-taxable. Selecting this option exposes ‘Category,’ which allows you to desig-
nate the category containing items that are taxable when an order is applied to the order mode. 

4. Select Apply indicator for tax free item to indicate the tax-free item using an asterisk on the 
guest check.

Apply indicator for tax free item — Includes an asterisk on the guest check next to any item in 
the quick combo sold as non-taxable. Documented Version: v19.3. Related Options: You must 
select ‘If non-taxable exclude from discount’ to enable this option. 

5. Click Save.

Figure 15  Payments - Promotions
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6. Repeat this procedure for each quick combo promotion for which you need to exclude 
GST-exempt items from the discount distribution.

7. Exit the Promotions function.  

Figure 16  Guest Check Example
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Embedding a website address within a survey QR code 

The Customer Survey feature provides restaurants the ability to prompt randomly selected guests for 
feedback about their dining experience in exchange for a reward or discount. The prompt prints on 
the guest check along with a phone number for guests to call and enter a unique code to access the 
survey. You can choose between text, bar code, or QR code. With these methods, guests use a smart 
phone or tablet to scan a bar code or QR code that prints on the guest check to access the survey on 
your website or app. You can now embed a website address within a QR code that prints on a survey. 
The query string includes the website address, the store ID, visit date, visit time, check ID/transaction 
number (up to 10 digits in length), and order mode. 

To embed a website address within a survey QR code: 

1. Select Maintenance > Messaging > Survey.
2. Select an existing survey for which to embed a website address in the QR code. 

Version Tracking Number Products Audience

POS v19.6 ALOHAP-03216 Aloha Quick Service, Aloha Table Service Configuration Technician
End User

Figure 17  Messaging - Survey 
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3. Under the ‘Settings’ group bar, verify QR code is selected from the ‘Code print type’ drop-down 
list.

4. Type the website address to embed in the survey QR code in ‘URL for survey.’

URL for survey — Designates the website address to embed within the QR Code that prints on 
the survey. Documented Version: v19.3.

5. Click Save and exit the Survey function.  

Reference
Refer to the Customer Survey Feature Focus Guide for more information.

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS304&actp=search&viewlocale=en_US
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Configuring multiple PMS hosts 

You can now integrate with up to ten Property Management Systems and allow the restaurant to post 
room charges to different hotels owned by the same parent company. 

SCENARIO: A guest is staying at Hotel A and meets a friend for dinner in the hotel restaurant. The
friend is staying at a sister hotel, Hotel B. Because the restaurant can post room charges to two differ-
ent hotels owned by the same parent company (two separate PMS hosts) both the guest and the friend
can charge their meal to their respective hotel rooms.

Configure up to ten PMS hosts in Maintenance > Electronic Draft Capture > PMS Parameters and 
make note of the record number. You will type the record number in ‘PMS tender ID’ under the 
‘Property management settings’ group bar on the ‘Type’ tab in Maintenance > Payments > Tenders.  

Version Tracking Number Products Audience

POS v19.6 ALOHAP-04244
ALOHAP-04246

Aloha Quick Service, Aloha Table Service, Aloha 
EDC

Configuration Technician
End User

Figure 18  Multiple PMS Hosts Example 

Reference
Refer to the PMS Integration Guide for more information regarding Property Management Systems.
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Printing the original check number on a quick refund check 

Currently, when a quick refund check prints, the original check number is not referenced. You can 
now link a quick refund check to a closed check (using GndAudit.dbf), and print the original check 
number on the quick refund check. If you customize your guest check layout, use Print Designer to 
define where to place the original check number on the quick refund check. 

To enable the printing of the original check number on a quick refund check:

1. Select Maintenance > Business > Store.
2. Select the Store Settings tab.
3. Select the Check Printing group located at the bottom of the screen. 

4. Under the ‘Guest Check Content’ group bar, select Print original check number on quick 
refund check.

Version Tracking Number Products Audience

POS v19.6 ALOHAP-04799
ALOHAP-14664

Aloha Quick Service Configuration Technician
End User

Figure 19  Store - Store Settings - Check Printing Group
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Print original check number on quick refund check — When performing a refund using the 
Quick Refund button, the original check number appears as a reference on the refund check. 
Documented Version: v19.3. 

5. Click Save and exit the Store function.

To define where to place the original check number on a custom guest check: 

1. Select Maintenance > Hardware > Print Designer.
2. Select the custom guest check design, such as ‘Guest check,’ from the drop-down list. 
3. Select the Design tab. 

4. Under the ‘Design’ group bar, click the Add drop-down arrow, select Quick refund original 
check number, and click OK. The new element appears at the bottom of the ‘Design’ group bar.

5. Click Move Up to place the original check number in the desired location.
6. Under the ‘Print’ style settings group bar, configure the remaining options. 
7. Click Save and exit the Print Designer function.

Figure 20  Print Designer - Design Tab
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Using the quantity button to modify like items 

When you sell multiples of a single like item on a guest check, you need to easily add the same 
modifier to more than one of the like items. For example, a guest orders twelve sliders, but wants a 
pickle added to only four of them. Prior to this enhancement, you had to select and add the Pickle 
modifier to each of the four like items one at a time. Now you can easily add a pickle to four of the 
sliders using the Quantity button. If Pickle is a priced modifier, the guest check updates to reflect the 
additional charge for the priced modifier multiplied by the number of like items selected for 
modification. 

To enable using the Quantity button to modify like items:

1. Select Maintenance > Business > Store.
2. Select the Store Settings tab.
3. Select the User Interface group located at the bottom of the screen. 

4. Under the ‘Functionality’ group bar, select Enable group modifier changes.

Version Tracking Number Products Audience

POS v19.6 ALOHAP-05934 Aloha Quick Service Configuration Technician
End User

Figure 21  Store Settings Tab - User Interface Group 



 Aloha Solution v19.6, Enhancement Release Guide
Aloha POS Software

34

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Enable grouped modifier changes — Allows you to use the Quantity button to easily add the 
same modifier to more than one like item on a guest check, if the like items appear consolidated 
in the guest check window. If the modifier you select is a priced modifier, the guest check 
updates to reflect the additional charge for the priced modifier multiplied by the number of like 
items selected for modification. For example, a guest orders 12 sliders, but wants pickles added 
to only four of them. Pickles, when added as a priced modifier, is $0.25 so the system adds 
$1.00 to the guest check. Documented Version: v19.3. Related Options: You must use the 
consolidated feature in the guest check window.

5. Click Save and exit the Store function.

SCENARIO: A guest orders 12 sliders and want pickles added to only four of the sliders. A group
combo called ‘Sliders by the Dozen’ is used to add the 12 sliders to the check. If the items are not
consolidated in the guest check window, touch the Consolidate button.

To use the Quantity button to easily add the same modifier to more than one like item on a 
guest check: 

1. Log in to the FOH.
2. Add the item to the guest check window. In this example, we added Sliders by the Dozen. 
3. If the items are not consolidated, touch the consolidation toggle button in the top right corner. 

4. Touch the quantity button that coincides with the number of items to modify, in this case, 4.

Note
To use this feature successfully, like items must appear consolidated in the guest check window.
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5. Touch the modifier item, such as Pickle. The modifier appears indented under the menu item in 
the guest check. 

6. Tender and close the check. 

Figure 22  Quick Service Consolidation Toggle Button
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Creating a filter for undesired words in the FOH

There are multiple locations when working in the Front-of-House (FOH) where employees can enter 
free-form text that is guest facing, such as tab names, check names, open modifiers, open items, 
special instructions, and more. Now you can set up a filter for preventing the entry of undesired 
words, such as profanity, in these locations. If an employee enters one of these words on the FOH, 
the system displays a message letting the employee know the entry is not allowed and to please 
re-enter the information. 

Version Tracking Number Products Audience

POS v19.6 ALOHAP-06726 
ALOHAP-07565

Aloha Quick Service, Aloha Table Service Configuration Technician
End User

Figure 23  Profanity Entered on the FOH
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As with any new function, you must configure a BOH security role to allow any employee assigned to 
that security role to view and edit the Filter Text function. 

To provide the ability to view and edit the Filter Text function: 

1. Select Maintenance > Labor > Security Roles.
2. Select a security role assigned to an employee requiring the ability to access the Filter Text 

function. 
3. Select the POS tab. 
4. Under the ‘Maintenance > System’ group bar, select View for Filter Text to allow an employee 

assigned this security role to view the Filter Text function.
5. Select Edit to allow an employee assigned to this security role to edit undesired words.
6. Select Add to allow an employee assigned to this security role to add additional undesired 

words. 
7. Click Save.

Figure 24  Entry Not Allowed - Please Reenter 
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8. Repeat this procedure for each security role requiring the ability to access the Filter Text 
function. 

9. Exit the Security Roles function.

To add undesired words to Filter Text: 

1. Select Maintenance > System Settings > Filter Text.
2. Click New. 

3. Under the ‘Settings’ group bar, accept the default name, ‘Filter text,’ or name the file to 
something of your choosing.

4. Accept the default of ‘2’ in ‘Number of spaces to filter,’ or type a number to eliminate the ability 
to use the same letters of an inappropriate or profane word using spaces. For example, ‘D U M 
....’

Number of spaces to filter — Eliminates the ability to use the same letters of an inappropriate 
or profane word using spaces. For example, ‘D U M ...’ The default is ‘2.’ Documented Version: 
v19.3.

5. Under the ‘Filtered words’ group bar, click Add.

Figure 25  System Settings - Filter Text 
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6. Type an undesired word of your choosing.
7. Repeat this procedure until you add all undesired words.
8. Click Save and exit the Filter Text function. 



 Aloha Solution v19.6, Enhancement Release Guide
Aloha POS Software

40

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Allowing the same employee to log in to multiple terminals  

You can allow an employee working the drive-thru window to log in to multiple terminals 
simultaneously during a shift, one for taking orders, the other for accepting payments.  

SCENARIO: Marcus works the drive-thru at the Aloha Café. He signs in to the two available termi-
nals; one to create checks and the other to accept payments. A guest pulls up and places an order,
which Marcus enters on terminal 1. He continues to enter items, and then sends the order to the
kitchen. Check 1 then moves to terminal 2. Note: Once a check moves to the terminal configured to
tender, it cannot be modified. Another guest pulls up to the drive-thru speaker and places an order.
Marcus enters the order and the first driver appears at the drive-thru window. Marcus tenders check 1
on terminal 2. He returns to terminal 1 and continues to enter items. He sends the order to the
kitchen, and check 2 moves to terminal 2. Marcus tenders check 2 on terminal 2. At the end of his
shift, he logs out of both terminal 1 and terminal 2.

To allow the same employee to log in to multiple terminals:

1. Select Maintenance > Labor > Jobcodes.
2. Select the job code from the drop-down list
3. Select Order Entry tab.

Version Tracking Number Products Audience

POS v19.3 ALOHAP-07177 Aloha Quick Service Configuration Technician
End User

Caution
Exercise extreme caution. The employee is responsible for the sales and payments of both terminals, 
and, consequently, responsible for whoever touches the terminals.
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4. Under the ‘Order entry’ group bar, select Allow multi-terminal login to allow employees 
clocked in under this job code to log in to and use multiple terminals simultaneously. 

Allow multi-terminal login  — Allows employees clocked under this job code to log in to and 
use multiple terminals simultaneously during a shift. For example, select this option for an 
employee who needs to take orders on one terminal and accept payments on another terminal. 
Documented Version: v19.3.

5. Click Save.
6. Repeat this procedure for each job code requiring the ability to log in to multiple terminals 

simultaneously. 
7. Exit the Jobcodes function. 

Figure 26  Order Entry Tab - Order Entry Group Bar 
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To create a non-tendering terminal:

1. Select Maintenance > Hardware > Terminal.
2. Select the desired terminal from the drop-down list. 

3. Under the ‘Settings’ group bar, select Order entry non-tendering terminal to restrict activity on 
this terminal to performing order entry and apply promotions and comps from the ‘Model’ 
drop-down list. You cannot tender or close a check from this terminal. Use this type of terminal in 
a double-window drive-thru environment for a terminal that does not have an assigned cash 
drawer. Related Options: Selecting this option enables ‘Auto login employee’ for which you can 
assign a generic employee for employees to use as a single login ID number. 

4. Click Save and exit the Terminals function.

Figure 27  Order Entry Non-Tendering Terminal 
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Adding more functions to a scripted button 

When you create a button, you have the option to script the button to perform a series of actions; 
combining multiple button functions in one button selection. Depending upon the series of scripts 
that you select, the actions may exceed the current 255 character allowance. You can now add more 
functions to your script, up to 512 characters. In BTN.dbf file, there are two columns available; the 
existing PARAMS, and a new column, PARAMS2. No configuration is necessary. 

Version Tracking Number Products Audience

POS v19.6 ALOHAP-07731 Aloha Quick Service Configuration Technician
End User

Figure 28  BTN.dbf
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Supporting fractional guest counts in custom FOH reports  

When you determine your guest count based on the number of items ordered from a specific 
category, such as entrées, the system takes the weight you define for your items in the specified 
category into consideration. For example, if you give an item in the guest count category a weight of 
‘2,’ the guest count increases by two each time a guest orders the item. Previously, the system 
accepted whole numbers only; however, in POS v6.2, you can define the weight of an item using a 
fractional value, such as 0.25. 

Now, any custom FOH report configured to use the #Guest variable to report guest count weight will 
also show fractional guest count weights for menu items. To define items with a guest count weight, 
access Maintenance > Menu > Items > General Settings tab, and type a whole or fractional number in 
‘Guest count weight’ under the ‘General’ group bar.  

Version Tracking Number Products Audience

POS v19.6 ALOHAP-08499 Aloha Quick Service, Aloha Table Service Configuration Technician
End User

Reference
Refer to the HKS320 Custom FOH Report Feature Focus Guide for more information.

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS320&actp=search&viewlocale=en_US
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Overriding occupational tax by order mode 

In POS v14.1, we introduced support for an occupational tax type which is a privilege or license tax 
applied to designated types of businesses, such as hotels, restaurants, and bars. The tax is levied 
prior to calculating surcharges, primary, and secondary taxes. The system then calculates any state 
and local taxes using the new subtotal.

Now you can override the occupational tax by order mode. For example, you levy the tax on guests 
who dine inside the restaurant, but not guests who use the drive-thru. Additionally, the system allows 
you to focus on a category of items for which to override the tax.

To override an occupational tax by order mode:

1. Select Maintenance > System Settings > Order Mode. 

2. Under the ‘Tax selections’ group bar, select the occupational tax to override from the ‘Override 
occupational Tax Type’ drop-down list. 

Version Tracking Number Products Audience

POS v19.6 ALOHAP-09044
ALOHAP-13611

Aloha Quick Service, Aloha Table Service Configuration Technician
End User

Figure 29  Order Mode - Order Mode Tab
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Override occupational Tax Type — Enables you to override an occupational tax based on the 
order mode you apply to the guest check. Documented Version: v19.3. Related Options: 
Selecting this option enables ‘Occupational Tax Type Category.’

3. Select a category from the ‘Occupational Tax Type Category’ drop-down list, if you want to 
override the occupational tax only for items ordered from a specific category when you apply the 
order mode. 

Occupational Tax Type Category — Enables you to select a category for which to override the 
occupational tax for items ordered from a specific category when you apply the order mode. 
(Optional) Documented Version: v19.3. Required Options: You must select ‘Override occupa-
tional Tax Type’ to expose this option.

4. Click Save.
5. Repeat this procedure for any other order modes for which to override the occupational tax.
6. Exit the Order Mode function.
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Printing perpetual check counter when dispatching a driver 

In some countries, the government requires a unique fiscal invoice identification number for every 
check, known as a ‘perpetual check counter.’ In POS v12.3, you can print the perpetual check 
counter upon assigning a driver with the ‘Generate check counter when driver is assigned for 
delivery’ option. You could still modify the check before closing the check, resulting in mismatched 
totals between the guest check and the perpetual check counter. 

Now you can print the perpetual check counter when you dispatch a driver. To reflect this new 
functionality, we renamed the option to ‘Generate check counter when an action is assigned for 
driver.’   

To print the perpetual counter when dispatching the driver:

1. Select Maintenance > Business > Store.
2. Select the Store Settings tab.

Version Tracking Number Products Audience

POS v15.1.30
POS v19.6

ALOHAP-12274
ALOHAP-14593
ALOHAP-14983

Aloha Quick Service, Aloha Table Service, Aloha 
Takeout (ATO) 

Configuration Technician
End User

Note
Previously, when there is a terminal hardware failure and the system requires a replacement, the 
perpetual counter reset itself to zero (0). Resetting to zero affects the perpetual counter and causes 
duplicated fiscal invoice identification numbers. The system recreates Counter.bin and eliminates 
duplication.

Important
The ‘Generate check counter when driver is assigned for delivery’ option located in Maintenance > 
Business > Store > Store Settings tab > Check Printing group > ‘Guest Check Content > Check 
Counter’ group bar is now called ‘Generate check counter when an action is assigned for driver,’ 
which offers three choices, ‘Default,’ ‘On assign driver,’ and ‘On dispatch driver.’ Upon upgrade, 
‘On assign driver’ is automatically selected for you.
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3. Select the Check Printing group located at the bottom of the screen. 

4. Under the ‘Guest Check Content > Check Counter’ group bar, select On dispatch driver from 
the ‘Generate check counter when an action is assigned for driver’ drop-down list. 

Generate check counter when an action is assigned for driver — Generates the perpetual 
check counter to print on the guest check at the moment you either close the check, assign the 
check to a delivery driver, or dispatch the delivery driver. Documented Version: Effective in 
v19.6, we renamed this option from ‘Generate check counter when driver is assigned for delivery 

Figure 30  Check Printing Group 
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to ‘Generate check counter when an action is assigned for driver,’ and provide the available 
choices in a drop-down list. Required Options: You must select ‘Print check counter’ to expose 
this option. 

Default — Assigns and prints the perpetual check counter at the moment you close the check. 

On assign driver — Assigns and prints the perpetual check counter at the moment you assign 
the driver. If you select this option, and a guest changes their order before you dispatch the 
driver, the amount reported for the perpetual check ID will be different than the actual check 
amount.

On dispatch driver — Assigns and prints the perpetual check counter at the moment you dis-
patch the driver. A guest can no longer change their order after you dispatch the driver; 
therefore, the amount reported for the perpetual check ID and the actual check amount are 
the same.

5. Select Do not count reprints before check counter is assigned to check to exclude reprints 
from the check counter when they occur prior to the assignment of the order to a delivery driver. 

6. Click Save and exit the Store function. 
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Supporting acknowledgments for declared cash tips from NBO  

When a manager, or an employee with similar access, uses Back Office (NBO) to make a change to 
time clock punches, pay rates, tip-share amounts, or tip credits, an acknowledgment appears on the 
Aloha POS Front-of-House (FOH) for the employee to agree or decline. The employee reads the 
information and either approves or declines the edit. Should the employee decline the edit, they must 
wait for manager approval before proceeding. We enhanced this functionality to also prompt for 
acknowledgment when a manager uses NBO to adjust declared cash tips.  

Version Tracking Number Products Audience

POS v19.6 ALOHAP-13132
ALOHAP-13959

Aloha Table Service Configuration Technician
End User

Important
The ‘Enable prompt for punch adjustment acknowledgment at clock in’ option located in 
Maintenance > Labor > Jobcodes > Jobcode Tab > Time and Attendance group bar is now called 
‘Enable prompt for punch and tip adjustment acknowledgment at clock in.

Reference
Refer to Punch Edits from NBO to Aloha POS Feature Focus Guide for more information.
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To enable the prompt for punch and tip acknowledgments to appear:

1. Select Maintenance > Labor > Jobcodes.
2. Select a job code from the drop-down list. 

3. Under the ‘Time and Attendance’ group bar, select Enable prompt for punch and tip 
adjustment acknowledgement at clock in.

Enable prompt for punch and tip adjustment acknowledgement at clock in — Enables an 
acknowledgment prompt to appear when an employee for whom you adjust a punch, declared 
cash tip, tip credit, or tip-share amount clocks in under this job code. Documented Version: 
v19.3. Related Options: This option enables ‘Requires manager approval to clock in if acknowl-
edgement is declined.’ 

4. Select Require manager approval to clock in if acknowledgement is declined to prompts 
for manager approval when an employee clocked in under this job code does not approve an 
adjustment to a punch, declared cash tip, tip credit, or tip-share amount. If approval is not given, 
the employee cannot clock in. 

Figure 31  Enable Prompt for Punch and Tip Adjustment Acknowledgement at Clock In
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Require manager approval to clock in if acknowledgement is declined — Prompts for 
manager approval when an employee clocked in under this job code f does not approve an 
adjustment to a punch, declared cash tip, tip credit, or tip-share amount. If approval is not given, 
the employee cannot clock in. Documented Version: v19.3. Required Options: You must select 
‘Enable prompt for punch adjustment acknowledgment at clock in’ or ‘Enable prompt for sales 
and tip distribution adjustment at clock in’ to enable this option.

5. Click Save.
6. Repeat this procedure for each job code for which you want to enable the prompt on the FOH.
7. Exit the Jobcodes function. 
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Supporting three decimal place pricing 

Some restaurants located in other countries support three decimal place pricing, such as ‘1.855.’ 
Now the system expands existing fields to support three decimal place pricing for promotions, item 
pricing, taxes, and more; allowing for more precise reporting. 

Version Tracking Number Products Audience

POS v19.3.6 ALOHAP-16961
ALOHAP-19926

Aloha Quick Service, Aloha Table Service Configuration Technician
End User

Tip
To expand fields to support three decimal place pricing, you must select ‘Use special currency’ and 
set ‘Number of digits’ to three on the ‘Regional Settings’ group bar in Maintenance > Business > 
Installed Products > Global tab, if using Aloha Manager. Select Maintenance > Business > Global 
Administration, if you are using Aloha Configuration.
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Supporting quick combos for fractional pizzas in Quick Service 

You can now apply a quick combo that includes a fractional pizza. For example, you offer a fractional 
pizza, a side item, and a drink for $20.00. Your guest wants one half Supreme pizza and one half 
Veggie Lovers pizza; a garden salad, and a soda. The system applies the correct price of the quick 
combo to the fractional pizzas. 

Version Tracking Number Products Audience

POS v19.6 ALOHAP-18278 Aloha Quick Service Configuration Technician
End User

Reference
Refer to the HKS1507 Quick Combo Feature Focus Guide and the HKS1673 Advanced Pizza for QS 
Feature Focus Guide for more information. 

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS1507&actp=search&viewlocale=en_US
https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS1673&actp=search&viewlocale=en_US
https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS1673&actp=search&viewlocale=en_US
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Contributing to multiple tip-share pools  

Some restaurants want the ability to contribute and distribute to multiple tip-share pools. Additionally, 
some restaurants want the ability to exclude categories from the tip-share pool. For example, a server 
has a table that has a $10.00 food sale and a $10.00 beer sale. These restaurants want to remove the 
$10.00 in food sales and to calculate only on the $10.00 beer sale for the bartender job code. Now 
you can contribute and distribute to multiple tip-share pools and include categories from the tip-share 
pools, and contribute a percentage by category. 

Enabling Tip Pool Category
You must enable the tip pool category feature so you can see and use all tip-share pool by category 
options in the user interface.

To enable tip pool category:

1. Select Maintenance > Business > Store.
2. Select the Store Settings tab.

Version Tracking Number Products Audience

POS v19.6 ALOHAP-19261 Aloha Table Service Configuration Technician
End User

Reference
Refer to the HKS384 Tipshare Distribution Feature Focus Guide for more information.

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS384&actp=search&viewlocale=en_US
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3. Select the Labor group located at the bottom of the screen. 

4. Under the ‘Employee settings - Tip share’ group bar, select Enable tipshare pool category 
contributions.

5. Click Save and exit the Store function. 

Including a category in a tip-share pool
In the existing Tip-share Pools feature, we have added a new ‘Categories’ tab. From there, you can 
select a category and define the tip pool percent to contribute.

To include a category in a tip-share pool:

1. Select Maintenance > Labor > Tip-share Pools.
2. Select a tip-share pool from the drop-down list. 
3. Select the Categories tab. 
4. Select the category from the ‘Available’ list and click >> to move the category to the ‘Included’ 

list.
5. Type the share of pool percent to contribute.

Figure 32  Enabling Tip-Share Pool Category Contributions 
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6. Repeat Steps 4 through 5 until the desired categories appear in the ‘Included’ list.
7. Click Save.
8. Repeat this procedure for each tip-share pool you want to define the tip pool percent to 

contribute.
9. Exit the Tip-share Pools function. 

Activating tip-share pool for category event
Use your existing Event Schedule to define a tip-share pool category. We have modified the ‘Set 
Tip-Share Pool’ event to support this new feature. Define the day part, job group, and tip-share pool 
IDs for one or more events.

To activate a new tip-share pool category during a specific day part using an existing event 
schedule:

1. Select Maintenance > System Settings > Event Schedule.
2. Select the event schedule from the drop-down list.
3. Select the Events tab. 

4. Click the Add drop-down arrow, select Set Tip Share Pool for Category from the Type list box, 
and click OK.

5. Under the ‘Events’ group bar, select the activation schedule that begins at the desired start time 
from the drop-down list. For example, ‘Always.’

6. Under the ‘Set Tip Share Pool Category’ group bar, select the job group to specify which job 
group contributes to the tip share when this event is active.

Figure 33  Set Tip Share Pool for Category 
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7. Select the day part for which you want to activate the new tip-share percentage. For example, 
‘Lunch.’ To run a tip-share event the entire day, select ‘All’ as the day part.

8. Select the tip-share pool ID containing the employees to receive the new tip share percentage.
9. Click Save.
10. Repeat this procedure for any other tip-share pool categories you want to configure.
11. Exit the Event Schedule function. 

Using tip-share pools
When a contributor clocks out, you can view the total contribution amount that represents 
contribution to multiple tip-share pools. 

To contribute a tip-share amount:

1. When you are ready to check out of the system, touch Checkout from the Working with Tables 
screen, or a floor plan in use. The ‘Are you ready to run your checkout?’ screen appears. 

2. Touch Yes. The Enter Tipshare Amount screen appears with the system calculated tip-share value. 

3. Touch OK to accept the default tip-share amount.

Figure 34   Enter Tipshare Amount Screen 
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4. Continue your clock out process. 

5. Enter your declared cash tips.
6. Continue your check out in the usual manner.

Distributing tipshare on the BOH
1. Navigate to CFC.
2. Select Functions > Tip-share Distribution. 

Figure 35  Enter Declared Cash Tips Screen 
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3. Select Today and click OK.   

4. Select all employees. There is a Tipshare Pool ID column at the end. 
5. Click Next. 

6. Click Distribute.
7. Click Exit.   

Figure 36  Employees Contributing to the Tipshare Pool

Figure 37  Tipshare Distribution - Confirmation Screen 
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Reporting tip-share pools by category 
The POS system provides the following reports in which to report tip-share pool groups:

1. Select Reports > Aloha Point-of-sale > Employee > Tip-share-Distribution.
2. Verify the following reports:      

Figure 38  Tipshare Distribution Detail

Figure 39  Tipshare Distribution Summary

Figure 40  Employee Daily Sales and Tip Distribution Report
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Figure 41  Employee Tip Report
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Merging split items  

Some restaurants want the ability to recombine the items that were split. For example, a party of three 
arrives celebrating a birthday party. The first guest orders Chicken Noodle soup, steak, gelato, and 
French Silk pie; the second guest order Potato soup, steak, and gelato; and the third guest orders 
Tortilla soup, steak, and gelato. The party decides to split the French Silk pie evenly amongst them; 
however, halfway through the meal, the guests decide to cover the cost of the third person.

You can now combine the split items and then redistribute as many times as necessary. The ‘Split 
Items’ and ‘Merge Split Items’ buttons appear in the upper right corner of the Split Checks screen. 
You can view the ‘Merge Split Items’ button if the split items are highlighted.  

Splitting the cost of an item between checks
Use the Split Item functionality to equally distribute the cost of an item to the appropriate guests. You 
must have the necessary separate checks available to receive the equal distributions. The distributed 
items appear in fractions based on the quantity number by which to divide the cost of an item.

SCENARIO: A party of three decide to split the cost of a French Silk Pie dessert. 

1. Log in to the FOH.
2. From the Working with Tables screen, touch the table in the Open Tables column. The Order 

Entry screen appears with the check in the guest check window.   

Version Tracking Number Products Audience

POS v19.6 ALOHAP-20672
ALOHAP-20674

Aloha Table Service Configuration Technician
End User

Note
You can continue to split and merge items on the guest check as long as the check containing the 
split is not fully tendered.
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3. Touch Split. The Split Checks screen appears with the separated checks. French Silk Pie is sitting 
on Check 1. 

4. Touch the item to split, such as French Silk Pie.
5. Touch Split Items. The Enter Quantity screen appears.   

Figure 42  Split Checks Screen 

Figure 43  Enter Quantity Screen 
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6. Enter the number by which to divide the cost of the item, such as 3, and touch OK. The item 
appears as fractions in the first guest check window based on the number you enter. 

7. Touch one of the split items in Check 1.
8. Touch inside the check window to receive the item.
9. Repeat step 7 and 8 until the items appear in the appropriate guest check.

Figure 44  Distributing the French Silk Pie 
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10. Touch OK. 

11. Touch another French Silk Pie and move it to check 3. The French Silk Pies are split equally 
between the checks.

12. Touch OK to return to the main screen.
13. Tender and close the checks in the usual manner.

Merging previously split items
Using the Splitting Items between Checks scenario, two of the guests decide to buy the third guest’s 
portion of the pie.

To merge previously split items:

1. Log in to the FOH.
2. From the Working with Tables screen, touch the table in the Open Tables column. The Order 

Entry screen appears with the check in the guest check window.
3. Touch Split. The Split Checks screen appears with the separated checks. French Silk Pie appears 

on all three checks. 

Figure 45  French Silk Pies Evenly Distributed 
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4. Touch the item to merge in Check 1, such as French Silk Pie.   

5. Touch Merge Split Items. 

The French Silk Pie appears on Check 1.

Figure 46  Merge Split Items Button 

Figure 47  Moved to Check 1
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6. Touch French Silk Pie on Check 1. 

7. Touch Split Items. The Enter Quantity screen appears.
8. Enter the number by which to divide the cost of the item, such as 2, and touch OK. The item 

appears as fractions in the first guest check window based on the number you enter.  

Figure 48  Enter Quantity Screen 

Figure 49  Split Checks Screen 
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9. Touch one of the split items in Check 1.
10. Touch inside the check window to receive the item.
11. Repeat steps 9 and 10 until the items appear in the appropriate guest check. 

12. Touch OK to return to the main screen.
13. Tender and close the checks in the usual manner. 

Figure 50  French Silk Pie Split Between Two Checks
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Saving different cards to the same tab or table 

In Aloha Table Service, you can configure the Saved Card functionality to enable a bartender or a 
server to slide a payment card across a magnetic stripe reader (MSR) to name a new tab or table 
using the cardholder name or the last four digits of the card number. The system retains the card 
information during the transaction for use at time of payment, and then expunges all information. The 
Saved Card functionality greatly enhances bar environments mainly or other non-traditional dine-in 
restaurants, to enhance speed-of-service when large parties prefer to pay separately. Also, this 
functionality enables a restaurant to capture the card number without the liability of holding the 
guest’s physical card. Using the existing Saved Card functionality, you can now also save payment 
cards at the seat level. 

In accordance of the PCI-DSS, you can show the first name and last name of the credit card assigned 
to the seat. Any credit card data saved locally purges after the check closes. 

Configuring the ability to save different cards to the same tab or table 
Configuring the ability to save different cards to the same tab or table requires you to (1) Configure 
pivot seating; (2) Configure a store to name a tab or table using a payment card; and (3) Configure a 
button using the Rename Tabs and Tables function.

To configure pivot seating:

1. Select Maintenance > Labor > Jobcodes.
2. Select a jobcode, such as ‘Bartender,’ from the drop-down list.

Version Tracking Number Products Audience

POS v19.6 ALOHAP-20678
ALOHAP-27495
ALOHAP-27830

Aloha Table Service Configuration Technician
End User

Note
To allow an employee to use the Split Checks function, access Maintenance > Labor > Pos Access 
Levels > Access Level tab, select ‘Split checks' under the ‘Financial’ group bar, and assign the 
access level to the employee.
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3. Select the Order Entry tab. 

4. Select Pivot seating to activate the pivot seating option.
5. Click Save.
6. Repeat this procedure for each job code that requires pivot seating.
7. Exit the Jobcodes function.
8. Continue to the next procedure.

To configure a store to name a tab using a payment card:

1. Select Maintenance > Business > Store.
2. Select the Store Settings tab.
3. Select the Order Entry group located at the bottom of the screen.

Figure 51  Pivot Seating 
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4. Under the 'Tabs and tables' group bar, select Card name to associate the tab with the name of 
the card holder, when the bartender enters an order.
-OR-
Select Card number, to associate the account number of the card holder to the tab. Note: This 
option applies to any employee who logs in using a job code with ‘Bartender’ selected. 

5. To name a table using payment cards, select Name table using a magnetic card. Selecting this 
option exposes the ‘Table naming method when card is swiped.’

6. Select Add card name to table, From the ‘Table naming method when card is swiped’ 
drop-down list, to name the table with the name of the card holder, 
-OR-
Select Add card number to table, to name the table with the last four digits on the payment 
card. 

7. Click Save and exit the Store function. 
8. Continue to the next procedure. 

To add a Rename Tabs and Tables button function to an order entry panel:

1. Select Maintenance > Screen Designer > Table Service Screen Designer.
2. Select Panel > Open Panel and select an order entry panel to edit. The panel appears in a fixed 

position at the bottom of the screen.

Figure 52  Name Table Using A Magnetic Card



 Aloha Solution v19.6, Enhancement Release Guide
Aloha POS Software

73

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

3. Select Panel > New Button. 

1.

4. Under the ‘Function’ group bar, select Rename Tabs and Tables from the 'Action' drop-down 
list.

5. Under the 'Appearance' group bar, type a name for the button, such as 'Store Card.' 
6. Configure the remaining options as you would for any other button
7. Select Panel > Save Panel and exit Table Service Screen Designer.

Figure 53  Name Table Using A Magnetic Card 
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Adding different cards to the same tab or table
The scenario below is specific to adding different cards to the same tab; however, the process is 
basically the same for a table.

SCENARIO: Tabs Two guests arrive at the bar. You start a tab, and two seats. After the guest who
pays for the round of drinks and Seat 1 leaves, one more guest arrives at the bar.

1. Log in to the FOH. The order entry screen appears. 
2. Collect the payment card from the guest to start a tab. 
3. Using the MSR on the terminal, slide the card. The payment card names the tab and saves the 

credit card information to the tab. 

4. Add menu items for the first guest to ‘Seat 1.’
5. (Optional) Touch Store Card to rename the tab. The Rename Tab screen appears.

Figure 54  Adding Menu Items 
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6. Using the alphanumeric keypad, rename the tab and touch OK. 
7. Touch Next Seat. A new seat appears.
8. With the new seat active, add menu items for the second guest in ‘Seat 2.’

9. Collect the payment card from the second guest to save a second card to the second seat.

Figure 55  Renaming Tab 

Figure 56  Adding Menu Items to Seat 2



 Aloha Solution v19.6, Enhancement Release Guide
Aloha POS Software

76

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

10. Touch Store Card again. The ‘Select target for saved card’ screen appears. 

11. Touch the seat number for which to save the card, and touch OK. The ‘Swipe card to assign to a 
seat’ screen appears. 

12. Using the MSR on the terminal, slide the card. The payment card is saved to Seat 2. 

13. Repeat steps 9 through 12 for any additional guests.
14. From the order entry screen, touch Done or an order mode to send to the kitchen. 

Figure 57  Select Target for Saved Card Screen - Seat 2

Figure 58  Swipe Card to Assign to a Seat Screen
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Tendering and closing separate seats
Each guest pays for their own meals. Guest 1 is also paying for a round of drinks on the tab. In this 
case, you split Seat 2 and Seat 3 to their own checks and tender each check. Guest 1 pays for drinks 
added to his seat and items added to the tab. You cannot close seats individually, so you must make 
separate checks.

1. Log in to the FOH, select the check, and navigate to the Close screen. The Tenders screen 
displays by default. 

2. Touch Split Checks. 

3. Touch Add.
4. Touch Seat 2 and its items and touch Check 2. The menu items move to Check 2.
5. Touch Add.
6. Touch Seat 3 and its items and touch Check 3. The menu items move to Check 3.

Figure 59  Split Checks Screen 
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7. Touch OK to dismiss the Split Checks screen and the Tender screen appears.
8. Select the appropriate check to tender. The Saved Card button appears in the Tenders screen, 

if a payment card is saved to a seat. 

Figure 60  Moving Check 1 to Check 3

Figure 61  Saved Card Button 
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9. Touch Saved Card. A confirmation screen appears.

10. Touch Yes.
11. Touch Close to close the appropriate check.
12. Repeat steps 10 through 12 until you close all separate checks. The Close button appears.
13. Touch Close to close the check. 

Figure 62  Close Out Tab and Seat 1
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Troubleshooting Split Checks
If a guest produces an expired credit card during the capturing of the credit card information, the 
following error appears: 

Touch Cancel to dismiss. 

If a guest produces a ‘not supported credit card’ or gift card, such as ‘Diners,’ it may be a result of 
the card type not being active in Tenders Maintenance, or the Type is ‘not applicable.’ The following 
error appears: 

Touch Cancel to dismiss. 

Figure 63  Invalid Card: Card Expired

Figure 64  Invalid Card: Not Supported 
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Changing percentage-based gratuities to a dollar amount  

Some restaurants have a policy of adding a gratuity to the guest check for large parties, usually 
configured as 20% of the total check. This practice ensures the servers receive a minimum tip 
amount. Your policy may require different percentages based on the size of the party, for example, 
20% for 20 to 29 guests, and 23% for 30 or more guests. Changing the percentage used to calculate 
the gratuity on the guest check is already possible in the POS system today.

This enhancement allows you to override a percentage-based gratuity on a guest check and change it 
to a fixed dollar amount. This is helpful when you have an agreement with the guest that they will pay 
a minimum gratuity amount based on the party size. For example, your guest agrees to pay a 
minimum gratuity of $40 for a party of 30 or more. The total check comes to $165.00. The calculated 
percentage-based gratuity comes to $37.95 ($165.00 x 23%). This new feature allows you to change 
the calculated gratuity of $37.95 to a fixed amount of $40.00. Prior to this new feature, you could 
only change the percentage to get as close to $40.00 as possible. 

On the FOH, when you touch the Add/Edit Gratuity button, a new button, ‘Enter $,’ appears in the 
lower right corner of the screen. Touch ‘Enter $’ to change a percentage-based gratuity to a dollar 
amount. You can toggle between the ‘Enter $’ and ‘Enter %’ buttons to edit the gratuity amount.

To change a percentage-based gratuity to a dollar amount:

1. Log in to the FOH and start a new table.
2. Enter menu items on the guest check.
3. Send items to the kitchen. The gratuity appears in the guest check window. 
4. Touch Done or an order mode to send the order to the kitchen.

When the guests are ready to leave and request their checks, return to the FOH terminal.

1. Log in to the FOH.
2. From the Working with Tables screen, touch the table in the Open Tables column. 
3. Touch Close.
4. Touch Add/Edit Gratuity. The Edit Gratuity screen appears.

Version Tracking Number Products Audience

POS v19.6 ALOHAP-20686 Aloha Table Service Configuration Technician
End User
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5. Touch Enter $.   

6. Type an amount, such as $40.00, and touch OK. Note: You do not have to enter a whole dollar 
amount; the amount can include cents, such as $40.50. 

Figure 65  Touch Enter $

Figure 66  Changing Percentage Based Gratuities to a Dollar Amount 

23%

$40.00
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7. The gratuity changes to the amount entered.
8. Tender and close the check as usual.

Figure 67  The New Dollar Gratuity Amount Appears
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Tying a guest check to a party  

You can now tie one or more guest checks to a party ID. For example, if you host several group 
parties on the same night, during order entry, you can tie one or more guest checks to the ID specific 
to the party the guest is attending. This feature operates off a new option in the Order Mode function 
that prompts you for the ID during order entry when you select the order mode for the guest check.

Configuring an order mode to prompt for a party ID
The Order Mode function offers a new option that, when selected, displays a prompt for a Party ID 
during order entry, after you select the order mode for the guest check. 

To configure an order mode to prompt for a Party ID:

1. Select Maintenance > System Settings > Order Mode.
2. Select an order mode for which the prompt is to appear from the drop-down list. 

3. Under the ‘Settings’ group bar, select Ask for party ID.

Version Tracking Number Products Audience

POS v19.6 ALOHAP-20692 Aloha Table Service Configuration Technician
End User

Figure 68  Ask for Party ID
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Ask for party ID — Displays the Enter Party Code screen, allowing you to tie the guest check to 
a party ID. The option allows for alphanumeric and special character entry. If you enter the incor-
rect party ID, you can correct it later as long as the check is still open. The option defaults to 
False. Documented Version: v19.3.

4. Click Save.
5. Repeat this procedure for any other order modes for which you want to prompt for a party ID.
6. Exit the Order Mode function. 

Additionally, the system allows you to enter, change, or update a party ID manually, while the check is 
still open. For example, if you accidentally enter an incorrect party ID, touch ‘Party ID’ to open the 
Enter Party Code screen and manually enter, change, or update the party ID. 

For Table Service, you must add the Party ID button to either a FOH floor plan panel in use or to the 
configurable bottom row of the order entry screen, referred to as the Action Item area. Teaching you 
how to create a custom panel to replace the hard-coded buttons that appear on the bottom row of the 
order entry screen is beyond the scope of this document. To learn how to create this panel, refer to 
the Custom TS Order Entry Screen Feature Focus Guide. We suggest you create at least one custom 
panel, add a button for each of the standard buttons, including the standard Hold button, so that the 
two panels are identical, and then return here in this document to learn how to add the Party ID 
button to the custom panel.  

To add a Party ID button:

1. Select Maintenance > Screen Designer > Table Service Screen Designer.
2. Select Panel > Open Panel, select the custom order entry panel to edit, and click OK.

Tip
This button exports data to BTN.DBF, with a function value of 276.
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3. Select an available button or create a new button. The Properties dialog box appears.

4. Under the ‘Function’ group bar, select Apply Party ID from the ‘Action’ drop-down list.

Apply Party ID — Provides a button that allows you to enter, change, or update a party ID. Once 
touched, the Enter Party Code screen appears and you can touch backspace to remove and enter 
a correct party ID. Documented Version: v 19.6.

5. Under the ‘Appearance’ group bar, type a name for the button, such as ‘Party ID.’ To display text 
on multiple lines, insert ‘\n’ without spaces for line breaks. For example, ‘Party/ID.’

6. Configure the remaining options as you would for any other button.
7. Select Panel > Save All Panels.
8. Exit the Screen Designer function. 

Assigning a party ID to a guest check 
For best practices, obtain the party ID from the guest when accepting orders. If you enter an incorrect 
party ID number, you can correct this error using the ‘Party ID’ button.

To assign a Party ID to a Guest Check:

1. Log in to the Front-of-House (FOH).
2. From the Working with Tables screen, touch New. The Enter Table Number screen appears.
3. Enter the table number using the numeric keypad, and touch OK.
4. Enter the number of guests sitting at the table using the numeric keypad, and touch OK.

Figure 69  Apply Party ID
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5. Enter the orders.
6. Select an order mode configured to prompt for a party ID. The Enter Party Code screen appears. 

7. Enter the party code ID. 
8. Touch OK.

The party ID appears in the guest check window.

Figure 70  Enter Party Code Screen

Figure 71  Guest Check Displays Party ID



 Aloha Solution v19.6, Enhancement Release Guide
Aloha POS Software

88

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

To change a party ID on a guest check:

1. Log in to the FOH.
2. From the Working with Tables screen, touch the table in the Open Tables column. The Order 

Entry screen appears with the full order appearing in the guest check window. 

3. Touch PartyID. The Enter Party Code screen appears. 

Figure 72  Party ID Button on Order Entry Panel 

Figure 73  Entering a Correct Party ID
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4. Enter the correct party ID. 
5. Touch OK. 

The corrected party ID appears in the guest check window.

Figure 74  Guest Check Displays Party ID 



 Aloha Solution v19.6, Enhancement Release Guide
Aloha POS Software

90

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Clocking out an employee that left mid-shift 

There are instances when an employee must leave during their shift; perhaps due to a family 
emergency, or you ask them to leave because business is slow. If an employee accumulates sales and 
then leaves without performing a checkout, you must be able to run the checkout, then clock the 
employee out. This is difficult without knowing the employee login credentials. You can now perform 
a checkout for an employee that accumulated sales and left without performing a checkout. There is 
no configuration required for this enhancement.

To clock out an employee that leaves mid-shift:

1. Log in to the FOH.
2. Touch Functions. The Special Functions screen appears. 
3. Touch Employee. The Employee screen appears. 

Version Tracking Number Products Audience

POS v19.6. ALOHAP-21991 Aloha Quick Service, Aloha Table Service Configuration Technician
End User

Figure 75  Employee Screen 
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4. Touch Edit Clock In. The Select Employee to Edit Clock In/Outs screen appears. 

5. Touch the employee and touch OK. The Edit Clock In/Out screen appears. 

6. Touch Clock Out. A prompt to run the checkout for the employee appears.

Figure 76  Selecting the Employee 

Figure 77  Edit Clock In/Out
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7. Touch Yes. A message letting you know the employee has been checked out appears. 

Figure 78  Warning Message

Figure 79  The Employee Has Been Checked Out Prompt
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8. Touch the message to dismiss it. 

9. Touch OK to return to the Employee screen.
10. Touch Exit to return to the floating logo.

Figure 80  Edit Clock In/Out Screen 
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Supporting group combos for fractional pizzas in Table Service 

You can now apply a group combo promotion that includes a fractional pizza. For example, you offer 
a fractional pizza, a side item, and a drink for $20.00. Your guest wants one half Supreme pizza and 
one half Veggie Lovers pizza; a garden salad, and a soda. The system applies the correct price of the 
group combo to the fractional pizzas.  

Version Tracking Number Products Audience

POS v19.6 ALOHAP-25393 Aloha Table Service Configuration Technician
End User

Reference
Refer to the HKS366 Group Combo Feature Focus Guide and the HKS321 Advanced Pizza for TS 
Feature Focus Guide for more information.

https://okm.ncrvoyix.com/infocenter/index?page=answers&question_box_status=changed&question_box=group+combos&lotusTik=lotusFlag_false&fac=CMS-STATUS.Published%2C&ichbox%5B%5D=en-US
https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS321&actp=search&viewlocale=en_US
https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS321&actp=search&viewlocale=en_US
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Configuring minimum guest count to force automatic gratuity by revenue center 

Currently, you can automatically add a gratuity to a guest check based on guest count; however, this 
configuration is global and the automatic gratuity is added to every guest check meeting the 
minimum guest requirement. With the introduction of the Gratuities function, you gained the ability to 
assign a gratuity to a revenue center, but you could not stipulate the minimum number of guests 
before adding the auto-gratuity to the guest check. Now you can stipulate the minimum number of 
guests required before adding the auto-gratuity.  

Select an order mode, table, or terminal to which the revenue center is attached. The system assigns 
a revenue center to every guest check you open, based on either the table you select or the terminal 
from which you initiate the guest check, as soon as you add the first item to the guest check. This 
revenue center stays with the guest check regardless if you transfer the check or add items to the 
check using a different terminal. Because you can configure a revenue center in multiple functions in 
the system (Order Modes, Table Definitions, Terminals,) if you apply an order mode to the guest 
check, the revenue center assigned to the order mode overrides the table definition, which overrides 
the terminal definition. 

To configure auto-gratuity based on minimum guest count using the Gratuities function:

1. Select Maintenance > System Settings > Gratuities.
2. Select an existing gratuity from the drop-down list, or click New and either accept the system 

assigned number or click the ellipsis button (...) next to ‘Number’ to display the Number 
Assignment dialog box, from which you can choose an alternate number.

Version Tracking 
Number Products Audience

POS v19.6 ALOHAP-26161 Aloha Table Service Configuration Technician
End User

Tip
To use this feature, you must configure the system to capture guest counts. How to configure the 
capture of guest counts is outside the scope of this document. Refer to Maintenance > Business > 
Store > Store Settings tab > Order Entry group in the Table Service Reference Guide for 
information regarding capturing the guest count.
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3. Type a name to identify the gratuity, such as ‘Gratuity 1.’ You can also identify the auto-gratuity 
based on the revenue center to which it applies, such as ‘Patio bar,’ ‘Pool bar,’ and more.

4. Select Force automatic gratuity to expose the ‘Minimum guests needed for automatic gratuity.’ 
5. Type the minimum number of guests needed for automatic gratuity, such as ‘8.’ 

Minimum number of guests needed for automatic gratuity — Specifies the minimum guest 
count required to apply this automatic gratuity. For example, if you set the minimum number to 
‘8,’ the entry of a guest count eight or greater causes the automatic gratuity to apply to the current 
guest check. Documented Version: POS v19.5.

6. Type the percentage for calculating the automatic gratuity, such as ‘10.00’ (10%).
-OR-
Type a dollar amount to add to the guest check for the automatic gratuity, such as $5.00.’

7. Type the text to appear on the guest check, such as ‘Automatic Gratuity.’
8. Configure the remaining options.
9. Click Save.

Figure 81  System Settings - Gratuities 
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10. Repeat this procedure for each gratuity requiring a minimum guest count for applying an 
automatic gratuity. 

11. Exit the Gratuities function. 

The system assigns a revenue center to every guest check you open, based on the order mode you 
apply to the check, the table you select, or the terminal you use to enter the order, as soon as you add 
the first item to the guest check. This revenue center stays with the guest check regardless if you 
transfer the check or add items to the check using a different terminal. If a revenue center is assigned 
to all three of these, the revenue center assigned to the order mode overrides the one assigned to the 
table, which overrides the one assigned to the terminal. For example, if you select table 5, which is 
assigned to one revenue center, and then apply the Large Party order mode to the guest check, the 
revenue center assigned to the Large Party order mode overrides the revenue center assigned to the 
table. 

To add gratuity assignments to revenue centers:

1. Select Maintenance > System Settings > Revenue Center.
2. Select a revenue center from the drop-down list.
3. Select the Gratuities tab.
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4. Select a gratuity in the ‘Available’ list box and click >> to move the gratuity to ‘Included’ list box. 
In this example, we are assigning a gratuity to the Dine-In revenue center, and the revenue center 
attached to the table is Dine-In. 

5. Click Save.
6. Repeat this procedure for any other revenue center to assign a gratuity.
7. Exit the Revenue Center function.

Figure 82  Revenue Center - Gratuity Assignments
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SCENARIO: Using guest counts assigned to the gratuity record attached to the Dine-In revenue cen-
ter to force automatic gratuity. 

To use guest counts to force auto-gratuity: 

1. Log in to the FOH.
2. From the Working with Tables screen, touch New. The Enter Table Number screen appears. 
3. Enter the table number using the numeric keypad, and then touch OK. 

4. Use the numeric keypad to enter the number of guests sitting at the table, such as ‘8,’ and touch 
OK.

5. Add items to the guest check. 
6. Touch Done or an order mode to send the order to the kitchen. The system automatically adds 

the gratuity to the guest check.

Figure 83  Entering the Guest Count
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7. When the guests are ready to leave, tender and close the check, as normal.

Figure 84  Sending the Order to Kitchen
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Displaying employees assigned to cash drawers 

Currently, a manager must log in to the Front-of-House (FOH) and navigate to the Manage Drawers 
function to view cash drawer assignments. Now you can configure a Cash Drawers Info button to 
appear on the FOH login screen. Touching this button displays a list of employees and their cash 
drawer assignments, allowing employees to easily check their assignments without requiring manager 
intervention. 

Version Tracking Number Products Audience

POS v19.6 ALOHAP-27614 Aloha Quick Service Configuration Technician
End User

Figure 85  Cash Drawers Info
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To display the Cash Drawers Info button on the login screen:

1. Select Maintenance > Business > Store.
2. Select the Store Settings tab.
3. Select the User Interface group located at the bottom of the screen. 

4. Under the ‘Display’ group bar, select Display employee assigned to cash drawer on login 
screen.

Display employee assigned to cash drawer on login screen — Enables a Cash Drawers Info 
button to appear on the FOH login screen, making it easier for employees to view cash drawer 
assignments without requiring a manager to log in and navigate to the Manage Drawers function. 
All configured cash drawers appear; an error message appears if the manager has not yet per-
formed cash drawer assignments. Documented Version: v19.5.

5. Click Save and exit the Store function. 

Figure 86  Store Settings Tab - User Interface Group 
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Viewing Cash Drawer Info

The manager, or someone with similar access, assigns employees to cash drawers.

1. Touch the floating logo to open the Front-of-House (FOH). The Login screen appears. See 
Figure 85.

2. Touch Cash Drawer Info to view the list of cash drawer assignments. 

3. Touch the screen to dismiss it.  

Figure 87  Cash Drawer Assignments 

Note
An error message appears if the manager has not yet performed cash drawer assignments.
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Changing the font size of text on Change Due message box 

You can now change the font size of the text on the Change Due message box to make it larger and 
easier to read. The system provides three options: ‘System Default (12),’ which is considered 
medium; ‘Large (64),’ and ‘Extra Large (88).’ First, you must verify your screen resolution to 
determine the appropriate size, and then refer to Figure 88 for additional resolution details.  

To change the font size of the Change Due message box:

1. Select Maintenance > Business > Store.
2. Select the Store Settings tab.

Version Tracking Number Products Audience

POS v19.5 ALOHAP-27618 Aloha Quick Service Configuration Technician
End User

Note
To change the height, width, and position of the change due dialog box, select Maintenance > 
Hardware > Terminals and configure the options.

Figure 88  Examples of Screen Resolution and Change Due Dialog Font Sizes 



 Aloha Solution v19.6, Enhancement Release Guide
Aloha POS Software

105

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

3. Select the User Interface group located at the bottom of the screen. 

4. Under the ‘Display’ group bar, select a font size from the ‘Change due dialog box font size’ 
drop-down list. The available options are ‘System Default (12),’ ‘Large (64),’ and ‘Extra Large 
(88).’

Change due dialog box font size — Allows you to change the font size of the change due box 
so that employees can easily read the message that appears. (1) You must check the resolution of 
your screen, then (2) select the appropriate size from the ‘Change due dialog box font size’ 
drop-down list. The available options are ‘System default (12), which is considered ‘medium,’ 
‘Large (64),’ and ‘Extra Large (88).’ Documented Version: v19.5.

5. Click Save and exit the Store function. 

Viewing the Change Due dialog box

This example uses a screen resolution of 1024 x 768 and the change due dialog box size of ‘Large 
(64).’

1. Add items to the guest check. The total due is $11.11. 
2. Touch an order mode to send the order to the kitchen. 
3. Touch Close to access the Tenders screen. 
4. Choose the payment type. This example uses $20.00 cash.

Figure 89  Store Settings Tab - User Interface Group 
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5. Touch $20. The Change Due box reads, ‘Change Due: $8.89.’

6. Give the guest their change.

Figure 90  Change Due Font Size - Large (64)
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Supporting Givex 24-digit gift card numbers 

The Aloha® POS system now supports Givex gift card numbers up to 24 digits. To accept 24-digit gift 
card numbers, you must update the Aloha POS version to 19.6, Aloha EDC to v19.4. and the Givex 
plugin to v15.1.178. Although no configuration is necessary, you may need to access Maintenance > 
Payments > Tenders > Identification tab and update the Givex gift card number to 24 digits under the 
‘Identification’ group bar.   

Version Tracking Number Products Audience

POS v19.3 ALOHAP-29565 Aloha Quick Service, Aloha Table Service, Aloha 
EDC

Configuration Technician
End User

Note
As the Givex UPI integrates solely with Aloha Electronic Draft Capture (EDC), this feature is not 
compatible with Connected Payments.

Reference
Refer to the HKS362 Givex Gift Cards Feature Focus Guide for more information.

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS321&actp=search&viewlocale=en_US
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Sending orders from two terminals to one serial display board

You can now configure multiple terminals to communicate with one serial display board. The 
terminals communicate with the serial display board on a 'first come, first served' basis, creating a 
one-to-many relationship. Orders appear on the display board in consecutive order; however, if an 
employee starts an order when one is already in progress on another terminal, the second order 
never appears on the display board. 

In the following scenario, terminals 3 and 4 send orders to the same serial display board:

SCENARIO: You start an order on terminal 3 and add items to the guest check. The order appears
on the display board. You close the check and the display board clears. Your coworker starts an order
on terminal 4 and adds items to the guest check. The order appears on the display board. Your
coworker closes the check and the display board clears. 

SCENARIO: You start an order on terminal 3 and add items to the guest check. The order appears
on the display board. Your coworker starts an order on terminal 4 and adds items to the guest check.
Because the display board is already in use, the order entered by your coworker does not appear on
the display board. The system does not display any order initiated when the display board is already
in use by another terminal and will not queue the order for later display. You close your check, and
the display board clears. 

SCENARIO: You and your coworker start an order at the same time. In the event that you and
coworker both start a check simultaneously, the order originating from the terminal with the lowest ID
appears on the display board; the other order is ignored. 

To send orders from more than one terminal to a serial display board:

1. Select Maintenance > Hardware > Display Boards.
2. Select the display board from the drop-down list.
3. Select the Display Orders From tab. 

Version Tracking Number Products Audience

POS v19.6 WIT 094473 Aloha Quick Service, Aloha Table Service Configuration Technician
End User
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4. Select the terminal from the ‘Available’ list and click >> to move the terminal to the ‘Included’ 
list.

5. Repeat step 4 until the desired terminals appear in the ‘Included’ list.
6. Click Save and exit the Display Boards function. 

Figure 91  Display Order From Tab
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Displaying text on manager approval screen for early break returns 

Some laws require an employee to take the full minimum break minutes before they return to work. 
When enforced, if an employee returns from the break before the minimum minutes required, the 
employee must receive manager approval to return to work. You can now display additional text to 
appear on the manager approval screen for early break returns. The purpose is to alert the manager 
approving the return of legal requirements and potential issues, allowing them to make more 
informed decisions regarding employee breaks.  

Version Tracking Number Products Audience

POS v19.6 WIT 177165 Aloha Quick Service Configuration Technician
End User

Reference
Refer to the HKS315 Employee Breaks Feature Focus Guide for more information.

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS315&actp=search&viewlocale=en_US
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Using car images to recall orders to active guest check window 

In Aloha Quick Service v15.1, we introduced the ability to integrate with Gulfcoast Software Solutions 
to capture and display images of vehicles associated with drive-thru orders in the active guest check, 
the review check, and on an Aloha Kitchen screen. Touching the image in either the active guest 
check window or the review check window brings you to a screen containing all images currently in 
the queue. Selecting an image recalls the check to the review check window. 

Now you can recall the check from the screen on which all images currently in the queue appear to 
the active guest check window instead of the review check window. This allows you to use drive-thru 
vehicle identification without also configuring and using the review check functionality. 

Version Tracking Number Products Audience

POS v19.6 WIT 177173 Aloha Quick Service Configuration Technician
End User

Reference
Refer to the HKS352 Drive-Thru Vehicle Identification Feature Focus Guide for more information.

https://okm.ncrvoyix.com/resources/sites/OKM/content/staging/HKS_KNOWLEDGE/0/HKS352/en_US/8.0/QS_DriveThruVehicleIdentificationFFG-HKS352.pdf
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Supporting charitable donations in Quick Service 

Some quick service restaurants support local charities by hosting donation drives. Currently, there is 
not an easy process to add a donation to the guest check. In an effort to produce acceptable speed of 
service metrics, some cashiers bypass the prompt and do not ask guests if they would like to make a 
donation; therefore, the opportunity to raise money for charities in need is lost.

Now you can add easily configured buttons that you can touch to apply the change due, a custom 
defined amount, or an open amount suggested by the guest. You can also configure a footer 
message by category to include a ‘thank you’ message to guests that donate. 

Version Tracking Number Products Audience

POS v19.6 WIT 178027
WIT 188365

Aloha Quick Service Configuration Technician
End User

Reference
Refer to the HKS1490 Charitable Donations in QS Feature Focus Guide.

https://okm.ncrvoyix.com/resources/sites/OKM/content/live/HKS_KNOWLEDGE/1000/HKS1490/en_US/QS_CharitableDonationsFFG-HKS1490.pdf
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Supporting visual indicators for order modes 

You can designate a combination of up to three characters and letters to appear next to every menu 
item on a guest check, to indicate the order mode you apply to each item. For example, -> might 
appear next to items to which you apply the To Go order mode, DIN next to Dine In items, and so on. 
You designate the indicator in the Order Mode function. For Quick Service sites, you can also 
designate an image to appear in the order entry queue as a visual indicator of the order mode 
applied to an order. For example, you can use a car to indicate an order in the queue came from the 
drive-thru order mode. You designate the image for the order mode in the Order Entry Queue 
function. 

Now you can designate an image to appear in the order entry queue and another image to appear as 
the background in the on-screen guest check, both of which are visual indicators of the order mode. 
You can use the on-screen guest check background in place of, or in addition to, the three characters 
and letters next to each item. This makes it easier to quickly identify the order mode and can reduce 
information that appears in the body of the on-screen guest check. 

Version Tracking Number Products Audience

POS v19.6 WIT 179700 Aloha Quick Service, Aloha Table Service Configuration Technician
End User

Figure 92  Table Service Dine-In Example
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Also effective in v19.3 are two new options in Store Settings that allow you to designate an image and 
background to use as visual indicators of orders you receive from an Application Program Interface 
(API), such as mobile orders.  

Visual Indicator Hierarchy

Since you can define images for the order entry queue and on-screen guest check in several 
locations, it is important to understand the hierarchy. 

From highest to lowest, the hierarchy for the order entry queue is: 

1. API Image defined in Maintenance > Business > Store > Store Settings tab > User Interface group 
> ‘Display > Graphics On External Orders’ group bar > ‘Image.’

2. Image defined in Maintenance > System Settings > Order Mode > ‘Settings’ group bar > 
‘Image.’

3. Image defined in Maintenance > System Settings > Order Entry Queue > ‘Settings’ group bar > 
‘Image.’ 

4. Default color for order entry queue. 

From highest to lowest, the hierarchy for the on-screen guest check is: 

1. API Image defined in Maintenance > Business > Store > Store Settings tab > User Interface group 
> ‘Display > Graphics On External Orders’ group bar > ‘On-screen check background.’

2. Background image defined in Maintenance > System Settings > Order Modes > ‘Settings’ group 
bar > ‘On-screen check background.’

3. Background image defined in Maintenance > Screen Designer > Quick Service Screen Designer 
> Order Panel panel type > ‘Image. (QS only)

Figure 93  Quick Service Mobile Order Example
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4. Background image or color defined in Maintenance > System Settings > Skins > ‘Check 
background media file’ or ‘Check color,’ unless employee uses training mode, then uses 
‘Training check color.’ 

5. Default color for on-screen check background. 

To import new images using the Media Files function:

1. Select Maintenance > System Settings > Media Files.
2. Click the New drop-down arrow, select Aloha Point of Sale, and click OK.
3. Accept the system assigned number or click the ellipsis button (...) next to ‘Number’ to 

display the Number Assignment dialog box, from which you can choose an alternate number. 
4. Type a name to help you easily identify the media file. This name does not have to match the file 

name. 
5. Select the file type from which to make a selection. The ‘Select File’ option appears.
6. Click the ellipsis (...) for the ‘Select File’ option, select the new image you created, and click 

Open.
7. Click the Preview tab to review the media file. 
8. Click Save.
9. Repeat this procedure for any other media files you need to import. For example, you can 

import separate images for dine in, takeout, and more.
10. Exit the Media Files function.  

Reference
Refer to the Media Files function in the Table Service or Quick Service Reference Guides for more 
information.
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To designate visual indicators for order modes: 

1. Select Maintenance > System Settings > Order Mode.
2. Select an order mode from the drop-down list. 

3. If you are using Quick Service, under the 'Settings' group bar, select the image to appear in the 
order entry queue as a visual indicator of the order mode.

Image — Designates the image to appear in the order entry queue as a visual indicator of the 
order mode. For example, an image of a car is a visual indicator of the drive-thru order mode. 
Documented Version: v19.3. Related Options: Any image you select in the User Interface 
group under the ‘Display > Graphics On External Orders’ group bar on the Store Settings tab in 
Maintenance > Business > Store supersedes the image you select here.

4. Select the image to appear as the background of an on-screen guest check as a visual indicator 
of the order mode. For example, an image of a car is a visual indicator of the drive-thru order 
mode. 

On-screen check background — Designates the image to appear as the background of an 
on-screen guest check as a visual indicator of the order mode. Documented Version: v19.3.

Figure 94  Order Mode
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5. Click Save.
6. Repeat this procedure for each order mode to which to add visual indicators. 
7. Exit the Order Mode function.  

To designate visual indicators for API-injected orders: 

1. Select Maintenance > Business > Store.
2. Select the Store Settings tab.
3. Select the User Interface group located at the bottom of the screen. 

4. Under the 'Display > Graphics On External Orders' group bar, select the image to appear in the 
order entry queue as a visual indicator of orders received from an Application Program Interface 
(API), such as mobile orders. 

Note
You can assign a visual indicator to the on-screen guest check using an order mode. As order 
modes can change over the life cycle of the check, the POS system updates the visual indicator 
to reflect the order mode of the item last ordered.

Figure 95  Store Settings Tab - User Interface Group
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Image — Designates the image to appear in the order entry queue as a visual indicator the order 
was received from an Application Program Interface (API), such as mobile orders. Documented 
Version: v19.3. Related Options: The image you select under the ‘Display > Graphics On Exter-
nal Orders’ group bar is first in the hierarchy and supersedes any image you configure in the 
Order Mode function. 

5. Select the image to appear as the background of an on-screen guest check as a visual indicator 
the order was received from an Application Program Interface (API), such as mobile orders. 

On-screen check background — Designates the image to appear as the background of an 
on-screen guest check as a visual indicator the order was received from an Application Program 
Interface (API), such as mobile orders. Documented Version: v19.3. Related Options: The 
‘On-screen check background’ image you select under the ‘Display > Graphics On External 
Orders’ group bar is first in the hierarchy and supersedes any image you configure in the Order 
Mode function. 

6. Click Save and exit the Store function. 
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Expanding customer survey access methods 

The Customer Survey feature allows a restaurant to prompt randomly selected guests for feedback 
about their dining experience in exchange for a reward or discount. The prompt prints on the guest 
check along with a phone number for your guests to call and enter a unique code to access the 
survey. Now there are two additional methods from which you can choose for guests to access a 
survey: 'Barcode,' and 'QR code.’ With these methods, guests use a smart phone or tablet to scan a 
bar code or QR code that prints on the guest check to access the survey on your website or app. 

Version Tracking Number Products Audience

POS v19.6 WIT 185817 Aloha Quick Service, Aloha Table Service Configuration Technician
End User

Reference
Refer to the HKS304 Customer Survey Feature Focus Guide for more information.

https://okm.ncrvoyix.com/resources/sites/OKM/content/live/HKS_KNOWLEDGE/0/HKS304/en_US/QSTS_CustomerSurveyFFG-HKS304.pdf
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Displaying immediate USB PIN pad error message 

Currently, if you use USB PIN pad devices, when you enter an order on the Front-of-House (FOH) and 
then touch the tender to enable the PIN pad device to complete the transaction, you have no 
indication if the device is unavailable due to a physical disconnection. You must then ask the guest for 
another form of payment, such as cash; or, move to another terminal and re-enter the order to 
complete the transaction.

Now an immediate ‘There is no PIN Pad attached to this terminal’ message appears if the USB PIN 
pad is disconnected. You can then choose another terminal into which to enter the order and 
complete the transaction.  

Version Tracking Number Products Audience

POS v19.6 WIT 190419 Aloha Quick Service, Aloha Table Service Configuration Technician
End User

Figure 96  PIN Pad Alert

Note
There is no configuration required for this enhancement.
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Limiting interface employee access 

An interface employee is a 'virtual employee' used by the Aloha POS system to perform automated 
tasks through Aloha Connect. NCR® products, such as Aloha Takeout and Aloha Mobile, use 
interface employees to automatically carry out tasks behind the scenes in the Aloha POS, while actual 
store employees use terminals to perform tasks. You create interface employees just like any other 
employee and assign them an interface job code with the ability to perform manager functions and 
other restricted capabilities. 

To prevent potential fraud, we added several protective measures that prevent interface employees 
from performing certain functions:

● You can no longer use an interface employee ID to log in to the FOH.
● You can no longer approve a function requiring manager approval. 
● Interface employees no longer appear in employee lists on the FOH, such as Manage Drawers or 

Edit Time.
● A clock in chit no longer prints for any employee clocking in using an interface job code. 

There is no configuration to implement these protective measures. 

Version Tracking Number Products Audience

POS v19.6 WIT 190442
WIT 190448
WIT 190453
WIT 193526

Aloha Quick Service, Aloha Table Service Configuration Technician
End User
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Refunding a check to original order mode 

When you perform a refund, rather than use the same order mode from which the order originated, 
the system uses an internal order mode ID 99, which you cannot change. If you try to select an order 
mode for the refund check, the ‘You cannot set the order mode to a refund’ message appears. As the 
POS allows you to establish tax rates based on different conditions, including the order mode you 
apply to a guest check, and order mode ID 99 backs out taxes based on the item tax rate, not 
refunding back to the original order mode can cause the refund calculations for the taxes to be 
different than the original check. Because the tax rates are different, the original transaction and the 
refund transaction do not directly offset each other. Now you are able to refund a check back to the 
original order mode.

To allow the selection of an order mode for a refund check (QS and TS): 

1. Select Maintenance > Business > Store.
2. Select the Store Settings tab.
3. Select the User Interface group located at the bottom of the screen. 

Version Tracking Number Products Audience

POS v19.6 WIT 396085 Aloha Quick Service, Aloha Table Service Configuration Technician
End User

Figure 97  User Interface Group - Functionality Group Bar
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4. For Quick Service, select Override refund order mode under the ‘Functionality’ group bar.
5. For both Quick Service and Table Service, leave None as the default order mode, so that a 

prompt requesting the order mode appears in the FOH.
6. Click Save and exit the Store function. 
7. If using Table Service, continue to the next procedure.

To allow the selection of an order mode for a refund check (TS only): 

1. Select Maintenance > Labor > Jobcodes.
2. Select a job code from the drop-down list.
3. Select the Order Entry tab.  

4. Under the ‘Order entry’ group bar, verify ‘Default order mode’ is set to None.
5. Select Prompt for order mode to force the system to prompt for an order mode selection when 

an employee clocked in under this job code performs a refund. Selecting this option disables and 
hides ‘Default order mode.’

Figure 98  Jobcodes - Order Entry Tab
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Prompt for order mode — Forces the system to prompt for an order mode selection when an 
employee clocked in under this job code exits the FOH order entry screen without selecting an 
order mode. Effective in v19.3, this option also prompts for the order mode under which to post 
a refund check when entering a refund in the FOH, if you select ‘None’ in ‘Default order mode.’ 
Documented Version: v19.3. Related Options: When you clear this option, the system exposes 
‘Default order mode,’ which allows you to designate a default order mode for this job code and 
bypass the prompt for order mode selection. Required Options: You must select ‘Order entry’ to 
expose this option.

6. Click Save.
7. Repeat this procedure for any other job code for which you want to prompt for order mode 

selection when performing a refund. 
8. Exit the Jobcodes function. 

When performing a refund in Table Service, a prompt similar to the following appears: 

Figure 99  Table Service FOH Order Mode Selection Screen
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When performing a refund in Quick Service the following message appears: 

Click anywhere in the message to remove it from the screen, then select the order mode to use for 
the refund. 

Figure 100  Quick Service FOH Order Mode Message
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Migrating item costing to Item Cost function 

Effective in CFC v17.5, you manage the costing of items using the Item Cost function, and the ‘Cost’ 
option is no longer available in the Items function. The Item Cost function supports real time updates. 
If you modify/enter an item cost using this function, a prompt to perform a real-time update appears.  

Version Tracking Number Products Audience

POS v19.6 WIT 417956 Aloha Quick Service, Aloha Table Service Configuration Technician
End User

Important
Upon upgrade to CFC v17.5, any item with a stated cost in the Items function appears in the 
Included list in the Item Cost function; any item without a cost appears in the Available list. You must 
access Maintenance > Labor > Security Roles > POS tab and make the appropriate security 
selections to provide access to the Item Cost function. The ‘All’ Security level already provides full 
access but you may need to make the appropriate selections for the ‘Standard’ access level under 
the Maintenance > Menu group bar.
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Running custom FOH report for multiple employees  

Currently, in Aloha versions 12.3, 14.1, 15.1, and 19.6, if you use custom Front-of-House (FOH) 
reports and select more that one employee or all employees to include in a report, the report 
information does not appear on the screen or when printed.

Effective in the above mentioned versions, the system offers a new option, ‘Allow report to be run for 
multiple employees at a time,’ which enables you to select and generate data in the report on more 
than one employee at a time.

Allow report to be run for multiple employees at a time — Enables you to select and generate 
data in the report on more than one employee at a time. If you clear this option and select more than 
one employee, the report appears blank and with no data. Documented Version: 19.6. 

Version Tracking Number Products Audience

POS v19.6 WIT 450214 Aloha Quick Service, Aloha Table Service Configuration Technician
End User

Reference
Refer to the HKS304 Custom FOH Reports Feature Focus Guide for more information.

https://okm.ncrvoyix.com/resources/sites/OKM/content/live/HKS_KNOWLEDGE/0/HKS304/en_US/QSTS_CustomerSurveyFFG-HKS304.pdf
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Supporting NPP Processor  

Hospitality merchants now have the option to process payments using the NCR Payment Processor 
(NPP) by leveraging a VisaNet emulation in Aloha® EDC. The major version of EDC must be at least 
equal to or greater than the Aloha POS version and must be a supported version. 

Version Tracking Number Products Audience

EDC v19.6 NPSEDCA-58 Aloha EDC, Aloha Quick Service, Aloha Table 
Service

Configuration Technician
End User

ReferenceRefer to Aloha EDC - Supporting the NPP Processor - HKS1606 for information on config-
uring the NPP processor. 

https://okm.corp.ncr.com/infocenter/index?page=content&id=HKS1606
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Enhancing ORDERPOINT!  

We made the following enhancements to the ORDERPOINT! product: 

● ORDERPOINT! now supports the XL-7 touch.
● ORDERPOINT! now supports the XL-7 no touch.
● The ORDEROINT! installer now checks for updated software requirements.
● We removed support for the Adobe® Shockwave Flash. Instead, ORDERPOINT! now supports 

Windows® Media Player with .mp4 and .wmv file formats. Additionally, we provide default 
animations for the XL-10. 

Version Tracking Number Products Audience

OP v19.6 ALOHAP-15965
ALOHAP-27104
ALOHAP-29016
ALOHAP-33016

ORDERPOINT! Configuration Technician
End User

ReferenceRefer to the ORDERPOINT! Implementation Guide - HKS302. 

https://okm.corp.ncr.com/infocenter/index?page=content&id=HKS302&actp=search&viewlocale=en_US
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Aloha Kitchen v19.11 
Aloha Kitchen is an add-on to Aloha Solutions and is not included as part of the Aloha Essentials core 
offering.  

Tracking 
Number

Description

ALOHAP-05407 “Embedding a URL in recipe viewer” on page 131

ALOHAP-05417 “Introducing Forecast Bin Estimate report” on page 136

ALOHAP-08806 “Introducing Production Assembly Line” on page 137

ALOHAP-12229
ALOHAP-21735

“Communicating with the Aloha POS using Aloha API and COM” on page 138

ALOHAP-14190
ALOHAP-15157
ALOHAP-15483
ALOHAP-15640
ALOHAP-15801
ALOHAP-16814
ALOHAP-17725

“Enhancing production chits in Print Designer” on page 139

ALOHAP-15251 “Defining AK speed of service target for NCR Pulse” on page 149

ALOHAP-18372
ALOHAP-23608

“Printing rewards member on production or order taker chit” on page 151

ALOHAP-18376 “Supporting Custom Paid Line Text element” on page 154

ALOHAP-18509 “Supporting Windows printer for drivers” on page 156

ALOHAP-18869 “Printing consumer name on production chit” on page 159

ALOHAP-23513 “Displaying checked-in icon and text on video screen” on page 162
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Embedding a URL in recipe viewer 

Some sites and corporations invest valuable time and money on the creation of instructional videos to 
virtually train their kitchen staff in lieu of gathering employees to a location at a specific time. The Task 
Info and Recipe Viewer functions in Aloha Kitchen already support embedded media files housed on 
the file server; however, sites want to store media on a website they can update, and prevent the 
need to continually send files or links to their stores. You can now embed a URL in the Recipe Viewer 
function of Aloha Kitchen, allowing the kitchen staff to access up-to-date company information from 
the terminals. The feature supports an unlimited number of uploaded links. 

Configuring an Embedded URL in Recipe Viewer
To embed a URL in Recipe Viewer, you must create a task in the Task Info function with an embedded 
URL and then associate the task in the Recipe Viewer function. 

To create a task info record with an embedded URL: 

1. With Kitchen selected in the product panel, select Maintenance > Kitchen Configuration > 
Task Info. 

2. Click New. 
3. Type a descriptive name for the task, such as ‘Training Video.’ 
4. Do not select an item from the ‘Item’ drop-down list. 

Version Tracking 
Number Products Audience

AK v19.6 ALOHAP-05407 Aloha Kitchen, Aloha Quick Service, Aloha Table 
Service 

Configuration Technician
End User

Caution
This feature requires Internet access from the kitchen controller, and only supports Windows 2007 
and higher. It is the responsibility of the site administrator to provide a secure network environment 
that includes firewall configuration, updated web browsers, and any other elements to maintain PCI 
compliance. An unsecured browser could put sensitive data at risk or expose it to malicious content. 
For any questions, contact your NCR representative or the NCR Data Security team.
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5. Select the Links tab.  

6. Click Add. 
7. Under the ‘Display name’ column, type the name to appear in Recipe Viewer. 
8. Under the ‘Link’ column, type the URL that launches the web page. 
9. Click Save. 
10. Repeat this procedure to associate another URL with another task. 
11. Exit the Task Info function. 

As with any task info record, you must associate it to a category in the Recipe Viewer function so an 
employee can access and view it from the terminal. 

To associate a task in Recipe Viewer: 

1. With Kitchen selected in the product panel, select Maintenance > Kitchen Configuration > 
Recipe Viewer. 

2. Under the ‘Settings’ group bar, right-click on root, and select Add category from the menu that 
appears. 

3. Type a name for the category, such as ‘Training Video.’ 
4. Select the Task Infos tab. 

Figure 101  Task Info - Links Tab
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5. Under the ‘Task Infos’ group bar, select and drag the task you created to the left and release it 
under the appropriate category. In keeping with the example, release under ‘Training Video’ 
on the left.  

6. Click Save and exit the Recipe Viewer function. 

Figure 102  Recipe Viewer Function
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Using an Embedded URL in Recipe Viewer
You launch an embedded URL through the Task Info command on the kitchen screen and use the 
commands from the Recipe Viewer keypad, either from a touch-screen controller or a bump bar. 
When the Recipe Viewer screen appears, the Recipe Viewer keypad is in focus and overrides the 
commands on the bump bar. When you press Close on the Recipe Viewer keypad, the commands 
revert back to the original commands configured for the bump bar. 

To use an embedded URL in recipe viewer: 

1. From the Kitchen screen, select Task Info. The Recipe Viewer screen appears with the Recipe 
Viewer keypad. 

2. Select the Links button. The ‘Pick item’ screen appears.   

Figure 103  Recipe Viewer Keypad to Bump Bar Button Equivalency

Figure 104  Pick Item Screen

recipe viewer key-
pad

bump bar
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3. Select the link and then touch Select. A website opens in a supported browser. 
4. Complete the required task, such as watching a training video. 
5. Touch Close to exit the screen. 

Note
If you do not have an Internet connection, the ‘Pick item’ screen does not appear.
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Introducing Forecast Bin Estimate report 

The data used for the existing Forecast report reads historical sales information from four previous 
weeks of subdirectories, or from NCR BackOffice, to predict the quantity of items needed in the bin 
for a specific time interval. You can also set a minimum quantity required for the time interval in the 
Forecasting function for instances where the quantity from the historical data might dip below the 
number needed in the bin; however, the Forecast report does not respect the minimum quantities. 

Effective in Aloha Kitchen v19.1.8, we introduce a new Forecast Estimate report which includes the 
required minimum quantity. This allows sites to compare the historical sales information in a more 
efficient manner and better operate their business. In addition, you can choose a future day within the 
next two weeks so you can increase your forecast outlook.  

Version Tracking 
Number Products Audience

AK v19.6 ALOHAP-05417 Aloha Kitchen, Aloha Quick Service, Aloha Table 
Service 

Configuration Technician
End User

Figure 105  Forecast Estimate Report

Reference
Refer to the HKS359 Forecast Bins Feature Focus Guide for information on configuring and using 
forecast bins. 

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS359&actp=search&viewlocale=en_US
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Introducing Production Assembly Line 

Many quick service restaurants utilize a make-line type of operation where one kitchen employee is 
responsible for adding or preparing one part or section of a menu item, and it is then passed to 
another employee to add or prepare the next part. The ingredients are pulled from individual ‘hotel 
pans’ displayed in front of the employee. The flow continues until the menu item is completely built. 
You see this concept in restaurants that serve burgers, pizzas, steam-table buffet lines, sandwiches, 
subs, Mexican food, and many other environments. 

This type of operation:

● Enforces consistency through repetition. 
● Requires limited training. 
● Creates a more efficient and effective production environment. 
● Increases your speed of service to each consumer who walks through the door. 

To accommodate this environment, Aloha® Kitchen uses production assembly line screens where the 
configuration spans across several functions. You design the production screens to simulate the 
layout of the hotel pans on the make-line. When an order appears on the screen, the ingredients 
needed to fulfill the order appear highlighted on the screen so the employee can easily build the item 
and move on to the next order.  

Version Tracking 
Number Products Audience

AK v19.6 ALOHAP-08806 Aloha Kitchen, Aloha Quick Service, Aloha Table 
Service 

Configuration Technician
End User

Figure 106  Make-Line Environment Illustration

Reference
Refer to the HKS1548 Production Assembly Line Feature Focus Guide for more information. 

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS1548&actp=search&viewlocale=en_US
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Communicating with the Aloha POS using Aloha API and COM 

Effective in Aloha® Kitchen (AK) v19.2, AK can communicate with the Aloha POS using Aloha API or 
COM, based on the installed version of the Aloha POS. This provides seamless communication 
between the two Aloha products. This new approach resolves isolated routing issues, such as when 
items and orders do not appear correctly on production and expo screens. 

If you couple Aloha Kitchen with POS v15.1, or earlier, AK communicates through COM. If you 
couple Aloha Kitchen with Aloha POS v19.6, or later, AK communicates through the Aloha API. The 
connection occurs automatically, including upon an upgrade, and there is no configuration required 
for this implementation. 

Version Tracking 
Number Products Audience

AK v19.2 ALOHAP-12229
ALOHAP-21735

Aloha Kitchen, Aloha Quick Service, Aloha Table 
Service 

Configuration Technician
End User
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Enhancing production chits in Print Designer  

With delivery and takeout operations continuing to expand in the marketplace, restaurants want more 
flexibility in designing the kitchen chit (production chit) to meet their operational needs. The kitchen 
chit is used at various end-points during the life of an order. It first serves as a communication to the 
kitchen staff to assist with proper preparation of an order. You then staple it to a bag or lay it on a tray 
for delivery by a food runner. Finally, the consumer receiving the order uses it to verify the order is 
correct. In summary, the kitchen chit acts as the printed representation of the order, reduces the 
number of errors in preparation, and must be organized so that it is beneficial to each actor. 

Now you can use the production chit layout in the Print Designer function to implement any of the 
following enhancements to organize the kitchen chit. 

● Group and print items based on categories. 
● Apply line attribute overrides, such as bold and italics, to menu items and modifiers on the 

kitchen chit. 
● Assign an image to each menu item, for printing on the kitchen chit.

Version Tracking 
Number Products Audience

AK v19.2 ALOHAP-14190
ALOHAP-15157
ALOHAP-15483
ALOHAP-15640
ALOHAP-15801
ALOHAP-16814
ALOHAP-17725

Aloha Kitchen, Aloha Quick Service, Aloha Table 
Service 

Configuration Technician
End User

Figure 107  Enhanced Production Chit Example
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● Assign an image to each modifier code, for printing on the kitchen chit.
● Associate a production chit with each order mode. 

Grouping and printing items by category 

Currently, items appear on the chit in the order in which you add them to the check, or using a 
defined priority. You can now group and print items using general (non-sales) categories to organize 
the kitchen chit. For example, you can group items by:

● Courses, such as appetizers, entrees, and desserts.
● Stations, such as grilled, fried, and cold.
● Length of time to prepare, such as two minutes, three minutes, five minutes. 

To do this, assign items to general categories in the Categories function, and then use the Chit Item 
Category Grouping function to group the categories. We recommend putting an item in only one of 
these categories. Once grouped, all production chit layouts defined in the Print Designer function 
use that grouping. Any item not assigned to a category within the grouping prints independently. You 
can configure only one Chit Item Category Grouping record, per store. If you later decide you do not 
want the grouping, delete the Chit Item Category Grouping record. 

To assign items to a general category:

1. With Kitchen selected in the product panel, select Maintenance > Menu > Categories. 
2. Click the New drop-down arrow, select General, and click OK. 
3. Type a name for the category, such as ‘Apps.’
4. Select the Items tab. 
5. Select an item from the ‘Available’ list and click >> to move the item to the ‘Included’ list. 
6. Repeat step 5 to include each item in the category. 
7. Click Save. 
8. Repeat this procedure until you assign all necessary items to a category. 
9. Exit the Categories function. 

Reference
Refer to the HKS375 Print Designer Feature Focus Guide for more information on configuring and 
using Print Designer.

Figure 108  Grouping Items on Kitchen Chit Example

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS375&actp=search&viewlocale=en_US
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To assign categories for chit item category grouping:

1. With Kitchen selected in the product panel, select Maintenance > Hardware > Print Designer 
Configuration > Chit Item Category Grouping. The Chit Item Category Grouping function 
appears.  

2. Under the ‘Groupings’ group bar, click Add. 
3. Select a category to include in the production chit grouping from the ‘Category’ drop-down list. 

Category — Allows you to select a general category to include in the grouping. The order in 
which a category appears here is the order in which it prints on the production chit. Documented 
Version: AK 19.3. 

4. Type the name to identify the category in ‘Group Header,’ if different than the default text. 

Group header — Denotes the name to appear for the grouping on all production chit layouts 
created in Print Designer. The name of the category appears as the default text, but you can use 
an alternate name that is more descriptive or friendly. To have more than one category appear as 
though it belongs to a single category, type the same group header for each applicable category. 
Documented Version: AK 19.3. 

5. Repeat steps 2 through 4 until you group all the necessary categories. 
6. Click Save and exit the Chit Item Category Grouping function. 

Figure 109  Chit Item Category Grouping Function
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Applying Line Attribute Overrides to Menu Items and Modifiers. 

Currently in Print Designer, you can configure elements to print in a smaller or larger font size and 
define the text alignment. Now you can add other basic text attributes, such as bold and italics, and 
print the element in a color of your choice. This allows an element to stand out while other elements 
print normally. 

Previously, the modifiers that accompany the menu items inherit the same attributes and there is no 
distinction between items and modifiers on a layout. We separated modifiers from the Items element 
and you can customize modifiers independently. For example, you can specify items to appear as 
large and in bold, and modifiers to appear as small and in italics. You cannot customize attributes for 
a specific item or modifier. 

To apply line attribute overrides to menu items and modifiers:

1. With Kitchen selected in the product panel, select Maintenance > Hardware > Print Designer 
Configuration > Print Designer. 

2. Select a production chit in use from the drop-down list. 

Figure 110  Line Attributes Applied to Item and Modifier
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3. Select the Design tab.  

4. Under the ‘Design’ group bar, click the Add drop-down arrow, select either Items or Modifiers, 
and click OK. 

5. Under the ‘Line attribute overrides’ group bar, select Use line attribute overrides. 

Use line attribute overrides — Enables you to use additional basic text attributes, such as bold, 
italic, and underlined, and to print the element in a color of your choice. This allows an element 
to stand out while other elements print normally. Selecting this option exposes the remaining 
options in the group bar. Documented Version: AK 19.3. 

6. Select the color in which to print the text of the element from the ‘RGB color settings’ palette, as 
desired. 

RGB color settings — Specifies the color in which to print the text of the element. The default is 
0.0.0. You must use a color printer. Documented Version: AK v19.3. 

7. Select Italic, as desired. 

Italic — Prints the text of the element in italic. Documented Version: AK v19.3. 

8. Select Underlined, as desired. 

Underlined — Prints the text of the element with an underline. Documented Version: AK v19.3. 

Figure 111  Print Designer - Design Tab
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9. Select Bold, as desired. 

Bold — Prints the text of the element in bold. Documented Version: AK v19.3. 

10. Repeat steps 4 to 9 for any other element for which to override the standard printing. 
11. Click Save and exit the Print Designer function. 

Printing an Image with a Menu Item 
You can designate an image to print to the left of a menu item on a production chit created in Print 
Designer. You may want to do this to promote signature items or identify generic items, such as an 
image of a drink for your drink items. You could also use an image to indicate the serving 
temperature recommended for items, such as HOT for a coffee, or use an image containing the first 
letter of an item, such as the letter B for a burrito.  

To designate an image to print to the left of a menu item on a production chit: 

1. Select Maintenance > Menu > Items > Item tab.  

Figure 112  Item with Image

Figure 113  Items - Items Tab
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2. Under the ‘Settings’ group bar, select the image to print to the left of the menu item from the 
‘Kitchen chit item image’ drop-down list. 

Kitchen chit item image — Designates the image to print to the left of the menu item on a 
kitchen chit, when using a production chit layout in Print Designer. You may want to do this to 
promote signature items or identify generic items, such as an image of a drink for your drink 
items. You could also use an image to indicate the serving temperature recommended for items, 
such as HOT for a coffee, or use an image containing the first letter of an item, such as the letter 
B for a burrito. We recommend using 22x22 as the dimensions for your image. Required 
Options: You must import the image using the Aloha Kitchen application type in the Media Files 
function to make the image available in the drop-down list. Documented Version: AK v19.3.

3. Click Save. 
4. Repeat this procedure for any other menu item for which to designate an image. 
5. Exit the Items function. 

Printing an Image Based on Modifier Code. 

You can designate an image to print to the left of a modifier code on a production chit created in 
Print Designer. You might use a plus sign for a modifier added to an item (Add), a minus sign for a 
modifier removed from an item (No), and others. You could also use an image with the word ADD or 
NO. 

Figure 114  Modifier Code with Image
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To designate an image to print to the left of a modifier code on a production chit:

1. Select Maintenance > Menu > Modifier Codes. 

2. Select a modifier code. 
3. Under the ‘Settings’ group bar, select the image to associate with the modifier code from the 

‘Kitchen modifier image’ drop-down list. 

Kitchen modifier image — Designates the image to print to the left of a modifier code on a 
kitchen chit, when using a production chit layout in Print Designer. You may want to use a plus 
sign for a modifier added to an item (Add), a minus sign for a modifier removed from an item 
(No), and others. You could also use an image with the word ADD or NO. We recommend using 
22x22 as the dimensions for your image. Required Options: You must import the image using the 
Aloha Kitchen application type in the Media Files function to make the image available in the 
drop-down list. Documented Version: AK v19.3.

4. Click Save. 
5. Repeat this procedure for any other modifier code for which to designate an image. 
6. Exit the Modifier Code function. 

Figure 115  Modifier Codes Function
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Associating a Production Chit Layout with an Order Mode 
You can associate a production chit layout designed in Print Designer for use with a specific order 
mode. For example, to print a production chit layout specifically for takeout orders, attach the layout 
to the Takeout order mode. Aloha Kitchen uses the layout to print the chit each time you place a 
takeout order. This option overrides the default layout selected in the ‘Item chit layout’ drop-down list 
in Maintenance > Kitchen Configuration > Kitchen Settings. 

To associate a production chit layout with an order mode:

1. With Kitchen selected in the product window, select Maintenance > System Settings > Order 
Mode. 

2. Select the Kitchen tab. 
3. Select an order mode from the drop-down list. 

4. Select the layout from the ‘Print layout override’ drop-down list. 

Print layout override — Specifies the production chit layout designed in Print Designer to use 
for printing the chit when you apply this order mode. Related Options: The ‘Print layout override’ 
option overrides the layout defined in Maintenance > Kitchen Configuration > Kitchen Settings. 
Documented Version: AK v19.3. 

5. Click Save. 
6. Repeat this procedure for each order mode for which to print an override production chit. 
7. Exit the Order Mode function. 

Figure 116  Order Modes - Kitchen Tab 
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Summary
In summary, you can implement all or any of these enhancements to customize the kitchen chit to 
meet your operational needs. You must use a production chit type in the Print Designer function. 
After all settings are in place in your configuration tool (Aloha Manager or Aloha Configuration 
Center), you must select Utilities > POS > Refresh POS and All Installed Products to transfer the new 
information to the FOH terminals, or wait for the End-of-Day (EOD) process to accomplish the data 
refresh for you. If you run the refresh prior to the End-of-Day process, select ‘Automatically restart all 
POS terminals’ and click OK to continue. After the data refresh is complete, all new settings become 
operational across the Aloha network. 
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Defining AK speed of service target for NCR Pulse 

You can now define the target speed of service and send data to an NCR Pulse user to see trending 
lines on graphical charts in red. This allows the Pulse user to monitor the status of orders in their 
restaurant. 

Prior to configuration, you must install the PulseAgent plug-in as a service to allow Aloha Kitchen to 
send data to Pulse. 

To install the AKPulse plug-in:

1. Obtain the PulseAgent.msi from the Pulse support team and place it in a staging directory. 
2. Run the PulseAgent.msi. Upon completion, the PulseAgent.exe appears in the Bootdrv directory 

and the PulseAgent service is started. 

Once you install the PulseAgent plug-in, you define the speed of service target, in minutes and 
seconds, at which to turn the graphical charts in Pulse to red. 

To define the speed of service target in Aloha Kitchen:

1. With Kitchen selected in the product panel, select Maintenance > Kitchen Configuration > 
Kitchen Settings.  

Version Tracking 
Number Products Audience

AK v19.6 ALOHAP-15251 Aloha Kitchen, Aloha Quick Service, Aloha Table 
Service, Pulse

Configuration Technician
End User

Figure 117  Kitchen Settings Function
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2. Under the ‘Pulse speed of service’ group bar, type the number of minutes to use for the target 
speed of service in ‘Target minutes.’ 

Target minutes — Specifies the target speed of service minutes for an order, from start to bump, 
before the lines on graphical charts in Pulse turn to red. The default is 0 (zero). Related Options: 
To specify the number of seconds for the target time, enter the number in ‘Target seconds.’ 
Related Requirements: You must be a Pulse user to use this feature. Documented Version: AK 
v19.3.

3. Type the number of seconds in ‘Target seconds’ to use for the target time for the speed of 
service. 

Target seconds — Specifies the target speed of service seconds for an order, from start to 
bump, before the lines on graphical charts in Pulse turn to red. The default is 0 (zero). Related 
Options: To specify the number of minutes for the target time, enter the number in ‘Target min-
utes.’ Related Requirements: You must be a Pulse user to use this feature. Documented Version: 
AK v19.3.

4. Click Save and exit the Kitchen Settings function. 

In the Pulse app, if an order exceeds the targeted minutes and seconds, the lines appear in red on 
the graphical charts. 

Figure 118  Pulse Tile Examples
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Printing rewards member on production or order taker chit 

You can now use Print Designer to configure text, such as ‘Rewards Member,’ to print on a 
production or order taker chit. The text prints when you assign a customer who has a Loyalty account 
to the check in the Aloha POS. The member number and any accrued or remaining point information 
do not print. 

Version Tracking 
Number Products Audience

AK v19.6 ALOHAP-18372
ALOHAP-23608

Aloha Kitchen, Aloha Quick Service, Aloha Table 
Service 

Configuration Technician
End User

Figure 119  Rewards Member Text on Chit
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To define the custom text to use for the ‘Rewards member’ print designer element: 

1. With Kitchen selected in the product panel, select Maintenance > Kitchen Configuration > 
Kitchen Settings.  

2. Under the ‘Orders’ group bar, type the text to print on the chit in Reward member text.’ 

Reward member text — Specifies the text to print on a production and order taker chit when 
you assign a Loyalty member to the check in the Aloha POS. Default: Rewards Member. 
Required Options: 1) You must use a production chit or order taker chit layout in the Print 
Designer function to use this option. 2) You must add the ‘Reward member text’ element in the 
Print Designer function to use this option. Documented Version: AK 19.3.

3. Click Save and exit the Kitchen Settings function. 

To add the Reward Member Text element to a production or order taker chit layout: 

1. With Kitchen selected in the product panel, select Maintenance > Hardware > Print Designer 
Configuration > Print Designer. 

2. Select a production chit or order taker chit in use. 

Figure 120  Kitchen Settings
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3. Select the Design tab.  

4. Under the ‘Design’ group bar, click the Add drop-down arrow, select Reward member text, 
and click OK. The element is added to the layout. 

Reward member text — Prints the text to indicate the consumer is a Loyalty rewards member. 
You must assign the consumer to the check in the Aloha POS to populate this element. Default 
Alignment: Center. Related Options: You can customize the text to print using ‘Reward member 
text’ in Maintenance > Kitchen Configuration > Kitchen Settings. Documented Version: AK 
v19.3. 

5. Click Move Up and Move Down to position the element on the chit. 
6. Under the ‘Print style settings’ group bar, configure the remaining options as you would any 

other element. 
7. Click Save. 
8. Repeat this procedure for any other production or order taker chit layout for which to add the 

‘Reward member text’ element. 
9. Exit the Print Designer function. 

Figure 121  Print Designer - Reward Member Text Element
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Supporting Custom Paid Line Text element 

Currently, when you tender a check, *** PAID *** appears on the printed kitchen chit, even when 
using the ‘Is paid’ element in Print Designer to customize your kitchen chit. You can now use the 
‘Custom paid line text’ element in Print Designer to define the text to appear on the kitchen chit when 
a check is tendered, such as PAID OUT. 

To configure the ‘Custom paid line text’ element: 

1. With Kitchen selected in the product panel, select Maintenance > Hardware > Print Designer 
Configuration > Print Designer. 

2. Select a layout that uses the ‘Production chit’ layout. 
3. Select the Design tab. 

4. Under the ‘Design’ group bar, click the Add drop-down arrow, select Custom paid line text, 
and click OK. The element is added to the layout. 

Version Tracking 
Number Products Audience

AK v19.6 ALOHAP-18376 Aloha Kitchen, Aloha Quick Service, Aloha Table 
Service 

Configuration Technician
End User

Figure 122  Custom Paid Line Text Element
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Custom paid line text — Allows you to define the text to appear on the chit when a check is ten-
dered, such as ‘PAID OUT.’ Use this element instead of the ‘Is paid’ element. Default Alignment: 
Center. Required Options: You must select ‘Show paid indicator’ in Maintenance > Hardware > 
Kitchen Screen under the ‘Order display’ group bar. Documented Version: AK v19.3.

5. Click Move Up and Move Down to position the element on the layout. 
6. Under the ‘Print style settings’ group bar, configure the remaining options as you would any 

other element. 
7. Under the ‘Custom paid line settings’ group bar, type the text to appear on the chit when a check 

is tendered in ‘Text.’ 
8. Click Save. 
9. Repeat this procedure for any other layout for which to add the ‘Custom paid line text’ element. 
10. Exit the Print Designer function. 
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Supporting Windows printer for drivers 

We support installation of the Epson TM-88 printer with Windows® printer drivers. These drivers 
have proven to print text and graphical images on a chit with more clarity. We recommend you use 
an Ethernet connection for your operations since an Epson TM-88 printer installed with Windows 
printer drivers may print slower in comparison to other printers. Using this implementation, you can 
also configure font attributes that override the default font and font size options for an element in the 
Print Designer function. For example, if you select ‘Large’ as the font size for an element in Print 
Designer, you can stipulate the font size for large as being 15 points in the Windows printer 
definition. While there is no option in the Print Designer function to specify the font type, you can 
override the default font using ‘Font name’ in the Windows printer definition.

To configure a Windows printer:

1. With Kitchen selected in the product panel, select Maintenance > Hardware > Printers. 
2. Click the New drop-down arrow, select Aloha Kitchen, and click OK. 

3. Type a name to identify the printer. 

Version Tracking 
Number Products Audience

AK v19.6 ALOHAP-18509 Aloha Kitchen, Aloha Quick Service, Aloha Table 
Service 

Configuration Technician
End User

Figure 123  Printers - Printers Tab
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4. Under the ‘Settings’ group bar, select Windows Printer from the ‘Mode’ drop-down list to 
expose the ‘Windows printer settings’ group bar. 

5. Select the terminal that uses the printer. 
6. Select the backup printer to use for the terminal. 
7. Under the ‘Windows printer settings’ group bar, type a name to identify the printer in ‘Printer 

name.’ 

Printer name — Uniquely identifies the printer. Documented Version: AK v19.3.

8. Select a font to use from the ‘Font name’ drop-down list, if desired. 

Font name — Specifies the font to use instead of the default font for chit printing. Documented 
Version: AK v19.3.

9. Select a font size to use for very small printing from the ‘Font size (very small)’ drop-down list, if 
desired. 

Font size (very small) — Specifies the font size to use for very small printing. The default is 5 
points. Required Options: This option overrides the default font size used for the ‘Very small’ 
choice for ‘Size’ on the Design tab in the Print Designer function. Documented Version: AK 
v19.3.

10. Select a font size to use for small printing from the ‘Font size (small)’ drop-down list, if desired. 

Font size (small) — Specifies the font size to use for small printing. The default is 7 points. 
Required Options: This option overrides the default font size used for the ‘Small’ choice for 
‘Size’ on the Design tab in the Print Designer function. Documented Version: AK v19.3.

11. Select a font size to use for medium printing from the ‘Font size (medium)’ drop-down list, if 
desired. 

Font size (medium) — Specifies the font size to use for medium printing. The default is 10 
points. Required Options: This option overrides the default font size used for the ‘Medium’ 
choice for ‘Size’ on the Design tab in the Print Designer function. Documented Version: AK 
v19.3.

12. Select a font size to use for large printing from the ‘Font size (large)’ drop-down list, if desired. 

Font size (large) — Specifies the font size to use for large printing. The default is 13 points. 
Required Options: This option overrides the default font size used for the ‘Large’ choice for 
‘Size’ on the Design tab in the Print Designer function. Documented Version: AK v19.3.

13. Select a font size to use for very large printing from the ‘Font size (very large) drop-down list, if 
desired. 
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Font size (very large) — Specifies the font size to use for very large printing. The default is 15 
points. Required Options: This option overrides the default font size used for the ‘Very large’ 
choice for ‘Size’ on the Design tab in the Print Designer function. Documented Version: AK 
v19.3.

14. Click Save. 
15. Repeat this procedure for any other printer using a Windows printer. 
16. Exit the Printers function. 
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Printing consumer name on production chit 

You can now print the consumer name to a production chit, using a custom production chit in Print 
Designer. You can customize the name in the following ways: 

● Print the first name only or not at all.
● Print the initials of the last name or not at all. 
● Print the first name and the initials of the last name on separate lines or not at all. 
● Configure the font size and style, as well as the alignment, of the consumer name on the chit. 

You capture the name of the consumer by naming a tab in Aloha Table Service or using the ‘Name 
Order’ function in Aloha Quick Service. If you use Aloha Takeout and enable kitchen integration, 
Aloha Takeout passes the consumer name from the guest record and overrides the name entered in 
the POS system. 

To customize the consumer name on a production chit:

1. With Kitchen selected in the product panel, select Maintenance > Hardware > Print Designer 
Configuration > Print Designer. 

2. Select a production chit layout from the drop-down list. 

Version Tracking 
Number Products Audience

AK v19.6 ALOHAP-18869 Aloha Kitchen, Aloha Quick Service, Aloha Table 
Service 

Configuration Technician
End User

Figure 124  Initial for Last Name on Custom Chit

Reference
Refer to the HKS694 Aloha Kitchen and Aloha Takeout Integration Guide for information on 
configuring and using the Kitchen Integration feature.

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS694&actp=search&viewlocale=en_US
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3. Select the Design tab. 

4. Under the ‘Design’ group bar, click the Add drop-down arrow, select Customer first name, and 
click OK. 

Customer first name — Prints the first name of the consumer on the production chit. Default 
Alignment: Left. Related Requirements: You must access Maintenance > System Settings > 
Order Modes and select ‘Parse order name for customer name’ to use this option. Documented 
Version: AK v19.3.6.

5. Click the Add drop-down arrow, select Customer last name first initial, and click OK. 

Customer last name first initial — Prints the initial of the last name of the consumer on the pro-
duction chit. Default Alignment: Left. Related Requirements: You must access Maintenance > 
System Settings > Order Mode > Kitchen tab and select ‘Parse order name for customer name’ 
for each order mode to use this option. Documented Version: AK v19.3.6.

6. Click Move Up and Move Down to position the element on the layout. 
7. Under the ‘Print style settings’ group bar, configure the remaining options as you would for any 

other element. 
8. Click Save. 
9. Repeat this procedure for any other layout to customize the consumer name on the production 

chit. 
10. Exit the Print Designer function. 

Figure 125  Print Designer - Design Tab
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In addition to adding the elements to print the consumer name on the production chit in Print 
Designer, you must also select ‘Parse order name for customer name’ for the order modes you use. 
This allows the system to bypass internal naming conventions of a check, such as ‘table #,’ and check 
#.’ 

To configure an order mode to parse the order name:

1. With Kitchen selected in the product panel, select Maintenance > System Settings > Order 
Mode. 

2. Select an order mode from the drop-down list.
3. Select the Kitchen tab. 

4. Select Parse order name for customer name. 

Parse order name for customer name — Bypasses internal naming conventions of a check, 
such as ‘table #’ and ‘check #,’ and allows the system to use Print Designer to print the consumer 
name on a production chit. Related Requirements: You must add either the ‘Customer first name’ 
or ‘Customer last name first initial’ element to a production chit in Print Designer to use this 
option. Documented Version: AK v19.3.6

5. Click Save. 
6. Repeat this procedure for each order mode to parse the order name. 
7. Exit the Order Mode function. 

Figure 126  Order Mode - Kitchen Tab
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Displaying checked-in icon and text on video screen 

When you integrate Aloha® Kitchen with Aloha Takeout, you can implement a curbside or call-ahead 
environment where the kitchen is notified when the guest arrives at the restaurant. This is usually 
triggered through a ‘checked-in’ function within Aloha Takeout and the message is then sent to Aloha 
Kitchen. 

Now a checked-in icon and custom text can appear on a header or footer layout of the video cell. This 
notifies the kitchen staff when a customer arrives and is waiting for their order, so they can prioritize 
and act appropriately.  

Version Tracking 
Number Products Audience

AK v19.3.6 ALOHAP-23513 Aloha Kitchen, Aloha Quick Service, Aloha Table 
Service 

Configuration Technician
End User

Figure 127  Checked In Indicator on Header and Footer Layout

Reference
Refer to the Curbside Management Feature Focus Guide for more information on the Curbside 
functionality. You can also refer to the Aloha Takeout and Aloha Kitchen Integration Guide for 
information. 
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To configure a kitchen screen to display a ‘checked in indicator and text’: 

1. With Kitchen selected in the product panel, select Maintenance > Hardware > Kitchen 
Screen. 

2. Select a kitchen screen in use. 

3. Under the ‘Display options’ group bar, type the text to use when a consumer arrives to pick up an 
order in ‘Customer checked in text.’ 

Customer checked in text — Denotes the text to appear when a consumer arrives to pick up an 
order. The default message is “Customer Checked In.” Required Options: You must select Main-
tenance > Kitchen Configuration > Header and Footer Layout and add the ‘Customer checked in 
text’ to a header or footer layout to display the text on a video cell. Related Requirements: You 
must select Maintenance > Takeout Configuration > Takeout Settings > Options tab in Aloha Take-
out and select ‘Enable kitchen integration’ to use this feature. Documented Version: AK v19.3.

4. Select Show checked in to allow the kitchen screen to display a ‘checked in’ icon. 

Show Checked in — Allows a ‘checked in’ icon to appear on the kitchen screen. Required 
Options: You must select Maintenance > Kitchen Configuration > Header and Footer Layout and 
add the ‘Customer checked in icon’ to a header or footer layout to display the icon on a video 
cell. Related Requirements: You must select Maintenance > Takeout Configuration > Takeout 
Settings > Options tab in Aloha Takeout and select ‘Enable kitchen integration’ to use this feature. 
Documented Version: AK v19.3.

Figure 128  Kitchen Screen Function
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5. Click Save. 
6. Repeat this procedure for other screens for which you want a checked in indicator and checked 

in text to appear. 
7. Exit the Kitchen Screen function. 

To configure checked in indicator to a video screen:

1. With Kitchen selected in the product panel, select Maintenance > Kitchen Configuration > 
Header and Footer Layout. 

2. Select a layout in use from the drop-down list. 
3. Select the Design tab. 

4. Under the ‘Elements’ group bar, click the Add drop-down arrow, select Customer checked in 
icon, and click OK. 

Customer checked in icon — Displays an image on the video cell to indicate a customer has 
arrived to pick their order. Related Options: Typically, you configure this feature with the ‘Cus-
tomer checked in text’ element. Related Requirements: You must select Maintenance > Takeout 
Configuration > Takeout Settings > Options tab in Aloha Takeout and select ‘Enable kitchen inte-
gration’ to use this feature. Documented Version: AK v19.3.

5. Click the Add drop-down arrow, select Customer checked in text and click OK. 

Figure 129  Header and Footer Layout - Customer Checked In Icon Element
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Customer checked in text — Displays text on the video cell to notify the kitchen a customer has 
arrived and checked in. Related Options: Typically, you configure this feature with the ‘Cus-
tomer checked in icon’ element. Related Requirements: You must select Maintenance > Take-
out Configuration > Takeout Settings > Options tab in Aloha Takeout and select ‘Enable kitchen 
integration’ to use this feature. Documented Version: AK v19.3. 

6. Arrange the placement of the elements as you would for any other element on a layout. 
7. Click Save. 
8. Repeat this procedure for each layout for which to configure a ‘Customer checked in icon’ and 

‘Customer checked in text’ element. 
9. Exit the Header and Footer Layout function. 
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Aloha Takeout v19.10 
Tracking Number Description

ALOHAP-03232 “Supporting manual check-ins from Aloha POS” on page 167

ALOHAP-12607 “Preventing an ATO check-in outside of release window” on page 171

ALOHAP-14143 “Adding VAT disclaimer to non-sales receipts” on page 173

ALOHAP-14029 “Using order modes to automatically close a check when payment received” on 
page 176

ALOHAP-15720 “Supporting lane locations” on page 179

ALOHAP-9094 “Configuring Aloha Takeout to use NCR BSP” on page 180

ALOHAP-30603 “Requiring source and destination record for online ordering injection” on 
page 1-181
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Supporting manual check-ins from Aloha POS  

This feature is still in development and is not yet fully functional. We will update the documen-
tation when the feature reaches optimal functionality.

When a consumer places an online order, a check-in process occurs when they arrive at the physical 
location. Either the Aloha Takeout (ATO) employee manually presses the Check In button on the ATO 
interface or, if the consumer used a cell phone app to place the order, an electronic device, such as 
a beacon records their arrival. Once the check-in occurs, the consumer either merges into a 
drive-thru lane (beacon technology) or gets in line at the counter to pick up their food. 

Some sites want manual check-ins to occur using the POS system without requiring the cashier at the 
counter or at the drive-thru window to access ATO, since this requires additional training on the ATO 
interface. Now you can perform a manual check-in from the Aloha POS without requiring access to 
ATO. 

Configuring manual check-ins from Aloha POS
To configure manual check-ins from the Aloha POS system, you must add a custom activity button in 
Screen Designer to interact with the ATO application. The supported panels for which you can add 
the button are Floorplan, Order Entry, and Close Screen in Aloha Table Service, and a regular panel 
in Aloha Quick Service. The custom text to add to the custom activity button is ORDER_CHECK_IN. In 
addition, you must configure the requirements for how you want the search capabilities to operate. 

To configure manual check-ins from the Aloha POS:

10. With POS selected in the product panel, select Maintenance > Screen Designer > Table 
Service Screen Designer or Quick Service Screen Designer. The screen designer function 
opens in a new window. 

11. Select Work with Panels. 
12. Select Panel > Open Panel, select a panel of the supported panel type, and click OK. 

Released 
Version

Tracking 
Number

Products Audience

ATO v19.6 ALOHAP-3232 Aloha Takeout, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User
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13. Select an available button, or select Panel > New Button to create a new button. The Properties 
dialog box appears. 

14. Under the ‘Function’ group bar, select Custom Activity from the ‘Action’ drop-down list. 
15. Type ORDER_CHECK_IN in ‘Custom Text.’ 
16. Under the ‘Appearance’ group bar, change the default text to descriptive text, such as 

‘Check-In.’ To display text on multiple lines, insert ‘\n’ without spaces to create line breaks. 
17. Configure the remaining options as you would for any other button. 
18. Select Panel > Save Panel and exit Screen Designer. 

To configure the requirements for checking in an ATO order from Aloha POS: 

1. Locate and open AlohaTakeoutOverride.xml. 
2. Navigate to the <CheckInOptions> section. 

3. Type DisplayNotificationOnAllTerminals as the value for ‘<CheckInAlert>.’ 
4. Type the terminal ID for which you want to display a check-in message as the value for 

‘<CheckInChitPrinterID>.’

Figure 130  Custom Activity Button Function

Figure 131  AlohaTakeoutOverride.xml
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5. Type True as the value for ‘<EnableCheckInChitPrinting>’ to print the check-in summary chit 
upon check-in or type False if you do not want to print the chit. 

6. Type the search filters, separated by a semi-colon, to make available when searching for an 
order, as the values for ‘<CheckInScreenSearchOptions>.’ Available search filters include, 
AtoOrderId, ReferenceId, PhoneNumber, and Any, with ‘Any’ being a string search across all 
other filters and the button appears as ‘Search.’ 

7. Type the maximum number of orders to appear on the screen when you perform a search, as a 
parameter for ‘<CheckInScreenMaxResults>. 

8. Type the amount of detail, separated by a semi-colon, that appears for each order as the values 
for ‘<CheckInScreenDisplayData>. Available options include OrderName, ReferenceId, 
OrderNotes, DisplayContactPhoneNumber, DisplayTotal, Subtotal, and Tax. 

9. Type True as the value for ‘<AllowCheckInClosedOrders>’ to return only tendered and closed 
checks or type False to return only open checks. 

10. Type True or False as the value for ‘<PreventCheckInOutsideReleaseWindow>.’ If set to False, 
only orders that released within the defined release window appear in the search result. 

11. Save AlohaTakeoutOverride.xml.
12. Restart the ATO application and service. 

Performing manual check-ins from the Aloha POS
You can check in an ATO order using a button on the Floorplan panel, Order Entry panel, or Close 
screen panel in Aloha Table Service, or a regular panel in Aloha Quick Service. Normally, these 
panels require you to have a check opened and displayed; however, checking in an ATO order does 
not affect or disrupt your current order. 

Order check-in custom activity accesses the ATO application in the background without displaying the 
ATO user interface. Once initiated, you can search for the ATO order either by order number, 
reference number, phone number, or using a global search string. 
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To manually check in an ATO order from Aloha POS:

1. When a consumer arrives at the restaurant and notifies you they are present, locate and touch the 
Check In button configured to interact with ATO. The Guest Check-In screen appears. 

2. Enter text in the search box and perform a search for the order using one of the following 
available options: 
Touch Search by Order ID to search by order number. 
Touch Search by Ref ID to search by reference number. The reference ID is an alternate order 
number generated by the Aloha Online Ordering product. 
Touch Search by Phone to search by the phone number associated with the ATO guest record. 
Touch Search to search across all available text strings associated with the order and guest. Be 
aware, this list may return many entries. 

3. If the search returns more than one result, touch the appropriate order in the list. If the search 
returns only one result, proceed to the next step. 

4. Touch Check In to check in the guest or touch Cancel to cancel the operation. 

Figure 132  FOH Guest Check-In Screen
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Preventing an ATO check-in outside of release window  

With the ‘Enable order release window restriction’ option, you can configure a start and end time of 
day during which the system can release an order to the kitchen. For example, if your store opens 
from 9:00 a.m. to 11:00 p.m., you can restrict the system to only send orders to the kitchen during 
those hours. This prevents sending orders to the kitchen before or after business hours when kitchen 
staff is not present. When selected, you define the start and end time during which you want the 
system to release orders to the kitchen. 

Now this configuration also prevents an ATO check-in from occurring outside of the release window. 
For example, if you configure the system to automatically check in an order using a beacon, and a 
vehicle arrives in the drive-thru after the release window, the arrival will not trigger a check-in. If you 
configure the system for a manual check-in, an employee cannot accidentally check in an order after 
the release window. 

Enable order release window restriction — Restricts the time frame when the system can 
release an order to the kitchen. This prevents the sending of orders to the kitchen before or after 
business hours when the kitchen staff is not present. For example, if the customer submits a web 
order to a site at 1:00 a.m., with a promise time of 5:00 p.m. the same day, Aloha Takeout sees 
this as a same day future order. If you also select ‘Release current day future orders immediately,’ 
the order fires to the kitchen immediately at 1:00 a.m. Subsequently, if the End-of-Day runs at 
3:00 a.m., the order then closes to cash. When selected, other options appear.

Released 
Version

Tracking 
Number

Products Audience

ATO v19.6 ALOHAP-12607 Aloha Takeout, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User

Figure 133  Preventing an ATO Check-in Outside of Release Window
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Release window start time (in 15 minute intervals) — Designates the time you want the sys-
tem to begin releasing orders to the kitchen. Required Options: You must select ‘Enable order 
release window restriction’ to enable this option. 

Release window end time (in 15 minute intervals) — Designates the time you want the sys-
tem to stop releasing orders to the kitchen. Required Options: You must select ‘Enable order 
release window restriction’ to enable this option. 
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Adding VAT disclaimer to non-sales receipts 

Value Added Tax (VAT) is used in some regions in place of a ‘sales’ tax.’ Each entity in the sales 
chain pays a VAT. Much like sales tax, if you have proper documentation, you may reclaim the 
portion of the VAT charged to you by your VAT registered suppliers. To reclaim the VAT on the 
purchases you acquired for your business you must have a valid VAT receipt (or VAT invoice) as 
proof of the purchase, and as proof that you paid the VAT on that purchase. If you do not have a valid 
VAT receipt, you cannot reclaim the portion of the VAT you paid that was already paid by your 
supplier. 

Each VAT registered supplier provides you with a VAT receipt showing details of the sale, including 
the sale date, the supplier’s VAT registration number, and the amount paid for the goods or services. 
Most importantly, it shows the amount of VAT the supplier charged to you, if applicable. A VAT 
receipt can be in either paper or electronic format.

A new option in the configuration management tool (Aloha Configuration Center or Aloha Manager) 
allows you to print a disclaimer on all non-sales receipts, indicating they are ‘NOT A VALID VAT 
RECEIPT.’ The default value for this option is False. For locations that require VAT, you must change 
the value of this option to True. 

Released 
Version

Tracking 
Number

Products Audience

ATO v19.6 ALOHAP-13490 Aloha Takeout, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User

Note
This text does not appear on non-sales receipts printed from the POS system.
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To enable printing the Non-VAT receipt warning:

1. With Aloha Takeout selected in the product panel, select Maintenance > Takeout 
Configuration > Settings.

2. Select the Printing tab. 

3. Under the ‘Printing’ group bar, select Print non-VAT receipt warning. The default text appears 
on the bottom of the chit subject to any text restrictions already defined, such as line length.

Print non-VAT receipt warning — Allows you to print a ‘NOT A VALID VAT RECEIPT’ dis-
claimer on all non-sales receipts. 

4. Click Save and Close to exit the Takeout Settings function. 

Figure 134  Print Non-VAT Receipt Warning

Note
Change the verbiage or the language of the default warning message using the Translation Editor 
utility, if necessary. The text you choose must not exceed the allowed line length. 
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To change the default text for this option:

1. Use File Explorer to browse to Bootdrv > AlohaTakeout > Utilities > TranslationEditor > Bin 
and double-click TranslationEditor.exe.

2. Select the language for your location. In this example, the language is en-US. 

3. In the search box, type ‘NOT A VALID’ to locate the option in each of these sections:
○ Radiant.Hospitality.AlohaToGo.Common.PrintHelperBase
○ Radiant.Hospitality.AlohaToGo.Common.PrintInterceptServiceBase
○ Radiant.Hospitality.AlohaToGo.OrderManagement.ItemChecklistDocument
○ Radiant.Hospitality.AlohaToGo.OrderManagement.OrderChecklistDocument

4. You must type the desired text change in the second column of the option for each section listed.
5. Click Done and exit the Translation Editor Utility.

Figure 135  Translation Editor Utility
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Using order modes to automatically close a check when payment received 

Aloha Takeout provides a global setting that allows the system to close checks automatically after 
applying payment. This ensures that online orders placed for dine-in or carry-out close seamlessly 
without building up the order queue on the FOH terminals; however, online orders placed for 
drive-thru pickup were also closing automatically, losing their place in the drive-thru order queue. 

This enhancement allows you to override the global setting, by order mode. For example, to prevent 
orders placed online for drive-thru pickup from automatically closing upon payment receipt, a new 
option allows you to specify that an order mode, such as the Drive-Thru order mode, can receive 
payment without automatically closing the check. This allows the order to remain in the correct 
position in the drive-thru queue. When the guest arrives at the pick-up window, you then press Close 
on the FOH terminal, to close the order.

Released 
Version

Tracking 
Number

Products Audience

ATO v19.6 ALOHAP-14029 Aloha Takeout, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User

Upgrade 
Path 

Upon upgrade, if the global option 'Close checks on apply payment' located on the Options tab under 
the 'Settings' group bar is selected, the system automatically selects the option of the same name 
located on the Order Modes tab. You must access each order mode for which you want to disable 
auto-close and clear this option. 
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To configure an order mode to prevent automatically closing the check upon payment 
receipt:

1. With Aloha Takeout selected in the product panel, navigate to Maintenance > Takeout 
Configuration > Takeout Settings, and select the Order Modes tab. 

2. Under the ‘Order Modes’ group bar, select or create the order mode for which to disable 
automatic check close on payment.

3. Under the ‘Settings’ group bar, select or clear Use quick location selection based on your 
operational needs.

Use quick location selection — Navigates directly to the check-in lane selection screen after a 
consumer enters their order number to check in, reducing the number of screen touches 
required to complete the order. When cleared, you can only select a check-in lane by touching 
the Lane button on the Order Confirmation screen after a consumer checks in. Related Require-
ments: Access Maintenance > Takeout Configuration > Check-In Locations to define the check-in 
lanes that appear for selection.

4. Clear Close check on apply payment.

Close check on apply payment — Automatically closes the check to the logged in employee 
when ‘Apply Payment’ is touched on the ATO FOH Pick Up or Dispatch screens. Clear this option 
if other employees, such as managers, apply payments to ATO orders, but allow other employees 

Figure 136  Aloha Takeout Settings, Order Modes Tab
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to close the check, or for order modes for which the order needs to remain in the queue. Options 
include: ‘Use value from Options tab,’ ‘True,’ and ‘False.’ Required Options: This option over-
rides the global option ‘Close checks on apply payment’ located on the Options tab under the 
‘Settings’ group bar. 

5. Click Save and Close to exit the Takeout Settings function
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Supporting lane locations  

ATO allows you to configure lanes to represent a designated spot or area at the restaurant used to 
specify such things as where a vehicle drives up for the guest to enter their order, or where the guest 
receives their order for pickup. Lanes are ideal for a multi-lane drive-thru environment or a carhop 
concept so the restaurant staff can easily identify where to bring the consumer order. 

Released 
Version

Tracking 
Number

Products Audience

ATO v19.6 ALOHAP-15720 Aloha Takeout, Aloha Quick Service, Aloha 
Table Service

Configuration Technician
End User

Figure 137  Multi-Lane Drive-Thru Concept

Reference
Refer to the HKS1670 Multi-Lane Drive-Thru Feature Focus Guide for more information about using 
lane locations to support the environment depicted in Figure 137. Please contact your NCR account 
representative for more information regarding carhop concept.

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS1670&actp=search&viewlocale=en_US
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Configuring Aloha Takeout to use NCR BSP  

The NCR Business Service Platform (NCR BSP) is cloud-based technology that provides a truly 
seamless guest experience for on-demand consumers, allowing them to access and interact with an 
authorized NCR partner using their mobile phone, a tablet, a desktop computer, a laptop, and more. 

In addition to the order services configurations introduced in ATO v17.1, and now you can configure 
ATO delivery service options to use and take advantage of NCR BSP to integrate cook times, delivery 
times and fees, driver management functions, and more. This allows you to provide a more accurate 
and dynamic experience for your delivery customers. 

The following enhancements streamline communication with ATO using NCR BSP.

Released 
Version

Tracking 
Number

Products Audience

ATO v19.6 ALOHAP-9094 Aloha Takeout, Aloha Quick Service, Aloha Table 
Service

Configuration Technician, 
End User

Reference
Refer to HKS1494 Aloha Takeout and BSL Integration Guide for complete information. 

Tracking 
Number

Enhancement

ALOHAP-19913 Send full or estimated price with time quote

ALOHAP-12203 Enhance ATO to use Driver API with BSP

HKS1494 Aloha Takeout and BSL Integration Guide
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Requiring source and destination record for online ordering injection  

As of ATO v19.x, you must define a Source and Destination record to address all order sources 
leveraged by an online ordering solution, such as a store website and a delivery marketplace. This 
enables the online ordering solution to inject orders into ATO. If this record does not exist, order 
injection fails. 

Released 
Version

Tracking 
Number

Products Audience

ATO v19.x ALOHAP-30603 Aloha Takeout, Aloha Quick Service, Aloha Table 
Service, Digital Ordering, Aloha Online Ordering

Configuration Technician, 
End User

Reference
Refer to Digital Ordering and Aloha Takeout Integration Guide - HKS1516 and the Source and 
Destination Feature Focus Guide - HKS380 for more information. 

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS1516&actp=search&viewlocale=en_US
https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS691&actp=search&viewlocale=en_US
https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS691&actp=search&viewlocale=en_US
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Other products included in the Aloha Solution
The following products are also included in the Aloha Solution:

Aloha Engage Mobile — Release notes are available on https://engage.readme.io/. A password is 
required. 

Aloha Insight / Aloha Loyalty / Stored Value / Customer Voice — Release notes are available 
within the product on the Enterprise website. 

Basic Loyalty (Consumer Marketing solution) — Release notes are not available at this time. This 
product is still in the SRT phase. 

Command Center — Release notes are available within the product. Select the Info icon on the right 
and then select Release Notes from the menu that appears. 

Configuration Center  — Release notes are available within the product. Select the Info icon on the 
right and then select Release Notes from the menu that appears. 

Digital Ordering  — Release notes are available on docs.ncr.com.

NCR Back Office for Enterprise — Release notes are sent to customers, as needed. 

NCR Mobile Pay — Release notes are available on docs.ncr.com. 

Pulse Real-Time  — Release notes are available within the app. 
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NCR Voyix welcomes your feedback on this document. Your comments can be of great value in 
helping us improve our information products. Please contact us using the following email address: 
Documentation.HSR@NCRVoyix.com

mailto:documentation.hsr@ncrvoyix.com
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