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 The purpose of this document 
This document contains instructions on how to set up and use the enhancements implemented in the 
Aloha® Solution 2026 enhancement release. In some instances, we combine features together to 
better explain the new enhancements. When applicable, we include a scenario, how to configure the 
feature in the Back-of-House (BOH), how to use the feature in the Front-of-House (FOH), and 
references to other materials to fully implement the feature. This document is not intended to fully 
explain a particular function or other options available or surrounding the function. This document 
does not guarantee the options are in the same location, nor that the functionality remains the same 
due to enhancements implemented in future versions of the affected products. 

What you need to know before installing Aloha Solution 2026
You need to know the following before installing Aloha Solution 2026. 

PCI Software Security Framework (SSF)
Aloha Solution 2026 is validated against PCI Software Security Framework (SSF) standards. PCI SSF 
is a collection of standards and programs for the secure design and development of payment 
software. Security of payment software is a crucial part of the payment transaction flow and is 
essential to facilitate reliable and accurate payment transactions.  

Reference
Refer to Aloha Solution Data Security Handbook Implementation Guide - HKS1653 for more 
information. 

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS1653&actp=search&viewlocale=en_US
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Setting the LAN Manager authentication level
The LAN Manager authentication level for Microsoft® Windows® 10 and 11 determines the response 
protocol used for network logons. For ATO to work properly, you must set the level to ‘Send LM & 
NTLM – use NTLMv2 session security if negotiated.’ This setting is for BOH only and cannot be 
performed during the RAL or ATO installation. Newer images are equipped with this requirement; 
however, you need to check this on your local computer and set the proper level. You must use an 
administrator account to set this. 

To set the LAN Manager authentication level:

1. Using the Windows search bar, search for and open the Local Security Policy app. 
2. In the ‘Security Settings’ tree, expand Local Policy.
3. Select Security Options. 
4. Under the Policy list, locate Network security: LAN Manager authentication level. The 

Properties dialog box appears with the Local Security Setting tab open. 
5. Select Send LM & NTLM – use NTLMv2 session security if negotiated from the drop-down 

list. 
6. Click OK. 
7. Exit the Local Security Policy app. 

Figure 1  LAN Manager authentication level
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Integrating with AlohaCP 
AlohaCP, previously known as Aloha Payment Service (APS), now integrates seamlessly with the 
Aloha POS system. Prior to this enhancement, when you set up Aloha to process payments through 
the NCR Voyix Payment Gateway (NPG), also known as Connected Payments, you had to: 

● Run the installation of Aloha POS. 
● Download AlohaConnectedPaymentsSetup.exe and separately install the NPG solution, which 

installs both APS and OpenEPS, is manifest-based, and installs a service on the Back-of-House 
(BOH). 

Effective in Aloha POS v19.9+, when you install Aloha POS, either interactively or silently, the 
installer automatically installs/upgrades AlohaCP for you. 

Reference
Refer to Alohas POS APS to AlohaCP Migration QRG - HKS1545 for more information. 

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS1545
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RAL (Remote Application Loader)

The PCI Least Privilege user requirement indicates that users of a payment application, such as the 
Aloha POS system, cannot carry more system privileges than strictly needed. Because of this require-
ment, the terminal user accounts no longer get administrative rights to perform registrations, installa-
tions, and other actions. To enable POS features and third-party applications to install via RAL, we 
provide a mechanism to support Chocolatey (Choco) package installation on the FOH terminals. 
Choco package files contain the instructions that RAL uses to install integrated and third-party applica-
tions on the FOH terminal, as well as perform actions necessary for the applications to function. Each 
application that relies on RAL for its FOH terminal installation must provide the terminal install Choco 
package with its own BOH installation. RAL now supports the Choco package installation for terminal 
configuration, as well as I/S related terminal configuration, on BOH devices. 

Reference
Refer to RAL v20.0 User Guide - HKS484 and Creating an Aloha Compatible Chocolatey Package - 
HKS1657 for detailed information. 

https://okm.ncrvoyix.com/resources/sites/OKM/content/staging/HKS_KNOWLEDGE/0/HKS484/en_US/11.0/RAL200_UserGuide-HKS484.pdf
https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS1657
https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS1657
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Aloha POS 
The following POS enhancements are included in the Aloha Solution 2026 Enhancement Release 
Guide: 

Aloha POS enhancements

“Scanning QR code for mobile payment with in-store API” on page 6

“Calculating suggested tip amounts based on portion the consumer pays” on page 9

“Enhancing Cash Discounts” on page 10

“Entering charitable donations using PIN pad” on page 11
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Scanning QR code for mobile payment with in-store API 

The Aloha POS system now supports printing a QR (quick response) code on the guest check to 
enable a seamless payment through the Sunday App. Consumers can scan the QR code at the table 
and complete a transaction in the cloud.

The QR code contains a URL that includes a configurable base URL plus other variable components, 
such as the BSL EUID (Enterprise Unit ID) and the BSL OrderID. 

The QR code section on the guest check is surrounded by accompanying text, such as ‘short code’ 
text with a code to type if the consumer’s phone cannot scan the QR code when there is a technical 
issue when scanning the QR code. The QR code and short code are configurable in the Print 
Designer function in CFC.

When coming from BSL, this information is captured from the ‘Additional Reference Ids’ and can be 
saved in the POS as order attributes, which the printed QR code can automatically locate and print.

You need to configure the QR section on the guest check with accompanying text, such as ‘Scan here 
and pay and go,’ and any other messaging such as a website link and backup code to type of the 
consumer’s phone is unable to scan the code. 

Configuring a QR Code in Aloha POS:
You must add the QR Code element to a guest check layout in Print Designer. As with any new layout 
in Print Designer, you must schedule an event for activation. 

To configure a QR code in Aloha POS: 

1. Select Maintenance > Hardware > Print Designer. 
2. Select a guest check layout in use from the drop-down list. 

Version Tracking Number Products Audience

POS v19.13
CFC v21.23

ALOHAP-42077 Aloha Quick Service, Aloha Table 
Service

Configuration Technician
End User

Reference
Refer to the Print Designer Feature Focus Guide HKS375 for more information on using Print 
Designer. 

https://okm.ncrvoyix.com/resources/sites/OKM/content/live/HKS_KNOWLEDGE/0/HKS375/en_US/QSTS_PrintDesignerFFG-HKS375.pdf
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3. Select the Design tab. 

4. Under the ‘Design’ group bar, click the Add drop-down arrow, select QR Code, and click OK. 
5. Position the QR Code element, using the Move up and Move down buttons. 
6. Under the ‘Print style settings, group bar. select Large from the ‘Size’ drop-down list. 
7. Select Default from the ‘Alignment’ drop-down list. 
8. Under the ‘QR Code Info’ group bar, enter the URL in ‘QR code (URL).’ 
9. Select the model type, such as ‘Model1.’ 
10. Enter the size of the QR code, such as 255. 
11. Select the data integrity method level to use for error code correction (ECC). 
12. Enter the short code (URL), such as ‘Short Code%7BQRShortCode%7D.’ 
13. Click Save and exit the Print Designer function. 

Figure 2  Print Designer - Design Tab
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Printing QR code and short code on the check
The QR code prints when the following conditions are met:

● The QR code URL with tokens is configured in CFC, such as ‘%Token%,’ and needs to be set on 
the check being printed. The QR code URL with tokens are enclosed with a %, such as 
http://integratorExample.com/%OrgID%/%OrderID%

● At least one token configured in the QR URL is set on the check being printed by 
SetObjectAttribute, where the value of the token is set on the corresponding check.

The short code prints when the following conditions are met:

● The above QR code URL conditions must be met.
● The short code is configured in CFC. The short code is enclosed with a %, such as 

%QRshortcode%.
● The above configured token for the short code (QRShortCode) is set on the check by 

SetObjectAttribute.

To print the QR code and short code on the check:

1. Log into the POS as a manager and add items to the check. 
2. Log out or goto a new check to unlock the guest check. 
3. Set the object attributes for OrgID and OrderID and the short code which are automatically 

added by ATG to the POS Trans log.
4. Log into the POS as a manager and navigate to the check with the added items.
5. For Quick Service, navigate to the panel containing your manager functions, and click Print 

Receipt. 
For Table Service, click Close, and then Print. 

The consumer opens the camera and scans the QR code. The code displays a URL with OrdID and 
OrderID, as defined with the configured URL. 
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Calculating suggested tip amounts based on portion the consumer pays 

Currently, the suggested tip amount is based on the full check total; however, when making a split or 
equal payment involving multiple consumers, the suggested tip amount is the same across all 
individuals. 

Effective in Aloha POS v19.13, the suggested tip amount is now calculated on the portion of the 
check the individual consumer pays. This ensures the total tip amount is distributed proportionately 
when multiple payments are applied to the check and the consumer sees the suggested tip amount 
that is applicable to their portion of the payment. 

As part of this enhancement, the suggested tip amount that is applicable to the portion the consumer 
pays, also appears on the PIN pad. 

Version Tracking Number Products Audience

POS v19.13
CFC v21.23

ALOHAP-42245 Aloha Quick Service, Aloha Table 
Service

Configuration Technician
End User
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Enhancing Cash Discounts 

Cash discounting is a pricing model where a restaurant offers a discount on listed, stated, or standard 
menu prices for consumers willing to pay in cash. Support for cash discounting started with Aloha 
POS v19.12+, using a percentage-based comp that automatically applies for a cash transaction. The 
system calculates the discounted amount for you and applies it to the check on the Point-of-Sale 
(POS). 

Effective in POS v19.12, we enhanced the solution and added logic for certain scenarios. 

● The cash discount is calculated from the subtotal of the check and recalculates the discounted 
amount each time you make an adjustment.

● When you delete the cash tender from the check, the discounted amount is also removed.
● When you void an item on the check after you apply the cash discount, the discounted amount is 

removed and you must reapply the cash discount tender.
● When you apply an overpayment of cash, such as $25.00 for a $20.00 check, the cash discount 

still calculates on the $20.00 amount. Similarly, when you apply a cash payment that is less than 
the check amount, the cash discount only calculates on the applied amount, leaving a balance 
due.

● When you split the check, the discounted amount calculates and appears for each seat/check.
● When you adjust the payment on the check, the discounted amount recalculates, as normal.
● You must apply a cash payment first before applying a non-cash payment.
● The ‘Equal Pay’ feature in Aloha Table Service is not supported with cash discounts. If a cash 

discount was already present, it is removed from the check when you initiate the ‘Equal Pay’ 
function

Version Tracking Number Products Audience

POS v19.12
CFC v21.23

ALOHAP-42666
ALOHAP-43076

Aloha Quick Service, Aloha Table 
Service

Configuration Technician
End User

Reference
For more information about Cash Discounts, refer to Supporting Cash Discounts in Aloha POS 
v19.12+ - HKS1742. 

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS1742
https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS1742
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Entering charitable donations using PIN pad 

Consumers can now contribute to charitable donations directly from the PIN pad during the 
transaction process, using Connected Payments. This provides a faster transaction flow and 
empowers the consumer to make their own donation decisions without the involvement of the cashier.  

Configuring charity donations using a PIN pad in Configuration Manager 
In Configuration Manager, configure the Charity Donations TAC to prompt for a donation amount on 
the PIN pad in use. 

To configure charity donations using a PIN pad in Configuration Manager:

1. Access Configuration Manager, and select the appropriate lane. 
2. Select the Terminal > Transaction Sequence tab. 

Version Tracking Number Products Audience

POS v19.13
CFC v21.23

ALOHACP-2837 Aloha Quick Service, Aloha Table 
Service

Configuration Technician
End User

Reference
Round It Up America is currently the only charity organization that supports this feature. Refer to the 
Round It Up America Feature Focus Guide - HKS318 for more information on configuring Round It 
Up America. 

Reference
Refer to the Connected Payments documentation for more information on Connected Payments. 

Figure 3  Configuration Manager - Terminal Tab

https://okm.ncrvoyix.com/resources/sites/OKM/content/live/HKS_KNOWLEDGE/0/HKS318/en_US/QSTS_RoundItUpAmericaFFG-HKS318.pdf
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3. Select the sequence you want to configure from the ‘Tender Type’ and ‘Transaction Type’ 
drop-down lists. Do not place the charity donation TAC in the Primary sequence.  

4. Drag the d - Charity Donations TAC to the top of the sequence. 
5. Repeat step 4 for each tender/transaction for which you want to prompt for a donation. Do not 

drag the TAC to any sequence that you do not want to display the prompt, such as Return, EBT - 
Balance Inquiry, Gift Card - Activate, Recharge, Balance Inquiry, and others.

6. Click >> next to Charity Donations to configure the prompts on the device on the TAC 
configuration screen. Charity donations has only one configuration screen and applies to all 
instances of the TAC, so you do not need to configure the TAC for each tender/transaction you 
place into the TAC. 
When the Donation TAC is used in the individual transaction sequence, instead of the first action 
sequence, it must be the first TAC in the sequence. To prevent a misconfiguration, when the d - 

Figure 4  Transaction Sequence Tab - Top Half

Figure 5  Transaction Sequence Tab - Bottom Half
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Donations TAC is found in an individual transaction sequence, the system moves the TAC to the 
start of the sequence and is processed first.  

The options on the Donation Type Selection tab only appear on the PIN pad if there are multiple 
charities configured in the POS, using the FieldData function call. Only one charity is currently 
supported for Aloha POS, OpenEPS does not display these messages. 

7. On the Donation Type Selection tab, type the text to appear in ‘Customer Display.’
8. Type the text to appear in ‘Cashier Display.’ 
9. Select the Donation Amount tab to define the text and predefined donation amounts, as well as 

determining if the ‘Other’ button and/or ‘Round Up’ button display. You can also add the 

Figure 6  Charity Donation TAC - Donation Type Selection Tab
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~CHARITY token to the text and it will be directly replaced by the name of the charity selected by 
the consumer (typically only if more than one charity is defined). 

Figure 7  Charity Donation TAC - Donation Amount Tab
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10. Select the Other Amount, Text Configuration tab to define the text displayed for the 'Other' 
button so the consumer can manually enter an amount to donate.

11. Click OK and exit Configuration Manager. 

Configuring charity donations using a PIN pad in CFC 
In Aloha Configuration Center, access the Store function and add the CHARITABLE_GIVING_VOID 
_REASON_CODE custom variable. If you do not add this variable, the system uses the first available 
reason code found in Rsn.dbf. Also ensure you have the CHARITABLE_GIVING_OPENITEM_TEXT 
custom variable in place.

Figure 8  Charity Donation TAC - Other Amount, Text Configuration Tab
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To add custom variables for charity donations:

1. In Aloha Configuration Center, select Maintenance > Business > Store. 
2. Select the Custom tab. 

3. Click Add and type CHARITABLE_GIVING_VOID _REASON_CODE in the ‘Setting name’ 
column, followed by the ID number of the reason code. 

4. Click Add and type CHARITABLE_GIVING_OPENITEM_TEXT in the ‘Setting name’ column 
followed by Charitable Giving or custom text of your choosing. This variable may already exist in 
your configuration. 

5. Click Save and exit the Store function. 

Figure 9  Store - Custom Tab
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Using Charitable Donations on a PIN pad
1. The employee accesses the guest check on the Aloha POS system. 

2. The consumer swipes, taps, or dips their card on the PIN pad device. The Donation Amount 
Round Up America screen appears on the device. 

Figure 10  Table Service FOH Screen

Figure 11  Donation Screen on PIN Pad Device
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In this example, the donation buttons are ‘$10.00,’ ‘Other,’ ‘Round Up,’ and ‘Skip.’ The Round 
Up button displays the amount of the check total rounded up to the next dollar, such as $0.53. 

3. The consumer performs one of the following options: 

○ Tap a pre-defined donation amount. 
○ Tap the calculated donation amount up to the next dollar, known as the ‘Round Up’ button. 
○ Tap Skip to not donate. 
○ Tap Other to donate an amount not listed and the other screen appears. Enter the amount 

using the keypad. 

Figure 12  Other Screen on PIN Pad Device
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Once complete, the donated amount appears on the guest check, along with the reason code. In 
this example, ‘Giving $0.53.’.  

4. Close the check as normal. 

Considerations:

● The following firmware files are added on the MX915 device to support Charity on PinPad 
○ P2P: dl-NCR-f5028x5401D1-USB-TWR-8dgtBinOff-230724.tgz
○ Donation form: dl-MX9XX_FORMDECK_files.tgz
○ VF Host tool: vfHostTermCom_3072.zip

● Using the VF host tool, first upload the P2P tgz file, then the Donation forms.
● The charity donation feature does not work for manual entry, or fallback to manual entry, on the 

Verifone MX915. 

Figure 13  Charity Donation Completed on FOH Screen
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Aloha Kitchen 
The following Aloha Kitchen enhancements are included in the Aloha Solution 2026 Enhancement 
Release Guide:   

Note
Aloha Kitchen is an add-on to Aloha Solutions and is not included as part of the Aloha Essentials 
core offering. 

Aloha Kitchen enhancements

“Supporting a repeating on-screen timer of seconds” on page 21

“Printing all items at once for an order on the expo station” on page 25

“Configuring order cursor to always return to the first video cell” on page 26
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Supporting a repeating on-screen timer of seconds 

Aloha Kitchen now supports a running on-screen timer in the metrics bar that repeats a countdown of 
a defined number of seconds. Once the countdown reaches 0 (zero), the number of seconds starts 
over. There is no interaction to restart the timer. 

SCENARIO: At the Grill station, employees must cook beef patties for 55 seconds on each side. 
With the on-screen timer, the employee monitors the first 55 seconds and flips the patty over when 
the timer counts down to 0 (zero) and starts over. When the timer counts down to 0 (zero) again, 
both sides of the patty are cooked. 

To configure a repeating on-screen timer of seconds:

1. Select AK from the product panel. 
2. Select Maintenance > Hardware > Kitchen Station. 

Version Tracking Number Products Audience

AK v19.14
CFC v21.22

AK-4226 Aloha Kitchen Configuration Technician
End User

Figure 14  On-Screen timer
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3. Select a station in use from the drop-down list. 

4. Under the ‘Settings’ group bar, select Enable On-Screen kitchen timer. 

Enable On-Screen kitchen timer — Provides a running on-screen timer in the metrics bar that 
repeats a countdown of a defined number of seconds. The timer automatically appears in the first 
available location in the metrics bar. User this option to gauge timed tasks performed in the 
kitchen, such as ensuring a beef patty is cooked for 55 seconds on each site. Related Options: 
This option exposes the ‘On-Screen kitchen time in seconds’ option. Related Requirements: To 
customize the position and style of the on-screen timer, access Maintenance > Kitchen Configura-
tion > Metrics to add a metric and return to the Kitchen Station function to customize. 

5. Type the number of seconds, up to 999, in ‘On-Screen kitchen time in seconds.’ 

On-Screen kitchen time in seconds — Specifies the number of seconds to repeat for the 
on-screen counter. Required Options: You must select ‘Enable On-Screen kitchen timer’ to 
expose this option. 

6. Click Save. 

Figure 15  Enable On-Screen kitchen timer
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7. Repeat this procedure for any other kitchen station requiring an on-screen kitchen timer. 
8. Exit the Kitchen Station function. 

The on-screen kitchen timer appears as a highlighted metric by default; however, you can customize 
the positioning and style of the metric. To do this, you must create a metric in the Metrics function 
and assign the metric to the kitchen station as you would for any other metric. 

To add the on-screen timer metric:

1. Select AK from the product panel. 
2. Select Maintenance > Kitchen Configuration > Metrics. 

3. Under the ‘Settings’ group bar, type a name for the metric, such as ‘On-screen Timer.’ 
4. Type a label to appear on the screen for the metric, such as ‘OST:’
5. Select On-Screen timer from the ‘Type’ drop-down list.
6. Configure the remaining options at your discretion. 
7. Click Save and exit the Metrics function. 

To customize the on-screen timer metric:

1. Select AK from the product panel. 
2. Select Maintenance > Hardware > Kitchen Station. 
3. Select the station on which you enabled an on-screen timer from the drop-down list. 
4. Select the Design > Metrics tab. 
5. Click Add. The system adds a blank row under the ‘Metrics’ group bar. 

Figure 16  Metrics function
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6. Under ‘Metric,’ select On-screen Timer from the drop-down list. 
7. Select Highlight to have the metric appear in bold. 
8. Click Move up and Move down to move the metric to the location you want to appear in the 

metric bar. 
9. Click Save. 
10. Repeat this procedure for another kitchen station requiring an on-screen kitchen timer. 
11. Exit the Kitchen Station function. 
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Printing all items at once for an order on the expo station 

A new ‘Print All’ option now appears for selection on the expo station flyout window when the 
expediter selects the order header of the video cell. This allows you to print a chit for each item in the 
order, followed by the order summary chit, in a single touch. The feature allows the kitchen to get an 
early start on packing and labeling containers for takeout orders and improves the overall efficiency 
of their takeout operation. There is no configuration for this enhancement. 

Version Tracking Number Products Audience

AK v19.14 AK-4232 Aloha Kitchen Configuration Technician
End User

Figure 17  Print All option

Tip
As with any item sent to the kitchen, you must route the item to a kitchen printer to print. 
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Configuring order cursor to always return to the first video cell 

Currently, when the expediter bumps an order that is not in the first video cell, the order cursor 
(highlighted cell) moves to the active order one position back in the queue. This behavior may lead 
the kitchen staff to waste time finding the order cursor in a long queue of orders and re-orienting 
their location on the bump bar during navigation. 

Effective in Aloha Kitchen v19.14, you can now enable the order cursor to always return to the first 
video cell in the queue, upon bump. This enforces consistency during the normal workflow and 
allows the employee to resume the normal flow of orders. It is especially helpful in navigation for 
bump bar users. Ultimately, this feature allows you to prepare orders chronologically. 

To configure the order cursor to always return to the first video cell:

1. Select AK from the product panel. 
2. Select Maintenance > Hardware > Kitchen Station. 

Version Tracking Number Products Audience

AK v19.14
CFC v21.22

AK-4289 Aloha Kitchen Configuration Technician
End User

Figure 18  Order Cursor



 Aloha Solution 2026, Enhancement Release Guide
Aloha Kitchen

27

© 2025 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

3. Select a station in use from the drop-down list. 

4. Under the ‘Settings’ group bar, select Return cursor to start of 1st on bump. 

Return cursor to start of 1st on bump — Enables the order cursor to always return to the first 
video cell in the queue. 

5. Click Save. 
6. Repeat this procedure any other kitchen station requiring the order cursor to always return to the 

first video cell. 
7. Exit the Kitchen Station function. 

Figure 19  Return cursor to start of 1st on bump
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Other products included in the Aloha Solution
The following products are also included in the Aloha Solution:

Aloha Engage Mobile — Release notes are available on https://engage.readme.io/. A password is 
required. 

Aloha Insight / Aloha Loyalty / Stored Value / Customer Voice — Release notes are available 
within the product on the Enterprise website. 

Basic Loyalty (Consumer Marketing solution) — Release notes are not available at this time. This 
product is still in the SRT phase. 

Command Center — Release notes are available within the product. Select the Info icon on the right 
and then select Release Notes from the menu that appears. 

Configuration Center  — Release notes are available within the product. Select the Info icon on the 
right and then select Release Notes from the menu that appears. 

Digital Ordering  — Release notes are available on docs.ncr.com.

NCR Voyix Back Office for Enterprise — Release notes are sent to customers, as needed. 

NCR Voyix Mobile Pay — Release notes are available on docs.ncr.com. 

Pulse Real-Time  — Release notes are available within the app. 
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NCR Voyix welcomes your feedback on this document. Your comments can be of great value in 
helping us improve our information products. Please contact us using the following email address: 
Documentation.HSR@NCRVoyix.com

mailto:documentation.hsr@ncrvoyix.com
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