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Preface
Is this guide for you?

The Aloha® Electronic Draft Capture (EDC) User Guide is intended for both the novice and 
experienced users of Aloha EDC. A new user might read the overview information for any given 
function to gain an understanding of what the function is and how it is designed to operate. An 
experienced user that already has the basic knowledge to use Aloha EDC might access this guide to 
learn about specific options, or to find out more about the various functions and screens in Aloha 
EDC, to gain a higher return on their investment.

This guide assumes you have the following knowledge:

● Basic understanding of restaurant terminology and concepts.
● Basic understanding of PCs and Microsoft® Windows®.
● Understanding of the operation of a computer mouse and keyboard.
● Basic understanding of how to work with Microsoft Windows-based menu structures and basic 

application components, such as scroll bars, buttons, drop-down lists, text boxes, radio buttons, 
and check boxes.

How this guide is organized
This guide is designed to help you familiarize yourself quickly with the Aloha EDC. It is organized as 
follows:

Chapter 1: About Aloha EDC
This chapter discusses the preparatory requirements for the Aloha EDC software. This includes the 
steps required to interface with the Aloha Point-of-Sale (POS) system, as well as instructions to set up 
the modem(s), processor(s), credit cards, and more.

Chapter 2: Interfacing the POS with Aloha EDC
This chapter discusses the available menu commands and their functionality within Aloha EDC, as 
well as how Aloha EDC works in relation to the Aloha POS system.

Chapter 3: Configuring Aloha EDC 
This chapter discusses tips for optimizing your use of the Aloha EDC program, processor errors, and 
installation guidelines.

Chapter 4: Using Aloha EDC
This chapter details how to use Aloha EDC Client.

Processor matrix
This appendix provides details of supported and non-supported processors.
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Field definitions
This appendix discusses tips for optimizing your use of the Aloha EDC program, processor errors, 
and installation guidelines.

Troubleshooting Aloha EDC
This appendix provides you with solutions when experiencing issues using Aloha EDC.

Index

System and hardware requirements
The system and hardware requirements for both the Back-of-House (BOH) and Front-of-House (FOH) 
depend on the Aloha POS version as well as the number of modules installed. 

Reference
Refer to the Aloha Solution Requirements Guide - HKS1626 for additional information regarding 
requirements for the Aloha POS system. 

https://okm.ncrvoyix.com/infocenter/index?page=answers&question_box_status=changed&question_box=hks-1626&lotusTik=lotusFlag_false&fac=CMS-STATUS.Published%2C&ichbox%5B%5D=en-US
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Introducing Aloha EDC
Aloha Electronic Draft Capture (EDC) is an application in the Aloha POS system suite of restaurant 
software products and is a critical component for operations that depend on payment cards, such as 
credit cards and debit cards, as a form of payment. It runs as a background process on the file server, 
constantly monitoring the system for payment card activity, and provides authorization and settlement 
capabilities for payment card transactions, using one or more processors of your choice. Depending 
on your merchant agreement, each processor will debit your merchant account for "processing fees" 
either monthly, daily, or both. You should become familiar with the agreement you have with your 
processors and be aware of the transactions for which you will incur a processing fee. 

What is authorization?

When a cardholder presents his or her card to you as payment, authorization begins. Aloha EDC 
transmits the information of the cardholder and the details of the transaction to the appropriate 
processor. The processor routes the information through the appropriate card network, either 
Banknet (MasterCard) or VisaNet (Visa), to the issuing bank of the cardholder to be approved or 
declined. The issuing bank verifies the information is valid and the cardholder has a sufficient 
balance or credit limit to make the purchase and sends a response code back through the card 
network to the processor, who in turn sends the response code back to Aloha EDC. If approved, 
Aloha EDC stores the transaction in a batch file, which is a group of transactions awaiting settlement. 
Authorization does not actually result in a charge on the payment card; think of it more as a temporary 
credit hold on the payment card until the approval code settles with a final amount, usually different 
than the authorized amount because of added tips or other edits. 

What is settlement?

Settlement is the process of sending and balancing already approved transactions in a batch file with 
the credit card processor. Usually, you settle batches on a daily basis, but it is possible to have 
multiple batches per day, or even batches that span multiple days. You begin by sending a batch file 
to your processor, typically at the close of each business day. The processor reconciles and transmits 
the batch of transactions to the appropriate card network. The processor deposits funds from the sales 
in the batch file to your merchant account. It is at this time that the transaction is final and the 
cardholder is billed. Do not wait too long to settle a batch; it is possible for the system to reject 
authorized transactions because the host system decided they were "discarded." In this event, you 
must enter and reauthorize the transactions again.

System and hardware requirements

Confirm your hardware meets the minimum requirements. Refer to RKS ID 10485 Aloha Hardware 
and OS Specifications to view the BOH file server hardware recommendations. Refer to RKS ID 
10486 Aloha POS and Order Entry Terminal Specifications to view the FOH terminal hardware 
recommendations. The FOH terminal hardware requirement list does not include peripherals, such as 
receipt printers, magnetic stripe readers, customer displays, and more.
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Installing Aloha EDC

For new installations and upgrades, beginning with Aloha EDC v14.1, it is a requirement to use Aloha 
Suite Installer. Refer to the Aloha Suite Installer Installation Guide - HKS1512. 

Things you should know
In this section, we provide information regarding the EDC folder structure, the EDC settlement 
process, and more.

Using CFC versus EDC Client
As early as EDC v7.0, you can use either Aloha Configuration Center (CFC)/Aloha Manager (AM) or 
Aloha EDC Client to configure EDC. This document assumes you are using CFC/AM to configure 
EDC. 

If you currently use CFC or Aloha Manager as your configuration management tool for the Aloha POS 
system, upon upgrade to EDC v14.1, it is highly recommended you also begin using CFC or Aloha 
Manager as the configuration management tool for EDC and that you not use EDC Client. 

Figure 1  EDC Applet in CFC (Left) and EDC Client (Right)

https://okm.ncrvoyix.com/resources/sites/OKM/content/live/HKS_KNOWLEDGE/1000/HKS1512/en_US/ASI_AlohaSuiteInstallerInstallationGuide-HKS1512.pdf
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Configuration changes made using EDC Client do not update EDC configuration in Aloha 
Configuration Center or Aloha Manager.

The best practice for configuring EDC once you migrate to CFC or Aloha Manager is to:

1. Enable Electronic Draft Capture in Configuration Center/Aloha Manager. 
2. Perform all EDC configuration necessary to make EDC operable at a store, or multiple stores, if 

applicable.
3. If using Configuration Center, select the Active Stores function, and move the appropriate 

stores to the ‘Active’ list. Note: Do not make a store active until you complete the EDC 
configuration required for that store. 

Overrides by CFC Exports
In EDC v14.1, any configuration in CFC/Aloha Manager overrides configuration performed directly 
in EDC Client (Edc.exe), if a record exists in Maintenance > Electronic Draft Capture > EDC Settings. 
Effective in v15.1, to prevent an accidental override from CFC if you continue to use EDC Client, 
navigate to the EDC folder and create a NoConfig file (no file extension). For example, 
D:\Bootdrv\Aloha\Edc\Noconfig.

EDC version independence
In earlier versions of the Aloha POS software, Table Service, Quick Service, and EDC all released on 
the same release schedule and you were required to use the same Aloha POS and EDC version 
number. Beginning with version 6.4, Aloha EDC became an independent application. It no longer 
relies on the installed version of the Aloha Quick Service or Table Service applications. This 
independence makes it possible to meet the ever-changing needs associated with payment cards 

Caution
Before you begin, be aware that CFC and Aloha Manager replace the existing EDC.ini file at each 
‘active’ store with an EDC.ini file containing the data you configure in CFC/AM. If you arbitrarily 
create a new record for EDC in CFC or Aloha Manager (click New and then click Save without 
actually making selections), a new record with established default values is written to EDC.ini. CFC 
and Aloha Manager read this as new configuration data and export a new EDC.ini file to the ‘active’ 
stores, essentially overriding the pre-existing EDC.ini for each active store.

Note
The debout.edc file notates the existence of the NoConfig file with the following: ‘Noconfig flag file 
has been found in EDC folder, it will not be allowed to configure EDC with EDC client.’
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without having to upgrade the entire Aloha POS installation. To support this version independence, 
we added EDC to Aloha Update as a separate product suite.

Terminal and host capture platforms
A Terminal Capture platform requires the system to temporarily keep card data for purposes of 
making adjustments, such as adding a tip to a check, and requires you to run a batch settlement 
process before you can receive the funds from the processor. A Host Capture platform processes the 
funds in real time and is more suited to an environment in which you do not make adjustments for 
things such as tips. Terminal Capture is the standard platform for all supported processors in EDC; 
however, EDC also supports Host Capture for the Vantiv, and Worldpay processors. Both provide the 
ability to use Host Capture in an environment where you can make adjustments, you just need to 
configure the processor accordingly. 

Point-to-Point encryption
Effective with Aloha POS v12.3 and EDC v12.3, or later, Point-to-Point Encryption (P2PE) provides 
sites regulated by Payment Card Industry Data Security Standards (PCI DSS) with the potential to 
reduce their compliance obligations. Using P2PE removes cardholder data from your environment by 
encrypting the data at the moment of capture, without the ability to decrypt. When the data is sent to 
a secure on-premises vault or the payment processor, Format-Preserving Encryption (FPE) is 
enforced. In the case of First Data, (CES), a token is provided to the Aloha POS system in place of the 
cardholder data.

Once you implement P2PE functionality, guests and employees can only process credit, debit, and 
EBT payment cards with the PIN pad device. Any attempt to slide one of these cards through an MSR 
attached to an Aloha POS terminal results in an error that guides you to use the PIN pad device 
instead. For other types of payment cards, such as gift cards, you still use a magnetic stripe reader 
(MSR).

In summary, the PIN pad device supports only the following transactions:

● Credit cards
● Debit cards
● EBT cards
● You must still use a magnetic stripe reader for these features:
● Employee MAG cards
● Gift cards

Note
While the EDC version is independent from the Aloha POS version, the major version of EDC must 
be at least equal to or greater than the Aloha POS version and must be a supported version.
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P2PE is an optional feature and is not implemented by default when you upgrade to an EDC version 
in which it is supported. Should you decide to implement P2PE, it is necessary to work with TSYS or 
First Data CES to ensure all requirements are in place and you order and receive the PIN pad devices 
preloaded with encryption software specific to your sites. If you currently pass payment information to 
the Aloha POS system from another Aloha application, such as Aloha Orderman, you cannot 
implement a P2PE solution at this time.

Understanding the Aloha EDC process
After you complete the installation requirements and start POS processing, EDC transactions process 
seamlessly from the FOH to the EDC server. The following explains the normal file process for credit 
card transactions, assuming POS processing is on and the EDC service is active.

What happens when I use EDC to apply, adjust, or void a payment?

1. The master terminal creates a request (.req) file in the \EDC folder on the site controller. 
2. EDC scans the \EDC folder for request files an average of once per second and, when found, 

immediately renames a request file to a hold (.hld) file of the same name in the \EDC folder, 
indicating that processing has begun.

Note
Refer to the Point-to-Point Encryption Feature Focus Guide - HKS374 for more information. 

Figure 2  EDC File Process

Note
If EDC does not receive a response (does not discover the request file) and you are not set up 
to perform mock authorizations, the FOH times out after three minutes, and an ‘Err/No 
Response’ message appears. The system deletes the request file, and you must request another 
form of payment from the guest. 
If you are set up to perform mock authorizations, the system activates spooldown mode, and 
converts the hold file to a spooling (.spl) file with the same name in the \EDC folder on the 
master terminal. If an \EDC folder does not exist on the master terminal, one is created at this 
time.

https://docs.ncrvoyix.com/downloads/aloha-pos/QSTS_PointtoPointEncryptionFFG-HKS374.pdf
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3. After EDC processes a request file, it writes the response from the processor to an answer (.ans) 
file in the \EDC folder and deletes the hold file. The ‘Approved’ field in the answer file indicates 
whether the action was successful, and the ‘Auth’ or ‘Error’ fields provide additional information.

4. EDC also writes the response to a transaction (.txn) file in the processor folder for the processor 
that will handle the batch for this transaction and deletes the answer file. Transaction (.txn) files 
are sequentially numbered, and are identical to the answer file.

When you make an adjustment to a transaction in the BOH, transaction and answer files are also 
generated. The FOH picks up the answer file and updates the FOH with the BOH changes. If the EDC 
program goes down while processing an action, then the hold file is left in the \EDC folder. When 
the EDC service starts, it scans for any .hld files. If EDC finds .hld files, it errors all of them out 
because it does not know if they processed or not. This is indicated by the 'HLD File not processed' 
error message.

What happens when I initiate batch settlement?

1. EDC creates a SETTLING marker file in the folder of the processor being settled.

2. EDC communicates with the processor and sends detailed information about all transactions in 
the folder to the processor for settling.

3. If settlement succeeds, EDC deletes the SETTLING marker file and attempts to archive the 
transactions in the folder by creating a settlement file called yyyymmdd.stl, where yyyymmdd is the 
current system date, not the Date-of-Business. If a settlement file by that name already exists, the 
system names the new settlement file yyyymmdd.A, yyyymmdd.B, and so on. Settlement files 
accumulate until you manually delete them or until you manually archive them for reporting 
purposes. 

4. If the system is able to archive the transactions in the folder, the system deletes the transaction 
(.txn) files and creates a SETTLED marker file. 

Note
If you settle a transaction using a processor other than the one that authorizes the transaction, 
the transaction file resides in the folder for the settlement processor rather than the folder for the 
authorization processor.

Note
Some processors support the ability to write rejected transactions in a batch to a separate file, 
allowing a merchant to settle a batch that would otherwise be rejected as a whole. The merchant 
must then review the rejected transactions and take the necessary actions. As of this writing, BA 
Merchant Services, First Data Buypass, First Data CES, First Data Nabanco, Paymentech, 
VisaNet, and Worldpay support removing rejected transactions from a batch into a separate file 
so that settlement can occur.
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-OR-
If the system is not able to archive the transactions in the folder, the following message appears 
five times, indicating you have a serious problem: “Settlement succeeded, but error nn occurred. 
CONTACT TECHNICAL SUPPORT and WRITE DOWN the settlement authorization (Error 
message x of 5).” This message indicates the batch successfully settled but was not cleared out, 
raising the risk of double-billing customers. Contact Technical Support, who may direct you to use 
the Force Settlement function. While rarely used, this function archives and clears out the current 
batch without performing any actual settlement with the processor. It is intended for use only 
when a batch successfully settles without the Aloha POS system knowing about it, such as when 
settlement is interrupted as described above, or when the processor manually settles a batch on 
their end to solve a problem. 

You also need to contact Technical Support if a batch settlement fails for a processor for which 
“Remove rejected transactions” is not supported. 

EDC folder structure
Normally, the primary EDC folder resides in the EDC folder under <Iberdir> on the BOH site 
controller, e.g. C:\Aloha\EDC, which you can override using the EDCProcPath environment 
variable.

The FOH uses EDCPath to find EDC on the server.

Under the EDC folder, each processor has its own folder. For example: \EDC\Amex or 
\EDC\Visanet.

Here is a description of the files found in the EDC folder:

File Description

EDC\Edc.ini EDC Configuration File

EDC\*req Request files from FOH

EDC\*.hld FOH requests currently being processed

EDC\*.ans Completed requests

EDC\Changed Marker file indicating to the FOH that at least one file has 
changed

EDC\ProcessorName\Txn* Txn files making up the current batch for the processor

EDC\ProcessorName\Settling Marker file indicating that settlement is currently in progress for 
the processor

EDC\ProcessorNameSettled Marker file indicating that settlement has been completed for the 
processor

EDC\ProcessorName\YYYYMMDD.stl Settlement file containing all of the txn* files for a settled batch
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EDC settlement process
The following steps occur during settlement:

● EDC creates a Settling file in the folder of the processor being settled.
● EDC dials out to the processor and sends detailed information about all of the transactions in the 

batch. The processor may approve or reject the batch.
● EDC deletes the Settling file.
● The txn file for the settlement transaction is written out.
● If settlement failed, nothing else happens.
● If settlement succeeded, Aloha EDC attempts to archive the current batch.
● A settlement file is created that contains a header with some batch information and the text of all 

.txn files in the batch. The name of the settlement file is typically YYYYMMDD.stl, where 
YYYYMMDD is the current date. If a settlement file already exists with that name, the settlement file 
is named YYYYMMDD.A, YYYYMMDD.B, and so on.

● If the settlement file is successfully created, the .txn files are deleted.
● A Settled marker file is created.
● If the archive batch process fails, it is a serious problem. Aloha EDC displays the following 

message five times: 'Settlement succeeded, but error nn occurred. Contact Technical Support 
and Write Down the Settlement authorization (Error message x of 5).' The reason this is serious is 
that the batch was settled, but was not cleared out for some reason. This raises the risk of settling 
the same batch twice and double-billing customers.

Configuring EDC outside of Bootdrv share
Aloha EDC is capable of storing data files related to credit card processing outside the established 
‘Iberdir’ path, by using the environment variable, EDCProcPath. This change affords more data 
security and customer protection by moving non-temporary files related to transaction authorizations 
and settlements outside the ‘Bootdrv’ share currently used by the Aloha POS system. Data not stored 
within the shared file structure is much less likely to be available to anyone entering the system from 
an external location. You can configure Windows and the Aloha POS system together to permit only 
the system administrator access to these files. Most likely you configured EDC outside the bootdrv 
share during installation.

To move non-temporary EDC files outside the Iberdir file structure:

1. Settle all pending batches, prior to continuing with this procedure.
2. On the EDC server (typically the Aloha BOH file server), create a new path for EDC outside the 

\Bootdrv file structure. For example, if the current file structure is C:\Bootdrv\ Aloha\EDC, you 
could use C:\AlohaEDC\EDC.

3. Log in to Aloha EDC and select File > Stop POS Processing.
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4. Log out, and close Aloha EDC, and close any remote instances of EDC running on other 
computers on the network, such as a manager workstation.

5. Stop the EDCSvr Windows service.
6. Create a new environment variable, EDCProcPath, specifying the new location for the EDC 

folder created above.
7. Move the contents of the old EDC folder to the new location.
8. Start the EDCSvr Windows service.
9. Open and log in to Aloha EDC.
10. Select File > Start POS Processing.

When you configure the system in this manner, the system (Aloha FOH, BOH, or Aloha EDC) writes 
all authorization request files (.req) to the default EDCPath, and the transaction (.txn) and settlement 
(.stl) files to the new EDCProcPath location. The system writes answer (.ans) files to the EDCPath 
location. The FOH deletes .ans files from EDCPath after processing the response, so the file remains 
in the shared path for only a short time. The system writes .stl and .txn files solely to the EDCProcPath 
location. EDCSvr reads the EDC.ini and other EDC files in the EDCProcPath location, and monitors 
the current EDCPath location for incoming .req files.

EDC and redundancy
1. Attempt to maintain live transaction authorization despite server failure.
2. Simulate live transaction authorization during server or network failure.

Redundant dial-out
Although dial-up connections are rarely used now, a few restaurants may have only one modem on 
the BOH computer that is used for EDC dial-out. If this is the case and the BOH goes down, you have 
lost EDC dial-out capability. Further, if you put a modem in the master terminal, and you run EDC on 
the master terminal as well as on the BOH, you have some EDC redundancy. Anytime the master 
terminal takes over as the file server, .req files begin to be spooled to the \EDC folder on the master 
terminal. If EDC is running on the master, it picks up those files and processes them. The only 
problem with this approach is that EDC currently does not ‘mirror’ the .txn files from the BOH on the 
terminals. Because of this, any transactions started before the file server went down will not be in the 
batch on the master terminal; therefore they cannot be adjusted or voided until the BOH recovers. 
New transactions rung after the BOH failure works normally. In this scenario, you must remember that 
there are two batches, one on the BOH and one on the master terminal. Each batch must be settled.

Note
The Aloha POS system assumes %Iberdir%\EDC as the default location for the environment 
variable, EDCPath. It is not necessary to create this variable, as the Aloha POS system assumes this 
location if you do not. If you want to use a path different from the default for EDCPath, create the 
new folder, and create a new environment variable, EDCPath, to match the new location. The 
EDCPath folder must be within the \Bootdrv location.
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Simulated authorization
Few restaurants install redundant modems, so a software-based approach is useful also. The Aloha 
POS system also supports a ‘fake’ authorization mode that allows FOH terminals to automatically 
authorize transactions when the BOH is down.

To enable this functionality, select ‘Allow authorization when EDC is offline’ in CFC > Maintenance > 
Business > Store > Store Settings > ‘Credit Card’ group > ‘EDC Setup’ group bar. Store and Forward 
is also available; to enable store and forward, select ‘Enable store and forward’ in CFC > 
Maintenance > Electronic Draft Capture > EDC Settings > EDC Settings tab > ‘Store and forward’ 
group bar. You can set a maximum amount of fake authorization; type the maximum amount in 
‘Maximum authorization amount’ in CFC > Maintenance > Business > Store > Store Settings > ‘Credit 
Card’ group > ‘EDC Setup’ group bar.

When EDC generates fake authorizations, they are spooled in the \EDC folder on the master terminal 
as .spl files; store and forward files are stored in %edcprocpath%\edc\processor\storeandforward. 
The master terminal debout indicates any ‘fake’ activity that occurs. The Aloha EDC program on the 
BOH server periodically scans the terminals and picks up these spooled transactions. This scanning is 
usually invisible, but the /DebugScan option on EDC will cause the Aloha EDC program to output 
detailed information into the Debout.edc file showing the scanning activity. When Aloha EDC picks 
up spooled transactions, it performs a real authorization at that point. Typically, the authorization 
succeeds, and the transaction is added to the current batch and is settled normally. ‘Fake transactions’ 
that successfully authorize print on the Aloha EDC batch report with ‘*’ next to them. If the 
authorization fails, the merchant is in jeopardy of losing money because the FOH allowed the sale to 
occur. Therefore, failed authorizations that were spooled using fake authorizations are selected at the 
bottom of the Aloha EDC batch report. The merchant should review these carefully, if they occur, to 
avoid losing revenue.

The /ScanRestrict FileName option on EDC will cause the scan to only pay attention to transactions 
from terminals where the \EDC folder contains FileName; this is helpful if you are running more than 
one copy of EDC and you want each copy of EDC to pick up transactions from only a particular set of 
terminals.

The ‘fake authorization’ mode is only activated when the BOH is down and the master terminal cannot 
open an .req file on the BOH server. If the BOH is up, fake authorizations do not occur, even if the 
Aloha EDC program is turned off and is not processing requests. This functionality is intended to 
handle hardware, not software, failures.
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When Aloha EDC attempts to authorize a transaction and EDC is unable to connect to the processor 
for some reason, it can take up to 45 seconds or longer before receiving a response. Store and 
Forward (SAF) allows you to set a timeout threshold, such as 10 seconds, for an authorization to 
occur. If EDC is not able to connect and receive a response from a processor within the allotted time 
frame, the system places that processor into the ‘store and forward’ state, meaning the system 
approves the transaction amount, if it is within the defined limits, stores the transaction, and attempts 
to authorize it again at a later time. EDC continues to provide immediate responses for subsequent 
transactions within the defined limits until it is able to re-establish a connection to that processor. 
Once successfully reconnected, Aloha EDC processes the stored transactions in the queue.

Anatomy of a transaction (.txn) file
Manually editing or otherwise manipulating .txn files is highly discouraged. However, when 
troubleshooting, it is useful and important to understand how they work.

The following fields are currently in .txn files: 

File Description

TYPE Type of action (Authorize, Preauthorize, Adjust, Void, Credit, Force, Settle, 
ForceSettle).

DOB Date of business

DATE System date

TIME System time

TERMINAL Originating terminal, or BOH.

MANAGER If manager approval was required, who did it.

EMPLOYEE FOH Employee performing the action.

TABLE Name of table or Quick Service order.

CHECK Check number.

PAYMENT Unique payment ID.

AUTHAMT Amount to authorize.

BATCHAMT Amount to settle.

BATCHTIP Tip amount to settle.

PROCESSOR Which credit card processor handles this transaction.

CARDTYPE Type of card (VISA, MC, Discover, and more).

CARD Card number, masked.

EXP Expiration (MMYY).

TRACK1 Track 1 magnetic card information, if available (encrypted).
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TRACK2 Track 2 magnetic card information, if available (encrypted).

REF Reference ID that identifies the batch transaction this action is updating. A 
transaction consists of all the txn files that have the same Ref ID.

APPROVED YES, if the action succeeded, NOT if failed for any reason.

AUTH Authorization code for successful authorization.

ERROR Error text for failed actions.

INFO Additional internal transaction information.

REASON For void actions, the explanation for the void.

NOCAPTURE Indicates that the authorization succeeded but the transaction is not allowed.

PROCNO Processor number of settlement processor.

FILENO Number of the txn file.

STANDALONE Yes, if the action occurred while the FOH was in fake authorization mode. 
Standalone transactions appear on the batch report with an ‘*’.

SECCODE Indicates that a CVV/CID code was presented to the processor.

PINDEX Processor index. Distinguishes the batch the transaction goes into when you have 
multiple simultaneous batches for a processor. Note: This setting comes from 
Terminal Maintenance in the EdcInfo field.

TERMID Terminal ID. This does not necessarily correspond to the Aloha POS terminal 
number. This is a specific terminal ID to be sent to the processor so that they can 
report on credit card activity by terminal. Note: This setting comes from Terminal 
Maintenance in the EdcInfo field.

File Description
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The following fields are used for check authorization only (Currently supported for Elavon BOH 
Processor only): 

Additional fields appear in txn files if the Aloha POS system is interfaced to a Property Management 
System (PMS). See Interfacing PMS with Aloha User Guide for further information.

This section provides lists of environment variables and command line options that impact Aloha 
EDC.

Environment variables that affect EDC

Command line options that affect EDC

File Description

MICR Magnetic Ink Character Recognition code along bottom of check

DLL Drivers license

CHECKNO Check number

STATE State

ZIP ZIP code

Environment 
Variable

Default Description

Iberdir C:\Aloha or C:\AlohaQS Root Aloha folder. Must be set for the current Aloha POS 
version for client\server remote access.

Datadir Data Subfolder of <iberdir> containing FOH configuration files.

EDCDir EDC Subfolder of <iberdir> containing EDC files.

EDCPath C:\Aloha\EDC
C:\Alohaqs\EDC
C:\Aloha\EDCProcPath

Full path of folder containing EDC files. 

PMSDir PMS Subfolder of <iberdir> containing PMS files.

PMSPath C:\Aloha\PMS or 
C:\Alohaqs\PMS

Full path of folder containing PMS files.

Command Line 
Option

Description

/NoMutex Do not enforce mutual exclusion. This means you can run more than one
copy of EDC at a time. Not usually recommended. Can be very hazardous.

/Iberdir xxx Overrides the Iberdir environment variable.
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/DataDir xxx Overrides the DataDir environment variable.

/EDCDir xxx Overrides the EDCDir environment variable.

/EDCPath xxx Overrides the EDCPath environment variable.

/PMSDir xxx Overrides the PMSDir environment variable.

/PMSPath xxx Overrides the PMSPath environment variable.

/DEBugExt xxx Changes the extension of the Debout file The default is EDC. When you
have multiple copies of EDC running, this option lets you specify different
extensions for their debugging output files.

/Title xxx Specifies text to display in the title of the EDC program window. Also useful when 
running multiple copies of EDC.

/ReportMode Runs in a mode that only allows the user to run batch reports. Sometimes useful for 
setting up extra copies of EDC on remote stations that do not interfere with regular 
EDC operation. /Iberdir is typically required if you are using /ReportMode on a 
remote machine, so that EDC can find the EDC.ini file and related security key 
information.

/ScanRestrict xxx Specifies that EDC is to scan for standalone transactions (.spl files) only
on FOH terminals that have an .xxx file in their EDC folder. Useful when running 
multiple copies of EDC in SuperSites.

/DebugScan Outputs detailed debugging information when scanning for .spl files on
FOH terminals. Not recommended for normal operation because of the
large volume of debugging, but can be useful in helping you understand
how EDC and redundancy work together.

Command Line 
Option

Description
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Downgrades
Downgrades are transactions that are charged at a higher rate than the preferred rate. Merchants 
become very unhappy when downgrades occur regularly. For a transaction to receive the preferred 
rate, the following must occur:

● The magnetic stripe from the card must be read. Manually keyed card numbers are downgraded 
because they present a higher risk of fraud.

● The transaction must be settled for an amount, which is not more than 20% over the original 
authorization amount, and not less than 20% below the original authorization amount.

Tip adjustments never dial out for additional authorization, no matter how large the tip. Tip 
authorization percentage is configurable, and defaults to 20%. This setting is in Aloha.ini as 
EDCAuthTipPercent and can be set from Aloha Manager under Maintenance > Store Settings > 
Credit Card Group. (Note: In Aloha.ini, 20% is represented as .20, not 20. In Aloha Manager, 20% 
is entered as 20, with no decimal point. This means that if a customer has a $10 order, the credit will 
be authorized for $12. As long as the settlement amount is between $9.60 (80% of $12) and $14.40 
(120% of $12), the transaction is not downgraded. This is normally the case. If the customer leaves 
more than a 44% tip, it is downgraded. Establishments that have a lot of very large tips might 
consider raising the default tip.
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Enabling EDC
Before you can use Aloha EDC to process transactions, you must establish the interface between 
Aloha EDC and the Aloha POS system. This chapter discusses the setup requirements within the 
configuration management tool, either Aloha Configuration Center or Aloha Manager, including 
making the configuration options available in the configuration management tool. 

To begin, you must enable EDC options to view the EDC features in the Aloha POS system. Once 
selected, you can set up EDC to use Aloha EDC or a third party payment application.

To enable EDC options to appear in the configuration management tool:

1. Select Maintenance > Business > Additional Features. (If using Aloha Configuration Center, 
log in as a corporate user, and access Maintenance > Business > Corporate Administration). 

2. Under the 'Options to display' group bar, select Display credit card. 
3. Click Save and exit the Additional Features function.
4. Log out of and back in to the configuration management tool. The Credit Card group now 

appears on the Store Settings tab in Maintenance > Business > Store. 

Reference
Refer to the Aloha Quick Service Reference Guide or Aloha Table Service Reference Guide for 
more information on options on the Credit Card group and the Tenders function.

Figure 1  Business - Additional Features

https://proddocsitesa.blob.core.windows.net/downloads/aloha-pos/QS199_ReferenceGuide.pdf
https://proddocsitesa.blob.core.windows.net/downloads/aloha-pos/TS199_ReferenceGuide.pdf
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To enable Aloha EDC functionality in the Aloha POS system:

1. Select Maintenance > Business > Store. 
2. Select the Store Settings tab.
3. Select the Credit Card group, located at the bottom of the screen. 

4. Under the 'EDC Setup' group bar, select Enable Electronic Draft Capture (EDC) to activate 
EDC functionality in the Aloha POS system. Selecting this option without selecting 'Use Aloha 
EDC' indicates you are using a third party system for credit card processing. 

5. Select Use Aloha EDC to indicate you are using the native Aloha EDC system for your credit 
card processing and not a third party system.

6. Click Save and exit the Store function.

Figure 2  Store Settings tab - Credit Card group
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Establishing EDC security parameters
In today’s world of technology, it is important to establish security parameters for non-cash payments. 
Use the procedure below to ensure the recommended safety practices.

To establish EDC security parameters: 

1. Select Maintenance > Business > Store. 
2. Select the Store Settings tab.
3. Select the Credit Card group, located at the bottom of the screen. 

4. Under the 'EDC Setup' group bar, select Only use track 2 credit card data if you want the mag 
card reader to only read track two of the magnetic stripe on the back of the credit card. 

5. Select Do not allow force authorizations to stipulate all credit card payments are to be 
electronically approved rather than forced to tender. If cleared, the 'Force' button does not 
appear on the FOH Close screen.

6. Select Cannot use same credit card twice in same day to prohibit the system from allowing 
the same credit card number for payment twice in the same business day. 

7. Specify the number of minutes, from 0 to 9999, at, or under which a guest can use the same 
credit card on the same day to make a purchase in 'Allow same credit card in same day if at or 
below minute threshold.' If a guest uses the same credit card outside of the threshold, manager 
approval is necessary. 

8. Specify the number of minutes, from 0 to 9999 over which a guest can use the same credit 
card on the same day to make a purchase in 'Allow same credit card in same day if greater than 
minute threshold.' If a guest uses the same credit card outside of the threshold, manager approval 
is necessary. 

9. Type the highest amount an employee can refund to a credit card in 'Maximum amount of credit 
card refunds.'

Figure 3  EDC Setup Group Bar
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10. Type the percentage of the order to add to the check total for authorizations in 'Add this tip % 
to total for authorization.' For example, if this tip percentage is set to 15%, and a customer 
charges $20.00 on a credit card, the authorization builds in 15% on top of the original $20.00 
for a total authorization of $23.00. There is a leeway of + or - 20% for restaurants and + or - 15% 
for retail before a downgrade fee is charged. If a restaurant does not have tipping, type 0. 

11. Select Display remaining card balance on partial approvals to allow the card balance of 
prepaid cards to appear on the FOH. If cleared, the card balance does not appear on the FOH. 
The card balance prints on the customer voucher; it does not appear on the merchant copy. 

12. Select Display warning message when transaction is processed offline to display a message 
on the FOH alerting the employee when EDC cannot connect to the system.

13. Select Authorize transactions less than 1.00 to indicate you want to allow credit payments that 
are less than a dollar. 

14. Select Include transactions authorized from BOH EDC on POS to enable an employee to 
process BOH EDC transaction from the FOH.

15. If using Quick Service, select the category of items from which guests can make purchases 
using their EBT food benefits card. Most laws require you not to include tobacco and alcohol 
items in this category. 

16. Select Show Last Settlement alert to indicate you want a warning message to appear on the 
Login screen letting you know you need to run a settlement. The 'Number of hours since last 
settlement' option appears. 

17. Type the number of hours that must pass since your last settlement before the warning message 
appears on the Login screen in 'Number of hours since last settlement.' 

Figure 4  EDC Setup Group Bar

Reference
Refer to the EBT Payment Cards Feature Focus Guide - HKS353 for detailed instructions.

https://docs.ncrvoyix.com/downloads/aloha-pos/QSTS_EBTPaymentCardsFFG-HKS353.pdf
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18. Select a processor, such as Elavon or Moneris, from the 'EMV Processor' drop-down list, to 
force employees and guests to insert or slide chip-enabled cards into a wireless PIN pad device 
to complete a transaction. If an employee attempts to slide the card using the MSR on an Aloha 
POS terminal, an error message, 'EMV enabled cards may not be swiped on POS terminals,' 
appears on the FOH; however, the employee can manually enter the card data at the Aloha POS 
terminal. 

19. If you select Moneris as the 'EMV Processor,' select Allow standard credit card processing 
on POS terminals to allow employees and guests to slide a chip-enabled card on a magnetic 
stripe reader (MSR) or enter the card manually on the FOH only as a backup method. Selecting 
this option may impede EMV functionality; however, if you do, you have the choice of having the 
FOH display an EMV liability warning message. 

20. Select Display EMV liability warning to enable the alert, 'Processing credit cards at this POS 
terminal could result in liabilities and fees due to EMV requirements. Would you like to 
proceed?' on the FOH when you use a chip-enabled card as a magnetic stripe card, or enter the 
card number manually in the FOH. 

21. Select Disable credit card adjustments to prevent an employee from making adjustments to 
credit card amounts. 

22. Click Save and exit the Store function.

Reference
Refer to the EMV Elavon Feature Focus Guide - HKS355 for more information.

https://docs.ncrvoyix.com/downloads/aloha-pos/QSTS_EMVElavonFFG-HKS355.pdf
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Supporting pre-authorizations
You usually use pre-authorizations in a bar tab environment. How you configure and use 
pre-authorizations in the Aloha POS system could determine if you are at risk for increased processor 
fees as a result of merchant policy changes from major card brands. If you currently use 
pre-authorizations, we recommend you turn this feature off, or, at the very least, turn off the 
subsequent authorization functionality, if applicable, as this functionality can cause multiple 
authorizations for the same check. If you continue using the pre-authorization feature without the 
subsequent authorization functionality and the final purchase amount exceeds the original 
pre-authorization amount by more than 20%, chances are you will still incur additional fees.

To support pre-authorizations in Table Service:

1. Select Maintenance > Business > Store. 
2. Select the Store Settings tab. 
3. Select the Credit Card group, located at the bottom of the screen. 

4. Under the 'Authorization' group bar, select Enable automatic pre-authorization to 
automatically contact the processor and perform a pre-authorization when the check total exceeds 
the amount in 'Initial pre-authorization amount.' 

5. Type the amount for the system to use for the first pre-authorization in 'Initial pre-authorization 
amount.'

6. Type the amount by which to increase the authorized amount when the guest check exceeds the 
pre-authorized amount in 'Subsequent pre-authorization amount.' For example, if the initial 
pre-authorization amount is $50.00 and the subsequent pre-authorization amount is $25.00, the 
next amount sent to the processor for pre-authorization is $75.00. 

Figure 5  Authorization Group Bar
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7. Type the amount at which the system warns the server when the guest check total is approaching 
the authorized amount in 'Threshold for subsequent pre-authorization.' The top of the FOH guest 
check window changes to red. 

8. Type the amounts from which an employee can choose after pressing the Preauthorization button 
on the FOH in '1st Preauthorization amount to be selected at POS' through '8th Preauthorization 
amount to be selected at POS.' Use these amounts to manually perform pre-authorizations when 
you do not activate automatic pre-authorizations. 

9. Click Save and exit the Store function.

Supporting offline authorizations
When the EDC server is offline, meaning it cannot connect to the processor for approval, you can 
have the system do a 'mock' authorization, meaning it can appear to approve the transaction so that 
you can go ahead and accept the card as payment. The transaction is 'spooled' and approved later 
when the EDC server is back online. You can minimize the risk involved in not receiving approval 
while the guest is still in your restaurant by establishing a maximum amount allowed for mock 
authorization. 

To support offline authorizations:

1. Select Maintenance > Business > Store. 
2. Select the Store Settings tab. 
3. Select the Credit Card group, located at the bottom of the screen. 

4. Under the 'EDC Setup' group bar, select Allow authorizations when EDC is offline to permit 
the FOH to perform 'mock' authorizations for sales less than a pre-defined amount if the EDC 
credit card server is down. When selected, if the FOH attempts to do a credit card authorization 
when the EDC server is down, a 'mock' authorization is done immediately and the transaction is 

Figure 6  Allow Authorizations When EDC is Offline
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spooled later for an actual authorization. An .spl file is created in the \EDC directory on the 
master terminal. As soon as the EDC file server becomes available, the EDC program on the 
server scans for spooled transactions (.spl files).

5. Type the maximum dollar amount to authorize when the server is down and the FOH is 
performing mock authorizations. 

6. Click Save and exit the Store function.

Supporting auto-detection of credit card type
The Aloha POS system offers the ability to automatically detect the card type based on the card prefix. 
In Quick Service the feature is referred to as Auto Detection of Payment Cards. In Table Service, this 
feature is referred to as Credit Card Lookup. Both allow you to slide a card across the magnetic stripe 
reader (MSR) or a proximity reader (RFID) without having to choose the type of card first, reducing 
the number of button touches required to close the check. The check must be appearing in the guest 
check window at the time of detection. 

Reference
Refer to the Credit Card Lookup in Quick Service Feature Focus Guide - HKS336 or the Credit Card 
Lookup in Table Service Feature Focus Guide - HKS1716 for detailed instructions on using this 
feature.

https://docs.ncrvoyix.com/downloads/aloha-pos/QS_CreditCardLookupinQSFFG-HKS336.pdf
https://docs.ncrvoyix.com/downloads/aloha-pos/TS_CreditCardLookupinTSFFG-HKS1716.pdf
https://docs.ncrvoyix.com/downloads/aloha-pos/TS_CreditCardLookupinTSFFG-HKS1716.pdf
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Supporting chip and PIN
Traditional magnetic stripe cards contain static data on the back of each card that can easily be 
duplicated using low cost equipment that is readily available for purchase on the Internet. Once 
duplicated, a criminal can use the copied card to commit fraud anywhere in the world that accepts 
the specific brand of credit card. Chip and PIN allows for dynamic information to pass through with 
each payment transaction. Because the data is dynamic and not static, duplication of any one card is 
very difficult, making Chip and PIN more secure.

To use Chip and PIN functionality in Aloha EDC: 

1. Select Maintenance > Business > Store. 
2. Select the Store Settings tab. 
3. Select the Credit Card group, located at the bottom of the screen. 

4. Under the 'EDC Setup' group bar, select Use Chip N Pin if your processor supports chip and 
PIN and you wish to use this functionality. Chip and PIN cards contain an embedded microchip, 
specifically constructed for interacting with Chip and PIN devices, that contains encoded 
cardholder data. Selecting this option enables the 'Minutes for EDC to wait before timeout' 
option. 

5. If using Chip and PIN, define the number of minutes for EDC to wait for credit card 
authorization from the processor before timing out, forcing you to tap the card again or select 
another form of payment, in 'Minutes for EDC to wait before timeout.'

6. Click Save and exit the Store function.

Figure 7  Use Chip N Pin
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Configuring voucher printing
Use the ‘Voucher print settings’ group bar to determine voucher print style, define your credit card 
masking, enter customized text, and more.

To configure basic voucher printing: 

1. Select Maintenance > Business > Store. 
2. Select the Store Settings tab. 
3. Select the Credit Card group, located at the bottom of the screen. 

4. Under the 'Voucher print settings' group bar, select Print a voided credit card slip when 
payment is deleted to print a voided receipt when you delete a credit card payment. The 
voucher reflects the full amount that was deleted, including the tip amount. 

5. Select Suppress cardholder name to prevent the name of the cardholder from printing on the 
credit card voucher. When using a magnetic stripe reader, the system replaces the 'Magnetic 
Card present: <cardholder name> line on the voucher with 'Magnetic Card present: Yes.' 

6. Select the printer at which to print a voucher when a card is declined from the 'Voucher printer 
for declined cards' drop-down list, regardless of signature rules you have in place that may 
prevent the printing of a voucher. This is helpful in environments for which there is either no 
immediate interaction with the guest, and you want to ensure someone sees and intercepts the 
decline voucher, providing you the opportunity to let the guest know to bring another form of 
payment. 

7. Select a labor group from the 'Limit declined card voucher printing to Labor Group' drop-down 
list to print a decline voucher only when the order originates from a specific labor group. Labor 
groups consist of specific job codes. This feature is helpful in situations where a guest is not 

Figure 8  Voucher Print Settings Group Bar
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present or on the telephone, such as with Aloha Online Ordering when instant approval is not in 
use, or future orders with saved credit card information.

8. Select Print check at master terminal printer when voucher prints to print an additional 
check at the master printer whenever a voucher prints at the voucher printer. 

9. Select Print check message on voucher to print the text from the active guest check message 
on the voucher. The active guest check is either message ID 01 or a guest check message you 
activate using a Set Guest Check Message event. 

10. Select a guest check message from the 'Print footer message on vouchers' drop-down list, to 
include a legal declaration in the footer of the voucher that states the guest is responsible for 
paying their debt. 

11. Select Print large text on voucher to print the text on the voucher in a larger font size. 
12. Select Use custom text on sales voucher to print custom text on the sales voucher, directly 

above the signature line. 
13. Type the custom text, up to 40 characters each, to print on the sales voucher in 'Custom text line 

1' and 'Custom text line 2.' For example, type 'Your account will be debited' in the first text box 
and 'in the above amount.' In the second text box.'

14. Type the text to indicate where the customer is to sign the voucher, such as 'Cardholder 
signature' in 'Text after signature line on sales voucher.'

15. Select Use custom text on refund voucher to print custom text on the refund voucher, directly 
above the signature line. 

Note
It is not necessary to select this option in environments where the decline message appears on 
the on-screen guest check, prompting you to request another form of payment.

Figure 9  Voucher Print Settings Group Bar
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16. Type the custom text, up to 40 characters each, to print on the refund voucher in 'Custom text 
line 1' and 'Custom text line 2.' For example, type 'Your account will be credited' in the first text 
box and 'in the above amount.' In the second text box.'

17. Type the text to indicate where the customer is to sign the voucher, such as 'Cardholder 
signature' in 'Text after signature line on sales voucher.'

18. Select the guest check message created just for printing a legal disclaimer on credit card 
vouchers for guest checks paid with a prepaid card. You must clear 'Do not print vouchers' in 
Maintenance > Payments > Tenders > Authorization tab for the prepaid card tender and create 
the legal disclaimer message in Maintenance > Messaging > Guest Check Message. 

19. Click Save and exit the Store function.

Configuring signature rules
For consumer convenience and faster service, some credit card companies allow merchants to waive 
a signature if the amount of the purchase is under a certain amount. In addition, credit card 
companies may offer a discount for purchases where you capture the card information using a 
magnetic stripe or RFID reader. The Aloha POS system offers the ability to configure signature rules 
based on the transaction amount, and how you capture the transaction, such as manually or offline, 
thus increasing the speed of service. 

To configure signature rules:

1. Select Maintenance > Business > Store.
2. Select the Store Settings tab.

Reference
Refer to “To designate this tender as one for which signature line rules apply:” on page 2-24 for 
information on how to designate a tender as one for which signature rules apply.
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3. Select the Credit Card group, located at the bottom of the screen. 

4. Under the 'Voucher print settings' group bar, type the amount up to which you do not require a 
guest signature for a transaction in 'Signature not required if check total is less than this amount.' 

5. Select Signature not required for Swiped Cards to apply signature rules to transactions for 
which you use a magnetic stripe reader to capture the card information. Clear this option to 
ignore signature rules and require a signature for all transactions for which you use a magnetic 
stripe reader to capture the card information. 

6. Select Signature not required for Tapped Cards to apply signature rules to transactions for 
which you use an RFID reader to capture the card information. Clear this option to ignore 
signature rules and require a signature for all transactions for which you use an RFID reader to 
capture the card information. 

7. Select Signature not required for Manually Entered Cards to apply signature rules to 
transactions for which you manually enter the card information. Clear this option to ignore 
signature rules and require a signature for all transactions for which you manually enter the card 
information. 

8. Select Require signature when transaction is approved offline to ignore signature rules and 
require a signature for all transactions processed while the system is in offline mode and cannot 
connect to the processor for approval. Clear this option to apply signature rules to a transaction 
even when it is processed offline. 

9. Select the number of vouchers, from 0 to 4, to print for each transaction from the 'Number of 
voucher copies to print' drop-down list. This option works with the Tenders function, when you 
select either 'Voucher' or 'Signature lines' from 'Print when the signature ceiling is met or 
exceeded.' 

10. Type the text to print on the first through fourth voucher copies. It is only necessary to type text 
for up to the maximum number of copies you are printing. 

Figure 10  Signature Rules
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11. Select the number of vouchers to print when the check amount is less than signature ceiling 
amount. 

12. If you select anything but None (0) in the prior step, select Print signature line on x voucher 
where x corresponds with the copy of the voucher, for each voucher on which to print a signature 
line.

13. Select the number of vouchers to print when the check amount is at or greater than the 
signature ceiling amount.

14. If you select anything but None (0) in the prior step, select Print signature line on x voucher 
where x corresponds with the copy of the voucher, for each voucher on which to print a signature 
line. 

15. Click Save and exit the Store function. 
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Creating a credit card tender
Before you can use EDC to process transactions, you must create the necessary tenders in the Aloha 
POS system. Depending on your operations, this could require several tender types, including 
'Credit card,' 'Debit,' 'Gift card,' and more. For the purposes of this guide, we focus solely on 
creating credit card tenders. If you support other types of payment cards in your operation, refer to 
the respective Feature Focus Guide for more information. Refer to the Table Service or Quick Service 
Reference Guides for detailed explanations of the options available in the Tenders function.

Credit card quick tips:

● You can use the auto-detect payment cards feature to minimize the number of buttons required on 
the Tenders screen and reduce the number of screen touches. For Quick Service, refer to the 
Auto Detection of Payment Cards Feature Focus Guide. For Table Service, refer to RKS ID 7317 - 
Supporting Credit Card Lookup to ensure this is how you want to operate within EDC. 

● Determine if you want to waive a customer signature if the amount of the purchase made with a 
credit card is under a certain amount and, if yes, configure credit card tenders to respect 
signature rules. 

● Establish the credit card provider on the Type tab in the Tenders function. 
● To create more secure credit card tenders, select 'Use Magnetic Cards ONLY' located on the 

Type tab to prevent manual credit card entry without manager approval. Clear 'Print on check' 
located on the Identification tab, to prevent the card account number from printing on the guest 
check. This option helps to prevent unauthorized use of credit card account numbers at the site. 
Refer to the Aloha POS Data Security Handbook for more information.

● For private label credit or gift cards, use ‘Prefix checking’ to define a valid prefix for these 
tenders.

The following procedure includes the required or suggested settings for setting up a credit card 
tender. 

To create a credit card tender:

1. Select Maintenance > Payments > Tenders.
2. Click the New drop-down arrow, select Credit card, and click OK.
3. Accept the system assigned number or click the ellipsis (...) next to ‘Number’ to display the 

Number Assignment dialog box, from which you can choose an alternate number.
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4. Under the ‘Settings’ group bar, type a name to identify the credit card, such as Visa. 

5. For Table Service, select First available button position to allow the system to place the tender 
button in the first available position of the FOH Close screen.

Figure 11  Tender tab

Figure 12  Select New Button Position - Table Service
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-OR-
Click the ellipsis (...) to display the Button Position dialog box and select an available position 
for the credit card tender. 

6. Select an image, such as the credit card logo, to appear on the button in place of the name, from 
the ‘Button image’ drop-down list.

7. Select the tender under which you want the credit card to report, if you do not want it to report 
as itself, from the ‘Report as’ drop-down list. 
-OR-
Leave the default value of Current if you want the credit card to report as itself.

8. Select how the tender behaves in the FOH when selected for payment from the 'Default amount 
behavior' drop-down list, if you want it to behave differently than the default choice of 'Ask for 
amount.' The other choices are 'Next highest amount,' 'Exact amount due,' and 'Specific 
amount.'

9. Select Active to make the tender available for use. If not active, an error message appears in the 
FOH when you select this tender for payment.

10. Select Can refund to indicate you can perform a refund for this tender from the Aloha POS FOH. 
You must select this option for non-cash tenders that allow refunds. An employee assigned to an 
Aloha POS access level with appropriate access must perform the refund. 

11. Clear Affect deposit since credit cards do not affect the total cash amount you have on hand for 
deposit. 

12. Select Print check on close to print a copy of the guest check at the time you close the check 
using this tender. To save paper, clear this option to turn off printing of the guest check at close 
in environments where you provide a copy of the guest check to the guest prior to applying 
payment. The guest typically does not require another copy of the guest check after you tender 
and close the check. 

13. Select Open drawer on close to open the drawer each time you apply payment and close a 
check to this tender.

14. Clear Print signature line. Use this option for non-cash tenders for which you require a 
signature from the guest, such as 'House account' and 'Property management' tender types. Do 
not confuse this option as one having to do with signature line rules that control when to print 
signature lines on credit card vouchers.

15. For Table Service, clear Combine on check. 
16. For Table Service, select Close check upon payment to automatically close a check when the 

payments applied to the check meet or exceed the guest check amount. 
17. For Table Service, clear or select Do not verify amount to determine the placement of the 

cursor on the FOH tender screen and whether you are able to change the amount to something 
less than the balance of the check. When you select this option, cursor focus is always just below 
the amount and you are unable to change the amount at all. When you clear this option, cursor 
focus is on the amount. You can change the amount to something less than the balance of the 
check but attempts to change the amount to something greater result in an error message. If the 
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tender allows tips, you can change the amount to something greater than the balance of the 
check; however, the system calculates the difference and moves the excess amount to the tip 
amount

18. Under the 'Tips' group bar, select Allow tips to allow guests to add a tip to the guest check and 
pay it with this credit card.

19. Enter the maximum allowable tip percentage in 'Maximum tip %.' Enter the percentage as a 
number and two decimal places. For example, enter a percentage of 50% as 50.00. 

20. For Table Service, type the percentage of tips to recover from employees for the cost of 
processing the transaction in 'Tip refund %.' Enter the percentage as a number and two decimal 
places. For example, enter a percentage of 50% as 50.00.

21. Select Remove tip line if auto gratuity to not print a tip line on guest checks paid with this 
tender, if you add an automatic gratuity. 

22. Select the Type tab. 

23. Under the 'Type settings' group bar, select the credit card provider from the drop-down list. 
Selecting a provider also selects 'Expiration,' which requires the entry of the expiration date when 
manually entering a credit card number. 

24. Select the surcharge to pass along to the guest to help recoup extra charges, such as the credit 
card processing fee, from the 'Apply a surcharge to this tender' drop-down list, if applicable.   

25. Under the 'Options settings' group bar, select Use magnetic card only to prevent an employee 
from manually entering a credit card number without manager approval when applying this 
tender as payment. To override this setting for a certain employee and allow them to enter the 
number manually without manager approval, select 'Manual credit card number' for the 

Figure 13  Type tab
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appropriate access level in Maintenance > Labor > Pos Access Levels, and then assign that 
access level to the employee.

26. Select Verify expiration to have the system compare the credit card expiration date against the 
system date to verify the card has not expired. 

27. Select Verify signature to display a prompt reminding the employee to verify the signature on 
the card matches the signature on the credit card voucher. 

28. For Quick Service, select Display tender screen on card swipe if you want the employee to 
verify the amount, or allow them to change the amount, applied to the card. If cleared, the system 
automatically sends the full amount of the transaction as soon as you slide the card across the 
reader. 

29. Click Save and continue to the next procedure.

To configure a credit card tender to be more secure: 

1. Select the Identification tab. 

2. Under the 'Identification' group bar, select Require identification to force employees to enter 
information, such as the card number, minimum and maximum digits to enter, and more. 
Selecting this option also enables the Security Verification tab, which allows you to establish more 
stringent security requirements, such as the entry of the zip code, for address verification, or the 
card security code (i.e. CVV, CID).

3. Type the text to prompt for the card number on the FOH tender screen, such as 'Card #,' in 
'Prompt.'

Figure 14  Identification tab
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4. Type the minimum and maximum number of digits required for the card number. The system 
supports payment cards up to 19-digit PANs.

5. Select Numeric only.
6. Clear Print on check.
7. Select the Security Verification tab. 
8. Under the 'Address' group bar, select Enter address verification code to require the entry of 

the cardholder's ZIP Code on the FOH Security Verification screen. Selecting this option enables 
the remaining options under the 'Address' group bar. 

9. Select Verify address on all cards to require the entry of the ZIP Code for all transactions, 
whether you enter the card number manually or electronically. Clear this option to prompt for the 
ZIP Code for manually entered card numbers only.

10. Type the minimum number of characters or digits you can enter for a ZIP Code in 'Number of 
characters.'

11. Select Numeric only to display a numeric keypad that only allows you to enter numeric values for 
the ZIP Code. Clear this option to allow the entry of characters from an alphanumeric keypad. 

12. Type the text to prompt for the ZIP Code on the FOH Security Verification screen in 'Verify 
address prompt.'

13. Under the 'Validation code' group bar, select Enter validation code to require the entry of the 
security code, such as the CVV or CID number printed on the exterior of a credit card, on the 
FOH Security Verification screen. Selecting this option enables the remaining options under the 
'Validation code' group bar. 

14. Select Require code entry to enforce the entry of the security code. A manager is not able to 
bypass the entry of the code. If you select this option, you have no choice but to enter the code or 
cancel the payment. 

15. Select For all cards manual or electronic to require the entry of the security code for all 
transactions, whether you enter the card number manually or electronically. Clear this option to 
prompt for the security code for manually entered card numbers only. 

16. Select Presence indicator to display additional buttons on the FOH Security Verification screen, 
allowing you to provide a reason for not entering the security code. If you also select ‘Require 
code entry,’ these buttons do not appear in the FOH. 

17. Select Print response code to print the response code returned from the processor for a 
security code submission on the voucher. 

18. Type the minimum number of characters required, up to 10, when entering the security code. 
For example, if the security code in your region contains three digits, select or type 3. 

19. Type the maximum number of characters required, up to 10, when entering the security 
code. You must select or type a number equal to or greater than the one chosen for 'Minimum 
number of characters required.' 

20. Select Numeric entry only to stipulate the entry of numeric values only for the security code. 
Clear this option to allow the entry of characters from an alphanumeric keypad. 
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21. Select Enter code twice to require the entry of the security code twice, when entering the card 
number manually instead of reading it electronically from a magnetic stripe reader. A Re-enter 
Code # prompt appears. Both entries must match before you can proceed. 

22. Type the text to prompt for the security code on the FOH Security Verification screen in 'Text 
to display on prompt.' You can enter up to 20 characters.

23. Click Save and continue to the next procedure. 

To establish prefix checking for a credit card tender:

1. Under the 'Prefix checking' group bar, type up to four prefixes to compare against the card 
number to ensure the card number is valid. 
-OR-
If you need to validate a range of numbers for this tender, not just a prefix, or have more than 
four prefixes to validate, select Validate to enable the Validation tab, on which you add a list of 
IDs or a range of IDs to validate against the account number entered on the FOH screen.

2. Select Include to stipulate the IDs on the Validation tab are valid IDs; select Exclude to stipulate 
the IDs on the Validation tab are invalid IDs.

3. Select the Validation tab and add the list of IDs or a range of IDS to validate against. 
4. Click Save and continue to the next procedure.
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To force the entry of an authorization code for a credit card tender:

1. Select the Authorization tab. 

2. Select Require authorization to force the entry of an authorization code, either one returned by 
Aloha EDC or one you manually enter, on the FOH tender screen.

3. Type the text, such as ‘Authorization #,’ in ‘Authorization prompt.’ This text appears on the FOH 
tender screen, and prints on the guest check if you also select ‘Print on check.’ You can enter up 
to 15 characters.

4. Type the maximum number of digits allowed for an authorization code in ‘Maximum length.’
5. Select Print on check to print the authorization code on the guest check.
6. Select Authorize using EDC to have EDC electronically return an authorization code. If you 

clear this option, you must manually enter an authorization code on the FOH tender screen 
before you can continue.

7. Click Save and continue to the next procedure.

Figure 15  Authorization tab
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To designate this tender as one for which signature line rules apply:

You define the requirements for signature line rules under the 'Voucher print settings' group bar in 
the Credit Card group on the Store Settings tab in Maintenance > Business > Store. Once defined, 
you then specify for which tenders the signature line rules apply. 

1. On the Authorization tab, select Apply signature line rules for vouchers. 
2. From the 'Print when the signature ceiling is met or exceeded drop-down list,' which appears 

when you select 'Apply signature line rules for vouchers,' select Signature lines to designate this 
tender as one for which signature line rules apply. The system prints all vouchers with signature 
lines when the payment is at or above the amount, but no vouchers when payment is below the 
amount.
-OR-
Select Voucher to designate this tender as one for which signature line rules DO NOT apply. The 
system prints all vouchers with signature lines regardless of the payment amount.
-OR-
Select Both to designate this tender as one for which signature line rules apply and the selections 
under the 'Voucher print settings' group bar in the Credit Card group control the number of 
copies to print when the payment is at or above the amount, when it is below the amount, and on 
which copies to print a signature line. 

3. Click Save and exit the Tenders function. 

Reference
Refer to “Configuring signature rules” on page 13 for information on how to configure signature 
rules.
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Providing the ability to perform a credit card refund
To provide the ability to perform a credit card refund from the Aloha POS FOH to offset a transaction 
for a closed check that was ordered incorrectly or when a guest asks for their money back, you must 
give an employee, such as a manager, an access level with sufficient access to perform a credit card 
refund. The Aloha POS access level controls performing a refund from the Aloha POS FOH. To 
perform a refund from the BOH using Aloha EDC, an employee must have a sufficient BOH security 
role. 

To provide the ability to perform a credit card refund from the Aloha POS FOH: 

1. Select Maintenance > Labor > Pos Access Levels.
2. Select an access level, such as ‘Manager,’ from the ‘POS Access Level’ drop-down list. 

3. Under the ‘Financial’ group bar, select Credit card refunds.
4. Click Save.
5. Repeat this procedure for other access levels that need the ability to perform a credit card 

refund.
6. Exit the Pos Access Levels function.

Figure 16  Pos Access Levels - Financial Group Bar
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Providing the ability to resend a failed credit card transaction (QS 
only)

In Quick Service, employees with the required access level can now resend a transaction that fails 
due to the network connectivity, time-outs, or for actual declines to the host without additional card 
slides from the guest. If the card is declined again, resending the transaction results in additional 
transaction fees.

To provide the ability to resend a failed transaction: 

1. Select Maintenance > Labor > Pos Access Levels.
2. Select an access level, such as manager, from the ‘POS Access Level’ drop-down list. 

3. Under the ‘Financial’ group bar, select Resend failed credit card transaction to enable any 
employee clocked in with this access level to send a failed transaction to the host again for 
authorization.

4. Click Save.
5. Repeat this procedure for each access level that needs the ability to resend a failed credit card 

transaction.
6. Exit the Pos Access Levels function. 

To add a Resend Failed Credit Card Transaction button to a panel:

1. Select Maintenance > Screen Designer > Quick Service Screen Designer.
2. Select Work with Panels.

Figure 17  Pos Access Levels - Financial Group Bar
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3. Select Panel > Open Panel, select a panel, such as ‘Mgr Functions,’ and click OK. 
-OR-
Create a new panel.

4. Right-click the panel and select New Button. The Properties dialog box appears. 

5. In the Properties dialog box, select Resend Failed Credit Card Transaction from the ‘Action’ 
drop-down list. 

6. Under the ‘Appearance’ group bar, type a name for the button, such as ‘Resend Credit Card. To 
display text on multiple lines, insert ‘\n’ without spaces for line breaks. 

7. Configure the remaining options as you would for any other button. 
8. Select Panel > Save Panel and exit the Quick Service Screen Designer function. 

Figure 18  Resend Failed Credit Card Transaction
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Adding text to clarify decline error messages
When an electronic payment declines, an error message appears on the front-of-house (FOH) 
terminal. Each processor sends a unique set of error messages; the wording of which may confuse 
employees. Due to the difference between the processors and the messages they provide, it is 
difficult for restaurants to effectively train their employees. Using the Aloha POS system, you can 
define additional text to appear when the original electronic payment decline error message fails to 
instruct the cashier on what steps to take to assist the guest. 

To add additional text to clarify decline error messages: 

1. Select Maintenance > Messaging > Custom EDC Response Messages.
2. Click New. 

3. Type a name for the custom EDC response messages.

Tip
We recommend you contact your processors and obtain a complete list of all possible electronic 
payment decline error messages; the system reads the existing key phrase of the processor error 
message, and displays additional text that you provide, giving guidance to your employees when an 
error message appears. Your text also appears in the guest check window.

Figure 19  Custom EDC Response Message tab
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4. Select the Phrases tab. 

5. Click Add.
6. Type the decline message, obtained from the processor, up to 30 characters, in ‘Existing key 

phrases.’ For example, ‘Sys Error-Call 197.’
7. Type additional information, up to 30 characters, in ‘Additional text to display 1.’ For example, 

‘Bad swipe or Bad Mag Reader.’
8. Type additional information, up to 30 characters, in ‘Additional text to display 2,’ if necessary. 

For example, ‘Try again.’
9. Type additional information, up to 30 characters, in ‘Additional text to display 3,’ if necessary. 

For example, ‘Contact Manager.’
10. Click Add and repeat this procedure for any additional key phrases that you want to provide 

instructions.
11. Click Save and exit Custom EDC Response Messages.

Figure 20  Phrases tab

Electronic pay-
ment decline 
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Additional text to display examples: 

FOH additional text example: 

Existing Key Phrase
Additional Text To 
Display 1

Additional Text To 
Display 2

Additional Text To 
Display 3

Invalid Exp Day 107 Expiration Date Invalid Request Manager 
assistance

Sys Error - Call 172 System Timed Out Try again Contact Manager

751 Auth Declined

Declined - Over Limit 
Amount

Card has insufficient 
funds

<Blank> Request alternate 
payment.

752 Trans Denied

Insufficient Funds

Card has insufficient 
funds

<Blank> Request alternate 
payment.

Figure 21  Additional Text Appears
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What you should know before configuring Aloha EDC 
After preparing the Aloha POS system for integration with Aloha EDC, you need to access the 
Electronic Draft Capture menu and configure EDC-specific menu options, such as additional EDC 
settings, processors, gateways, modems, and more. 

Before you configure Aloha EDC, you need to understand the methods of communication used in the 
industry for processing transactions.

Dial-Up Support  — Uses a conventional telephone line to establish a connection to the Internet and 
send data to/receive data from the host. Although not as common, dial-up is still used where other 
methods are not available or the cost is too high, such as in some rural or remote areas. Dial-up com-
munication requires a dedicated phone line, provides slow response times, and is the least reliable of 
the available communication methods.

TCP/IP Frame Support  — Uses a broadband Internet connection to send and receive data packets 
to and from the host. EDC resorts to dial-up as a backup method of communication, if configured to 
do so.

TCP/IP Internet Secure or Encrypted Support (SSL/TLS) — Uses a broadband Internet connec-
tion to send and receive encrypted and protected data packets, with the help of the HTTPS protocol, 
to and from the host. EDC resorts to dial-up as a backup method of communication, if configured to 
do so.

Gateway Support — Uses a secure socket layer (SSL) connection over TCP/IP that acts as a bridge 
between the site and the host. Currently Aloha EDC supports two gateways: First Data IPN and FDS 
Secure Transport. This method of communication is not available for every processor. Refer to Con-
figuring gateways for more information. EDC resorts to dial-up as a backup method of communica-
tion, if configured to do so.
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Defining additional EDC settings
Additional EDC options include defining the maximum refund amount for credit cards, defining how 
frequently EDC retries an SSL connection, enabling Store and Forward, and more.

1. Select Maintenance > Electronic Draft Capture > EDC Settings. 

2. Under the ‘Settings’ group bar, type the maximum dollar amount, up to $9999.00, you can 
refund a credit card. Use this function to prevent employees from entering incorrect amounts 
accidentally. For example, ‘200.00.’ 

3. Type the consecutive number of attempts that Aloha EDC uses to retry SSL connection. 
4. Under the ‘Offline recovery’ group bar, select Mock authorize until offline transactions are 

processed to allow the FOH to perform ‘mock’ authorizations for sales less than the defined 
amount when the site is unable to communicate with the host. When the FOH attempts to 
authorize a payment transaction, EDC “approves” the authorization and the transaction is held as 
a spooling (.spl) file in the EDC directory. When EDC is again able to connect, it scans for 
and sends all spooling files to the host for approval.

‘Mock Authorization’ mode is only activated when EDC is unable to communicate with the 
processor. If EDC is able to communicate with the processor, ‘mock authorizations’ do not occur, 

Figure 1  Electronic Draft Capture - EDC Settings

Caution
The monies from spooling files are not realized until EDC receives an authorization and settles a 
batch.
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even if the EDC program is turned off and is not processing requests. EDC is able to go into 
spool-down without losing network connection.

5. Specify the number of queued transactions for the system to reach to initiate live processing. 
For example, ‘20.’ Once the system reaches 20 queued transactions, the system initiates live 
processing.

6. Under the ‘Store and forward’ group bar, select Enable store and forward to enable the Store 
and Forward (SAF) feature. If EDC does not receive an authorization from the processor within 
the alloted time frame, the system provides a premature authorization and stores the transaction. 
EDC continues to provide authorizations for each additional FOH transaction until it is able to 
reconnect to the processor, at which time Aloha EDC processes the stored transactions in the 
queue.

7. Type the number of seconds, from zero to 30, allowed for attempting to authorize a transaction.
8. Type the number of seconds, from zero to 900, to wait before attempting to authorize the oldest 

transaction placed in the queue by Store and Forward.
9. Type the dollar amount above which the system will not ‘store and forward’ the transaction, in 

‘Floor for transaction amount.’ If EDC does not receive an authorization before the allotted time 
frame for a transaction greater than this amount, the system declines the transaction. If you define 
the floor limit as zero, the system allows EDC to ‘store and forward’ any transaction amount.

10. Type the highest number of transactions, per processor, to allow EDC to ‘store and forward’ in 
‘Maximum number of offline transactions.’ When the system attempts to authorize an offline 
transaction greater than this number, the transaction is declined and the guest must provide 
another form of tender. 

11. Click Save and exit EDC Settings.

Reference
Refer to the Store and Forward (SAF) Feature Focus Guide - HKS381 for more information.

https://docs.ncrvoyix.com/downloads/aloha-pos/QSTS_StoreandForwardFFG-HKS381.pdf
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Configuring gateways
Use the Gateways menu option to configure a secure portal, via the Internet, used to transmit and 
convert encrypted information into a language that is compatible with the protocols used by the 
receiving network. In terms of Aloha EDC, a gateway acts as a medium between the client and the 
host to process credit card authorizations and settlements, using a method of encryption. The 
merchant communicates through the gateway using a Secure Socket Layer (SSL) connection over 
TCP/IP, thereby, adding security and speed for transactions.

We currently support two gateways, both for use only with First Data processors: First Data IPN (First 
Data Nabanco) and FDS Secure Transport (First Data CES and First Data Buypass). Records already 
exist in the Gateways function, you only need to update the applicable record with information 
specific to your site.

To configure a First Data IPN gateway:

1. Select Maintenance > Electronic Draft Capture > Gateways.

2. Select First Data IPN from the ‘Gateways’ drop-down list. Note: You cannot create a new 
gateway.

3. Under the ‘First Data IPN’ group bar, type the primary IP host address to use for connecting to 
the gateway.

Figure 2  Configuring a Firs Data IPN Gateway

Note
The default values in this dialog box are used for staging. You must type the IP host addresses 
and port numbers supplied by the processor.
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4. Type the port number for the primary IP address.
5. Type secondary IP host address to use when you are unable to connect to the gateway using 

the primary IP host address. 
6. Type the port number for the secondary IP address.
7. Click Save and exit the Gateways function. 

To configure an FDS Secure Transport gateway:

1. Select Maintenance > Electronic Draft Capture > Gateways. 

2. Select FDS Secure Transport from the ‘Gateways’ drop-down list. Note: You cannot create a 
new gateway.

3. Under the ‘FDS Secure Transport’ group bar, type the Primary Secure Discovery URL to use 
for connecting to the gateway.

4. Type the Secondary Secure Discovery URL to use when you are unable to connect to the 
gateway using the primary secure discovery URL. 

5. Click Save and exit the Gateways function. 

Figure 3  Configuring an FDS Secure Transport Gateway
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Configuring processors
Use the Processor function to select and configure the payment card processors used by the 
restaurant to authorize and settle electronic payment transactions paid for with a credit card, debit 
card, gift card, and more. Use the processor worksheets when you contact the processor to obtain the 
necessary information, such as Merchant ID, Terminal ID, Internet addresses, TCP/IP settings, phone 
numbers, and more.

If a Dialing tab appears for a selected processor, the processor supports a dial-up connection. Some 
sites now rely solely on a broadband connection for their secure socket layer (SSL) authorizations and 
do not install an analog modem on the BOH computer. The typical protocol for Aloha EDC is in the 
event the system cannot connect to the host using an SSL connection, the system automatically 
attempts a dial-up connection regardless if a physical modem is installed. This causes delays for each 
transaction while the system tries to find the modem to dial out. If you are using Paymentech, you can 
configure the Paymentech processor to not roll over to a modem connection. Do this by selecting ‘No 
modem failover’ in the Paymentech processor dialog box.

You can configure multiple processors for a single restaurant, depending on your needs, such as one 
processor for handling authorizations, and another for handling settlements. While the processor 
type list box offers many processors, Aloha EDC currently supports the following processors. The 
remaining processors are no longer supported.

The following procedure walks you through the basic configuration of a processor; depending on the 
processor you select, some options may not be available. Refer to Appendix B for definitions for the 
options available for each processor. 

To configure a processor:

1. Select Maintenance > Electronic Draft Capture > Processor.
2. Click the New drop-down arrow, select a specific processor, such as CES, and click OK.
3. Accept the system assigned number or click the ellipsis (...) next to ‘Number’ to display the 

Number Assignment dialog box, from which you can choose an alternate number. 
4. Under the ‘Identification’ group bar, select Active to indicate the processor is in use. 
5. Type a number, usually ‘1,’ in ‘Index,’ if necessary. If you set up multiple merchant IDs for the 

same credit card processor, use this option to indicate another processor record with a different 
merchant ID, such as ‘2.’ For example, if you already defined CES as a processor, and required 
another CES record with a different merchant ID, set the Index to ‘2’ on the second record. The 
system combines the processor name and the specified index number to create a new processor, 
‘CES-2.’

6. Select each tab and type the information specific to the processor and your site. Refer to 
Appendix B for definitions of the options available for the each processor.

7. Click Save.
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8. Repeat this procedure for each processor you need to configure. 
9. Exit the Processor function.

Assigning cards to processors
Currently, Aloha EDC provides for these major credit cards: MasterCard, Visa, American Express, 
Diners, Carte Blanche, Discover, Enroute, JCB, and Military. The Aloha system recognizes Diners and 
Carte Blanche as being the same, thus you should configure Diners/Carte Blanche as one credit card 
type in the Maintenance > Payments > Tenders function.

To assign cards to processors:

1. After you configure your processors, select Maintenance > Electronic Draft Capture > Cards. 

2. Select the processor to use for each card type. Unless you are using multiple processors, you 
would use the same processor for all types. Select ‘None’ for any card you do not accept. 

Figure 4  Electronic Draft Capture - Cards

Tip

Be aware that you cannot perform a downward adjustment for American Express® cards when 
using TSYS (VisaNet protocol) as the processor. Refer to “Understanding payment reversals” on 
page 4-8 for more information. 
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3. Under the ‘Private Label Credit Cards’ group bar, select the processor to use for each private 
label card type. Unless you are using multiple processors, you would use the same processor for 
all types. Select ‘None’ for any card you do not accept.

4. Under the ‘Gift Cards’ group bar, select the processor to use for the corresponding gift card you 

accept. In most cases, such as Paymentech and Stored Value, you can select only one supporting 
processor for the gift card. Select ‘None’ for any card you do not accept.

5. Under the ‘Debit Cards’ group bar, select the processor from the ‘US Debit’ drop-down list. 
Note: Selecting a processor as the US Debit processor disables the Canadian Debit option.

6. Under the ‘Other cards’ group bar, select the processor to use for ‘Chip ‘N Pin,’ ‘EBT,’ and 
‘Campus card,’ if necessary.

7. Click Save and exit the Cards function. 

Figure 5  Electronic Draft Capture - Cards
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Configuring modems
Use the Modems function to configure a modem to use for communicating with a processor. You 
typically only use a modem as a backup method of communication to use when you are unable to 
connect through the Internet or gateway. We recommend using a high speed modem with a baud 
rate over 9600; however, due to the limitations of some credit card processors, you may have to turn 
off all modem intelligence.

We also highly recommend you use an external modem, rather than internal. Credit card processors 
have very short time-outs when negotiating a connection. With advanced modem features enabled, 
the modem takes too long when trying to establish a high-speed connection, and the processor 
modem often disconnects before making a connection.

What you should know before configuring a modem
There are several common problems encountered when setting up a modem, all of which you should 
solve before attempting to configure a modem and assign it to a processor. The most frequently 
encountered difficulties are:

Incorrect COM port — This is a common problem encountered when installing internal modems. 
Most internal modems have jumpers used to hardware-select both the COM port and the IRQ. These 
jumper settings must match the software settings or the computer will not communicate with the 
modem. Device conflicts are common when an internal modem and an on-board IO port share the 
same IRQ. In this case, it is best to disable the on-board IO port using the conflicting IRQ. This is sel-
dom a problem with external modems.

Incorrect IRQ  — As a general rule, IRQ settings cannot be shared between devices, thus when two 
devices are assigned the same IRQ, the result is a device conflict that prevents either from functioning 
properly, if at all. Under normal circumstances, COM1 and COM3 are assigned to IRQ 4, and COM2 
and COM4 are assigned to IRQ 3. There are ways to configure Windows to allow two COM ports to 
share an IRQ, however, it is recommended that the modem used by Aloha EDC be assigned to its 
own IRQ and COM port. This is seldom a problem with external modems.

Incorrect Init Strings  — If an unlisted modem is installed, the correct register settings must be 
entered for ‘Authorization Init String’ and ‘Settlement Init String’ located in Configure > Processors > 
Dialing Properties. An incomplete or incorrect initialization string does not normally prevent the sys-
tem from communicating with the modem, but can prevent the modem from making a connection 
with the credit card processor. Consistent failure to connect is a common symptom of an incorrect ini-
tialization string.

Note
If the processor is Amex, at least a 9600 baud modem is required to settle a batch. Amex is the only 
processor that requires a modem faster than 2400 baud.
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Telephone Line Interference  — EDC requires a dedicated phone line. The phone line should not 
interact with any internal telephone or PBX system. Static, crosstalk, or other examples of degraded 
quality in the telephone system or phone lines will cause difficulties in modem connections with the 
processor.

If you install an unlisted modem, it is up to you to enter the correct register settings for ‘Authorization 
Init String’ and ‘Settlement Init String’ located in the Dialing Properties dialog box. An incomplete or 
incorrect initialization string does not normally prevent the system from communicating with the 
modem, but can prevent the modem from making a connection with the credit card processor. 
Consistent failure to connect is a common symptom of an incorrect initialization string.

Each initialization string should begin with the Attention Command (AT) followed by the commands 
to:

● Reset modem to factory settings.
● Disable DCE flow control.
● Disable v.42/MNP data compression.
● Disable XON/XOFF or RTS/CTS flow control.
● Enable direct data link only.

Consult the user manual shipped with the modem and determine the appropriate commands.

For example, the init string for a Hayes modem is ATZ&K0&M0&C1&D2 where

Note
This guide does not document how to install modems. Refer to the documentation supplied with the 
modem.

AT Attention command. Alerts modem to subsequent commands

Z Resets factory defaults.

&K0 Disables flow control.

&MO Turns off the modem speaker.

&C1 Turns DCD on when the carrier from the remote modem is detected.

&D2 Sets the Data Terminal Ready status to that needed by Aloha EDC.

\S Additional register setting to the Init String by adding S??= where ?? is the 
Sregister
to set, followed by the desired number to the right of the equal sign.

Note
Most modems have register settings to set the dialing speed of the modem. Set the dialing speed of 
the modem to 50 milliseconds to speed up the authorization process.
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For example, the init string for a GVC 14.4 modem is AT&F5%C0\\G0\\Q0\\N1S11=50 where: 

You must select a supported modem for EDC to use. You can configure multiple modems for a 
restaurant, depending on your needs, such as one modem for handling transactions for all credit 
card processors, a modem for each credit card processor, or multiple modems for the same credit 
card processor.

To configure a modem:

1. Select Maintenance > Electronic Draft Capture > Modems.  

AT Attention command. Alerts modem to subsequent commands.

&F5 Resets factory defaults. This is important, otherwise you may end up with an init 
string that works on one modem but not another, due to a setting which is not in the 
init string.

%C0 Compression off

\G0 Disable DCE flow control

\Q0 Hardware flow control off

\N1 Direct data link only

S11=50 Set touch tone time to 50 milliseconds. This enables quicker dialing.

Figure 6  Select Modem Type Dialog Box
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2. Click the New drop-down arrow, select the appropriate modem type, and click OK. The 
modems available in the list box have been tested with Aloha EDC and have the correct 
initialization strings stored in the system.

3. Accept the system assigned number or click the ellipsis (...) next to ‘Number’ to display the 
Number Assignment dialog box, from which you can choose an alternate number. 

4. Type the name of the modem.
5. Type an unused COM port to designate the com port to use for the modem. If you use multiple 

modems of the same type, we recommend adding the com port number to the end of the modem 
description. Modems are assigned to credit card processors and this helps to differentiate 
between the modems. Note: If the specified com port is used for another modem, an error 
message, ‘This Com Port is already in use. you must select a different port,’ appears. 

6. Type the Phone Prefix to specify the number(s) the system must dial prior to dialing the phone 
numbers configured on the Dialing tab in Maintenance > Electronic Draft Capture > Processor. 
For example, type ‘9’ if you must dial 9 to get an outside line.

7. If you selected Other as the modem type, under the ‘Override Processor Specific Init Settings’ 
group bar, click the Add drop-down arrow, select the processor, and click OK.

8. Type the Authorizing Init String.
9. Type the Settlement Init String.
10. Click Save.
11. Repeat this procedure for any other modem you want to configure.
12. Exit the Modems function. 

Figure 7  Selecting a Modem
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Configuring private label cards
Use the Private Label Cards function to configure up to five private label cards owned by private 
institutions, such as a Sears card or a campus meal card. Typically, these are cards that carry credit 
for purchases, but are valid only if used at a location found within the company, such as an in-house 
cafeteria.

To configure a private label card:

1. Select Maintenance > Electronic Draft Capture > Private Label Cards.
2. Click the New drop-down arrow, select Private1, and click OK.
3. Accept the system assigned number or click the ellipsis (...) next to ‘Number’ to display the 

Number Assignment dialog box, from which you can choose an alternate number. 

4. Type the name of the private label card.
5. Type the High range to denote the eight-digit prefix of the card number, which represents the 

upper range of card numbers.
6. Type the Low range to denote the eight-digit prefix of the card number, which represents the 

lower range of card numbers.
7. Type the maximum card digit length in Maximum length.
8. Type the minimum card digit length in Minimum length.
9. Select Check digit to verify the number of digits in the private label card.
10. Select Prompt for expiration date to specify a required entry of the expiration date for private 

label card approval.
11. Type additional information about the private label card in ‘Optional text.’

Figure 8  Electronic Draft Capture - Private Label Cards
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12. Click Save.
13. Repeat this procedure, for up to four more additional private label cards, that you want to 

configure.
14. Exit the Private Label Cards function.
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Launching Aloha EDC and logging In
Effective with EDC v7.0 and later, the EDC main screen now has a new ‘look and feel’ with a new 
interface. Aloha EDC functions the same as before, but areas of the screen are rearranged into 
logical elements for easier readability: POS STATUS, LAST SETTLEMENT, and CONNECTION 
STATUS.

To launch Aloha EDC and log in to access the EDC main screen:

1. Using CFC or Aloha Manager, select File > Launch EDC.
-OR-
Launch the Aloha EDC program from the Start menu or a shortcut placed on the desktop.

2. Click Login or press ALT + L. The Aloha EDC Login dialog box appears. 

3. Type your user name. 
4. Type your password.
5. Click OK. The EDC main screen appears.

Figure 4 - 1  Aloha EDC Login Dialog Box

Figure 4 - 2  EDC Main Screen
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Use the Aloha EDC main screen to determine the status of POS processing and turn it either on or off, 
as necessary, and to view activity for each transaction processed through EDC. You also determine 
the status of the processors in use and when you last settled a batch.

If gift card transactions occurred offline during a time in which EDC was unable to connect to the gift 
card host, the total appears in red at the top of the screen. To realize the monies from these 
transactions, you must review and process these transactions. 

The current transaction activity appears on this screen, including totals by card for all transactions in 
the current batch. As FOH order entry terminals pass new requests to Aloha EDC, the system updates 
this information, providing running totals and a monitor on the credit card activities.

Starting POS processing
After you configure the Aloha EDC program, you must start POS processing for the EDC program to 
communicate with the FOH and process transactions.

To start POS processing, select File > Start POS Processing.

Stopping POS processing
To configure EDC, you must stop EDC processing to access the Configure menu. This disables the 
EDC program from sending transactions and performing any authorizations or adjustments. When 
you finish configuring EDC, you must restart POS processing.

Note
POS processing should be active at all times, except during setup and configuration.



 Aloha EDC v19.9, User Guide
Chapter 4: Using Aloha EDC

4-4

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

To stop POS processing:

1. Select File > Stop POS Processing, or click On, which acts as a toggle button. The following 
message appears.

2. Click Yes. 

‘Off’ and an ‘x’ appear on the ‘Processing’ toggle button, indicating the POS has stopped.

Figure 5  Aloha EDC - POS Processing On

Figure 6  Aloha EDC C - POS Processing Off
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Performing EDC functions from the BOH
Perform such things as authorizing, adjusting, forcing, refunding, and voiding transactions from the 
Aloha FOH whenever possible; however, you can use the Functions menu available on the Aloha 
EDC main screen to perform these functions from the BOH for your convenience or when the FOH is 
down. In all cases, ensure POS processing is started so that EDC can communicate with the processor 
and receive real-time authorization. The Functions menu also provides access to batch processing 
commands. 

When you use the Authorize, Force, and Refund functions, the actions do not impact data in the 
Aloha POS FOH. These actions do not impact a specific FOH guest check not do they affect any totals 
that report FOH activity. The system does, however, write manual transactions to the current batch file 
and these transactions become part of the EDC reporting history. Keep this in mind when 
comparing/balancing FOH totals with credit card receipts. 

When you use the Adjust and Void commands, the actions impact the data in the Aloha POS FOH 
because the transaction originally started with a check in the FOH. These actions require you to select 
the FOH check and if you recall the check prior to running the EOD, the activity appears on the guest 
check and the totals on the FOH reflect the adjusted amount. 

Figure 7  Functions Menu
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Authorizing a manual credit card
When possible, authorize and scan cards from the FOH. When this is not possible, use the Authorize 
function to enter and authorize a transaction independent of the FOH. Transactions entered using the 
Authorize function become part of the current batch, but are not associated with a guest check in the 
FOH. Use this only in special circumstances that require you to override or supplement the FOH 
transactions for the day. 

To enter and authorize a manual transaction from the BOH:

1. Log in to Aloha EDC. 
2. If POS processing is not started, select File > Start POS Processing.
3. Select Functions > Authorize to display the Authorize dialog box.  

4. Type the credit card number.
5. Type the expiration date, month and year, of the credit card.
6. Type the ZIP code of the guest, such as ‘76155,’ for the address verification system (AVS).
7. Type the security code of the credit card, if necessary.
8. Type the total amount of the guest check.
9. Type the tip, if necessary.
10. Click OK to receive the approval number and return to the main screen.

Figure 8  Authorize Dialog Box
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Adjusting a payment amount
When possible, if you need to correct a payment amount applied to a guest check, adjust the 
transaction from the FOH before you run the EOD. When this is not possible, such as when you have 
already run the EOD or you generated the original transaction using the Authorize function, use the 
Adjust function to select the transaction and modify the payment amount independent of the FOH. 
You must select the actual transaction and make the adjustment prior to settling the batch. 

To adjust the payment amount of a transaction from the BOH:

1. Log in to Aloha EDC. 
2. If POS processing is not started, select File > Start POS Processing.
3. Select Functions > Adjust to display a list of transactions to adjust. The Select Transaction dialog 

box appears. 

4. Select the transaction to adjust and click OK. The Adjust dialog box with the transaction detail 
appears. 

Figure 9  Select Transaction Dialog Box

Figure 10  Original Amount (Left) and Adjusted Amount (Right)
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5. Type the new amount and click OK to save the adjustment. A confirmation message appears.

6. Click Yes to confirm the new amount. The Result dialog box appears. 

7. Click OK to return to the main screen.

Understanding payment reversals
A payment reversal, also referred to as credit card reversal, reversal payment, partial reversal, or 
chargeback, is when the funds a cardholder used in a transaction are returned to the cardholder's 
bank. This can be initiated by the cardholder, merchant, issuing bank, acquiring bank, or card 
association. For example, a $10.00 payment is authorized, and then later the amount is increased for 
such things as adding a tip to the amount. The reversal could also reflect a downward adjustment on 

Figure 11  Confirm Dialog Box

Figure 12  Result Dialog Box
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a payment. For example, a $10.00 payment is authorized, and then later the amount is lowered to 
$5.00.  

Tip

Due to a limitation with American Express®, you cannot perform a downward adjustment when you 
process an American Express card payment using TSYS (VisaNet protocol) as the processor. When 
you attempt to perform a downward adjustment, a message stating, “The adjustment of the payment 
has failed. Partial reversal not supported for this card” appears. 
The following text is written to Debout.edc: “PerformAdjust: Cannot do a partial reversal on an 
Amex Card as it is not supported by the processor. Please void/refund and redo the transaction if 
possible.” 
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Forcing a transaction
Use the Force function as a backup procedure to use when a card does not process automatically, or 
when the processor requires a manual authorization. A forced transaction is not associated with a 
guest check on the FOH. The force command usually requires you to initiate a voice connection to the 
processor help desk to obtain an approval code.

To force a transaction from the BOH:

1. Log in to Aloha EDC.
2. If POS processing is not started, select File > Start POS Processing. 
3. Select Functions > Force to display the Force dialog box. 

4. Type the credit card number.
5. Type the expiration date, month and year, of the credit card.
6. Type the total amount of the guest check.
7. Type the tip, if necessary. 
8. Type the approval code received from the processor help desk.
9. Click OK. A confirmation prompt appears. 
10. Click OK to return to the main screen.

Figure 13  Force Dialog Box
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Refunding a transaction
When possible, issue a refund to a customer from the Aloha POS FOH before you run the EOD. 
When this is not possible, use the EDC Refund function to issue a refund to a customer and credit 
their account independent of the Aloha POS FOH. A refund using this function is not associated with 
a guest check and it does not affect FOH totals. A refund does not communicate with the processor; 
however, it will post a credit amount to the current batch. Use the Void function to delete a refund.

To refund a transaction from the BOH:

1. Log in to Aloha EDC.
2. If POS processing is not started, select File > Start POS Processing. 
3. Select Functions > Refund to display the Refund dialog box.

4. Type the credit card number.
5. Type the expiration date, month and year, of the credit card.
6. Type the total amount of the guest check. The amount is entered as a positive number.
7. Type the tip, if necessary. 
8. Type the reason for the refund.
9. Click OK. A confirmation prompt appears.
10. Click OK to return to the main screen. 

Figure 14  Refund Dialog Box
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Voiding a transaction
When possible, perform a void from the Aloha POS FOH before you run the EOD. When this is not 
possible, use the EDC Void function to void a transaction independent of the Aloha POS FOH. You 
must select the actual transaction and perform the void prior to settling the batch.

To void a transaction from the BOH:

1. Select Functions > Void to display a list of transactions in the batch. 

2. Select the transaction to void and click OK. The Void dialog box with the transaction detail 
appears with a confirmation prompt. 

Figure 15  Select Transaction Dialog Box

Figure 16  Void Dialog Box
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3. Click OK to void the transaction, or click Cancel to cancel the void. The Result dialog box 
appears. 

4. Click OK to return to the main screen.

Settling a batch
As the FOH accepts payments, the monies from credit card payments are not realized until you settle 
a batch. A batch is a collection of transactions processed through Aloha EDC that is sent to the 
respective host for finalization. Collecting of actual payments are outside of the Aloha EDC program.

A batch does not rely on the End-of-Day process. You can settle multiple batches in one day, or 
combine several days into one settlement. You must always verify batch totals before settling a batch. 
In restaurants with split-settlement—that is, settlement is handled through more than one processor—
the system prompts for the processor to settle.

When you settle a batch, you cannot perform any other functions until the settlement ends. The system 
initiates the data connection with the processor, carries out the settlement procedures, and finalizes 
the process by writing the transactions to a dated settlement file, with the format of yyyymmdd.stl in 
the \EDC\<processor name> folder. For example, if you use CES for settlement, settlement files 
appear in the \EDC\CES folder. Aloha EDC starts a new batch file to accept transactions. The 
settlement files provide a history of all transactions settled through each processor, and remain on the 
system until you manually delete them. The decision of when to delete the files is left to restaurant 
management.

Use the Settle Batch function to settle the current batch, which is usually part of a normal management 
routine each day. An alternative to manually executing the Settle Batch function is to automate the 
process using the Winhook batch file or, if available, the auto-settlement options provided in the 
processor-specific configuration.

To settle a batch:

1. Log in to Aloha EDC.
2. If POS processing is not started, select File > Start POS Processing.
3. Select Functions > Settle Batch. 

Figure 17  Result Dialog Box
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4. Select a processor. The Settle Batch dialog box appears. 

5. Under the ‘Sort By’ box, select DOB to sort the batch by business date, or select Processor 
Name to sort the batch by processor. In this example, we sort by DOB.

6. Select the business date and click Settle. The Confirm dialog box appears. 

Figure 18  Settle Batch Dialog Box

Figure 19  Confirm Dialog Box
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7. Click OK to settle the batch. The Batch Settlement Results dialog box appears. 

8. Click Finish to return to the main screen.

Forcing a settlement
When a settlement is interrupted or when the processor manually settles a batch on their end to solve 
a problem, the transactions are settled on the processor end but the EDC server does not receive the 
confirmation from the credit card processor and the files do not get archived in Aloha EDC. Unless 
corrected, it is possible to charge a customer more than once for the same transaction. Use the Force 
Settlement function to archive the current batch without performing the normal settlement procedures. 
You only want to force a settlement in unusual circumstances, and usually at the direction of a support 
technician.

To force a settlement:

1. Log in to Aloha EDC.
2. If POS processing is not started, select File > Start POS Processing.
3. Select Functions > Force Settlement.

Figure 20  Batch Settlement Dialog Box

Caution
Use Force Settlement only when a batch has already been confirmed and settled. The restaurant 
receives no revenue from a batch if the Force Settlement function is used on a batch that has not yet 
been settled. Do not use this function unless you have received instructions from the technical 
support personnel to do so.
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4. Select a processor. The Settle Batch dialog box appears. 

5. Under the ‘Sort By’ group box, select DOB to sort the batch by business date, or select 
Processor Name to sort the batch by processor. In this example, we sort by DOB.

6. Select the business date and click Settle. The Confirm dialog box appears. 

7. Click OK to clear the current batch, if you have confirmed that it has in fact settled. The 
Re-Confirm message appears.

Figure 21  Settle Batch Dialog Box

Figure 22  Confirm Dialog Box
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8. Click OK to continue. The Force Settlement dialog box appears. 

Figure 23  Re-Confirm Dialog Box

Figure 24  Force Settlement Dialog Box
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9. Type the settlement information, such as ‘20160219 - force settle,’ and click OK. The Batch 
Settlement Results dialog box appears. 

10. Click Finish to return to the main screen.

Editing a rejected transaction
Use the Edit Rejected Transactions function to edit transactions that are rejected during a batch 
settlement and written to a reject (rej) file, if supported by the processor. You can recall the 
transaction, edit the information, and then re-add it to the current batch for processing during the next 
batch settlement. The Edit Rejected Transactions menu option is only accessible if you select ‘Remove 
rejected transactions’ on one or more of the processor specific dialog boxes that support the Edit 
Rejected Transactions functionality. 

To edit a rejected transaction:

1. Log in to Aloha EDC.
2. If POS processing is not started, select Start POS Processing. 
3. Select Functions > Edit Rejected Transactions to display a list of transactions on file.

Figure 25  Batch Settlement Results Dialog Box

Reference
Refer to the supported processors section to determine if the processor supports editing rejected 
transactions. If you use a processor that does not support this function, the Edit Rejected Transaction 
menu option is unavailable.
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4. Select the rejected transaction (.rej) to edit and click OK. The Edit Rejected Transaction dialog 
box with the transaction detail appears.

5. Make the necessary changes to the information.
6. Click Re-add. The edited transaction is reinserted into the current batch.

To remove a transaction from the batch, click Delete.
7. Exit the Edit Rejected Transactions function.

Reporting EDC
Use the Report menu to view and print EDC transactions, offline transactions, and export reports to a 
common format. You can report information from the current batch, previous settlement batches in 
the history files, or a combination of current and previous batches. 

Note
When you click Re-add or Delete, the POS status momentarily changes to ‘Off’ on the Aloha 
EDC main screen. Once the system puts the rejected transactions back into the current batch, 
the POS status returns to ‘On.’

Figure 26  Report Drop-down Menu
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Viewing and printing the batch transaction report
View and print the Batch Transaction report to monitor and keep track of transactions for current and 
settled batches. You can include multiple batches, card types, and have up to two sorts. Perform this 
procedure before or after settling a batch. 

To view and print the Batch Transaction report:

1. Log in to Aloha EDC. 
2. If POS processing is not started, select Start POS Processing. 
3. Select Reports > Review Transactions to display the Batch Transaction Report dialog box. 

4. Select the batch(es) to include in the report from the list of batch files that exist on the system. 
These appear in date order with the current batch for each processor at the top of the list, 
followed by the batch history files (*.stl). You can generate a report from the batches listed here, 
using data from the current batch, a particular date, a combination of the current batch and 
multiple dates, or all dates.

5. Select the employee(s) to include in the report or select ‘All to include all employees. 

Figure 4 - 1  Batch Transaction Report Dialog Box

Note
The date on the .stl file is the actual date settled, not the date of business. If a restaurant settles 
their credit cards after midnight, the settlement date will not match the date of business. Any 
batch history files (*stl) manually deleted from the system do not appear in the Batches box.
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6. Select the credit card type(s) to include in the report. All card types are listed. 
7. Select the report type to determine the level of detail, either ‘Full’ or ‘Summary,’ of the report. 
8. Select Multi-Store Mode to sort and total the report by store or by terminal. Used in locations 

that have several stores within the same site. In this case, the report sorts by the selection made 
here first, then the selections made in ‘First Sort By’ and ‘Second Sort By.’ 

9. Make a selection from the First Sort By inset to determine the first sort order. This option 
determines the criteria to use as the first sort order of the report. In this case, the data is sorted 
first by Employee, then by Card Number.

10. Make a selection from the Second Sort By inset to determine the second sort order after ‘First 
Sort By’. This option determines the criteria to use as the second sort order of the data on the 
report. In this case, the data is sorted first by Employee, then by Card Number.

Note
You must configure your terminal ID, revenue center, and store in Maintenance > Hardware > 
Terminals for the report to sort by store.
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11. Click View to preview the report. 

Figure 5  EDC Transaction Report Preview
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Use the arrow keys to maneuver around within the report. Click the magnifying icon located on 
the bottom of the dialog box and then click the area of the report you wish to magnify, to zoom in 
on a particular area of the report.

12. Click Print to print the report, if desired.
13. Close the report.

A legend appears at the bottom of the Transaction Report and only appears if the transaction 
occurred.

● * = Automatic authorization occurred in standalone mode.
● F = Forced Transaction
● C = Contactless entered card number
● M = Manually entered card number
● ( ) = No Capture: The transaction in batch was not part of settlement. This does not refer to a 

voided transaction. Possible causes: Uncompleted PreAuth, or card type not enabled on this 
Merchant ID.

● O = Offline transaction
● P = Partial authorization
● V = Voided gift card transaction.

Number Description

1 Report title

2 Report page number

3 Navigation: Move forward or backward in the report.

4 Close / Exit the report.

5 Print options: print only the page, or the entire report.

6 Magnifying glass. Zoom up to 140%

7 Horizontal scroll bar

8 Vertical scroll bar

Note
The ‘No Capture’ indication only happens with CES processors. It is not to be confused with voided 
transactions that are placed in parenthesis from processors that require voids to remain in the batch. 
Currently, Elavon is the only supported processor that has these indications.
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Exporting the batch transaction report
The EDC reports in the Aloha POS system display the net results of all transactions per card type and 
not the transaction history of adjustments, voids, declines, reversals, and other types of 
communication. This information has typically been retrieved from .txn and .stl files, however, the 
implementation of masking and encrypting card numbers compromises the ability to trace 
transactions related to an account. The restaurant must be able to trace card activity for the following 
reasons:

● For instances when balances become out of sync between Aloha POS reports and the gift card 
host.

● For discrepancies from customers about transactions. For example, the customer may inquire why 
there are multiple transactions when an employee applies their credit card to the wrong check, 
voids the transaction, and then applies the payment to the correct check.

With the ability to create an EDC Batch Transaction report, the restaurant can provide a history of card 
use, in the order that it occurred, for a date, or a range of dates, export the file into an application, 
such as MSExcel©, and save the history to a disk, if necessary. The restaurant can then compare the 
transaction history recorded at the store to the history at the processor or host.

Creating and exporting the batch transaction report
You must create the EDC Batch Transaction report from the Reports menu in EDC and export the file 
to an application that supports a comma separated value (CSV) format. You select the batches to 
include in the report, as well as the card types on which you want to report, and the employees who 
performed the transactions.

To create and export the EDC transaction report:

1. Log in to Aloha EDC.
2. Select Reports > Create Transaction Report. 
3. Select the batch on which you want to report.

To select multiple batches in a row, hold down the Shift key, select the first batch and the last 
batch to include in the report.

4. Select the card types to include in the report.
5. Select the employee who performed the transactions.

To select multiple employees in a row, hold down the Shift key, select the first employee and 
the last employee to include in the report.
To select multiple employees not in a row, hold down the Ctrl key, and select the employees 
to include in the report.

6. Click Export. The information writes to a .csv file and a confirmation message appears.
7. Click OK. 
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To view the EDC Batch Transaction report, double-click the .csv file to open MSExcel and display the 
transaction history. A portion of this report is shown in the following example: 

The column titles appear on the first row. The card field appears as un-encrypted and adds spaces for 
every fourth digit to help with cell formatting. Blank fields are left blank and not filled with $0.00.

To change the file path of the export file:

1. From the Batch Transaction Export dialog box, click Export Settings to display the Export 
Settings dialog box. 

2. Type the file path and the name of the export file.
3. Click Save.

Type DOB Date Time Employee Table Check
Auth 
Amt

Authorize 20160217 20160217 11:36:39 148 Nick Amaro Table 
12

10002 19.22

Adjust 20160217 20160217 11:53:41 148 Nick Amaro Table 
12

10002 19.22

Void 20160217 20160217 12:05:16 148 Nick Amaro Table 
12

10002
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Automating the batch transaction report
The Batch Transaction report details transaction information processed through EDC, such as 
authorized amount, return codes, offline status, card balance before and after a transaction occurred, 
and much more. You can electronically export the file to a comma separated value (csv) format. You 
can now automate the creation of the file during the End-of-Day (EOD) process.

To automate the EDC Batch Transaction export:

1. Open the Winhook batch file using Notepad.
2. Add an additional command, using the following parameters in the command line, to pass the 

information to EDC.exe.

* Indicates a required parameter in the command line.
When finished, your command line might look like the following: 
Date Current /ExportFile AlohaQS/Exports/Transactions.csv /ProcessorNumber 2 / Index 2.

3. Select File > Save to save the Winhook batch file, and close Notepad. The export file generates 
during the next EOD.

Parameter Description

/Date * Indicates the date of a dated subdirectory, or the current date if you are 
exporting today’s activity. You can also use /Date Latest to query file 
extensions, such as .stl, .A, and .B, and disregard the /BatchOffset 
parameter.
Example: /Date 20050505 or /Date Current or /Date Latest.

/ExportFile * Represents the full path and the name of the export file. You can point to a 
dated subdirectory using a variable.
Example: /ExportFile <iberdir>/Exports/Transactions.csv

/ProcessorNumber * Represents the ID number of the processor. Refer to the Processor ID table 
in this section for more information. 
Example: /ProcessorNumber 6.

/Index Used if there are multiple instances of a processor, such as CES 1 and CES 
2.
Example: /Index 2

/BatchOffset Used if there are multiple batches for the processor, for a given
day. The parameter defaults to the current batch or the first settlement file.
Example: /BatchOffset 1

/Help Writes the command parameters with their corresponding description to 
Debout.edc.
Example: /Help or /?
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The following table lists the processors currently supported by the Aloha POS system and the 
processor ID number used for the parameter in the EDC Export file:

Processor ID Currently Supported Processor Name

3 AMEX

BA Merchants Services (settlement only)

11 Chase Paymentech

18 Comdata (VisaNet protocol)

8 Elavon 

10010 First Data Buypass

1 First Data CES 

First Data Nabanco

2 Heartland (VisaNet protocol)

23 Moneris

2 TSYS (VisaNet protocol) 

17 Vantiv Host Capture

17 Vantiv Terminal Capture

16 Worldpay

17 WorldPay Host Capture
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Appendix A:  Processor matrix 

Warning
While the processor type list box offers many processors, Aloha EDC currently supports only those 
provided in this matrix. The remaining processors are no longer supported.The following table 
provides a quick overview of the processors supported by Aloha EDC:

Processor
Host 
Capture

Credit 
Card

Debit 
Card

Gift 
Card

EBT 
Card

Dial-Up TCP/IP SSL Gateway

AMEX No Yes No No No Yes No Yes No

BA Merchant 
Services 
(settlement 
only)

No Yes No No No Yes No No No

Chase 
Paymentech

No Yes Yes Yes No Yes Yes Yes No

Comdata
(VisaNet 
protocol)

No No No Yes No Yes Yes Yes, 
credit 
cards 
only?

No

Elavon No Yes No No No Yes No Yes No

First Data 
Buypass

No Yes Yes No Yes Yes No Yes FDS 
Secure 
Transport

First Data 
CES

No
P2PE

Yes Yes Yes Yes Yes Yes Yes, for 
credit 
cards 
only?

FDS 
Secure 
Transport

First Data 
Nabanco

No Yes No Yes No Yes Yes Yes, for 
credit 
cards 
only?

First Data 
IPN

Heartland 
(VisaNet 
protocol)

No Yes No No No Yes Yes Yes, 
credit 
cards 
only?

No

Moneris No Yes Yes Yes No Yes No
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Processors no longer supported
As early as Aloha EDC v7.0, EDC no longer supports the following processors, as these processors 
no longer meet compliance standards. All user interface support for these processors is completely 
removed.

● $$$ in the Bank (Shift4)
● Aloha Net
● CardSmith
● Direct Net
● Global Payments
● Independent
● Maverick
● PayPal Basic Check-in
● Tender Retail
● Visa Net

If you are upgrading to Aloha EDC v12.3 or later, and using one of these processors, you must 
change to a supported processor before or at the time of the upgrade. 

TSYS 
(VisaNet 
protocol) 

No
P2PE

Yes Yes
QS 
only

No Yes Yes Yes Yes, 
credit 
cards 
only.

No

Vantiv Host 
Capture

Yes Yes No No No Yes Yes Yes No

Vantiv 
Terminal 
Capture

No Yes No Yes No Yes Yes Yes No

Worldpay No Yes Yes Yes No

Worldpay 
Host 
Capture

Yes Yes Yes No No Yes Yes Yes No

Caution
Prior to upgrading to Aloha EDC, please ensure you settle all transactions first. If you fail to settle 
transactions, you may encounter issues after the upgrade.

Processor
Host 
Capture

Credit 
Card

Debit 
Card

Gift 
Card

EBT 
Card

Dial-Up TCP/IP SSL Gateway
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Appendix B: Field definitions

Cards
Select Maintenance > Electronic Draft Capture > Cards to access this function.

Cards tab
Group Bar: Credit Cards

Select the processor to use for each credit card type you accept from a guest. Select ‘None’ as the 
processor for any credit card type you do not accept. Current credit card types available are:

● MC
● Visa
● AMEX
● Diners/CB
● Discover
● Enroute
● JCB
● Military

Group Bar: Private Label Credit Cards

Select the processor to use for each credit card type you accept from a guest. Select ‘None’ as the 
processor for any credit card type you do not accept. Aloha EDC allows you to configure up to five 
private label credit card types.

● Private Label 1
● Private Label 2
● Private Label 3
● Private Label 4
● Private Label 5

Group Bar: Gift Cards

Select the processor to use for each gift card type you accept from a guest. Select ‘None’ as the 
processor for any gift card type you do not accept. 

● Paymentech
● ValueLink
● Comdata
● Vantiv
● Private
● Heartland Payment Systems
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Group Bar: Debit Cards

Select the processor to use for the debit card you accept from a guest. Once you select a processor 
for one debit card type, the other debit card option becomes unavailable.

● US Debit
● Canadian Debit

Group Bar: Other cards

Select the processor to use for the cards you accept from a guest. Select ‘None’ as the processor for 
any card type you do not accept.

● Chip ‘N Pin
● EBT
● Campus card

EDC Settings
Select Maintenance > Electronic Draft Capture > EDC Settings to access this function.

EDC Settings tab
Use the EDC Settings tab to define the refund limit, the method for offline recovery, and more.

Group Bar: Settings

Credit card refund limit — Specifies the maximum dollar amount, up to $9999.00, you are 
allowed to refund on a credit card.

Retry SSL every this many connections — Specifies the consecutive number of times Aloha EDC 
uses a dial-up connection before trying to connect again using an SSL connection. This reduces the 
time spent waiting for a message that the SSL connection is down. For example, if you enter three, 
the system notices the Internet connection is lost, uses a dial-up connection for three consecutive 
transactions, and attempts an SSL connection on the fourth transaction.

Group Bar: Offline Recovery

Mock authorize until offline transactions are processed  — Allows the FOH to perform ‘mock’ 
authorizations for sales less than the defined amount when the site is unable to communicate with the 
host. When the FOH attempts to authorize a payment transaction, EDC “approves” the authorization 
and the transaction is held as a spooling (.spl) file in the EDC directory. When EDC is again able to 
communicate, it scans for and sends all spooling files to the host for approval.

Start live processing with this many queued transactions — Defines the number of transactions 
remaining in the spooldown queue at which you want the system to begin live processing when EDC 
is able to communicate with the processor again. This is helpful when coming out of mock authoriza-
tion mode. The system processes the remaining transactions in the queue before it can authorize a 
live transaction, which can cause the authorization of the live transaction to take a long time if there 
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are a lot of transactions in the queue, forcing the customer to wait. Consider making this a small num-
ber, such as five. The system continues to spool each new transaction as though it were still in mock 
authorization mode until the number of transactions remaining in the queue reaches the number you 
specify here, at which time it starts live processing. Required Options: You must select ‘Mock autho-
rize until offline transactions are processed’ to enable this option. 

Group Bar: Store and forward

Enable store and forward — Enables the Store and Forward (SAF) feature, allowing you to set a 
timeout threshold, such as 10 seconds, for an authorization to occur. If EDC does not receive an 
authorization from the processor within the allotted time frame, the system provides a premature 
authorization and stores the transaction. EDC continues to provide authorizations for each additional 
FOH transaction until it is able to reconnect to the processor, at which time Aloha EDC processes the 
stored transactions in the queue. Documented Version: v14.1.

Authorization timeout threshold  — Defines the number of seconds, from zero to 30, to allow for 
receiving an authorization from the processor when using ‘Store and Forward.’ If EDC does not 
receive an authorization from the processor within the allotted time frame, EDC provides a premature 
authorization for the transaction and stores it for authorization at a later time. If the timeout threshold 
is set to zero, the system follows the default timeout process, which may require up to 45 seconds or 
longer before providing a response to the FOH. Required Options: You must select ‘Enable store 
and forward’ to view this option. Documented Version: v14.1.

Number of seconds to wait before attempting recovery — Defines the number of seconds to 
wait, from zero to 900, before attempting to authorize the oldest transaction placed in the queue by 
Store and Forward. For example, if you type ‘30,’ the system attempts to authorize the transactions in 
the queue every 30 seconds until achieving a successful authorization. Note: We recommend 30 sec-
onds to avoid delays and/or memory issues. If you set the number of seconds to zero, you must man-
ually attempt recovery using the Attempt Recovery button available on the Store and Forward 
Transaction List for any employee with a sufficient security role. Required Options: You must select 
‘Enable store and forward’ to view this option. Documented Version: v14.1.

Floor for transaction amount  — Designates the amount above which the system will not ‘store and 
forward’ the transaction. If EDC does not receive an authorization before the allotted time frame for a 
transaction greater than this amount, the system declines the transaction. For example, if you type 
‘20,’ the system declines transactions equal to or greater than $21.00. If you define the floor limit as 
zero, the system allows EDC to ‘store and forward’ any transaction amount. Required Options: You 
must select ‘Enable store and forward’ to view this option. Documented Version: v14.1.

Maximum number of offline transactions  — Allows you to define the highest number of transac-
tions, up to 999, to allow EDC to ‘store and forward,’ per processor. For example, if you type 200 as 
the maximum, once there are 200 ‘store and forward’ transactions for a processor, the system 
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declines the next transaction for that processor. If you set the maximum number to zero, there is no 
limit to the number of transactions you can ‘store and forward.’ Required Options: You must select 
‘Enable store and forward’ to view this option. Documented Version: v14.1.

Custom tab
Use the Custom tab to establish a value other than one that is hard-coded or not available for a setting 
in Aloha Configuration Center or Aloha Manager for EDC. 

Group Bar: Custom

Setting — Designates the name of the variable as it exists in EDC.ini.

Value  — Designates the new, custom value for the setting. 

Gateways
Currently, only First Data processors use a gateway to process payment card authorizations and 
settlements. Select Maintenance > Electronic Draft Capture > Gateways to access this function. 

Gateways tab
The options on the Gateways tab vary depending on the type of gateway you select: First Data IPN or 
FDS Secure Transport.

Group Bar: First Data IPN

Primary IP Host Address — Allows the gateway and processor to communicate with each other 
using a primary, globally-unique IP address.

Primary Port Number — Associates with an IP address of a host; a 16-digit number which com-
pletes the destination identifies a specific process to which an Internet or other network message is to 
be forwarded when it arrives at server A port is always associated with an IP address of a host and the 
protocol type of the communication, and thus completes the destination or origination address of a 
communications session. A port is identified for each address and protocol by a 16-bit number, com-
monly known as the port number.

Secondary IP Host Address — Allows the gateway and processor to communicate with each other 
using a secondary, globally-unique IP address.

Secondary Port Number — Associates with a secondary IP address of a host; a 16-digit number 
which completes the destination identifies a specific process to which an Internet or other network 
message is to be forwarded when it arrives at server A port is always associated with an IP address of 
a host and the protocol type of the communication, and thus completes the destination or origination 
address of a communications session. A port is identified for each address and protocol by a 16-bit 
number, commonly known as the port number.
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Custom tab
Use the Custom tab to establish a value other than one that is hard-coded or not available for a setting 
in Aloha Configuration Center or Aloha Manager for EDC. 

Group Bar: Custom

Setting  — Designates the name of the variable as it exists in EDC.ini. 

Value  — Designates the new, custom value for the setting. 

Modems
Select Maintenance > Electronic Draft Capture > Modem to access this function.

Modem tab
Use the Modem tab to establish the modem you are using to send transactions and enter the COM 
port and a phone prefix, if required, used by the modem. 

Group Bar: Settings

COM Port — Designates the com port to use for the modem. The default com port for a selected 
modem is input here when a new modem is added.

Phone Prefix — Specifies the numbers that must be dialed prior to dialing phone numbers specified 
on the Dialing tab in Maintenance > Electronic Draft Capture > Processor. For example, type ‘9’ if the 
system must first dial 9 to get an outside line.

Authorizing Init String — Designates the series or string of commands to initialize the modem for 
authorization of a transaction. 

Settlement Init String — Designates the series of string of commands to initialize the modem for 
settlement of a transaction. 

Group Bar: Override Processor Specific Init Settings 

Processor — Designates the processor for which the modem communicates.

Authorizing Init String — Designates the new series or string of commands to override a specific 
processor for authorization of a transaction.

Settlement Init String — Designates the new series or string of commands to override a specific 
processor for settlement of a transaction.

Custom tab
Use the Custom tab to establish a value other than one that is hard-coded or not available for a setting 
in Aloha Configuration Center or Aloha Manager for EDC. 
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Group Bar: Custom

Setting  — Designates the name of the variable as it exists in EDC.ini. 

Value  — Designates the new, custom value for the setting. 

Private Label Cards
Select Maintenance > Electronic Draft Capture > Private Label Cards to access this function.

Private Label tab
Use the Private Label tab to configure cards owned by private institutions, such as a Sears card or 
campus meal card. 

Card name — Specifies the name of the private label card. 

High range — Designates the eight-digit prefix of the card number, which represents the upper 
range of card numbers to use when validating a private label card. You can enter up to eight num-
bers.

Low range — Designates the eight-digit prefix of the card number, which represents the lower range 
of card numbers to use when validating a private label card. You can enter up to eight numbers.

Maximum length — Designates the maximum card digit length.

Minimum length — Designates the minimum card digit length.

Check digit — Verifies the number of digits in the private label card.

Prompt for expiration date — Displays a prompt to require an entry of the expiration date for the 
private label card approval.

Optional text — Denotes any additional information about the private label card you wish to add.

Custom tab
Use the Custom tab to establish a value other than one that is hard-coded or not available for a setting 
in Aloha Configuration Center or Aloha Manager for EDC. 

Setting  — Designates the name of the variable as it exists in EDC.ini. 

Value  — Designates the new, custom value for the setting. 
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Processor
Select Maintenance > Electronic Draft Capture > Processor to access this function. There are 
several types of processors from which to choose when you configure the processors for payment 
card transactions. Depending on your operation, you may need to configure more than one 
processor type. Click the down arrow next to ‘New’ to select a processor type. While the processor 
type list box offers many processors, Aloha EDC currently supports only those provided in this matrix. 
The remaining processors are no longer supported.

Processors supported
The supported processors from which can choose are:

● AMEX 
● BA Merchant Services 
● Chase Paymentech 
● Comdata (Use VisaNet protocol) 
● Elavon 
● First Data Buypass 
● First Data CES 
● First Data Nabanco 
● VisaNet (Use VisaNet protocol) 
● Moneris 
● NCR Payment Processor (NPP) 
● TSYS (Use VisaNet protocol) 
● Vantiv Enhanced Host Capture 
● Vantiv Terminal Capture 
● VisaNet 
● Worldpay 
● Worldpay Host Capture 

As requirements vary from processor to processor, we provide field definitions pertaining to each 
unique processor; however, each processor ‘shares’ an ‘Identification’ group bar. 

Active — *Indicates the processor is active and in use.

Index — Allows you to set up multiple merchant IDs for the same credit card processor, but normally 
set to ‘1.’ For example, if you already defined CES as a processor, and require another CES record 
with a different merchant ID, set the Store Index to ‘2’ on the second record. The system combines 
the processor name and the specified store index to create a new processor (in this example, CES2). 
The store index number does not have to be incremented in sequential order. 
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Processors no longer supported
As early as Aloha EDC v7.0, EDC no longer supports the following processors, as these processors 
no longer meet compliance standards. All user interface support for these processors is completely 
removed.

● $$$ in the Bank (Shift4)
● Aloha Net
● CardSmith
● Direct Net
● Global Payments
● Independent
● Maverick
● PayPal Basic Check-in
● Tender Retail

If you are upgrading to Aloha EDC v12.3 or later, and using one of these processors, you must 
change to a supported processor before or at the time of the upgrade.

Caution
Prior to upgrading to Aloha EDC, please ensure you settle all transactions first. If you fail to settle 
transactions, you may encounter issues after the upgrade.
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AMEX
The following options appear for AMEX.

Processor tab
Use the Processor tab to define options specific to the Amex processor.

Group Bar: Amex

Contact the processor and obtain information to complete the available options residing under the 
‘Amex’ group bar.

● SE number
● Submitter identification
● Invoice batch

Enable prepaid card processing — Supports partial authorizations on Amex prepaid cards and 
offers two options for authorization.

Authorize with balance — If the authorization request (meal plus tip) is greater than the balance 
remaining on the card, AMEX returns a decline, and the current card balance. If the authorization 
request (meal plus tip) is less than or equal to the balance remaining on the card, Amex returns 
an approval, along with the card balance after the transaction. 

Partial authorization — If the authorization request (meal plus tip) is greater than the balance 
remaining on the card, Amex returns a ‘partially authorized’ value, and the card balance, which in 
this case is always zero. The Aloha POS system adjusts the amount due on the check in accor-
dance with the amount approved by the processor and the guest must present an additional 
method of payment for the balance of the check. If the authorization request (meal plus tip) is less 
than or equal to the balance remaining on the card, AMEX returns an approval and the card bal-
ance after the transaction.

TCP/IP tab
Use the TCP/IP tab to enable authorization and settlement settings.

Group Bar: Authorization Settings

Connect using HTTPS (Secure HTTP) — Authorizes payment transactions using a high-speed SSL 
(HTTPS) connection.

Group Bar: Settlement settings

Connect using FTPS (Secure FTP) — Settles payment transactions using a secure, high-speed 
FTPS connection. This feature enables the required American Express credentials. Contact the pro-
cessor to complete the ‘User name,’ ‘Password,’ and ‘File name’ options.
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Dialing tab
Use the Dialing tab to record helpful telephone numbers, enable a settlement processor, modem, and 
baud rates.

Group Bar: Phone numbers

Contact the processor and obtain the telephone contact numbers to complete the available options 
residing under the ‘Phone numbers’ group bar. 

● Authorization
● Voice authorization
● Settlement assistance
● Help desk

Group Bar: Modem

Current modem — Specifies the supported modem defined in Configure > Modems. When you 
select a modem, the corresponding initialization strings used by the modem when performing credit 
card authorizations and settlements are automatically populated.

Group Bar: Configurable baud rate

Authorization baud rate — Designates the baud rate used for the modem connection during autho-
rization.

Custom tab
Use the Custom tab to establish a value other than one that is hard-coded or not available for a setting 
in Aloha Configuration Center or Aloha Manager for EDC. 

Group Bar: Custom

Setting  — Designates the name of the variable as it exists in EDC.ini. 

Value  — Designates the new, custom value for the setting. 
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BA Merchant Services
BA Merchant Services is used for settlement only. The following options appear for BA Merchant 
Services.

Processor tab
Use the Processor tab to define options specific to the BA Merchant Services processor. 

Group Bar: BA Merchant Services

Contact the processor and obtain information to complete the available options residing under the 
‘Amex’ group bar.

● Compuserve routing
● Merchant number
● Terminal number
● Store number
● Merchant category code

Inquiry only — Contacts the processor without proceeding to apply the tender.

Remove rejected transactions  — Enables EDC to remove rejected transactions from a settlement 
batch and logs a Reject.txn file to the current batch, similar to a voided transaction. This functionality 
is used in conjunction with Functions > Edit Rejected Transactions. Some processor dialog boxes 
have this option grayed out so you cannot select it.

Dialing tab
Contact the processor and obtain the telephone contact numbers to complete the available options 
residing under the ‘Phone numbers’ group bar. 

● Authorization
● Voice Authorization
● Settlement 
● Settlement assistance
● Help desk

Group Bar: Settlement processor

Enable settlement processor — Enables you to use one processor to authorize transactions and 
another processor to settle transactions.

Processor — Allows you to select a configured processor in which to settle payment transactions.
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Group Bar: Modem

Current modem — Specifies the supported modem defined in Configure > Modems. When you 
select a modem, the corresponding initialization strings used by the modem when performing credit 
card authorizations and settlements are automatically populated.

Group Bar: Configurable baud rates

Authorization baud rate  — Designates the baud rate used for the modem connection during 
authorization. 

Settlement baud rate — Designates the baud rate used for the modem connection during settle-
ment.

Custom tab
Use the Custom tab to define custom values for such things as when a processor requests a value 
other than one that is hard-coded or not available in Aloha Configuration Center or Aloha Manager 
for EDC. 

Setting  — Designates the name of the variable as it exists in EDC.ini. For example, type IPHOST if 
you want to enter a custom value for a URL. 

Value  — Designates the new, custom value for the setting.
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Chase Paymentech
When configuring Chase Paymentech, select Paymentech from the ‘Select Owner’ list box. The 
following options appear for Chase Paymentech. Formerly know as Paytech.

Processor tab
Use the Processor tab to define options specific to the Chase Paymentech processor. 

Group Bar: Paymentech

Contact the processor and obtain information to complete the available options residing under the 
‘Paymentech’ group bar.

● Client ID
● Terminal ID
● Merchant ID

Enable multiple transactions  — Enables multiple authorization transactions during a single dial-up 
connection. This is necessary when the system has initiated an authorization call to a processor and a 
second authorization request is sent from an order entry terminal in the FOH. When you select this 
option, the system passes the second authorization request to the processor before hanging up the 
connection, substantially speeding up the transaction. ‘Enable Multi-trans’ is selected by default on all 
the configuration dialog boxes in EDC, except NPC. Clear this option, if you allow only one authori-
zation per call.

Remove rejected transactions  — Enables EDC to remove rejected transactions from a settlement 
batch and logs a Reject.txn file to the current batch, similar to a voided transaction. This functionality 
is used in conjunction with Functions > Edit Rejected Transactions. Some processor dialog boxes 
have this option grayed out so you cannot select it.
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Group Bar: Offline gift card transactions

Support offline transactions and retries — Supports the ability to obtain an authorization by tele-
phone in the event that the system is unable to connect to the processor in order to process a transac-
tion.

No offline Gift Card transactions — Disables the system to prevent gift card transactions when 
internet is unavailable.

Allow offline transactions auto retry — Allows the EDC server to repeatedly attempt to send trans-
actions when the internet is unavailable.

Maximum amount allowed for activation — Defines the maximum amount allowed for activation 
for offline authorization when in offline mode.

Maximum amount allowed for redemption  — Defines the maximum amount allowed for redemp-
tion for offline authorization when in offline mode.

Allow offline transactions without retries — Allows the EDC server to attempt to send transactions 
once when the internet is unavailable.

Maximum amount allowed for activation — Defines the maximum amount allowed for activation 
for offline authorization when in offline mode.

Maximum amount allowed for redemption  — Defines the maximum amount allowed for redemp-
tion for offline authorization when in offline mode.

Group Bar: Credit Card prepaid transaction

Processing and authorization

Authorization only — Verifies with the processor if the prepaid card has sufficient funds during 
the transaction.

Authorization with balance — Verifies with the processor if the prepaid card has sufficient funds, 
provides the authorization and the remaining balance of the card.

Partial authorization — Verifies with the processor the remaining balance of the prepaid card and 
applies the amount to the transaction while the guest must provide another form of payment to 
complete the transaction.

Group Bar: Debit

PIN debit partial authorization — Allows this processor to support the authorization of a portion of 
the original transaction amount, if that amount exceeds the available balance on the PIN debit pre-
paid card.



 Aloha EDC v19.9, User Guide
Appendix B: Field definitions

B-15

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

TCP/IP tab
Use the TCP/IP tab to enable authorization and settlement settings.

Group Bar: Network Settings

Secure Socket Layer Connection type

Secure socket layer — Enables the standard security technology to establish an encrypted link 
between a web server and a browser. This link ensures that all data passed between the web server 
and browsers remain private and integral. Requires an SSL certificate.

Group Bar: Secure Internet authorization

Contact the processor and obtain information to complete the available options in the ‘Secure internet 
authorization’ group bar.

● Host address
● Resource
● User name
● Password

TCP/IP Connection type

Primary authorization IP address — Designates the first IP address in which the EDC server 
attempts to connect. This is a set of four numbers, each of which contains one to three digits, with a 
single dot (.) separating each number or set of digits. For example, ‘78.125.0.209.’

Primary authorization port — Specifies the first 16-bit number which denotes a communication 
endpoint in the TCP transport for the IP network protocol.

Secondary authorization IP address — Designates the second IP address for communicating with 
the processor. This is a set of four numbers, each of which contains one to three digits, with a single 
dot (.) separating each number or set of digits. For example, ‘73.127.4.979.’

Secondary authorization port — Specifies the second 16-bit number which denotes a communica-
tion endpoint in the TCP transport for the IP network protocol. If this fails and you configure Store and 
Forward (SAF), SAF begins.

Primary settlement IP address — Designates the first settlement IP address in which the EDC 
server attempts to connect. This is a set of four numbers, each of which contains one to three digits, 
with a single dot (.) separating each number or set of digits. For example, ‘78.125.0.209.

Primary settlement port — Specifies the first 16-bit number which denotes a communication end-
point in the TCP transport for the IP network protocol.
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Secondary settlement IP address — Designates the second settlement IP address in which the 
EDC server attempts to connect. This is a set of four numbers, each of which contains one to three 
digits, with a single dot (.) separating each number or set of digits. For example, ‘78.125.0.209.

Secondary settlement port — Specifies the second 16-bit number which denotes a communication 
endpoint in the TCP transport for the IP network protocol.

Dialing tab
Contact the processor and obtain the telephone contact numbers to complete the available options 
residing under the ‘Phone numbers’ group bar. 

● Authorization
● Voice authorization
● Settlement
● Settlement assistance
● Help desk

Group Bar: Settlement processor

Enable settlement processor — Enables you to use one processor to authorize transactions and 
another processor to settle transactions.

Processor — Allows you to select a configured processor in which to settle payment transactions.

Group Bar: Modem

Current modem — Specifies the supported modem defined in Configure > Modems. When you 
select a modem, the corresponding initialization strings used by the modem when performing credit 
card authorizations and settlements are automatically populated.

Group Bar: Configurable baud rates

Authorization baud rate  — Designates the baud rate used for the modem connection during 
authorization. 

Settlement baud rate — Designates the baud rate used for the modem connection during settle-
ment. 

Reversal tab
Many credit card companies require real-time reversal support for credit and debit card 
authorizations, to prevent delays in guests regaining access to their funds when a sale is not 
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completed. Select the credit card(s) for which you want the ability to support real-time reversals from 
the available list.

● Master Card
● Visa
● American Express
● Discover
● Diners
● Enroute
● JCB

Custom tab
Use the Custom tab to define custom values for such things as when a processor requests a value 
other than one that is hard-coded or not available in Aloha Configuration Center or Aloha Manager 
for EDC. 

Setting  — Designates the name of the variable as it exists in EDC.ini. For example, type IPHOST if 
you want to enter a custom value for a URL. 

Value  — Designates the new, custom value for the setting.
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Elavon
The following options appear for Elavon, formerly known as Nova.

Processor tab
Use the Processor tab to define options specific to the Elavon processor. 

Group Bar: Nova

Contact the processor and obtain information to complete the available options residing under the 
‘Nova’ and ‘SSL’ group bars.

● Bank ID number (BIN)
● Terminal ID
● Internet address

Group Bar: SSL

Internet address — Designates the numerical label assigned to each device, such as a computer or 
printer, that participates in a computer network that uses the Internet Protocol for communication. An 
IP address servers two principals functions: host or network interface identification and location 
addressing.

Dialing tab
Contact the processor and obtain the telephone contact numbers to complete the available options 
residing under the ‘Phone numbers’ group bar. 

● Authorization
● Authorization backup
● Settlement
● Settlement backup

Group Bar: Settlement processor

Enable settlement processor — Enables you to use one processor to authorize transactions and 
another processor to settle transactions.

Processor — Allows you to select a configured processor in which to settle payment transactions.

Group Bar: Modem

Current modem — Specifies the supported modem defined in Configure > Modems. When you 
select a modem, the corresponding initialization strings used by the modem when performing credit 
card authorizations and settlements are automatically populated.
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Group Bar: Configurable baud rates

Authorization baud rate  — Designates the baud rate used for the modem connection during 
authorization. 

Settlement baud rate — Designates the baud rate used for the modem connection during settle-
ment. 

Options tab
Group Bar: Partial authorization

Credit prepaid transaction — Allows this processor to support the authorization of a portion of the 
original transaction amount, if that amount exceeds the available balance on the prepaid credit card.

Reversals tab
Group Bar: Real time reversal

Many credit card companies require real-time reversal support for credit and debit card 
authorizations, to prevent delays in guests regaining access to their funds when a sale is not 
completed. Select the credit card(s) for which you want the ability to support real-time reversals from 
the available list.

● Master Card
● Visa
● American Express
● Diners/CB
● Discover
● Enroute 
● JCB

Custom tab
Use the Custom tab to define custom values for such things as when a processor requests a value 
other than one that is hard-coded or not available in Aloha Configuration Center or Aloha Manager 
for EDC. 

Setting  — Designates the name of the variable as it exists in EDC.ini. For example, type IPHOST if 
you want to enter a custom value for a URL. 

Value  — Designates the new, custom value for the setting.
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First Data Buypass
When configuring First Data Buypass, select FDS Buypass from the ‘Select Owner’ list box. The 
following options appear for First Data Buypass.

Processor tab
Use the Processor tab to define options specific to the First Data Buypass processor. 

Group Bar: FDS BuyPass

Contact the processor and your assigned Merchant ID number residing under the ‘FDS BuyPass’ 
group bar.

Connect using FDS s secure transport — Enables high speed, secured communication between 
the processor and FDS transport.

Enable host capture — Allows you to authorize transactions without having to store transaction 
details between the authorization and settlement.

Group Bar: Partial authorization

Credit prepaid transaction — Allows this processor to support the authorization of a portion of the 
original transaction amount, if that amount exceeds the available balance on the prepaid credit card.

PIN debit transactions — Allows this processor to support the authorization of a portion of the orig-
inal transaction amount, if that amount exceeds the available balance on the PIN debit prepaid card.

Dialing tab
Contact the processor and obtain the telephone contact numbers to complete the available options 
residing under the ‘Phone numbers’ group bar. 

● Authorization
● Voice authorization
● Settlement
● Settlement assistance
● Help desk

Group Bar: Settlement processor

Enable settlement processor — Enables you to use one processor to authorize transactions and 
another processor to settle transactions.

Processor — Allows you to select a configured processor in which to settle payment transactions.
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Group Bar: Modem

Current modem — Specifies the supported modem defined in Configure > Modems. When you 
select a modem, the corresponding initialization strings used by the modem when performing credit 
card authorizations and settlements are automatically populated.

Group Bar: Configurable baud rate

Authorization baud rate — Designates the baud rate used for the modem connection during autho-
rization.

Reversals tab
Use the Reversals tab to enable real-time reversal support for credit authorizations, to prevent delays 
in guests regaining access to their funds when a sale is not completed.

Group Bar: Real time reversal

Select the credit card(s) for which you want the ability to support real-time reversals from the available 
list.

● MC
● Visa
● Diners/CB
● Discover
● Enroute
● JCB

Auto Settlement tab
Use the Auto Settlement tab to activate or deactivate auto settlement, or activate force auto settlement.

Custom tab
Use the Custom tab to define custom values for such things as when a processor requests a value 
other than one that is hard-coded or not available in Aloha Configuration Center or Aloha Manager 
for EDC. 

Setting  — Designates the name of the variable as it exists in EDC.ini. For example, type IPHOST if 
you want to enter a custom value for a URL. 

Value  — Designates the new, custom value for the setting.
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First Data CES
When configuring First Data CES, select CES from the ‘Select Owner’ list box. The following options 
appear for First Data CES. Formerly known as First Data North, FDMS North, and Cardnet.

Processor tab
Use the Processor tab to define options specific to the First Data CES processor. 

Group Bar: CES

Contact the processor and obtain information to complete the available options residing on the 
Processor tab.

● Credit card merchant ID
● Gift card merchant ID
● Terminal ID
● BOH terminal ID
● Gift card alternate merchant ID
● EBT merchant FNS ID

Enable multiple transactions  — Enables multiple authorization transactions during a single dial-up 
connection. This is necessary when the system has initiated an authorization call to a processor and a 
second authorization request is sent from an order entry terminal in the FOH. When you select this 
option, the system passes the second authorization request to the processor before hanging up the 
connection, substantially speeding up the transaction. ‘Enable Multi-trans’ is selected by default on all 
the configuration dialog boxes in EDC, except NPC. Clear this option, if you allow only one authori-
zation per call.

Remove rejected transactions  — Enables EDC to remove rejected transactions from a settlement 
batch and logs a Reject.txn file to the current batch, similar to a voided transaction. This functionality 
is used in conjunction with Functions > Edit Rejected Transactions. Some processor dialog boxes 
have this option grayed out so you cannot select it.

Group Bar: Point to point encryption

Enable point to point encryption and disable credit card entry in EDC — Removes card-
holder data from your environment by encrypting data at the moment of capture, without the ability to 
decrypt and prevents employees from entering credit card numbers in EDC. Enables the Authentica-
tion code.

Options tab
Use the Options tab to support partial authorizations and offline gift card transactions.
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Group Bar: Partial authorization

Credit prepaid transaction — Allows this processor to support the authorization of a portion of the 
original transaction amount, if that amount exceeds the available balance on the prepaid credit card.

Offline gift card transactions group bar

Retries — 

Automatically offline mode retries — Allows automatic approval of transactions with offline autho-
rizations, when EDC cannot connect to the host for an electronic response.

Is currently offline and tries once — Enables the system to go into automatic offline mode after 
one attempt to connect to the host.

Maximum amount allowed for activation — Defines the maximum amount allowed for activation 
for offline authorization when in offline mode.

Maximum amount allowed for redemption — Defines the maximum amount allowed for redemp-
tion for offline authorization when in offline mode.

TCP/IP tab
Use the TCP/IP tab to enable authorization and settlement settings.

Group Bar: TCP/IP or Gateway connection 

Connect using FDS Secure Transport - Contact the processor to obtain the credit card terminal ID and 
service name.

TCP/IP Connection type

Primary authorization IP address — Designates the primary IP address for communicating with 
the processor. This is a set of four numbers, each of which contains one to three digits, with a single 
dot (.) separating each number or set of digits. For example, ‘78.125.0.209.’

Primary authorization port — specifies the primary 16-bit number which denotes a communication 
endpoint in the TCP transport for the IP network protocol.

Secondary authorization IP address — Designates the secondary IP address for communicating 
with the processor. This is a set of four numbers, each of which contains one to three digits, with a 
single dot (.) separating each number or set of digits. For example, ‘73.127.4.979.’

Dialing tab
Contact the processor and obtain the telephone contact numbers to complete the available options 
residing under the ‘Phone numbers’ group bar. 

● Authorization 
● Voice Authorization
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● Settlement 
● Settlement assistance
● Help desk

Group Bar: Settlement processor

Enable settlement processor — Enables you to use one processor to authorize transactions and 
another processor to settle transactions.

Processor — Allows you to select a configured processor in which to settle payment transactions.

Group Bar: Modem

Current modem — Specifies the supported modem defined in Configure > Modems. When you 
select a modem, the corresponding initialization strings used by the modem when performing credit 
card authorizations and settlements are automatically populated.

Group Bar: Configurable baud rates

Authorization baud rate  — Designates the baud rate used for the modem connection during 
authorization. 

Settlement baud rate — Designates the baud rate used for the modem connection during settle-
ment. 

Reversals tab
Use the Reversals tab to enable real-time reversal support for credit authorizations, to prevent delays 
in guests regaining access to their funds when a sale is not completed.

Group Bar: Real time reversal

Select the credit card(s) for which you want the ability to support real-time reversals from the available 
list.

● Master Card
● Visa
● American Express
● Diners/CB
● Discover
● Enroute JCB

Auto Settlement tab
Use the Auto Settlement tab to activate or deactivate auto settlement, or activate force auto settlement.
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Custom tab
Use the Custom tab to define custom values for such things as when a processor requests a value 
other than one that is hard-coded or not available in Aloha Configuration Center or Aloha Manager 
for EDC. 

Setting  — Designates the name of the variable as it exists in EDC.ini. For example, type IPHOST if 
you want to enter a custom value for a URL. 

Value  — Designates the new, custom value for the setting.

First Data Nabanco
When configuring First Data Nabanco, select Nabanco from the ‘Select Owner’ list box. The 
following options appear for First Data Nabanco. 

Group Bar: Nabanco

Contact the processor and obtain information to complete the following options residing under the 
‘Nabanco’ group bar.

● Credit Card merchant ID
● Gift Card merchant ID
● Gift Card alternate merchant ID
● Terminal serial number
● Qual code
● State
● Country
● Postal code
● Category code
● Amex merchandise description
● Amex SE
● JCB SE
● Diners SE
● Discover SE

Enable multiple transactions  — Enables multiple authorization transactions during a single dial-up 
connection. This is necessary when the system has initiated an authorization call to a processor and a 
second authorization request is sent from an order entry terminal in the FOH. When you select this 
option, the system passes the second authorization request to the processor before hanging up the 
connection, substantially speeding up the transaction. ‘Enable Multi-trans’ is selected by default on all 
the configuration dialog boxes in EDC, except NPC. Clear this option, if you allow only one authori-
zation per call.
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Remove rejected transactions  — Enables EDC to remove rejected transactions from a settlement 
batch and logs a Reject.txn file to the current batch, similar to a voided transaction. This functionality 
is used in conjunction with Functions > Edit Rejected Transactions. Some processor dialog boxes 
have this option grayed out so you cannot select it.

Group Bar: Offline Gift Card transactions

Support offline transactions — Supports the ability to obtain an authorization by telephone in the 
event that the system is unable to connect to the processor in order to process a transaction.

Automatically offline mode retries — Allows automatic approval of transactions with offline autho-
rizations, when EDC cannot connect to the host for an electronic response.

Is currently offline and tries once — Enables the system to go into automatic offline mode after 
one attempt to connect to the host.

Maximum amount allowed for activation — Defines the maximum amount allowed for activation 
for offline authorization when in offline mode.

Maximum amount allowed for redemption — Defines the maximum amount allowed for redemp-
tion for offline authorization when in offline mode.

TCP/IP tab
Use the TCP/IP tab to enable authorization and settlement settings.

Group Bar: TCP/IP or Gateway connection 

Connect using FDS Secure Transport - Contact the processor to obtain the credit card terminal ID and 
service name.

TCP/IP Connection type

Primary authorization IP address — Designates the primary IP address for communicating with 
the processor. This is a set of four numbers, each of which contains one to three digits, with a single 
dot (.) separating each number or set of digits. For example, ‘78.125.0.209.’

Primary authorization port — specifies the primary 16-bit number which denotes a communication 
endpoint in the TCP transport for the IP network protocol.

Secondary authorization IP address — Designates the secondary IP address for communicating 
with the processor. This is a set of four numbers, each of which contains one to three digits, with a 
single dot (.) separating each number or set of digits. For example, ‘73.127.4.979.’
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Dialing tab
Contact the processor and obtain the telephone contact numbers to complete the available options 
residing under the ‘Phone numbers’ group bar. 

● Authorization 
● Voice Authorization
● Settlement 
● Settlement assistance
● Help desk

Group Bar: Settlement processor

Enable settlement processor — Enables you to use one processor to authorize transactions and 
another processor to settle transactions.

Processor — Allows you to select a configured processor in which to settle payment transactions.

Group Bar: Modem

Current modem — Specifies the supported modem defined in Configure > Modems. When you 
select a modem, the corresponding initialization strings used by the modem when performing credit 
card authorizations and settlements are automatically populated.

Group Bar: Configurable baud rates

Authorization baud rate  — Designates the baud rate used for the modem connection during 
authorization. 

Settlement baud rate — Designates the baud rate used for the modem connection during settle-
ment. 

Auto Settlement tab
Use the Auto Settlement tab to activate or deactivate auto settlement, or activate force auto settlement.

Custom tab
Use the Custom tab to define custom values for such things as when a processor requests a value 
other than one that is hard-coded or not available in Aloha Configuration Center or Aloha Manager 
for EDC. 

Setting  — Designates the name of the variable as it exists in EDC.ini. For example, type IPHOST if 
you want to enter a custom value for a URL. 

Value  — Designates the new, custom value for the setting.
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Moneris 
The following options appear for Moneris.

Processor tab
Use the Processor tab to define options specific to the Moneris processor. 

Group Bar: Moneris

Contact the processor and obtain information to complete the available options residing under the 
‘Moneris’ and ‘SSL’ group bars.

● Merchant ID
● BOH terminal ID

Group Bar: SSL

● Internet address

Options tab
Use the Options tab to support credit prepaid transactions, EMV, and disabling adjustments.

Group Bar: Credit Card Prepaid Transaction

Credit prepaid transaction — Allows this processor to support the authorization of a portion of the 
original transaction amount, if that amount exceeds the available balance on the prepaid credit card.

Group Bar: EMV

Process EMV transactions — Enables the Moneris processor to process the EMV transactions.

Group Bar: Options

Disable adjustments — Prevents an employee from adjusting a credit card payment, such as for 
adding a tip, once the payment has processed. Use this feature in conjunction with Maintenance > 
Business > Store > Store Settings tab > Credit Card group > EDC Setup group bar > Disable 
credit card adjustments to prevent the adjustments. Documented Version: v15.1.

● If you select both ‘Disable adjustments’ in EDC and ‘Disable credit card adjustments’ in the Aloha 
POS system, the system prevents an employee from adjusting a processed credit card payment.

● If you select ‘Disable adjustments’ in EDC and clear ‘Disable credit card adjustments’ in the Aloha 
POS system, the employee can adjust the processed credit card payment; however, EDC stops 
the transaction and an ‘Adjustments were disabled at the time of this transaction’ error message 
appears.

● If you clear ‘Disable adjustments’ in EDC and select ‘Disable credit card adjustments’ in the Aloha 
POS system, the FOH prevents the employee from adjusting the processed credit card payment.
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Dialing tab
Contact the processor and obtain the telephone contact numbers to complete the available options 
residing under the ‘Phone numbers’ group bar. 

● Authorization
● Voice authorization
● Settlement 
● Settlement assistance
● Help desk

Group Bar: Modem

Current modem — Specifies the supported modem defined in Configure > Modems. When you 
select a modem, the corresponding initialization strings used by the modem when performing credit 
card authorizations and settlements are automatically populated.

Number of dial attempts — Designates the number of times the modem attempts to connect to the 
processor.

Group Bar: Configurable baud rate

Authorization baud rate — Designates the baud rate used for the modem connection during autho-
rization.

Settlement baud rate — Designates the baud rate used for the modem connection during settle-
ment. 

Custom tab
Use the Custom tab to define custom values for such things as when a processor requests a value 
other than one that is hard-coded or not available in Aloha Configuration Center or Aloha Manager 
for EDC. 

Setting  — Designates the name of the variable as it exists in EDC.ini. For example, type IPHOST if 
you want to enter a custom value for a URL. 

Value  — Designates the new, custom value for the setting.
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NCR Payment Processor (NPP)
The configuration of NCR Payment Processor (NPP) requires you to use the VisaNet protocol. Select 
Visa Net from the ‘Select Owner’ list box. 

Processor tab
Use the Processor tab to define options specific to the VisaNet processor. 

Group Bar: Visa Net

Contact the processor and obtain information to complete the available options residing under the 
‘Visa Net’ group bar.

● Acquirer BIN
● Merchant number
● Merchant name
● Merchant location (city)
● Merchant category
● Store number
● Location number
● State
● Postal code (nine-digit)
● Time zone
● Enable daylight savings
● Terminal number
● Terminal ID
● Agent number
● Chain number 
● Reimbursement attribute
● Enable multiple transactions

TCP/IP tab
Use the TCP/IP tab to enable authorization and settlement settings.

Group Bar: Network Settings

Secure Socket Layer Connection type

Reference
Refer to the EDC Supporting the NCR Payment Processor QRG - HKS1606 for information on how to 
configure the NPP processor.

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS1606&actp=search&viewlocale=en_US
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Secure socket layer — Enables the standard security technology to establish an encrypted link 
between a web server and a browser. This link ensures that all data passed between the web server 
and browsers remain private and integral. Requires an SSL certificate.

Dialing tab
Contact the processor and obtain the telephone contact numbers to complete the available options 
under the ‘Phone numbers’ group bar.

● Authorization 
● Settlement 

Group Bar: Configurable baud rate

Authorization baud rate — Designates the baud rate used for the modem connection during autho-
rization.

Settlement baud rate — Designates the baud rate used for the modem connection during settle-
ment.

Custom tab
Use the Custom tab to define custom values for such things as when a processor requests a value 
other than one that is hard-coded or not available in Aloha Configuration Center or Aloha Manager 
for EDC. 

Setting  — Designates the name of the variable as it exists in EDC.ini. For example, type IPHOST if 
you want to enter a custom value for a URL and type IPPort if you want to enter a custom port number.

Value  — Designates the new, custom value for the setting. For example, IPHOST is visnet.proces-
sor.ncr.com and IPPORT is 5003.
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Vantiv Enhanced Host Capture
The following options appear for Vantiv Enhanced Host Capture.

Group Bar: Vantiv Enhanced Host Capture

Contact the processor and obtain information to complete the available options residing under the 
‘Vantiv Enhanced Host Capture’ group bar.

● Merchant ID
● Bank ID
● Terminal ID
● BOH terminal ID 

Enable multiple transactions  — Enables multiple authorization transactions during a single dial-up 
connection. This is necessary when the system has initiated an authorization call to a processor and a 
second authorization request is sent from an order entry terminal in the FOH. When you select this 
option, the system passes the second authorization request to the processor before hanging up the 
connection, substantially speeding up the transaction. ‘Enable Multi-trans’ is selected by default on all 
the configuration dialog boxes in EDC, except NPC. Clear this option, if you allow only one authori-
zation per call.

Enable auto close/Disable adjustments — Indicates the site receives the funds in real time and 
cannot make adjustments to transactions for such things as adding a tip; however, the site is also not 
responsible for running a batch settlement at the end of the day to clear out the daily activity. The sys-
tem automatically clears out the transaction files during the end-of-day process. When cleared, the 
site still receives the funds in real time and can make adjustments for such things as adding a tip; 
however, they must manually initiate a batch settlement at the end of the day to clear out the daily 
activity.

Options tab
Use the Options tab to support partial authorization.

Group Bar: Partial authorization

Credit prepaid transaction — Allows this processor to support the authorization of a portion of the 
original transaction amount, if that amount exceeds the available balance on the prepaid credit card.

TCP/IP tab
Use the TCP/IP tab to enable authorization and settlement settings.

Group Bar: Network Settings

Secure Socket Layer Connection type
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Secure socket layer — Enables the standard security technology to establish an encrypted link 
between a web server and a browser. This link ensures that all data passed between the web server 
and browsers remain private and integral. Requires an SSL certificate.

TCP/IP Connection type

Primary authorization IP address — Designates the primary IP address for communicating with 
the processor. This is a set of four numbers, each of which contains one to three digits, with a single 
dot (.) separating each number or set of digits. For example, ‘78.125.0.209.’

Primary authorization port number — Specifies the primary 16-bit number which denotes a com-
munication endpoint in the TCP transport for the IP network protocol.

Secondary authorization IP address — Designates the secondary IP address for communicating 
with the processor. This is a set of four numbers, each of which contains one to three digits, with a 
single dot (.) separating each number or set of digits. For example, ‘73.127.4.979.’

Dialing tab
Contact the processor and obtain the telephone contact numbers to complete the available options 
under the ‘Phone numbers’ group bar.

● Authorization
● Voice authorization
● Settlement
● Settlement assistance
● Help desk

Group Bar: Settlement processor

Enable settlement processor — Activates the processor for settlements.

Processor — Designates the processor used for settlements.

Group Bar: Modem

Current modem — Specifies the supported modem defined in Configure > Modems. When you 
select a modem, the corresponding initialization strings used by the modem when performing credit 
card authorizations and settlements are automatically populated.

Group Bar: Configurable baud rate

Authorization baud rate — Designates the baud rate used for the modem connection during autho-
rization.

Settlement baud rate — Designates the baud rate used for the modem connection during settle-
ment.
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Custom tab
Use the Custom tab to define custom values for such things as when a processor requests a value 
other than one that is hard-coded or not available in Aloha Configuration Center or Aloha Manager 
for EDC. 

Setting  — Designates the name of the variable as it exists in EDC.ini. For example, type IPHOST if 
you want to enter a custom value for a URL. 

Value  — Designates the new, custom value for the setting.

Vantiv Terminal Capture
The following options appear for Vantiv Terminal Capture. Formerly known as ‘Fifth Third Processing 
Solutions,’ ‘Fifth Third Bank,’ and ‘53.’

Processor tab
Use the Processor tab to define options specific to the Vantiv Terminal Capture processor. 

Group Bar: Vantiv Terminal Capture

Contact the processor and obtain information to complete the following options residing under the 
‘Vantiv Terminal Capture’ group bar.

● Merchant ID
● Bank ID
● Credit card terminal ID
● Gift card terminal ID
● BOH terminal ID

Industry — Allows the selection of the specific hospitality for your site; ‘Food/Restaurant,’ ‘Hotel,’ or 
‘Retail.’

Enable multiple transactions  — Enables multiple authorization transactions during a single dial-up 
connection. This is necessary when the system has initiated an authorization call to a processor and a 
second authorization request is sent from an order entry terminal in the FOH. When you select this 
option, the system passes the second authorization request to the processor before hanging up the 
connection, substantially speeding up the transaction. ‘Enable Multi-trans’ is selected by default on all 
the configuration dialog boxes in EDC, except NPC. Clear this option, if you allow only one authori-
zation per call.

Options tab
Use the Options tab to support partial authorization.
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Group Bar: Partial authorization

Credit prepaid transaction — Allows this processor to support the authorization of a portion of the 
original transaction amount, if that amount exceeds the available balance on the prepaid credit card.

TCP/IP tab
Use the TCP/IP tab to enable authorization and settlement settings.

Group Bar: Network Settings

Secure Socket Layer Connection type

Secure socket layer — Enables the standard security technology to establish an encrypted link 
between a web server and a browser. This link ensures that all data passed between the web server 
and browsers remain private and integral. Requires an SSL certificate.

Primary authorization IP address — Designates the primary IP address for communicating with 
the processor. This is a set of four numbers, each of which contains one to three digits, with a single 
dot (.) separating each number or set of digits. For example, ‘78.125.0.209.’

Primary authorization port number — Specifies the primary 16-bit number which denotes a com-
munication endpoint in the TCP transport for the IP network protocol.

Secondary authorization IP address — Designates the secondary IP address for communicating 
with the processor. This is a set of four numbers, each of which contains one to three digits, with a 
single dot (.) separating each number or set of digits. For example, ‘73.127.4.979.’

Dialing tab
Use the Dialing tab to record helpful telephone numbers, enable a settlement processor, modem, and 
baud rates.

Group Bar: Phone numbers

Contact the processor and obtain the telephone contact numbers to complete the available options 
under the ‘Phone numbers’ group bar.

● Authorization
● Voice authorization
● Settlement 
● Settlement assistance
● Help desk

Group Bar: Settlement processor

Enable settlement processor — Activates the processor for settlements.

Processor — Designates the processor used for settlements.
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Group Bar: Modem

Current modem — Specifies the supported modem defined in Configure > Modems. When you 
select a modem, the corresponding initialization strings used by the modem when performing credit 
card authorizations and settlements are automatically populated.

Group Bar: Configurable baud rate

Authorization baud rate — Designates the baud rate used for the modem connection during autho-
rization.

Settlement baud rate — Designates the baud rate used for the modem connection during settle-
ment.

Reversals tab 
Group Bar: Real time reversal

Many credit card companies require real-time reversal support for credit and debit card 
authorizations, to prevent delays in guests regaining access to their funds when a sale is not 
completed. Select the credit card(s) for which you want the ability to support real-time reversals from 
the available list.

● MC
● Visa
● AmEx
● Diners/CB
● Discover
● Enroute
● JCB

Auto Settlement tab
Use the Auto Settlement tab to activate or deactivate auto settlement, or activate force auto settlement.

Custom tab
Use the Custom tab to define custom values for such things as when a processor requests a value 
other than one that is hard-coded or not available in Aloha Configuration Center or Aloha Manager 
for EDC. 

Setting  — Designates the name of the variable as it exists in EDC.ini. For example, type IPHOST if 
you want to enter a custom value for a URL. 

Value  — Designates the new, custom value for the setting.



 Aloha EDC v19.9, User Guide
Appendix B: Field definitions

B-37

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

VisaNet
The following options appear for VisaNet, formerly known as ‘Vital,’ ‘VitalNet,’ and ‘TSYS Acquiring 
Solutions.’ Use the VisaNet protocol to configure ComData, Heartland, NCR Payment Processor, and 
TSYS. 

Processor tab
Use the Processor tab to define options specific to the VisaNet processor or a processor that uses the 
VisaNet protocol, such as Comdata, Heartland, and TSYS. 

Group Bar: Visa Net

Contact the processor and obtain information to complete the available options residing under the 
‘Visa Net’ group bar.

● Acquirer BIN
● Merchant number
● Merchant name
● Merchant location 
● State
● Postal code
● Time zone
● Enable daylight savings
● Terminal number
● Terminal ID
● BOH terminal ID
● Agent number
● Settlement agent number
● Chain number 
● Sharing group
● Reimbursement attribute
● EBT FCS ID
● Authentication code

Enable multiple transactions  — Enables multiple authorization transactions during a single dial-up 
connection. This is necessary when the system has initiated an authorization call to a processor and a 
second authorization request is sent from an order entry terminal in the FOH. When you select this 
option, the system passes the second authorization request to the processor before hanging up the 
connection, substantially speeding up the transaction. ‘Enable Multi-trans’ is selected by default on all 
the configuration dialog boxes in EDC, except NPC. Clear this option, if you allow only one authori-
zation per call.
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Remove rejected transactions  — Enables EDC to remove rejected transactions from a settlement 
batch and logs a Reject.txn file to the current batch, similar to a voided transaction. This functionality 
is used in conjunction with Functions > Edit Rejected Transactions. Some processor dialog boxes 
have this option grayed out so you cannot select it.

Group Bar: Point to point encryption

Enable point to point encryption and disable credit card entry in EDC — Removes card-
holder data from your environment by encrypting the data at the moment of capture, without the abil-
ity to decrypt and prevents employees from entering credit card numbers in EDC. Enables the 
Authorization feature.

Options tab
Group Bar: Partial authorization

Credit prepaid transaction — Allows this processor to support the authorization of a portion of the 
original transaction amount, if that amount exceeds the available balance on the prepaid credit card.

PIN debit transactions — Allows this processor to support the authorization of a portion of the orig-
inal transaction amount, if that amount exceeds the available balance on the PIN debit prepaid card.

TCP/IP tab
Use the TCP/IP tab to enable authorization and settlement settings.

Group Bar: Network Settings

Secure Socket Layer Connection type

Secure socket layer — Enables the standard security technology to establish an encrypted link 
between a web server and a browser. This link ensures that all data passed between the web server 
and browsers remain private and integral. Requires an SSL certificate.

TCP/IP Connection type

Primary authorization IP address — Designates the primary IP address for communicating with 
the processor. This is a set of four numbers, each of which contains one to three digits, with a single 
dot (.) separating each number or set of digits. For example, ‘78.125.0.209.’

Primary authorization port number — Specifies the primary 16-bit number which denotes a com-
munication endpoint in the TCP transport for the IP network protocol.

Secondary authorization IP address — Designates the secondary IP address for communicating 
with the processor. This is a set of four numbers, each of which contains one to three digits, with a 
single dot (.) separating each number or set of digits. For example, ‘73.127.4.979.’
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Dialing tab
Contact the processor and obtain the telephone contact numbers to complete the available options 
under the ‘Phone numbers’ group bar.

● Authorization 
● Voice authorization
● Settlement 
● Settlement assistance
● Help desk

Group Bar: Settlement processor

Enable settlement processor — Activates the processor for settlements.

Processor — Designates the processor used for settlements.

Group Bar: Modem

Current modem — Specifies the supported modem defined in Configure > Modems. When you 
select a modem, the corresponding initialization strings used by the modem when performing credit 
card authorizations and settlements are automatically populated.

Group Bar: Configurable baud rate

Authorization baud rate — Designates the baud rate used for the modem connection during autho-
rization.

Settlement baud rate — Designates the baud rate used for the modem connection during settle-
ment.

Reversals tab
Group Bar: Real time reversal

Many credit card companies require real-time reversal support for credit and debit card 
authorizations, to prevent delays in guests regaining access to their funds when a sale is not 
completed. Select the credit card(s) for which you want the ability to support real-time reversals from 
the available list. 

Custom tab
Use the Custom tab to define custom values for such things as when a processor requests a value 
other than one that is hard-coded or not available in Aloha Configuration Center or Aloha Manager 
for EDC. 

Setting  — Designates the name of the variable as it exists in EDC.ini. For example, type IPHOST if 
you want to enter a custom value for a URL. 
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Value  — Designates the new, custom value for the setting.

Worldpay
The following options appear for Worldpay.

Processor tab
Use the Processor tab to define options specific to the Worldpay processor. 

Group Bar: WorldPay

Contact the processor and obtain information to complete the available options residing under the 
‘WorldPay’ group bar. 

● Acquirer BIN
● Merchant number
● Merchant name
● Merchant location
● Merchant category
● Merchant ABA number
● Terminal ID
● Agent number
● Settlement agent number
● Chain number
● Sharing group 
● Reimbursement attribute

Enable multiple transactions  — Enables multiple authorization transactions during a single dial-up 
connection. This is necessary when the system has initiated an authorization call to a processor and a 
second authorization request is sent from an order entry terminal in the FOH. When you select this 
option, the system passes the second authorization request to the processor before hanging up the 
connection, substantially speeding up the transaction. ‘Enable Multi-trans’ is selected by default on all 
the configuration dialog boxes in EDC, except NPC. Clear this option, if you allow only one authori-
zation per call.

Remove rejected transactions  — Enables EDC to remove rejected transactions from a settlement 
batch and logs a Reject.txn file to the current batch, similar to a voided transaction. This functionality 
is used in conjunction with Functions > Edit Rejected Transactions. Some processor dialog boxes 
have this option grayed out so you cannot select it.
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Group Bar: Point to point encryption

Enable point to point encryption and disable credit card entry in EDC — Removes card-
holder data from your environment by encrypting data at the moment of capture, without the ability to 
decrypt and prevents employees from entering credit card numbers in EDC. Enables the Authentica-
tion code. (WorldPay only.)

Options tab
Group Bar: Options

Enable token replacement — Allows the processor to receive sensitive cardholder data in an 
encrypted form. The host processes the payment and assigns a unique identifier, or token, to the 
transaction. The processor sends the token back to the point-of-sale for future reference, thus eliminat-
ing the storage of sensitive credit card data in a recognizable form at the site and increases data secu-
rity.

Enable transaction decline on CVV mismatch — Allows the system to refuse payment should an 
incorrect CVV, or Card Verification Value as the security feature for ‘card not present’ payment card 
transactions instituted to reduce the incidence of credit card fraud, be entered in to the Aloha POS 
system. (WorldPay only.)

Group Bar: Partial authorization

Credit prepaid transaction — Allows this processor to support the authorization of a portion of the 
original transaction amount, if that amount exceeds the available balance on the prepaid credit card.

PIN debit transactions — Allows this processor to support the authorization of a portion of the orig-
inal transaction amount, if that amount exceeds the available balance on the PIN debit prepaid card.

TCP/IP tab
Use the TCP/IP tab to enable authorization and settlement settings.

Group Bar: Network Settings

Secure Socket Layer Connection type

Secure socket layer — Enables the standard security technology to establish an encrypted link 
between a web server and a browser. This link ensures that all data passed between the web server 
and browsers remain private and integral. Requires an SSL certificate.

TCP/IP Connection type

Primary authorization IP address — Designates the primary IP address for communicating with 
the processor. This is a set of four numbers, each of which contains one to three digits, with a single 
dot (.) separating each number or set of digits. For example, ‘78.125.0.209.’
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Primary authorization port — Specifies the primary 16-bit number which denotes a communication 
endpoint in the TCP transport for the IP network protocol.

Secondary authorization IP address — Designates the secondary IP address for communicating 
with the processor. This is a set of four numbers, each of which contains one to three digits, with a 
single dot (.) separating each number or set of digits. For example, ‘73.127.4.979.’

Dialing tab
Contact the processor and obtain the telephone contact numbers to complete the available options 
residing under the ‘Phone numbers’ group bar. 

● Authorization
● Voice authorization
● Settlement
● Settlement assistance 
● Help desk

Group Bar: Settlement processor

Enable settlement processor — Enables you to use one processor to authorize transactions and 
another processor to settle transactions.

Processor — Allows you to select a configured processor in which to settle payment transactions.

Group Bar: Modem

Current modem — Specifies the supported modem defined in Configure > Modems. When you 
select a modem, the corresponding initialization strings used by the modem when performing credit 
card authorizations and settlements are automatically populated.

Group Bar: Configurable baud rates

Authorization baud rate  — Designates the baud rate used for the modem connection during 
authorization. 

Settlement baud rate — Designates the baud rate used for the modem connection during settle-
ment. 

Reversals tab
Group Bar: Real time reversal

Many credit card companies require real-time reversal support for credit and debit card 
authorizations, to prevent delays in guests regaining access to their funds when a sale is not 
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completed. Select the credit card(s) for which you want the ability to support real-time reversals from 
the available list.

● MC
● Visa
● AmEx
● Diners/CB
● Discover
● Enroute
● JCB

Custom tab
Use the Custom tab to define custom values for such things as when a processor requests a value 
other than one that is hard-coded or not available in Aloha Configuration Center or Aloha Manager 
for EDC. For example, you can use the custom tab to specify a different URL for the Worldpay 
processor when used on a site controller with a Windows 10 operating system. EDC stores these 
values in EDC.ini. 

Setting  — Designates the name of the variable as it exists in EDC.ini. For example, type IPHOST if 
you want to enter a custom value for a URL. 

Value  — Designates the new, custom value for the setting. In keeping with the Worldpay example, 
the custom URL to use on a Windows 10 system is api.lynksystems.com. 
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Worldpay Host Capture
The following options appear for Worldpay Host Capture.

Processor tab
Use the Processor tab to define options specific to the Worldpay Host Capture processor. 

Group Bar: WorldPay

Contact the processor and obtain information to complete the available options residing under the 
‘WorldPay’ group bar. 

● Merchant ID
● Bank ID
● Terminal ID
● BOH Terminal ID 
● EBT merchant FCS ID 

Enable multiple transactions  — Enables multiple authorization transactions during a single dial-up 
connection. This is necessary when the system has initiated an authorization call to a processor and a 
second authorization request is sent from an order entry terminal in the FOH. When you select this 
option, the system passes the second authorization request to the processor before hanging up the 
connection, substantially speeding up the transaction. ‘Enable Multi-trans’ is selected by default on all 
the configuration dialog boxes in EDC, except NPC. Clear this option, if you allow only one authori-
zation per call.

Options tab
Group Bar: Partial authorization

Credit prepaid transaction — Allows this processor to support the authorization of a portion of the 
original transaction amount, if that amount exceeds the available balance on the prepaid credit card.

PIN debit transactions — Allows this processor to support the authorization of a portion of the orig-
inal transaction amount, if that amount exceeds the available balance on the PIN debit prepaid card.

TCP/IP tab
Use the TCP/IP tab to enable authorization and settlement settings.

Dialing tab
Contact the processor and obtain the telephone contact numbers to complete the available options 
residing under the ‘Phone numbers’ group bar. 

● Authorization
● Voice authorization
● Settlement
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● Settlement assistance 
● Help desk

Group Bar: Modem

Current modem — Specifies the supported modem defined in Configure > Modems. When you 
select a modem, the corresponding initialization strings used by the modem when performing credit 
card authorizations and settlements are automatically populated.

Group Bar: Configurable baud rates

Authorization baud rate  — Designates the baud rate used for the modem connection during 
authorization. 

Settlement baud rate — Designates the baud rate used for the modem connection during settle-
ment.

Custom tab
Use the Custom tab to define custom values for such things as when a processor requests a value 
other than one that is hard-coded or not available in Aloha Configuration Center or Aloha Manager 
for EDC. For example, you can use the custom tab to specify a different URL for the Worldpay 
processor when used on a site controller with a Windows 10 operating system. EDC stores these 
values in EDC.ini.

Setting  — Designates the name of the variable as it exists in EDC.ini. For example, type IPHOST if 
you want to enter a custom value for a URL.

Value  — Designates the new, custom value for the setting. In keeping with the Worldpay example, 
the custom URL to use on a Windows 10 system is api.lynksystems.com.
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Appendix C: Troubleshooting Aloha EDC

Aloha EDC support information
If you cannot troubleshoot a problem with Aloha EDC, you must contact NCR Voyix or your processor 
help desk for technical support. If you contact the NCR Voyix help desk, provide the following files:

● Dated subdirectory from the day that had the issue.
● Settlement file for the same day, or a set of .txn files if you are unable to settle the batch.
● Debout.edc
● EDC.ini
● A complete description of the issue and when it began.

Verify the dated subdirectory and the settlement file are for the same date of business; if you call the 
next day, the date on the settlement file is often the morning after the batch is built. For example, 
there is a dated subdirectory 20160804 and 20160804.stl, but actually the 20160804.stl is a batch 
from 20160803 that was settled the following morning.

Debug event
You may need to configure a debug event for the site. The debug event file writes to Debug.cfc in the 
%Iberdir%\Data directory to report data on specific actions by the Aloha POS system for 
troubleshooting.

Note
We recommend that you not add or activate any debugging events unless you are actively 
troubleshooting problems, and that you remove these debugging event as soon as possible. 
Additional data added to Debug.cfg can make the files very large.
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To activate an EDC Debug Event:

1. Select Maintenance > System Settings > Debug Event.

2. Click New.
3. Under the ‘Identification’ group bar, type a name to identify the debug event.
4. Under the ‘Debug Event Terminals’ group bar, click the Add drop-down arrow, select EDC, and 

click OK.
5. Select the activation schedule from the drop-down list. The Activation schedules that appear are 

configured in Maintenance > System Settings > Activation Schedules. If you configure the 
activation schedule with a start time, start and end dates, the information auto-populates in the 
remaining options. Note: If you configure a debug event you want to repeat on an irregular 
schedule, you clear Active under the Debug Event Terminals group bar until you want to run the 
event again, to eliminate the need for recreating the event each time you wish to run it.

6. Select the terminal from the drop-down list. The terminals that appear are configured in 
Maintenance > Hardware > Terminals.

7. Select Active to activate the debug event terminal. 
8. Click Save and exit the Debug Event function.

Interruptions during settlement
If the Aloha EDC program ends unexpectedly during settlement, either because it crashed, or the 
machine was turned off, the settling file is not deleted. When Aloha EDC starts, it checks to see if 
there is a leftover settling file from the last time it ran. If there is, it refuses to do anything and displays 
the following message: ‘Your last settlement was interrupted. You need to check whether your batch 
made it through OK.’ Contact technical support to remove this message. The only function available is 

Figure C - 1  Debug Event
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the Batch Report; Aloha EDC does not know whether or not the current batch went through 
successfully.

Course of action:

Note
It is extremely important to remove the .txn files out of the processor directory before you start the 
next business day. You do not want these sales mixed with the sales of the next business day if 
ultimately you are required to delete the file. 

Caution
Be very careful when performing these actions. A mistake can result in double-settling a batch, 
causing unhappy guests or losing a batch, causing unhappy customers.

Step Action

1 Print a batch report for the current batch.

2 Exit Aloha EDC entirely; closing the UI does not stop Aloha EDC. Go to Services and stop the 
Aloha EDC service.

3 Contact the processor and find out when the last settlement came through and the total amount.

Current batch unsuccessful?
Delete the settling file.
Restart Aloha EDC.
Resettle batch 

Current batch successful? 
Delete the settling file.
Restart Aloha EDC.
Perform the Force Settlement function to 
archive the current batch without trying to 
settle it.

4 If the processor cannot tell whether or not the batch was successful, you must: 
Get the system up and running immediately.
Go to File Manager.
Select your processor.
In the processor directory, delete the file titled ‘Settling.’
Create a subdirectory titled ‘EDCMMDD.’
Cut and past all .txn files into the new subdirectory. You should only have .stl files and a 
‘Settled’ file remaining in the processor directory.

5 Restart Aloha EDC. There should be no credit card transactions remaining. You may proceed 
with the business of the day.
Do not forget to start the processor from the Aloha EDC main screen, if it has not already 
started.
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Amex settlement failing with error message
Amex has settlement hosts across the country, and assigns its merchants to a particular settlement 
host. If you receive a ‘You are not authorized to access this host’ error message when attempting to 
settle a batch, (1) ensure that you are authorized to settle directly with Amex, and (2) verify you have 
the correct telephone number. In rare cases, if you used a different point-of-sale system prior to the 
Aloha POS system and Amex did not receive updated information regarding Aloha, Amex rejects all 
settlement attempts.

6 Did you move .txn files into an EDCMMDD subdirectory?

If yes, you must:
Move the .txn files back into the correct 
processor directory once the batch is 
successful.
Ensure that there are no .txn files in the 
current processor directory before you move 
the files back. The best time to do this is after 
a settlement.
Restart Aloha EDC, as Aloha EDC only reads 
the .txn files at start-up. 
Continue to next step.

If no:
Continue to next step.

7 Current batch unsuccessful?
Delete the settling file.
Restart Aloha EDC.
Resettle batch 

Current batch successful? 
Delete the settling file.
Restart Aloha EDC.
Perform the Force Settlement function to 
archive the current batch without trying to 
settle it.

Step Action
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Common errors 
Processor Error Messages Resolution

AMEX INVL Response to INIT 
CTL

They have incorrect account information or are connecting at an 
incorrect baud rate.

AMEX Y Modem Error during 
transfer failed error - 618

Lost carrier during settlement (phone line hung up before 
complete transmission of the settlement file).

CES Invalid Data Rec # When sending one of the packets it has found one with 
incorrect information. Need to turn debug on and find the last 2 
transaction it sent. After locating and identifying the 2 
transactions, figure out why they are failing and correct the 
problem or void them.

CES Batch Full CES supports a maximum of 349 transactions per batch. In 
Aloha POS version 5.2.5.104 and later, you can add the 
‘MaxTransactionPerBatch’ variable to the CES section of EDC.ini 
and assign it a value that represents the expected maximum 
number of transactions. CES does not recommend changing this 
value, since it increases the opportunities for errors during 
settlement.

VISANET No batch received. Need to try again later. Possibly too much load on the 
processors network for it to keep up, processor network is 
temporarily out of service. Try again later

VISANET Rejected batch - 
Parameter record on field 
x error E.

Usually caused by the Merchant Account information not being 
correct. Verify account information, including: Bank ID number 
(BIN), Merchant ID number. Verify that Visanet has not 
terminated your account. Verify that your account is enabled for 
Multi-Trans before enabling the Multi-Trans feature.

VISANET Rejected batch - Detail 
record nn field y error E

Often caused by an invalid forced transaction in the batch. Also, 
verify that the merchant is entitled to settle AMEX and Discover 
transactions if you are trying to settle them. Void the transaction 
that is numbered nn. Write down all the information so that you 
can retry the transaction later, and void the transaction to 
remove it from the batch and try to settle again. If successful, 
note any differences between the failed transaction and the 
successful transaction.
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VISANET “Unexpected Bel” or 
“Unexpected Ack” error 
when trying to settle

Like LRC errors, this error is usually indicative of a bad 
connection with the processor. When the Aloha POS system 
sends a batch to Visanet, it verifies each block sent by 
alternating between a ‘bel’ or an ‘ack’ response. If the Aloha 
POS system receives two ‘bels’ in a row or two ‘acks,’ then a 
block of data was lost. you can immediately attempt to settle the 
batch and it will typically settle. If the problem persists, try again 
later.

VISANET Duplicate batch #xxx on 
MMDD

If you look at the setup properties of Visanet, you will notice a 
batch number in the lower left hand corner. Each batch is 
assigned a number, and this number will increment with each 
batch. If Radiant Systems, or a dealer has to settle a batch at our 
office, the batch number will increment in the office but not at 
the store. Unless the store manually increments the number by 
one, they will receive this message.

VISANET Error 51 Declined When authorizing a credit card, a message is returned with 
error ‘51 Declined’. This response has been returned by Visa 
and means ‘Insufficient Funds’ or ‘Insufficient Credit Limit’.

Processor Error Messages Resolution
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NCR Voyix welcomes your feedback on this document. Your comments can be of great value in 
helping us improve our information products. Please contact us using the following email address: 
Documentation.HSR@NCRVoyix.com

mailto:documentation.hsr@ncrvoyix.com
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