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Revision Record 

Date Version # Description

Prior to 
12/14/2022

v14.+ Introduced Campaign Rulebook.

v17.1+ Included customer surveys and the ability to set printing conditions, such as 
a specific comp or promo cannot be applied to the guest check for the 
customer survey to print.

v19.3.8+ Added the ability to define a set of conditions under which a customer 
survey prints.

12/14/2022 Converted the document to use new template.

01/17/2023 Updated the front cover and back page to reflect new NCR branding.

06/20/2024 Updated document to reflect NCR Voyix branding. 
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About Campaign Rulebook  

Campaign Rulebook, available in Aloha® Quick Service and Aloha Table Service, supports marketing 
campaigns that help you generate traffic and increase sales in your restaurant. One common 
marketing approach is to offer a guest a reward they can redeem on a later visit, based on their 
purchases from the current visit. Using Campaign Rulebook, you can define a set of conditions under 
which a guest can earn a reward, either in the form of a printed voucher the guest can redeem on a 
later visit, a survey to complete, or it can be an immediate bounce-back reward. For example, when a 
guest purchases an entrée, you can print a voucher or customer survey offering the guest a free 
dessert on their next visit, with the provision that the guest redeem the voucher within a designated 
time period. Additionally, you can provide a survey whereby your guests can rate their visit to the 
restaurant and receive a reward after completion. Or, you can offer an immediate reward, such as a 
free $5.00 gift card with the purchase of $50.00 in gift cards. You can also print a voucher, on 
demand (see Figure 1), offer a guest a free item on their next visit. 

You can also define a set of conditions under which a customer survey prints. For example, when a 
guest purchases a minimum of $10.00 from the Food category, the designated customer survey 
prints on their guest check. You can also stipulate that a specific comp or promo cannot be applied to 
the guest check for the customer survey to print. In the Customer Survey function, a new choice, All, 
is available for ‘Day part 1’ on the Survey tab under the ‘Day part/frequency setup’ group bar. 
Selecting All ensures the survey prints for all day parts and removes the remaining ‘day part’ and 

Campaign Rulebook at a Glance

Core Product Aloha Quick Service, Aloha Table Service

Complementary Products No

Separate License Required? No

Other References Print Designer Feature Focus Guide, Customer Survey Feature 
Focus Guide, Aloha Quick Service Reference Guide, Aloha 
Table Service Reference Guide
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‘frequency’ options. When using Campaign Rulebook to set conditions under which a survey prints, 
you must use the Event Schedule function to activate the campaign and kick off the survey. 

Create your surveys using the Survey function. You define the times when the survey is valid, the 
frequency the survey prints, such as for specific day parts or all day, a banner to precede the survey, 
and the text to appear in the survey. 

Examples of some marketing campaigns include:

● ‘Purchase an entrée valued at $30.00 and receive a free appetizer on your next visit.’
● ‘Purchase $50.00 in gift cards and receive a free $5.00 gift card.’
● ‘We’d like to offer you a free hamburger as a thank you for completing our survey within 5 days 

of your visit. www.alohacafesurvey.com Survey number: 1234-567-89. At the end of the survey, 
provide your email so we can send you the free hamburger offer.’

● ‘Thank you for your visit. Please accept this voucher as a token of our appreciation. This voucher 
is good for $5.00 off your next visit, from 01/12/2014 to 3/12/2014.’ 

Figure 1  Print on Demand Offer

Reference
Refer to the Customer Survey Feature Focus Guide - HKS304 for more information.

Tip
The Promotions feature in the Aloha POS system is robust and can handle a lot of your marketing 
needs. Campaign Rulebook does not replace the Promotions function. If possible to achieve your 
promotion goal using Promotions, choose this function first. 

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS304
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Configuring Campaign Rulebook
This document provides the configuration requirements within Aloha Manager and Aloha 
Configuration Center (CFC) for Campaign Rulebook. Refer to the Procedures at a Glance table for 
abbreviated steps, or, if you prefer more detail, click the link. 

Campaign Rulebook Procedures at a Glance:

If you are viewing this document using Adobe Acrobat Reader, click each link for detailed information 
regarding the task. 

1. Access Maintenance > Hardware > Print Designer and design a voucher for each campaign in 
which you are trying to drive traffic back in to your restaurant at a later date. Use the layout of the 
‘General message’ type in Print Designer to define and format the text that prints on the voucher. 
Refer to the Print Designer Feature Focus Guide for complete details regarding the layout of the 
‘General message’ type. See page 7. 

2. Access Maintenance > Messaging > Survey to create a survey in which to use in conjunction with 
a campaign. See page 9. 

3. Access Maintenance > Guest Experience > Campaign Rulebook to create the rule that defines 
the conditions and actions under which a guest receives a reward for a campaign. See page 9.

4. Access Maintenance > Guest Experience > Campaign Rulebook to define conditions under 
which a customer survey prints. See page 16.

5. Access Maintenance > System Settings > Activation Schedule and Maintenance > System 
Settings > Event Schedule to activate the campaign. See page 20.

6. Access Maintenance > Payments > Promotions and create a New Price promo that auto-applies 
for use with a bounce-back gift card campaign. To designate the bounce-back gift card as free, type 
$0.00 as the new price. See page 22.

7. Access Quick Service Screen Designer or Table Service Screen Designer and add a button to 
the Front-of-House (FOH) that allows you to print a campaign voucher on demand. (Optional) See 
page 25.

8. Access Utilities > POS > Refresh POS & All Installed Products to refresh your POS system. See 
page 27.
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Designing the voucher for a campaign
To define and format a voucher to print for a campaign in which you are trying to drive traffic back in 
to your restaurant at a later date, use the layout of the ‘General message’ type in Print Designer. We 
recommend you begin by copying the default ‘General Message’ template provided for you, rather 
than creating a layout from scratch, to save time and to complete the task more quickly. You can then 
remove elements from, or add elements to, your new layout, and move elements up or down, to 
change the order in which they appear on the voucher. 

1. Select Maintenance > Hardware > Print Designer. 

2. Select 9996 General Message from the ‘Print Designer’ drop-down list, if not already selected.
3. Click Copy in the Command panel to display the copy options. 

4. Accept the system assigned number or click the drop-down arrow next to ‘Copy to number’ to 
display the Number Assignment dialog box, from which you can choose an alternate number, 
and click OK.

5. Replace the default text of General Message in ‘Name’ with text that helps identify the layout, 
such as ‘Guest Appreciation.’

Figure 2  Print Designer - Layout Tab

Figure 3  Copy of General Message
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6. Click the Design tab. The default layout for the ‘General message’ layout appears. 

7. Add or remove elements to the layout, based on your needs. For example, to insert a blank line 
between two lines of text, click the Add drop-down arrow, select Linefeed as the type, and click 
OK. 

8. Use Move Up and Move down to change the order in which elements appear in the layout. 
9. Select an element under the ‘Design’ group bar and options specific to that element appear 

under the ‘Print style settings’ group bar. Customize each element as you see fit.

a. Select the relative size of printed text for the selected element from the ‘Size’ drop-down list. 
Your choices are Large, Medium, Small, Very small, and Very large.

b. Select Expanded width, to stretch the printed element horizontally across the line.
c. Select Expanded height, to increase the height of the printed element.
d. Select Italic, Underlined, Red, or Bold, to change the appearance of the element, if 

desired.

10. For ‘User text’ elements, under the ‘User text settings’ group bar, type the text to appear on that 
line of the voucher.

11. To establish the number of calendar days after printing the voucher an offer is valid, select the 
Redemption period element under the ‘Design’ group bar and type the number of days, such 
as 10. The system then determines the redemption period beginning with the next business date. 

Figure 4  Print Designer - Design Tab
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For example, if you print the voucher on January 7th, the redemption period will be from January 
8th to January 18th. 

12. Click Save and exit the Print Designer function.

Creating a customer survey
We expanded the Campaign Rulebook feature to allow you to also include a customer survey. You 
define a set of conditions under which a customer survey prints. You can also stipulate that a specific 
comp or promo cannot be applied to the guest check for the customer survey to print. Create a 
customer survey in the Survey function. 

Creating a campaign in Campaign Rulebook
The Campaign Rulebook function is where you define the actual set of conditions under which a 
guest can earn a reward for a campaign. You also specify the reward the guest receives when they 
meet the conditions of the campaign. The reward can be in the form of a printed voucher to be 
redeemed on their next visit to your restaurant, or an immediate reward, such as a free $5.00 gift 
card with the purchase of $50.00 in gift cards, or a survey to complete in exchange for a free item. 

We recommend you create a separate category for each campaign. For example, create a separate 
category for your bounce-back gift cards in which you place only and all of your bounce-back gift 
card items. Create another category for your bounce-back t-shirts, and so on. In the case of 
bounce-back gift cards, you must also create a New Price promotion in which you stipulate the 
discounted price for the gift card. This is necessary because the system needs to automatically 
authorize the gift card at its full price, and then adjust the price for the bounce-back gift card to free 
on the guest check. 

Reference
Refer to the Customer Survey Feature Focus Guide - HKS304 for more information.

Tip
For campaigns in which you offer other non-gift card items for free, just create a zero-priced item; a 
New Price promotion is not necessary.

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS304
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To create a campaign:

1. Select Maintenance > Guest Experience > Campaign Rulebook.
2. Click New and accept the system assigned number or click the ellipsis (...) next to ‘Number’ 

to display the Number Assignment dialog box, from which you can choose an alternate 
number.  

3. Under the ‘Identification’ group bar on the Campaign Rulebook tab, type a name for the 
campaign, such as ‘Guest Appreciation.’

4. Under the ‘Settings’ group bar, select Apply action repeatedly if condition is met more than 
once, if you create a campaign that allows a guest to receive the reward for each valid 
occurrence of the campaign conditions on a guest check. For example, in a campaign that 
stipulates a ‘Free Taco’ voucher prints when a guest orders an entrée and a drink, if a family 
orders a burrito platter, an enchilada platter, and two drinks, valid conditions exist on the guest 
check for the guest to receive two ‘Free Taco’ vouchers. 

5. Type the maximum number of times to apply the action, to stipulate the number of times a guest 
can qualify for a campaign, per guest check.

6. Continue to the next procedure. 

Figure 5  Campaign Rulebook Tab
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To establish the conditions under which a guest qualifies for a campaign reward: 

1. Select the Rules tab. 

2. Under the ‘Campaign Rules’ group bar, click Add. The ‘Rule’ appears in red text until you add a 
condition or action to the campaign rule, at which time the rule appears in green text. 

3. To create a condition based on the category from which a guest makes a selection, on the 
Conditions tab located to the right, click the ‘Add’ drop-down arrow, select Category as the type, 
and click OK. The ‘Category Condition’ group bar appears. 

a. Click Add to add a blank record.

Figure 6  Rules Tab

Figure 7  Condition - Categories



 Campaign Rulebook
Configuring Campaign Rulebook

12

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

b. Click the drop-down arrow and select the category from which a guest must make a 
purchase to qualify for the campaign.

c. Type the minimum amount a guest must purchase from the selected category before 
qualifying for the campaign in ‘Sales threshold.’ Zero (0.00) is a valid amount. For example, 
you can stipulate a guest must purchase at least $25 from the FOOD category to qualify for 
the campaign.

d. To create an ‘or’ situation and stipulate a guest can make a purchase from any of two or more 
categories to qualify, repeat steps a thru c. For example, do this if a guest must make a 
selection from either the FOOD category or the ENTREES category to qualify for this 
campaign. 

4. To create a condition based on the check total, under the ‘Conditions’ group bar, click the ‘Add’ 
drop-down arrow, select Check total as the type, and click OK. The ‘Check total Condition’ 
group bar appears.

a. Click Add to add a blank record.

Tip
You can define multiple conditions in a single rule. The system analyzes the conditions in the 
order they appear in the rule, and continues until a condition is true; once true, it applies the 
reward and exits Campaign Rulebook.

Figure 8  Condition - Check Totals
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b. Click the drop-down arrow and type the check total amount required to qualify for the 
campaign. For example, you can stipulate the guest check must total at least $30 to qualify for 
the campaign. 

To delete a condition, click Remove under the ‘Conditions’ group bar.
5. To create a condition where the presence of a comp on the guest check stops the campaign from 

printing, under the ‘Conditions’ group bar, click the ‘Add’ drop-down arrow, select Comp as the 
type, and click OK. The ‘Comp Condition’ group bar appears.

a. Click Add to add a blank record.
b. Click the drop-down arrow and select the comp to exclude the campaign from printing on 

the guest check.
c. To add another comp, repeat steps 2 and 3.

To delete a condition, click Remove under the ‘Conditions’ group bar.
6. To create a condition where the presence of a specific promo on the guest check stops the 

campaign from printing, under the ‘Conditions’ group bar, click the ‘Add’ drop-down arrow, 
select Promo as the type, and click OK. The ‘Promo Condition’ group bar appears. 

a. Click Add to add a blank record.

Tip
You can define multiple conditions in a single rule. The system analyzes the conditions in the 
order they appear in the rule, and continues until a condition is true; once true, it applies the 
reward and exits Campaign Rulebook.

Figure 9  Condition - Comps
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b. Click the drop-down arrow and select the promo to exclude the campaign from printing on 
the guest check. For example, ‘Free Small Shake.’

c. To add another promo, repeat steps 2 and 3.

To delete a condition, click Remove under the ‘Conditions’ group bar. 
7. Continue to the next procedure.

To stipulate the actions of the campaign: 

1. Select the Actions tab, located to the right of the Conditions tab. 
2. To print a voucher on the guest check for the guest to redeem on a later visit to your restaurant, 

click the Add drop-down arrow under the Actions group bar, select Print general message as 
the type, and click OK. The ‘Print general message’ group bar appears. 

a. Under the ‘Actions’ group bar, click Add to add a blank record.
b. Click the drop-down arrow and select Print general message.
c. Under the ‘Print general message’ group bar, click Add and select the general message 

you created in Print Designer for this campaign. 
d. To add additional general messages to the guest check, repeat steps a through c.

The completed rule appears under the Campaign Rules group bar, allowing you to review 
your selections. To delete an action, click Remove.

Figure 10  Printing General Message
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3. To print a customer survey with the offer of a free or discounted item at the end, click the Add 
drop-down arrow under the Actions group bar, select Print survey as the type, and click OK. 
The ‘Print survey’ group bar appears. 

a. Click Add to add a blank record.
b. Click the drop-down arrow and select Print survey. 
c. Under the ‘Print survey’ group bar, select the survey to print.
d. To add additional surveys to the guest check, repeat steps a through c.

The completed rule appears under the Campaign Rules group bar, allowing you to review 
your selections. To delete an action, click Remove.

Figure 11  Printing Survey
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4. To reward the guest with a discounted item added to their guest check, such as a $5.00 
bounce-back gift card at no charge, click the Add drop-down arrow under the Actions group bar, 
select Add item as the type, and click OK. The ‘Add item’ group bar appears. 

a. Click Add to add a blank record.
b. Click the drop-down arrow and select the Add item from the drop-down list.
c. Under the ‘Add item’ group bar, select the item to add.
d. To add additional items, repeat steps a through c.

The completed rule appears under the Campaign Rules group bar, allowing you to review 
your selections. To delete an action, click Remove.

5. Click Save and exit the Campaign Rulebook function.

Defining conditions for printing customer surveys
Campaign Rulebook feature allows you to also define a set of conditions under which a customer 
survey prints. For example, when a guest purchases a minimum of $10.00 from the Food category, 
the designated customer survey prints on their guest check. You can also stipulate that a specific 
comp or promo cannot be applied to the guest check for the customer survey to print. In the 
Customer Survey function, a new choice, All, is available for ‘Day part 1’ on the Survey tab under the 
‘Day part/frequency setup’ group bar. Selecting All ensures the survey prints for all day parts and 
removes the remaining ‘day part’ and ‘frequency’ options. When using Campaign Rulebook to set 

Figure 12  Adding Item(s)
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conditions under which a survey prints, you must use the Event Schedule function to activate the 
campaign and kick off the survey. 

To define conditions under which a customer survey prints: 

1. Select Maintenance > Guest Experience > Campaign Rulebook. 
2. Click New and accept the system assigned number or click the ellipsis (...) next to ‘Number’ 

to display the Number Assignment dialog box, from which you can choose an alternate 
number.

3. Under the ‘Identification’ group bar on the Campaign Rulebook tab, type a name for the 
campaign, such as ‘Guest Appreciation.’

4. Under the ‘Settings’ group bar, clear Apply action repeatedly if condition is met more than 
once, if you create a campaign that allows a guest to receive the reward for each valid 
occurrence of the campaign conditions on a guest check. For example, in a campaign that 
stipulates a ‘Free Taco’ voucher prints when a guest orders an entrée and a drink, if a family 
orders a burrito platter, an enchilada platter, and two drinks, valid conditions exist on the guest 
check for the guest to receive two ‘Free Taco’ vouchers. 

5. Type 0 (zero) to apply the action unlimited times, or specify a number to limit the number of 
times to apply the action. 

6. Continue to the next procedure. 

Reference
Refer to the Customer Survey Feature Focus Guide - HKS304 for more information.

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS304
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To establish the conditions under which to print the customer survey:

1. Select the Rules tab. 

2. Under the ‘Campaign Rules’ group bar, click Add. The ‘Rule’ appears in red text until you add a 
condition or action to the campaign rule, at which time the rule appears in green text. 

3. To create a condition based on the category from which a guest makes a selection, on the 
Conditions tab located to the right, click the ‘Add’ drop-down arrow, select Category as the type, 
and click OK. The ‘Category Condition’ group bar appears.

a. Click Add to add a blank record.
b. Click the drop-down arrow and select the category from which a guest must make a 

purchase to receive the survey.
c. Type the minimum amount the guest must purchase from the selected category before 

receiving the survey in ‘Sales threshold.’ Zero (0.00) is a valid amount. For example, you can 
stipulate a guest must purchase at least $50 from the FOOD category before receiving the 
survey. 

4. To create a condition based on the check total, on the Conditions tab located to the right, click 
the ‘Add’ drop-down arrow, select Check total as the type, and click OK. The ‘Check total 
Condition’ group bar appears.

a. Click Add to add a blank record.
b. Type the amount of the check total the guest must purchase before receiving the survey.

Figure 13  Campaign Rulebook - Conditions Tab
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5. To stipulate a comp that cannot be included on the check, on the Conditions tab located to the 
right, click the ‘Add’ drop-down arrow, select Comp as the type, and click OK. The ‘Comp 
Condition’ group bar appears.

a. Click Add to add a blank record.
b. Click the drop-down arrow and select the comp to exclude, such as ‘Mngr Comp’ or 

‘Employee Meals,’ setting the condition that if the related comp appears on the guest check, 
the guest does not receive the survey. 

6. To stipulate a promo that cannot be included on the check, on the Conditions tab located to the 
right, click the ‘Add’ drop-down arrow, select Promo as the type, and click OK. The ‘Promo 
Condition’ group bar appears.

a. Click Add to add a blank record.
b. Click the drop-down arrow and select the promo to exclude, such as ‘Free Med Fries,’ 

setting the condition that if the related promo appears on the guest check, the guest does not 
receive the survey. 

7. Continue to the next procedure.

To establish the customer survey to print for the campaign: 

1. Select the Actions tab, located to the right of the Conditions tab. 

2. Click the Add drop-down arrow under the Actions group bar, select Print survey as the type, 
and click OK. The ‘Print survey’ group bar appears.

a. Click Add to add a blank record.

Figure 14  Campaign Rulebook - Actions Tab

Completed rule
Actions
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b. Click the drop-down arrow and select the survey you created earlier. 

The completed rule appears under the ‘Campaign Rules’ group bar, allowing you to review 
your selections.

3. Click Save and exit the Campaign Rulebook function. 

Activating a campaign
The Activation Schedule and Event Schedule functions work together to establish when and what 
campaigns to activate in a Campaign Rulebook. The activation schedule you choose determines when 
the campaign is to recur, such as daily or only on Thursday, and the time it is to start, such as start of 
day, or at 5:00 p.m. There are two event types used for supporting a campaign: Activate Guest 
Experience Campaign and Disable Guest Experience Campaign. Use Activate Guest Experience 
Campaign to designate a campaign to make active and choose an activation schedule with a desired 
recurrence and start time for kicking off the campaign. Use Disable Guest Experience Campaign to 
end a campaign prior to the end of day and choose an activation schedule with a desired recurrence 
and start time for disabling the campaign. 

Creating an activation schedule
Analyze your existing activation schedules to determine if a schedule with the desired recurrence 
interval and start time exists for activating the campaign as well as for cutting it off each day. If yes, 
use that activation schedule to activate the campaign; if not, create a new activation schedule to meet 
your needs. For the purpose of the scenario in this section, the campaign recurs daily and is in effect 
until 8:00 p.m. each day. The POS system provides a default ‘Always’ activation schedule configured 
for start-of-day, which meets the recurrence needs and start time for initiating the campaign; however, 
we need to create another activation schedule that starts at 8:00 p.m. to disable the campaign at that 
time and not wait until the end of day. 

To create an activation schedule that starts at 8:00 p.m. daily to use for disabling a cam-
paign:

1. Select Maintenance > System Settings > Activation Schedule.
2. Click the New drop-down arrow, select Daily as the schedule type, and click OK. 
3. Type a name for the activation schedule, such as Disable Daily Campaign.
4. Under the ‘Time’ group bar, enter the time using a 48-hour clock. To activate the schedule at 8:00 

p.m. type 20:00. 
5. Click Save and exit the Activation Schedule function. 

Reference
Refer to the Quick Service Reference Guide or Table Service Reference Guide for more information 
on Activation Schedules. 

https://proddocsitesa.blob.core.windows.net/downloads/aloha-pos/TS199_ReferenceGuide.pdf
https://proddocsitesa.blob.core.windows.net/downloads/aloha-pos/QS199_ReferenceGuide.pdf
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Adding the Activate/Disable Guest Experience Campaign to event schedule
Adding the Activate Guest Experience Campaign event type to an event schedule designates the 
campaign to activate and the dates on which to offer this campaign to your guests. How you are using 
the Event Schedule function determines whether you add this event type to an existing event schedule 
or add it to a new event schedule you create. For the purposes of this document, we assume you use 
one event schedule to which you add all events. Add the ‘Disable Guest Experience Campaign’ event 
type to stop a campaign at a specific time of day rather than waiting for the end of day to occur to 
disable it.

To activate the campaign using an existing event schedule.

1. Select Maintenance > System Settings > Event Schedule. 
2. Select the event schedule to edit from the drop-down list.
3. Select the Events tab. 

4. Click the ‘Add’ drop-down arrow, select Activate Guest Experience Campaign as the event 
type, and click OK. Activate Campaign appears in the list of events.

5. Select Always from the ‘Activation Schedule’ drop-down list. Because the Always activation 
schedule stipulates to begin at ‘start of day,’ you cannot edit the ‘Start time’ in the event 
definition. This information is read only. If you want to stipulate a specific time of day to start the 
campaign, you need to select or create an activation schedule that starts at the correct time.

6. Select the date on which you want the campaign to become active at the store in ‘Start date.’ 
7. Select the date on which you no longer want the campaign to be active at the store in ‘End date.’ 
8. Under the ‘Activate Guest Experience Campaign’ group bar, select the campaign to activate from 

the drop-down list.
9. Continue to the next procedure.

Figure 15  Type - Activate Guest Experience Campaign
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To stop the campaign at a specific time of day rather than waiting for the end of day to dis-
able it: 

1. Click the Add drop-down arrow, select Disable Guest Experience Campaign, and click OK. 
Disable Campaign appears in the list of events. 

2. Select the activation schedule that starts at the time you want to stop the campaign. 
3. Select the same date on which you want the campaign to become active at the store in ‘Start 

date.’ 
4. Select the same date on which you no longer want the campaign to be active at the store in ‘End 

date.’
5. Under the ‘Disable Guest Experience Campaign’ group bar, select the campaign to disable from 

the drop-down list.
6. Click Save and exit the Event Schedule function.

Creating a promotion for a bounce-back gift card campaign
To configure the system so that it automatically adds a bounce-back gift card to the guest check based 
on a minimum purchase, such as a free $5.00 gift card with the purchase of $50.00 in gift cards, 
you must use the New Price promotion type, set the new price, in this case $0.00 (free), and 
configure it to auto-apply. The New Price promotion is necessary because the system automatically 
authorizes the gift card at its full price, but adjusts the price for the bounce-back gift card to free on 
the guest check when it is offered as a reward on a bounce-back campaign. When creating a 
campaign where the guest receives a bounce-back gift card, we recommend putting the bounce-back 
gift card in a separate category. For example, create a category in which you only place your 
bounce-back gift card items. 

Figure 16  Type - Disable Guest Experience Campaign
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To configure a promotion to authorize a bounce-back gift card at its full amount, and then 
auto-apply the bounce-back gift card to the guest check at its discounted price:

1. Select Maintenance > Payments > Promotions. 

2. Click the New drop-down arrow, select New Price as the type, and click OK. 

Figure 17  Type - New Price
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3. Accept the system assigned number or click the ellipsis button (...) next to ‘Number’ to 
display the Number Assignment dialog box, from which you can choose an alternate number. 

4. Type a name, such as Free $5 BB GC, to assist with identifying the promotion.
5. Select Active.
6. Use the drop-down arrows to select the dates on which the New Price promotion starts and ends 

from the calendar.
7. For Table Service, clear First available button position to enable ‘Button position’ and ensure 

None appears in ‘Button position.’ A bounce-back promotion does not need to appear on the 
Promotions screen because it auto-applies to the check. 

8. Select Print check on close, to automatically print a copy of the guest check immediately after 
applying this promotion, for the guest to view.

9. Select Manager required, if a manager must enter their number to apply the bounce-back 
promotion. Clear this option to allow any employee to apply the bounce-back promotion.

Figure 18  Promotion Tab
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10. Select the New Price tab. 

11. Select Auto-apply to automatically discount the bounce-back item when items on the guest check 
qualify for the bounce-back promotion.

12. Select the Eligibility tab.
13. Under the ‘Items’ group bar, click Add and select the bounce-back gift card item. 
14. Type the discounted price for the bounce-back gift card in the New Price column. To discount a 

bounce-back gift card so that it is free, type 0.00 as the new price.
15. Click Save and exit the Promotions function.

Adding button to FOH for on-demand campaign voucher printing
The Aloha POS system allows you to print a campaign voucher on demand from a FOH terminal. 

Figure 19  New Price Tab

Tip
We highly recommend using a script on the button, so that you can include manager approval for 
security reasons and have better control over who receives the campaign voucher. 
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You can add the button to any panel in Quick Service; however, for Table Service, you must add the 
button to either a floor plan in use or create a panel of the Order Entry type to customize the buttons 
available to you in the lower right portion of the order entry screen.  

To add a button for on-demand campaign voucher printing:

1. Select Maintenance > Screen Designer > Quick Service Screen Designer or Table 
Service Screen Designer. 

2. Select Work with Panels.
Select Panel > Open Panel, select a panel, and click OK. 
-OR-
Create a new panel. If you are using Table Service, select either New Floorplan Panel or New 
Order Entry Panel. 

3. Right-click the panel and select New Button. The Properties dialog box appears.
4. Under the ‘Function’ group bar, select Script from the ‘Action’ drop-down list.
5. Select the ellipsis button (...) from the ‘Script Actions’ drop-down list. The Edit Script Actions 

dialog box appears.
6. Click Add. 
7. Under the ‘Function’ group bar, select Just-in-time Manager Approval from the ‘Action Type’ 

drop-down list. 
8. Select one or more access levels that need the ability to approve the on-demand print 

from the ‘POS Access Levels’ drop-down list.
9. Click OK. 
10. Click Add. 
11. Under the ‘Function’ group bar, select Print Message from the ‘Action Type’ drop-down list. 
12. Select the applicable campaign message, created using Print Designer, from the ‘Message’ 

drop-down list. 
13. Click OK 
14. Under the ‘Appearance’ group bar, type a name for the button, such as ‘Free\nBurrito.’ To 

display text on multiple lines, insert ‘\n’ without spaces for line breaks.
15. Configure the remaining options as you would for any other button.
16. Select Panel > Save Panel and exit Quick Service Screen Designer or Table Service 

Screen Designer. 

Tip
If you choose to customize the buttons available in the lower right portion of the order entry screen, 
refer to the Custom TS Order Entry Screen Feature Focus Guide - HKS349 for more information.

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS349
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Refreshing the data
After all settings are in place in Aloha Manager, you must select Utilities > POS > Refresh POS & All 
Installed Products to transfer the new information to the FOH terminals, or wait for the End-of-Day 
(EOD) process to accomplish the data refresh for you. If you run the refresh prior to the EOD 
process, select ‘Automatically restart all POS terminals’ and click OK to continue. After the data 
refresh is complete, all new settings become operational across the Aloha network. 

Caution
Refresh data with caution and never during peak hours of operation. All FOH terminals reboot 
during a refresh and are down for a short period of time.
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Using Campaign Rulebook
In keeping with the examples sited in “About Campaign Rulebook” on page 4, the following 
procedures walk you through printing a voucher the guest can redeem on a later visit based on their 
current purchases, an immediate bounce-back reward for a free $5.00 gift card with the purchase of 
$50.00 in gift cards, and printing a voucher on demand, offering the guest a free item on their next 
visit. 

Auto-printing a voucher based on guest purchases
You offer a campaign that automatically prints a voucher when a guest purchases an entrée valued at 
$30.00. The voucher allows the guest to receive a free slice of French Silk pie on their next visit, as 
long as that visit is within a specific time frame. The guest orders a Steak, valued at $30.00. 

To auto-print a voucher based on guest purchases:

1. Log in to the FOH. 
2. Start a new check. 
3. Add the Steak item to the guest check. The system recognizes the Steak item is an entrée valued 

at greater than $30.00.
4. When the guests are ready to leave, close the guest check. 

A message in the form of a voucher prints at the bottom of the guest check, letting the guest know 
they qualify for the free appetizer if they visit the restaurant within the designated time frame.

Figure 20  Auto-Printing a Voucher Based on Guest Purchases

Survey Banner text

Survey Message text
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Printing a survey based on conditions
You offer a survey campaign that automatically prints a survey when a guest check totals $30.00 and 
an employee meal comp is not included on the check. Your guest rates their experience at your 
restaurant and provides an email address upon completion, which allows you to email a coupon to 
the guest for a free item. 

To print a survey:

1. Log in to the FOH.
2. Start a new check.
3. Add the items to the guest check, which totals over $30.00.
4. Verify an employee meal comp is not on the guest check.
5. When the guests are ready to leave, close the guest check. 

A message in the form of a survey prints at the bottom of the guest check, letting the guest know 
if they complete the survey and provide a coupon validation code, they will receive $5.00 off 
their next meal. 

Figure 21  Printing a Survey Based on Conditions

Survey Banner text

Survey Message text
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Rewarding a guest with a bounce-back gift card
You offer a campaign that automatically rewards a guest with a free $5.00 gift card when the guest 
purchases a minimum of $50.00 in gift cards. The system discounts the bounce-back gift card 
differently, depending on if you use Quick Service or Table Service. Quick Service discounts the 
bounce-back gift card as soon as the verification is complete; Table Service discounts the 
bounce-back gift card only after you touch Close to apply payment and close the guest check.

To reward a guest with a bounce-back gift card in Quick Service:

1. The cashier adds a $50.00 gift card to the guest check. The system recognizes the guest 
qualifies for a free $5.00 bounce-back gift card reward based on the purchase of a $50.00 gift 
card and displays a prompt to notify the cashier. The cashier can touch OK to confirm and 
activate the free bounce-back gift card, or touch Cancel to decline it.

2. The cashier touches OK to confirm. 

3. The cashier adds a $5.00 bounce-back gift card to the guest check to enable activation. The 
system verifies the gift card and, when approved, automatically applies the promotion to reduce 
the price of the bounce-back gift card to zero.

4. The cashier applies payment and closes the check. 

To reward a guest with a bounce-back gift card in Table Service:

1. The server adds a $50.00 gift card to the guest check. The system recognizes the guest 
qualifies for a free $5.00 bounce-back gift card reward based on the purchase of a $50.00 gift 
card and displays a prompt to notify the server. The server can touch OK to confirm and activate 
the free bounce-back gift card, or touch Cancel to decline it. 

2. The server touches OK to confirm. 

3. The server adds a $5.00 bounce-back gift card to the guest check to enable activation. The 
system verifies the check. 

4. The server touches Close to apply payment to the check. The system automatically applies the 
promotion to the $5.00 bounce-back gift card to reduce the price to zero. 

5. The server accepts payment and closes the check. 

Tip
If the cashier does not have sufficient access, the manager approval screen appears. A 
manager, or employee with sufficient access, must enter their password to continue. 

Tip
If the server does not have sufficient access, the manager approval screen appears. A manager, 
or employee with sufficient access, must enter their password to continue. 
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Printing a voucher on demand
You offer a campaign that allows you to print a voucher on demand, thanking a customer for their visit 
and offering $5.00 off their next visit as a token of appreciation. The guest must return to your 
restaurant and redeem the voucher within a specific time frame. This campaign is helpful in situations 
where you want to promote goodwill with a customer who may have been unhappy with their service. 

To print a voucher on demand: 

1. The cashier touches the ‘voucher’ button on the FOH. The manager approval screen appears. 
2. If required, a manager, or employee with sufficient access, enters their password. The voucher 

prints to the local printer. 
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Campaign Rulebook, Feature Focus Guide

NCR Voyix welcomes your feedback on this document. Your comments can be of great value in 
helping us improve our information products. Please contact us using the following email address: 
Documentation.HSR@NCRVoyix.com

mailto:documentation.hsr@ncrvoyix.com
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