Feature Focus Guide:
Custom FOH Reports

Core Product: Aloha Quick Service, Aloha Table Service
Last Updated: January 28, 2025

Contents
About Custom FOH Reports  ...............ooiiiiiiiiiiiiiiiiiiiicie e 4
Configuring Custom FOH Reports ...............ccccccciiiiiiiiiiiiiiiiiee e, 6
Providing the ability to run custom FOH reports .............ccovvviiiiiieiiiiiiiiiiciee e 7
Enabling on-screen viewing of custom FOH reports ............coooiiiiiiiiiiieeiiiiiiiiiiiieeeeeen, 8
Creating a custom FOH report ..o 9
Adding a custom report button to @ panel .............ccccciiiiiiiiiii 31
Designing the FOH Select a Report screen in Table Service ...............cccoiiiviiiiieeenn.l. 32
Refreshing the data ............ouuiiiiiiiiiiiiiiiii e 34
Using Custom FOH Reports ... 35
Viewing a custom FOH report ... 37
Troubleshooting Custom FOH Reports .................ccccciiiiiiiiiiiiiiiiiie e 40
Appendix A: Use €ase SCENArioS ................cccooooiiiiiiiiiiiiiee e 41
Reporting count of items sold by category and order mode .............cccccvvvviviviniininnnnnnn, 41
Including/excluding comps and promos when calculating guest count ........................ 45
Appendix B: Upgrading Custom FOH Reports .....................cccoiii . 47
N C R V:":YI X © 2025 NUCR Voyix._ All rights reserved. NCR Voyix — Confide_mial
(1 se and Disclose Solely Pursuant to Company Instructions

1



Custom FOH Reports
Copyright and Trademark Information

Copyright and Trademark Information

The products described in this document are proprietary works of NCR Voyix.

NCR Voyix is a registered trademark of NCR Voyix.

Aloha is a registered trademark of NCR Voyix.

Microsoft and Windows are registered trademarks of Microsoft Corporation in the United States and/or other
countries.

All other trademarks are the property of their respective owners.

It is the policy of NCR Voyix to improve products as technology, components, software, and firmware become
available. NCR Voyix, therefore, reserves the right to change specifications without prior notice.

Not all features, functions and operations described herein are available in all parts of the world. In some
instances, photographs are of equipment prototypes; therefore, before using this document, consult with your
NCR Voyix representative or NCR Voyix office for the most current information.

© 2025 NCR Voyix

Atlanta

Georgia

USA

WWW.NCrvoyix.com

All Rights Reserved

N C R v.".YI X © 2025 NCR Voyix. All rights reserved. NCR Voyix — Confidential
% o® Use and Disclose Solely Pursuant to Company Instructions

2



https://www.ncrvoyix.com

Custom FOH Reports
Revision Record

Revision Record

Date

Prior to
12/15/2022

Version #

v7.0+

Description

Implemented Custom FOH Reports using a manual method with an
external .cfg file that you place in the Data directory.

v12.3.31+

Enhanced the solution by adding the Custom FOH Report function in the
configuration management tool. This allows you to build expressions for
syntaxes in an easier manner. Additionally, we migrated the configuration
of a custom report from an external .cfg file created with a text editor to
creating the file with the new interface, and provided additional filters.

v12.3.52+

Added the ‘Allow report to be run for multiple employees at a time’ option
to provide the ability to select and generate data in the report for more
than one employee at a time.

v15.1+

Added a new option for controlling how data sorts and appears in a
custom FOH report. Also added a new option for viewing custom FOH
reports in the FOH instead of automatically printing them to the local
receipt prinfer.

v19.3.8+

Added the ability to use the current #GUESTS variable to show fractional
guest count weights for menu items.

01/13/2023

Converted the document to use new templates. Updated the front cover
and back page to use new NCR branding.

07/07/2023

v19.9

Added item count variables #ltemsxy|z and #Totalltemsxy|z. A use case for
the variables is available in Appendix A.

06/11/2024

Updated document to reflect NCR Voyix branding.

01/28/2025

v19.11

Added guest count variable #FilterdGuestsxy|z. A use case for the
variables is available in Appendix A.
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About Custom FOH Reports

Custom FOH Reports at a Glance

Core Product Aloha Quick Service, Aloha Table Service
Separate License Required? No
Other References Aloha Quick Service Manager Guide; Aloha Quick Service

Reference Guide; Aloha Table Service Manager Guide; Aloha
Table Service Reference Guide

<no line pnnts>
*=*FLASH REPORT***
==*Aloha Cafe
Custom FOH Report —
DOB: 01/01/2012
sssssssssssssssssassssssss
sesgaLESeee
P R i o 0 O 8 0 O N
-Store Portion: 212.00 TOTAL SALES: 500.00
_LJ- 's Sales: 0.00
Ticket Average: h.51 05 Entertain: oS 10.00
CrOfGuests: L1
CROFChecks: 29 03 Saff Disc 15% 15.00
CtofFsalescats: 130
ARLOFSalesCats: 212.00 01 MGR Comp 100% 5.00
ANtDFTaxes: 15.93
AntoOfInclusiveTaxes: 0.00 3
AntOFExclusiveTaxes: 15.93 [TOTAL COMPS: 000
antOFSurcharges: S [ [ S
CEofTenders: 3n IGROSS SALES: 470.00
ARLOFTenders: 257.23
ANtOF TendersHotRedeened : o.00
esepROMOS®**
AntOf TendersinForeignCurrency: 289.51 e FROMOS
ARLOFTips: 0.00 00:Ciec 5% 00
CtofConps: 10
= - Ant0FConps: 16.00 04 Disc 10% 20.00
v : b
nps 0.00 01 Saff Disc 15% 2.00
h CLOfPromos: [
Q" ol 0- 9 lroTaL prOMOTIONS: 22.00
il OOHE NET SALES: 448.00
***DAYMENTS®*"*
20 Cash: 200.00
Jos visa: 100.00
05 Mastercard: 100.00
01 Amex: 10.00
01 Diners: 10.00]
ITOTAL PAYMENTS 420.00
B, 'n—hﬁ-\w,’&m
Figure T Custom FOH Report
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About Custom FOH Reports

Use Custom Front-of-House (FOH) Reports to replace or extend the existing default FOH reports
available in the Aloha® Point-of-Sale (POS) system. By creating your own reports, you have unlimited
flexibility for reporting on any facet of your operation, such as comps and promotions, tipouts, and
more. Additionally, you can filter the reporting data by one or many employees.

A Caution

If you have Custom FOH reports in place and use Print Intercept to view a custom report on the
screen versus automatically printing a report, upon upgrade to Aloha POS v15.1, you must select a
new option called ‘Display custom reports on the FOH' under the ‘Report settings’ group bar under
the Report Printing group located in Maintenance > Business > Store > Store Settings tab. If you do
not, all custom FOH reports automatically print to the local receipt printer.

If you configured custom FOH reports prior to Aloha POS v12.3 you did so by creating an external
configuration file using MS Notepad® and then placing the file in the Data directory. While not
required, we recommend you upgrade your custom FOH reports to use the configuration
management tool, either Aloha Configuration Center or new Aloha Manager. See “Appendix B:
Upgrading Custom FOH Reports” on page 47.
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Configuring Custom FOH Reports

This section details the configuration requirements for customizing a FOH report. If you are an
experienced user, refer to Procedures at a Glance for abbreviated steps. If you prefer more detail,

continue reading this document.

Custom FOH Reports Procedures at a Glance:

If you are viewing this document using Adobe® Acrobat Reader, click each link for detailed information

regarding the task. Click Previous View |@| to return fo this location and proceed to the next step.

1.

Access Maintenance > Labor > POS Access Levels and select ‘Custom Reports’ for each access
level requiring the ability to run custom FOH reports. See page 7.

If you use an Aloha POS version earlier than v15.1, open PrtIncptr.ini using a text editor such as
Notepad, and set FOHDOC_CUSTOMISABLE_REPORT to 1, fo allow you to view a custom report
on-screen instead of automatically sending it fo a printer. You then have the choice to print the report,
if desired. Effective with Aloha POS v15.1, you must access Maintenance > Business > Store > Store
Settings tab > Report Printing group and select ‘Display custom reports on FOH’ under the ‘Report
Settings’ group bar. See page 8.

Access Maintenance > Business > Custom FOH Reports and create a custom report using the
Report Line Builder function. See page 9.

For Quick Service operations and floor plans used in Table Service, access Maintenance > Screen
Designer and add a ‘Custom Report’ button to a panel for each report you use. See page 31.

For Table Service operations, use Notepad a CustRpt.ini file to design the buttons to appear on the FOH
Custom Report screen. See page 32.

Access Utilities > POS > Refresh POS & All Installed Product Data to update the information on
the FOH terminals, or wait for the End-of-Day (EOD) process to accomplish the data refresh for you.

See page 34.

N C R V.".YI X © 2025 NCR Voyix. All rights reserved. NCR Voyix — Confidential
% o® Use and Disclose Solely Pursuant to Company Instructions

6



Custom FOH Reports
Configuring Custom FOH Reports

Providing the ability to run custom FOH reports

To provide the ability for an employee to run custom FOH reports requires you to select ‘Custom
Reports’ in the access level to which you assign the employee. If you clear this option, the employee
accessing the report receives the manager approval screen and a manager with sufficient access must
enter their password to allow the employee to continue.

To provide the ability for an employee to run custom FOH reports:

1. Select Maintenance > Labor > Pos Access Levels.

2. Select an access level that requires the ability to run custom FOH reports.

Pos Access Levels

2 Day Mar v

B Identification
MNumber
MName

B Reports
Restaurant Sales
Server Sales
Manager Flash
Payment
8 Product Mix
8 server Flash

& Breake

Custom Reports

KR OO R

FOH labor reports
B Financial
£ Employee
System

Figure 2 Pos Access Levels

3. Under the ‘Reports’ group bar, select Custom Reports to enable all employees clocked in under
this access level the ability to run custom reports from the FOH.

Click Save.
Repeat this procedure for each access level requiring the ability to run custom FOH reports.

6. Exit the Access Levels function.

N C R v.".YI X © 2025 NCR Voyix. All rights reserved. NCR Voyix — Confidential
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Enabling on-screen viewing of custom FOH reports

If you use an Aloha POS version earlier than v15.1, custom FOH reports print to the local printer by
default. To view a custom report on-screen instead of automatically sending it to the printer, and print
the report only when desired, requires you to enable the print intercept functionality. To enable print
intercept, register and ensure Prilnter.dll resides in the Bin directory. You must also include the
appropriate command lines in Prilncptr.ini in the Data and Newdata directories.

Effective with Aloha POS v15.1, if you want custom reports to appear on the FOH instead of
automatically printing, select ‘Display custom reports on the FOH’ under the ‘Report settings’ group
bar, in the ‘Report Printing’ group on the Store Settings tab in Maintenance > Business > Store.

If using an Aloha POS version earlier than v15.1, to view custom FOH reports on-screen:

1. If using Aloha POS version 6.7 or earlier, access Maintenance > Business > Store > Store
Settings > System group > Interfaces tab and select Use FOH Com interface. For Aloha
POS v12.3 and later, the COM interface is enabled by default.

2. If you currently use print intercept to view standard reports on screen, locate and select
PrtIncptr.ini in the Newdata directory and press Enter. The file opens in Notepad; otherwise,
you need to create this file in Notepad and place it in the Newdata directory.

3. Add the following command line:

FOHDOC_CUSTOMISABLE_REPORT=1

4. Select File > Save.

5. Exit Notepad.

If you currently use print intercept to view standard reports on screen, continue to step 7;
otherwise, open a command prompt on each terminal, navigate to the Aloha\Bin folder on the
Aloha POS system, and execute the following command:

regsvr32 Priinter.dll

7. Refresh the system and start the FOH.

NCR V:2:YIX O N e o Disclose Seley Purant 1o Company atcon
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If using Aloha POS v15.1 or later, to view custom FOH reports on-screen:

1. Select Maintenance > Business > Store.
2. Select the Store Settings tab.
3. Select the Report Printing group located at the bottom of the screen.

Location Information | Licensi\ Custom | Si

B Transaction Chits
& Checkout Reports
B Report settings
POS Flash report time interval in minutes
Enable print option for POS Flash report
1‘5' Automatic 15 minute interval report Disable report b4
ﬁé Limit the: FOH Sales, PMIX and Flash reports to revenue center
@' Sort POS Sales by Revenue Center report by day part

'3

£OS5 labos

&

Do.nok ook

Kpoo

Display custom reports on the FOH

<
S—

Order Entry | Labor| Financials| Check Printing| Chit Printing | REp bing | User Interface| Security| System| Credit Card| ¢ »

Figure 3 Report Settings Group Bar

4. Under the ‘Report settings’ group bar, select Display custom reports on the FOH 1o allow all
custom FOH reports to appear on the FOH screen when you touch the desired report button. You
can also print the report at the local receipt printer if you touch ‘Print’ on the Report screen.

5. Click Save and exit the Store function.

Creating a custom FOH report

You use the Custom FOH Reports function to create your report and the content within the report.
Before you start, you need to be aware of the variables to use in the report and the rules to follow the
correct syntax for the report. If you do not know these, the report may not operate correctly or will not
generate data at all. Once you understand the variables and the configuration rules, you can use the
expression builder inside the configuration tool to build your report. See “Creating a custom FOH

report” on page 2 to build your report.

N C R v.".YI X © 2025 NCR Voyix. All rights reserved. NCR Voyix — Confidential
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Understanding configuration variables

The following tables contain the variables you can use.

Initial
Variable Description N |a.
Version
RELATE TO COMPS:
#C Total count of all comps. Calculation
SC Total amount of all comps. Calculation
#Cnnnn Total count of comp nnnn, where nnnn is the ID of | Calculation
the comp.
SCnnnn Total amount of comp nnnn, where nnnn is the ID | Calculation
of the comp.
Initial
Variable Description " |a.
Version
RELATE TO DELIVERY:
#Delivery Total count of delivery orders. Calculation
$DelComm Total amount of delivery commissions. Calculation
StartMileage Starting mileage. String
EndMileage Ending mileage. String

Variable

Initial

Description

Version

RELATE TO EMPLOYEES:

FirstName Employee first name. String

LastName Employee last name. String

NickName Employee nickname. String

EmployeelD Employee ID number String

JobcodelD Job code ID under which the employee clocked String
in.

JobcodeName Name of the job code under which the employee | String
clocked in.

ShiftNumber Shift number under which the employee worked String
for the checkout.

NCR V::YIX
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Initial

Variable Description X
Version

RELATE TO ENTREE COUNT:

#Entrees Total count of entrees sold. Calculation

Initial

Variable Description

Version

RELATE TO GIFT CERTIFICATES:

#GC Total count of all gift certificates sold. Calculation
$GC Total amount of all gift certificates sold. Calculation
#GCnnnn Total count of gift certificate nnnn sold, where Calculation

nnnn is the ID of the gift certificate.

$GCnnnn Total amount of all gift certificates nnnn sold, Calculation
where nnnn is the ID of the gift certificate.

#GCC Total count of all gift certificate comps. Calculation
$GCC Total dollar amount of all gift certificate comps. Calculation
#GCCnnnn Total count of gift certificate nnnn sold, where Calculation

nnnn is the ID of the gift certificate.

$GCCnnnn Total dollar amount of gift certificate nnnn comps, | Calculation
where nnnn is the ID of the gift certificate.

#GCP Total count of all gift certificate promos. Calculation
S$GCP Total dollar amount of all gift certificate promos. Calculation
#GCPnnnn Total count of gift certificate nnnn promos, where | Calculation

nnnn is the ID of the gift certificate.

$GCPnnnn Total dollar amount of gift certificate nnnn promos, | Calculation
where nnnn is the ID of the gift certificate.

N C R v.".YI X © 2025 NCR Voyix. All rights reserved. NCR Voyix — Confidential
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Initial

Variable Description

Version

RELATE TO GRATUITIES:

SAutoGrat Total amount of all gratuity. Calculation

$SAutoGratnnnn Total amount of gratuity of tender type nnnn, Calculation
where nnnn is the ID of the tender.

SAutoGratWage Total amount of all wage gratuity. A wage gratuity | Calculation POS v13.1
is gratuity with ‘Exclude from employee tip’
selected.

$AutoGratWagennnn Total amount of a wage gratuity, where nnnn is the | Calculation POS v13.1

ID number of the gratuity configured as a wage
gratuity. A wage gratuity is gratuity with ‘Exclude
from employee tip’ selected.

SEmpGrat Total dollar amount of non-distributed and Calculation POS v14.1
nonteam gratuity for the shift of an employee. This
variable is used for a tip and sales distribution
environment.

STeamGrat Total dollar amount of distributed gratuity from Calculation POS v14.1
team checks. This variable is used for a tip and
sales distribution environment.

Initial

Variable Description

Version

RELATE TO GUEST CHECKS:

#Checks Total count of all checks Calculation
#SplitChecks Total count of split checks for this server for this Calculation
checkout.

Note: This variable is not supported for a
custom FOH report.

N C R v.".YI X © 2025 NCR Voyix. All rights reserved. NCR Voyix — Confidential
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Variable

Description

Initial

Version

RELATE TO GUEST COUNTS:

#FilteredGuestsxy|z

The count of guests where x indicates to filter by
the listed comp(s) or promotion(s), y is the comp
ID, and z is the promotion ID to include or
exclude. If more than one of either comp or
promotion, separate the IDs with commas. For
example, #FilteredGuestsinclusive3|4,5
represents a count of guests filtered by comp ID 3
and promotion IDs 4 and 5.
#FilteredGuestsExclusive11|20 represents a count
of guests from all comps except ID 11, and all
promotions except ID 20. Refer to Appendix A for
a use case scenario.

Note: This variable is not supported for a
custom checkout report.

Calculation

POS
v

#Guests

Total count of all guests.

To report fractional guest counts, use the same
variable and define a fractional value in ‘Guest
count weight’ under the ‘General’ group bar in
Maintenance > Menu > ltems > General Settings
tab, and select ‘Reports use fractional guest
counts’ on the Guest Count tab in Maintenance >
Business > Store > Store Seftings tab > Order
Entry group.

Calculation

NCR V::YIX
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Variable

Description

Initial
Version

RELATE TO ITEM COUNT:

#ltemsxy|z

The count of items sold from a specified category
and one or more order modes where x indicates
to include or exclude the listed order mode(s), y is
the category ID, and z is the order mode IDs to
include or exclude. If more than one order mode,
separate the IDs with commas. For example,
#ltemslnclusive3|4,5 represents a count of items
from category ID 3 with order mode IDs 4 and 5.
#ltemsExclusive11]|20 represents a count of items
from category ID 11 with all order modes except
ID 20. Refer to Appendix A for a use case
scenario.

Note: This variable is not supported for a
custom checkout report.

Calculation

POS v19.9

#Totalltemsxy|z

Total count of items sold from a specified category
and one or more order modes where x indicates
to include or exclude the listed order mode(s), y is
the category ID, and z is the order mode IDs to
include or exclude. If more than one order mode,
separate the IDs with commas. For example,
#Totalltemsinclusive3|4,5 represents a total count
of items from category ID 3 with order mode IDs 4
and 5. #TotalltemsExclusive11|20 represents a
total count of items from category ID 11 with all
order modes except ID 20. When paired with the
#ltemsxy|z, variable, ensure both have the same
category and order mode requirements.

Note: This variable is not supported for a
custom checkout report.

Calculation

POS v19.9

NCR V::YIX
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Variable

Description

Initial
Version

RELATE TO ITEMS:

#Clearltems

Total count of all cleared items.

Calculation

POS v6.8

SClearltems

Total amount from all cleared items.

Calculation

POS v6.8

Variable

Description

Initial
Version

RELATE TO ORDER MODE CHARGES:

mode nnnn, where nnnn is the ID of the order
mode.

#OMCnnnn Total count of order mode charges for ordermode | Calculation
nnnn, where nnnn is the ID of the order mode.
$SOMCnnnn Total amount of order mode charges for order Calculation

Variable

Description

Initial
Version

RELATE TO PETTY CASH ACCOUNTS:

SACCTD Total amount of petty cash accounts. Calculation
#ACCTD Total count of petty cash accounts. Calculation
#ACCTnnnn Total count of transactions for cash account nnnn, | Calculation
where nnnn is the ID of the petty cash account.
SACCTnnnn Total amount of transactions for cash account Calculation
nnnn, where nnnn is the ID of the petty cash
account.

Variable

Description

Initial

Version

RELATE TO PROMOTIONS:

#P

Total count of all promos.

Calculation

$P

Total amount of all promos.

Calculation

NCR V::YIX
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Variable

Description

Initial
Version

#Pnnnn Total count of promo nnnn, where nnnn is the ID Calculation
of the promotion.

$Pnnnn Total amount of promo nnnn, where nnnn is the ID | Calculation
of the promotion.

Variable

Description

Initial
Version

RELATE TO REFUNDS:

#R

Total count of all refunds.

Calculation

POS v7.0

SR

Total amount of all refunds.

Calculation

POS v7.0

Variable

Description

Initial
Version

RELATE TO REVENUE ITEMS:

#Rev

Total number of revenue items sold.

Calculation

SRev

Total amount of all revenue items sold.

Calculation

Variable

Description

Initial

Version

RELATE TO ROUNDING:

$Rounding

Total amount of rounding adjusted total, if using
the ‘round check to nickel’ option.

Calculation

NCR V::YIX
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Variable

Description

Initial
Version

RELATE TO SALES:

#EmpSls

Total dollar amount of non-distributed and
non-team sales for the shift of an employee. The
sales amount is for net sales based on sales -
inclusive tax - comps - promos, irregardless of the
‘NetHasComps’ and ‘NetHasPromos’ variable.
This variable is used for a tip and sales distribution
environment.

Calculation

POS vi14.1

#S

Total count from all sales categories.

Calculation

$S

Total amount from all sales categories.

Calculation

#Snnnn

Total count from sales category nnnn, where nnnn
is the ID of the sales category.

Calculation

SSnnnn

Total amount from sales category nnnn, where
nnnn is the ID of the sales category.

Calculation

#NoSales

Total count of No Sale (open drawer) operations
performed (Quick Service only).

Calculation

SCash

Total amount of calculated cash, based on the
following calculation: sales + taxes + gift
certificates sold - tenders - comps - promos + not
redeemed + tip reduction + mode charges.

Calculation

SDeclCash

Total amount of declared cash (Table Service
only).

Calculation

SNet

Total dollar amount of net sales from all
categories.

Calculation

SNetnnnn

Total dollar amount of net sales from category
nnnn, where nnnn is the ID of the category.

Calculation

STeamSls

Total dollar amount of distributed sales from team
checks. The sales amount is for net sales based on
sales - inclusive tax - comps - promos, irregardless
of the ‘NetHasComps' and ‘NetHasPromos'
variable. This variable is used for a tip and sales
distribution environment.

Calculation

POS v14.1

$TipSale

Tippable sales for the check.

Note: This variable is only supported on a Guest
Check Message.

Calculation

POS v6.4

NCR V::YIX
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Variable

Description

Initial
Version

RELATE TO STORE INFORMATION:

RestUnitNumber Restaurant ID number. String
RestUnitName Restaurant unit name. String
RestAddressOne First line of restaurant address. String
RestAddressTwo Second line of restaurant address. String
StoreNumber SupersSite store ID. String
StoreName SuperSite store name. String

Variable

Description

Initial
Version

RELATE TO SERVICE CHARGES:

#SVC

Total count of service charges.

Calculation

$svC

Total amount of service charges.

Calculation

Variable

Description

Initial
Version

RELATE TO SURCHARGES:

SSur

Total amount of all surcharges.

Calculation

SSURnnnn

Total amount of surcharge nnnn, where nnnn is the
ID of the surcharge.

Calculation

Variable

Description

Initial
Version

RELATE TO SYSTEM:

report.

SystemDate Date at the time of printing. String
PrintTime Time when the printing occurs. String
DOB Date of business. String
RptFirstName The first name of the employee who ran the String POS v14.2

NCR V::YIX
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Initial
Variable Description i |a.
Version
RptLastName The last name of the employee who ran the report. | String POS v14.2
RptEmployeelD The ID of the employee who ran the report. String POS v14.2
RptjobCodelD The ID of the job code of the employee who ran String POS v14.2
the report.
RptjlobCodeName The job code of the employee who ran the report. | String POS v14.2
RptShifftNumber The shift number of the employee who ran the String POS v14.2
report.

Variable Description Iniiia.|
Version

RELATE TO TAXES:

#GST Total count of GST taxes. Calculation

$GST Total amount of GST taxes. Calculation

$X Total amount of all taxes. Calculation

SXnnnn Total amount of tax nnnn, where nnnn is the ID of | Calculation

the tax.

$XI Total amount of inclusive taxes. Calculation

SXE Total amount of exclusive taxes. Calculation
#TaxExempt Total count of tax exempt transactions. Calculation
STaxExempt Total amount of tax exempt transactions. Calculation

Initial

Variable Description

Version

RELATE TO TENDERS:

#CCGROREQxxx@nnn | Total count of all credit card transactions greater Calculation POS v12.3
than a specified amount, where xxx is the
specified threshold and nnn is the tender ID. For
example, to count the number of transactions
above $25.00 with a Visa (tender ID 1), type
#CCGROREQ25@001.

N C R v.".YI X © 2025 NCR Voyix. All rights reserved. NCR Voyix — Confidential
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Variable

Description

Initial
Version

SCCGROREQxxx@nnn

Total amount from all credit card transactions
greater than a specified amount, where xxx is the
specified threshold and nnn is the tender ID. For
example, to obtain the total amount of sales from
Master Card (tender ID 2), which were over
$50.00, type $CCGROREQ50@002.

Calculation

POS v12.3

#T

Total amount of all tenders.

Calculation

ST

Total dollar amount of all tenders (includes
gratuity, voluntary tips, and non-redeemed
payments).

Calculation

#Tnnnn

Total count of tender nnnn, where nnnn is the ID of
the tender.

Calculation

STnnnn

Total amount of tender nnnn, where nnnn is the ID
of the tender.

Calculation

STNRnnnn

Total amount of tender nnnn not redeemed
(overpayment without charge to guest), where
nnnn is the ID of the tender.

Calculation

TFCnnnn

Total amount of foreign currency tender nnnn in
foreign currency, not base currency, where nnnn
is the ID of the tender.

Calculation

Variable

Description

Initial

Version

RELATE TO TIPS:

SEmpCCTips

Total dollar amount of non-distributed and
non-team charge tips for the shift of an employee.
This variable is used for a tip and sales distribution
environment.

Calculation

POS vi14.1

$TeamCCTips

Total dollar amount of all distributed charge tips
from team checks. This variable is used for a tip
and sales distribution environment.

Calculation

POS v14.1

$Tips

Total amount of all tips on noncash tenders. Wage
gratuities are excluded from this amount.

Calculation

S$Tipsnnnn

Total amount of tips for tender nnnn, where nnnn
is the ID of the tender. Wage gratuities are
excluded from this amount.

Calculation

NCR V::YIX
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Variable

Description

Initial
Version

excluded from this amount.

$TipsCollected Total dollar amount of tips collected. Wage Calculation
gratuities are excluded from this amount.

$TipsOwed Total dollar amount of tips owed. Wage gratuities | Calculation
are excluded from this amount.

$TipRedux Total amount of tip reduction. Wage gratuities are | Calculation

Variable

Description

Initial
Version

RELATE TO TIPSHARE:

SEmpTipsharePaid

Total dollar amount of non-distributed and
non-team contributed tipshare for the shift of an
employee. This variable is used for a tip and sales
distribution environment.

Calculation

POS v14.1

$TeamTipsharePaid

Total dollar amount of contributed tipshare based
on distributed sales from team checks. This
variable is used for a tip and sales distribution
environment.

Calculation

POS v14.1

$TipsharePaid

Total amount of tipshare paid

Calculation

Variable

Description

Initial

Version

RELATE TO VOIDS:

#V

Total count of all voids.

Calculation

POS v7.0

Y

Total amount of all voids.

Calculation

POS v7.0

NCR V::YIX
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Understanding configuration rules

It is necessary to follow certain rules when creating your configuration file.

Print for all employees or by job code

Use a header to tell the system to print the custom information. You must dedicate the first line to a

header; otherwise, anything placed before the header does not print. If the custom information is to
print for all employees, use [Defaul]. If the custom information is to print for a specific job code, or
job codes, use a ‘jobcode’ header. The information prints until you insert another header to tell the
system to print differently.

Header Examples

[Defauli] Prints custom information for all employees.

[Jobcode:1,5,41] Prints custom information for employees who clocked in under job code IDs 1,5, and
41 only.

[Jobcode:40] Prints custom information only for employees who clocked in under job code ID 40.

® Tip

The first line of your custom information must be a header.

Fill a line with a single character

For readability and dividing sections, you can insert a line composed entirely of a single character.

You must use the ‘Fill' command, enclosed inside greater and less than brackets. Common characters
*

are-, *, or =.
Fill Command Result Printed on the Report
<F|”(*)> *khkkkhkhkkhkhkkhkhkhkhhkkhhkkhhkhdhhdhdhddhhdhhkhhkkihkkhdhkrdhhkkkx
* %

Insert free text

You can insert free text for such things as section headings, labels for calculations, and more. Do not
use closing and ending greater and less than brackets (<>) around any free text. These characters are

reserved for a dynamic calculation or string.

Free Text Result Printed on the Report
Sales Section Sales Section
N C R v.".YI X © 2025 NCR Voyix. All rights reserved. NCR Voyix — Confidential
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Insert blank lines

Each line in the custom configuration file equals to a line printed for your custom information. If you
want a blank line to print, insert a blank line in the configuration file. A line for a header is ignored.

Lines in Checkout.cfg Result Printed on the Report

[Defauli]

<Val(1:DOB)> 01/01/2011

<Fill(=)>

Insert dynamic calculations and strings

Dynamic calculations and strings are the main components of your custom information. A calculation
is a count or equation of a value on which you want to report, such as the number of all comps, or the
calculated total of all comp amounts. A string is the name of a supported variable pulled from within
the system, such as the last name of an employee, or the date of business.

To configure, you must include three required elements, all inside of beginning and closing greater
and less than brackets, as shown in the following:

<Val(width:formula)>
Val - Indicates the result will be a dynamic calculation or string.

Width - Specifies the number of spaces to use for the value, depending on if you are inserting a

dynamic calculation or a string.

NCR V::YIX

Width Used with a Calculation

Width Used with a String

Enter a number, from 1 to 6, to indicate the number
of digits for a calculated value, such as 00.00. The
value is always flush right and the decimal point is
not considered in the width. You must ensure you
indicate the correct number of spaces for the given
value to avoid truncating. For example, if you
specify a width of 3, and the result is 1234, the 1
does not print on the report.

Always enter a width of 1 when using a string. The
system pulls in the string no matter the length of
characters within the string.
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Formula - Specifies the equation of the calculation or the name of the string.

Width Used with a Calculation Width Used with a String

Enter the formula for the calculated value. Always enter a supported string, such as

e You can use supported algebraic operators, such <Val(1:LastName)> or <Val(1:DOB)>. The system
as (), =,/,+,, and more. Multiplication and pulls in and prints the string on the report.

division operators have a higherprecedence over
addition and subtraction.

e You must enter the entire equation within the same
formula, such as <Val(4:#Guest/#Checks)>. You
cannot use a formula to operate with another
formula, such as
<Val(4:#Guest>/<Val(4:#Checks)>.

e An equation results in a numeric value with no
label. If you want a label with your calculation, you
must use free text as a label, or a string, such as
Total Comps: <Val(4:#C)>.

e The result from an equation uses constant
numbers, such as 1 or 2.5. Fractions are never
displayed.

Align text and values on a line

Whether you use free text, a dynamic calculation, or a string, you can align all or individual attributes
on a line. Each line is left aligned, by default, but you can change the positioning with the <Center>
and <Right> commands. Given this, there is no need to use a <Left> command for a line. The
aftributes start left aligned again on the following line.

Alignment Examples Result Printed on the Report

<Center> Guests and Checks Guests and Checks

Liquor: <Right> <Val(7:$S0003)> Liquor 1234.56
Guests: <Center> <Val(4#Guests)> <Right> Guests: 200 7.21
<Val(4:$S/#Guests)>

N C R v.".YI X © 2025 NCR Voyix. All rights reserved. NCR Voyix — Confidential
% o® Use and Disclose Solely Pursuant to Company Instructions

24



Custom FOH Reports
Configuring Custom FOH Reports

Designing a custom FOH report

Once you become familiar with the variables and configuration rules, you can design your FOH
report. You can format and use as many variables as needed, while designing the report.

® Tip
Custom FOH reports were initially supported in Aloha POS v7.0 using a manual method. If you
created a custom FOH report this way, you can still use the report. Refer to “Appendix B: Upgrading
Custom FOH Reports” on page 47.

For ease of creating a custom FOH report, use the Report Line Builder dialog box to insert any
dynamic calculations and strings in the report. For each line that contains a dynamic calculation, you
must click the ellipses (...) for the corresponding variable line in the report to access the dialog box.
You can also type the dynamic calculations and strings manually into the ‘Report line’ column without
using the Report Line Builder, if desired.

To create a custom FOH report:

1. Select Maintenance > Business > Custom FOH Reports.

B Identification

Allow report to be run For multiple employees at a time
B Display options

Design |

Daily Sales Report
CustomFOHReporthumber1.cfg

vl

Standard v

Note: If the list on the right is empty, the information on the report will be for all employees.

Filter by Jobcode

Filter by

»>

<<

4 Training
S Bartender1

6 Line v

Figure 4 Custom FOH Report Function

2. Click New. The configuration management tool, either Aloha Manager (AM) or Aloha
Configuration Center (CFC), creates a configuration file named CustomFOHReportNumberx,
where x is the sequential number of the report, in the NewData directory.

NCR V::YIX
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3. Under the ‘Identification’ group bar, type a name to identify the report.

4. Select Allow report to be run for multiple employees at a time to enable you to select and
generate data in the report on more than one employee at a time. If you clear this option and
select more than one employee, the report appears blank and with no data.

5. Under the ‘Display options’ group bar, select how you wish to sort and display the data from
the ‘Report format’ drop-down list. Your choices are:

Standard — Displays values for the entire day for the line item. This is the default behavior.

Sort data in 15 minute increments — Displays the total value of each line item in 15 minute
increments, for the entire day. Zero (0) appears for time increments for which data is not present.

Sort data in 30 minute increments — Displays the total value of each line item in 30 minute
increments, for the entire day. Zero (0) appears for time increments for which data is not present.

Sort data in 60 minute increments — Displays the total value of each line item in 60 minute
increments, for the entire day. Zero (0) appears for time increments for which data is not present.

Sort by Day Part — Displays the total value for each line item for each configured day part. Zero
(O) appears for day parts for which data is not present.

Sort by Revenue Center — Displays the total value for each line item for each configured revenue
center. Zero (0) appears for revenue centers for which data is not present.

6. If you want to report on a specific job code, or group of job codes, select a job code from the
‘Available’ list and click >> to move the job code to the ‘Filter by list.

7. Select the Design tab.
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8. Click Add.

Custom FOH Reports

Il Daily Sales Report v I

| Custom FOH Report | Design

Design
|Report lines |Edit report line

Remove

Move up

[

Move down

Figure 5 Custom FOH Report - Design Tab

To insert free text, type text directly in ‘Report lines.’
To insert a blank line, leave the line as blank.

To insert a line of characters to indicate a separation in text, type the line of characters.
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To insert a dynamic calculation, click the ellipses (...) to display the Report Line Builder dialog
box. Using the help text, example, and report line as a guide, build the specific line of the report,
and click Insert.

Repnrt Line Builder x|
Categaties Elements Specffic records

Value ~| |Total count of &ll comps |Mumber A Mame | Cwner |
;Zrtr;attmg Manager 10... |1 Aloha Café

Z Employee Meal 1 Aloha Café
3 Free Item 1 Aloha Café
4 Office Empl... 1 Aloha Café
S Fire & Police 1 Aloha Cafe
& OFf Duky Em... 1 Aloha Café
7 WP 1 Aloha Café
& Open § OFf 1 Aloha Cafe |
9 Open % OFF 1 Aloha Café
10 Customer C... 1 Aloha Café ™

Delivery
Employees

|
|
Entree Count |
Gift Certificates |
Gratuities |
Guest Checks
Guest Counts |
Items |
Order Mode Charges
Petty Cash Accounts |
Promotions e |

Help text
h e Help tesct:

Inserts a #C symbol Followed by the ID of a specific comp ko display the total number of transactions involving that comp,

Example
text
P Example:
<Val{7: #CE)=Stalf Disc 15% <Right=<\al{7:$CZ)>
Insert
-

~

cxample

report line
—

Figure 6 Report Line Builder

9. Click OK to return to the Custom FOH Reports function.

10. Repeat steps 6 and 7 until you complete the content of the custom FOH report.
11. Click Save.

12. Repeat this procedure for any other custom FOH report you want to configure.
13. Click Close to exit the Custom FOH Report function.

A sample configuration file and the resulting report is as follows:

Configuration File Result Displayed on the Report

1. | [Default] <no line prints>

2. | <Center> ***FLASH REPORT*** ***FL ASH REPORT™* * *

3. | <Fill(=)> ==========——————————=—oo=o=

4. | <Center>***<Val(1:RestUnitName)>*** ***Aloha Cafe* **

5

6. | Print Date:<Val(1:SystemDate)><Right> Print 01/01/2012 12:00 AM
Time:<Val(1:PrintTime)>

7. | DOB:<Val(1:DOB)> DOB: 01/01/2012

NCR V:2:YIX O N e o Disclose Seley Purant 1o Company efcon
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Line  Configuration File Result Displayed on the Report
8. | <Fill(=)> ======================
9. | <Center>***SALES*** ***SALES* **

10. | <Fill(=)> =======================
11. | TOTAL SALES:<Right><Val7:$S)> TOTAL SALES:
12. | <Fill(=)> —=====================
13.
14. | <Center>***COMPS*** ***COMPS* * *
15. | <Val(7:#C0001)> Entertain: 02
<Right><Val(7:$C0001)> Entertain:
16. | <Val(7:#C0002)> Staff Disc 15% 03 Staff Disc 15%
<Right><Val(7:$C0002)>
17. | <Val(7:#C0003)> MGR Comp 100% 01 MGR Comp 100%
<Right><Val(7:$C0003)>
18. | TOTAL COMPS: <Right><Val(7:$C)> TOTAL COMPS:
19. | <Fill(=)> ======================
20. | GROSS SALES: <Right> <Val(7:$5-$C)> GROSS SALES:
21.
22. | <Center> ***PROMOS* ** ***PROMOS* * *
23. | <Val(3:#P1000)> Disc 5%: <Right> 00 Disc 5%
<Val(7:5P1000)>
24. | <Val(3:#P1001)> Disc 10%: <Right> 04 Disc 10%
<Val(7:$P1001)
25. | <Val(3:#P1002)> Staff Disc 15% <Right> 01 Staff Disc 15%
<Val(7:5P1002)>
27. | TOTAL PROMOTIONS: <Right> <Val(7:$P)> TOTAL PROMOTIONS:
28. | <Fill(=)> ======================
29. | NET SALES: <Right> <Val(7:$S-$C-$P)> NET SALES:
30. | <Fill(=)> ======================
31.
32. | <Center> ***PAYMENTS** * ** *PAYMENTS* * *
33. | <Val(3:#T0001)> Cash: <Right> 20 Cash:

<Val(7:$T0001+$T0002+$TO003+STO004) >

NCR V::YIX
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15.00

0.00

20.00
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Line

34.

Configuration File

<Val(3:#T0008)> Visa: <Right>
<Val(7:$T0008)>

35.

<Val(3:#T0009)> Mastercard: <Right>
<Val(7:$T0009)

36.

<Val(3:#T0010)> Amex <Right>
<Val(7:$T0010)>

37.

<Val(3:#T0011)> Diners <Right>
<Val(7:$T0010)>

38.

<Fill(=)>

39.

TOTAL PAYMENTS: <Right> <Val(7:ST)>

40.

<Fill(=)>

41.

OUTSTANDING: <Right> <Val(7:$S-$P-$C-$T)>

42.

<Fill(=)>

43.

44,

<Center> ***VQOIDS** *

45.

<Val(3:$V)> VOIDS: <Right> <Val(7:$V)>

46.

<Fill(=)>

47.

48.

<Center> GUESTS AND CHECKS

49.

Number of Guests: <Right> <Val(4:#Guests)>

50.

Number of Checks: <Right> <Val(4:#Checks)>

51.

Guests per Check: <Right>
<Val(4:#Guests/#Checks)>

52.

53.

<Center> ***END OF REPORT***

Result Displayed on the Report

05 Visa: 100.00

05 Mastercard: 100.00

01 Amex: 10.00

01 Diners: 10.00

TOTAL PAYMENTS 420.00

OUTSTANDING: 28.00

***VOIDS***

03 VOIDS: 20.00
GUESTS AND CHECKS

Number of Guests: 200

Number of Checks: 50

Guests per Check: 4

***END OF REPORT** *

NCR V::YIX
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Adding a custom report button to a panel

For Aloha Quick Service operations, you must add a button to a panel for each customized report you
create. You must also do this in Aloha Table Service, if you want to add a custom report button to a
floor plan in use. If you want the report button to appear in a relative location as your other
hard-coded reports in Table Service, refer to “Designing the FOH Select a Report screen in Table

Service” on page 32.

To add a custom report button to a panel:

1. Select Maintenance > Screen Designer > Quick Service (or Table Service) Screen
Designer.

2. Select Work with Panels.

3. Select Panel > Open Panel. The Open Panels dialog box appears.

4. Select a panel to edit, such as Manager Reports, and click OK. The panel appears.

5. Select Panel > New Button. The Properties dialog box appears.

X
IButton: Custom Report A I
Properties I
Use new button displ False -
Gradient None
Shadow False
Bevel False
Outline False
Scale image False
Style Rounded rectangle
Tag None
Custom Report =1
Select Employees  False
Report Type Custom FOH Reports defined
Custom FOH Report  Daily Sales Report =
Action
Prints a custom report defined in a report definition file.
Figure 7 Custom Report Button Properties (Custom FOH Reports Defined)

6. Under the ‘Function’ group bar, select Custom Report from the ‘Action’ drop-down list to add a
custom report button to the ‘Select Report’ screen on the FOH.

7. Select True or False in the ‘Select Employees’ drop-down list, to allow you to select specific
employees to include in the report at runtime. If set fo False, the system generates data for all
employees who worked during the time frame selected for the report.
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8. Select Custom FOH Reports defined to indicate this button calls a custom FOH report created
using the Custom FOH Report function.

® Tip
The other option, ‘Externally defined,’ is used only for a custom FOH report you manually

created using MS Notepad. Refer to “Appendix B: Upgrading Custom FOH Reports” on
page 47.

9. Select the report to link to this button in ‘Custom FOH Report.’

10. Type the text to identify the specific report you want to generate in ‘Name.’ The text appears on
the button.

11. Complete the remaining options for the button, such as font, background color, and text
alignment.

12. Repeat this procedure for each custom report you want to add to the panel.

13. Select Panel > Save Panel and exit the Screen Designer function.

Designing the FOH Select a Report screen in Table Service

For Table Service operations that are not accessing reports from a floor plan screen, you must select
your custom report buttons from the FOH Select Reports screen. The screen appears blank until you
design the buttons to appear on the screen using a CustRpt.ini file, which is placed in the Data and
Newdata directories. The file defines where to place a button using an internal grid, the text to
appear on the button, the title to use for the report, and the custom report configuration file you are
accessing. As an added feature, you can configure whether to generate data for the entire store or
select specific job codes to include in the report data. The format of CustRpt.ini is as follows:

CusiRpt.ini Example

[BUTTONO]
Position=0
Select_Employees=1
Label=All Statistics

File=AllStats.cfg

[BUTTON1]

Position=1
Select_Employees=1
Label=Tipouts & Credit
File=Tipouts&Credit.cfg
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CusiRpt.ini Example

[BUTTON2]

Position=2
Select_Employees=1
Label=Promo & Payment\nBreakdown

File=Promo&Pmt.cfg

[BUTTON3]
Position=3
Select_Employees=1

Label=Flash

File=Flash.cfg

[ButtonX] — Specifies the section header for each button you are adding to the CustRpt.ini file,
such as ‘Button2.” Use the x value to identify the location of the button in relation to the screen.

Select_Employees — Determines how you want to generate the data, using the values of O or 1.
Assign a value of O to Select_Employees, to use data for the entire store, or assign a value of 1, to
enable an additional screen to appear from which you can select specific employees to include in the
report data.

Position — Indicates the positioning on the screen where you want to place the button, using an
internal grid. Position ‘O’ indicates the first button on the top upper left, and the numbering continues
across the screen.

Label — Indicates the name of the report to appear on the button. Use "\n’ with no spaces between
words, to display the text on multiple lines.

File — Specifies the name of the report configuration (.cfg) file to link to the custom button.
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Refreshing the data

After all settings are in place in Aloha Manager, you must select Utilities > POS > Refresh POS & Al
Installed Products to transfer the new information to the FOH terminals, or wait for the End-of-Day
(EOD) process to accomplish the data refresh for you. After the data refresh is complete, all new
seftings become operational across the Aloha network.

Caution

Refresh data with caution and never during peak hours of operation. All FOH terminals reboot
during a refresh and are down for a short period of time.
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Using Custom FOH Reports

To use custom FOH reports, select the appropriate report button and the report appears in the FOH.
The generated data is uptothe-minute for the current day. If available for this report, the Select One
or More Employees screen appears, allowing you to select the employees to include in the report
data.

To run a custom FOH report in Aloha Table Service:

1. From the FOH Working with Tables/Tabs screen, touch Functions. The FOH Special Functions
screen appears.

2. Touch Reports. The Reports screen appears.

Exit

Reports

Restaurant Break Alert Employees Payment
Sales Report Clocked In Report
Server Flash Labor Item
Sales Report Report Availability

Drawer Sales By

Figure 8 FOH Reports Screen
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3. Touch Custom Reports. The Select Report screen appears.

Select Report

Tipouts & Credit Promo & Payment Comp & Payment

Figure 9 FOH Select Report Screen

4. Select the button corresponding to the custom report you wish to run. If available, the ‘Select
one or more Employees’ screen appears, allowing you to choose the employees to include in the
report data.

Select one or more Employees

[All]
Susie Server

Sally Server

BUSINESS EQUIPMENT

Figure 10 Select One or More Employees Screen
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5. Select the employees to include in the report, or select (All) to generate data for all employees.
The report appears on the screen, if available, and you can print it, if desired, or it prints to the
designated printer.

To run a custom FOH report in Aloha Quick Service:

1. Navigate to the panel containing your reports.

2. Select the button corresponding to the custom report you wish to run. If available, the ‘Select
one or more Employees’ screen appears, allowing you to choose the employees to include in the
report data.

3. Select the employee to include in the report, or select (All) to generate data for all employees.
The report appears on the screen, if available, and you can print it, if desired, or it prints to the
designated printer.
Viewing a custom FOH report

1. When you run a custom FOH report, a screen stating ‘Please wait. System is generating report’

appears.
Please wait. System is
generating report.
Figure 11 Wait Message
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Once the system dismisses the message, the report appears.

= Daily Sales Report N

08/12/2014

Guests and Checks

Number of Guests:
Number of Checks:
Guests per Check: $

N

Sales

Total Sales: 9.18
Food: 9.18
Liquor: 0.00
Beer: 0.00
Wine: 0.00
Retail: 0.00
Tenders
15 Visa $150.00
10 AMEX $50.00
3 Debit $40.00
Comps

: J Print J m Two Cols J N
Figure 12 Custom FOH Report Example - 1T Column

2. Touch Two Cols to view the report with two columns.

-~ Daily Sales Report

$ ) o) O e

Figure 13 Custom FOH Report Example - 1 Column
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3. Touch Print to print the report to a local printer.

4. Touch Done when finished.

NCR V::YIX
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<no line prints=>

***FLASH REPORT***

***ploha Cafe***

01/01/2012

DOB: 01/01/2012

x tthMpsttt
02 Entertain:

03 Staff Disc 15%

01 MGR Comp 100%

TOTAL COMPS:

GROSS SALES:

S+ 1 mOM OSK xx
00 Disc 5%

04 Disc 10%

01 Staff Disc 15%

TOTAL PROMOTIONS:

**%PAYMENTS***
20 Cash:

05 Visa:
05 Mastercard:

01 Amex:
01 Diners:

TOTAL PAYMENTS

Figure 14 Sample Custom FOH Report
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Troubleshooting Custom FOH Reports
The following tips provide troubleshooting for custom FOH reports:

Report does not display or print

If a report does not print, ensure the appropriate file, with a .cfg extension, resides in the Data and
NewData directories. Additionally, you must link the .cfg file to the corresponding Custom Report
button on a panel. See “Adding a custom report button to a panel” on page 31 and “Designing the
FOH Select a Report screen in Table Service” on page 32.

Calculation or string does not appear

If a calculation or string does not appear in a custom section of a custom FOH report, ensure the
following:

e You typed the correct syntax for the formula, such as <Val(3:#Guests/#Checks)>
e You used the correct algebraic operators.

e You used a variable which is supported with your Aloha POS version.

See “Creating a custom FOH report” on page 9.

Report appears blank with no data

This usually occurs when you select more than one employee for which to generate data in the report.
The configuration management tool is unable to resolve the multiple selection. If you intend to select
more than one employee, or all, you must select ‘Allow report to be run for multiple employees at a
time’ in Maintenance > Business > Custom FOH Reports. See “Creating a custom FOH report” on

page 9.
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Appendix A: Use case scenarios

This section provides the following use case scenarios when using custom FOH reports. You can

leverage these to adapt to your own business model.

e Reporting count of items sold by category and order mode

e Including/excluding comps and promos when calculating guest count.

Reporting count of items sold by category and order mode

This section details a use case example for using the ltem Count variables. Use the #ltemsxy|z and

#Totalltemsxy|z variables to track the count of items sold by category and order mode. Each variable

definition requires you to configure a parameter that stipulates whether to include or exclude order

modes. The intent is to use variables with identical selections together for a new standalone custom

report that relies on time increments for parsing the data; however, you can integrate them with an

existing custom report.

SCENARIO: Managers find the number of times an item is sold during increments of the day a valu-
able analytical asset for projections and forecasting. They want to track the number of donuts sold
from the dine-in order mode for each hour of the day.

Sales / Non-Sales
00:
01:
02:
03:
04:
05:
06:
07:
08:

#ltemslInclusive4|2, 09:
. — 0:

ariable -
11:

12:
13:
100
100
16:
100
18:
19:
20:

14
15

17

21

22:
23:

00

: 00

D¢

D¢

00 Dc

00
00
00
00
00

Donuts

Donuts:

Donuts

Donuts:

00 D«

00
00
00
00

00 D

00

00
00
00
00

Donuts

Donuts:

Donuts
Donuts

Donuts

00 Do

00
al

00

Donuts

Donuts

Food

Categories Dem

)
# lotalltemsinclusive4|2,
: ariable
)
)

&3 K8
4

Figure 15 Custom FOH Report with ltem Counts Variables
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To add item count variables to a custom FOH report:

1. Select Maintenance > Business > Custom FOH Reports.
2. Click New.

Custom FOH Reports

[t Donut Count

B Identification
Number 1
Name Donut Count
File name CustomFOHRepartNumber1.cfg
Allow report to be run for multiple employees at a time vl
B Display options
Report format [Sort data in 60 minute increments v

Note: If the list on the right is empty, the information on the report will be for all employees.,

Filter by Jobcode
Available Filter by

>
v

A Name | Al Name
4 Training el << : | 2 Manager
5 BEC L [ ] 3 Supervisor
6 Line [

=

Figure 16 Custom FOH Report Tab

3. Type a name for the report, such as ‘Donut Count.’
Select Allow report to be run by multiple employees at a time.

5. Select a time increment from the ‘Report format’ drop-down list, such as ‘Sort data in 60 minute
increments.’

6. Select the Design tab.
Under the ‘Design’ group bar, click Add. A new line of the report appears.
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8. Click the ellipses (...) to display the Report Line Builder dialog box. Using the help text, example
and report line as a guide, build the specific line of the report and click Insert.

Report Line Budder

Categores Bements Spedific records Order modes

Vaiue A Count of fems soid for the specifed category and order modd Mumber Pare Onner 3 Mumber /| Name Owner
Formatang Total count of items sold for the specfied y and order "

ormateng otal count of items sold for the spex ategory and or 5 i i ] tlwadean |3 Ao &

2 LIQUOR | Gobal ] 2 Pk Up 3 Autorn

3 BEER 1 Gobal ] 3 OriveThru 3 Autom
4 WDE 1 Gobal O 4 Delvery 3 Autom
5 NJA BEVERAGE |1 Giobal ] 5 Quick 3 Autore
9 DESSERT 1 Gobal 0O 6 Caterng 3 Autors
17 PMS Sales 1 Gobal O 7 Cubsde 3 Autom
18 FamiyStyle M | 1 Gobal ] 8 WEB 1 Globa
15 FamiyStyle [t | | Gobal ] 5 CAAIVERY | Giobal
2 GBERAL 1 Gobal 10 WAKIN 1 Globa

v < » . v
sive " Excusive

Count of tems for the selected category and order mode(s), erther indusrve (any order mode selected) or exdusive (any order mode except those
selected), per selected Deplay OpSon Report format,

Ttermg Count <Rught><Vai(?: sitemginducve 2| 1,2 >

Reportne Doruts: <Right > <Val{ 7: #ltemsindusive 16/5) > T Cancel

Figure 17 Report Line Builder - ltem Count

9. Select ltem Count from the ‘Categories’ list. The variables for ‘item count’ populate in the
‘Elements’ list and the ‘Order modes’ selection list become available.

10. Select Count of items sold for the specified category and order mode from the ‘Elements’
list.

11. Select one sales or one general category from which to report from the ‘Specific records’ list.

12. Select one or more order modes from which to report from the ‘Order modes’ list.

To include all order modes, select the check box above the list of order modes.

b. To include specific order modes, select Inclusive and then each order mode to include in
the report from the list of order modes.

c. To exclude specific order modes, select Exclusive and then each order mode to exclude
from the report from the list of order modes.
13. Click OK to return to the Design tab.

14. Repeat steps 7 through 13 to add the Total count of items sold for the specific category
and order mode variable to the report.
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15. Add any other design elements to customize the report, such as inserting free text, blank lines,
or a line with a single character. Use the example shown below as a guide.

|1 Sakes | Non-Sales Categories Demo

Custom FOH Report  Design

Report ines Edit report ine Add
# Donuts: <Right > <val(7: 1 temsincusive 165) > 1 ]
Total Donuts: <Right » <Val(7: #TotalTtemalnchmive 165) » Remove
i 1 Move W
Food: <Right > <Val(7: Zltemsindusrve | |5) >
Total Food: <Right > <Val(7: #Totalltemaindusive 1|5) > e Move down
Figure 18 FOH Custom Reports - Design Tab
16. Click Save and exit the Custom FOH Reports function.
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Including/excluding comps and promos when calculating guest count

Many restaurants use the number of items sold from a category, typically entrees, to calculate the
guest count. Each time you order the item, the guest count increases by the default weight of one.
When the entree is fully discounted by a promotion or a comp, the item is reduced to a $0.00
amount and is no longer respected in the calculation.

Effective in Aloha POS v19.11, you can now use a custom FOH report to include or exclude selected
comps and promotions when calculating the guest count. This gives you maximum control on how
you want an ‘entree-based’ guest count to report. For example, you may want to have a report where
the guest count includes entrees and another report that excludes fully discounted shift meals earned
by the employee.

® Tip
This feature only applies to an entree-based guest count configuration. It is not supported with any
other guest count calculation method.

To configure entrees to be counted as guest counts:

Select Maintenance > Business > Store.

Select the Store Settings tab.

Select the Order Entry group from the bottom of the screen.

Under the ‘Guest Count’ group bar, select Use entrees for guest counts.

Select the category from the ‘Entree Category’ drop-down list.

S o

Click Save and exit the Store function.
To configure a FOH custom report for guest counts:

Select Maintenance > Business > Custom FOH Reports.
Click New.
Type a name for the report, such as ‘GC with Promos’

Select Allow report to be run by multiple employees at a time.

o M 0 b -

Select a time increment from the ‘Report format’ drop-down list, such as ‘Sort data in 60 minute
increments.’

Select the Design tab.
7. Under the ‘Design’ group bar, click Add. A new line of the report appears.

N C R v.".YI X © 2025 NCR Voyix. All rights reserved. NCR Voyix — Confidential
% o® Use and Disclose Solely Pursuant to Company Instructions

45



Custom FOH Reports

Appendix A: Use case scenarios

8. Click the ellipse (...) to display the Report Line Builder dialog box. Using the help text example
and report line as a guide, build the specific line of the report.

Report Line Builder

Categories Elements Comps Promos
Value A | |Total count of all guests ) 0] Nu Name Owner O Number 7 Name Owner
:uoarﬂr:amg s Ll - O 1/8.0.G. 1 Chipo... ~ O 1/$0ffDe...|1 Chipot.. A
Comps O 3|Mngr Comp |1 Chipo. O 2|{2for-1 |1 Chipot...
Delivery [m] 5| Fiyer Comp | 1 Chipo. O 3/%OffD... |1 Chipot..
Employees ]
Entree Count O 7|Bev Coupon | 1 Chipo. O 4|Burrito ... |1 Chipot
Gift Certificates O 8/PRComps |1 Chipo. O 5| PartySe...| 1 Chipot
Gratuities 9/EmpMeals 1 Chipo... O 10 | Vid-Quik... | 1 Chipot
Guest Checks

g O 15|Coin Comp | 1 Chipo. O 11/Vid BOG... |1 Chipot...
Items O 30|Vid-Comp% | 1 Chipo. O 12{Vido Co... |1 Chipot...
Items Count O 31|Meal /Bev |1 Chipo ] 13 VidCoupon | 1 Chipot
Order Mode Charges - =
|Petty Cash Accounts v E 32|VidCompO... |1 Chipo... , E 14| VidNewP... | 1 Chipot...

Help text: @ Inclusive " Exclusive

Count of guests for the selected promos and comps, either indusive (any promo/comp selected) or exdusive (any promo/comp except those

selected), per selected Display Option Report format.

Example:

Items Count <Right> <Val(7: #FilteredGuestsindusive 1,2|5,7)>

OK
Report line EmployeeGuests = <Val(7: #FilteredGuestsInclusived[) > Cancel

Figure 19 Print Designer Guest Counts Variable

9. Select Guest Counts from the ‘Categories’ list. The variables for ‘Guest Counts’ populate in the
‘Elements’ list and the ‘Comps’ and ‘Promos’ selection lists become available.

10. Select Guest filtered Inclusive and Exclusive from the ‘Elements’ list.
11. Select one or more comps or promotions from their respective selection boxes.
a. To include all comps or promotions, select the check box above either list appearing in the
selection box.

b. To include specific comps or promotions, select Inclusive and then each comp or promotion
to include in the report from the respective list.

c. To exclude specific comps or promotions, select Exclusive and then each comp or
promotion to exclude from the report from the respective list.
12. Click Insert.
13. Click OK.

14. Add any other design elements to customize the report, such as inserting free text, blank lines,
or a line with a single character.

15. Click Save.
16. Repeat this procedure to create another custom report with a specific guest count calculation.

17. Exit the Custom FOH Reports function.
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Appendix B: Upgrading Custom FOH Reports

We introduced custom FOH reports in Aloha POS v7.0 as an external configuration file that you
create using MS Notepad and then place it in the Data directory. When you tie the file to a button
function, the system uses the file to generate the report in the FOH. Since the configuration file is
external, the data is not housed in either Aloha Configuration Center or Aloha Manager. To
compound the problem, in a hosted multi-store environment, you had to send the external
configuration files to your stores separately. Additionally, creating the configuration file manually
required a certain level of programming knowledge that increased the margin of error when typing a
syntax string.

In Aloha POS v12.3, we added the Custom FOH Report function in Aloha Configuration Center and
Aloha Manager to alleviate these issues. Using the configuration management tool, you create an ID
record for each custom FOH report so you do not need separate external configuration files and store
the data in the database. Additionally, we provide a user interface for building the syntax strings
when creating your report.

If you implemented custom FOH reports prior to Aloha POS v12.3, you can upgrade the reports to
the configuration management tool or choose to keep your current implementation. As the preferred
solution, we recommend you upgrade your custom FOH reports to use the configuration
management tool, either Aloha Configuration Center or Aloha Manager. Provided you already
followed the steps depicted in the body of this guide, you need to modify a couple of areas in your
configuration.

If you created custom FOH reports prior to Aloha POS v15.1 and configured Print Intercept to view a
custom report on-screen versus automatically printing a report, when you upgrade to Aloha POS
v15.1, you must select a new option called ‘Display custom reports on the FOH' under the ‘Report
seftings’ group bar in the Report Printing group on the Store Settings tab in Maintenance > Business
> Store to continue this behavior. If you do not, all custom FOH reports automatically print to the local
receipt printer by default.

Upgrading your custom FOH report to the configuration management tool

The first step is to enfer the content of your existing report into the Custom FOH Report function so
the report is housed in the database. Instead of retyping each line into the function, you simply need
to create a Custom FOH Report record and manually copy and paste each line in the ‘Report line’ text

boxes. Refer to “Creating a custom FOH report” on page 9 for additional information.
To enter the content of your existing report into the Custom FOH Report function:

Select Maintenance > Business > Custom FOH Reports (Figure 4).
2. Click New.

3. Type a name to identify the report. You can use the same name as the external configuration file
you are replacing.
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4. If you want to report on a specific job code, or group of job codes, select a job code from the
‘Available’ list and click >> to move the job code to the ‘Filter by’ list.

5. Select the Design tab.

Click Add.
Custom FOH Reports
[ °]
) Custom FOH Report :\;»' :

Copy each line of —_—

s vesign

configuration file |Report lines | Edit report line

Ehie [ ;,
Remove |

Figure 20 Custom FOH Report - Design Tab

7. Copy a line of text from the external configuration file and paste it into the ‘Report line’ text box.

B Note

You can use this opportunity to adapt or change the content to your specific needs relating to
the report.

8. Repeat step 7 until you paste each line into the Custom FOH Reports function.
Click OK to return to the Custom FOH Reports function.
10. Click Save.
11. Repeat this procedure for any other custom FOH report you want to upgrade.
12. Click Close to exit the Custom FOH Reports function.
The second step is tying the FOH button to the custom FOH report that is now housed in your

configuration management tool. To do this, please follow the instructions provided in “Adding a
custom report button to a panel” on page 31.
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Keeping your current custom FOH report implementation

If you want to keep your current custom FOH report implementation, using external configuration
files, the system performs the upgrade path for you. The button function configuration for each report
changes to point to an externally defined report. If you notice a problem with your report, you can
verify this configuration in Screen Designer. Note: This is not the preferred solution and we
recommend you upgrade your custom FOH reports to the configuration management tool.

To verify your button configuration points to an external custom FOH report:

1.

Noos N

Select Maintenance > Screen Designer > Quick Service (or Table Service) Screen
Designer.

Select Work with Panels.

Select Panel > Open Panel. The open Panels dialog box appears.

Select a panel to edit, such as ‘Manager Reports,” and click OK. The panel appears.
Select Panel > New Button. The Properties dialog box appears.

Under the ‘Function’ group bar, select Custom Report from the ‘Action’ drop-down list.

Select Externally defined to indicate the system uses a manually created external configuration
file.

[Properties £
IBuﬂon: Custom Report Ll
Propetties I
Use new button displ False -~
Gradient None
Shadow False
Bevel False
Outline False
Scale image False
Style Rounded rectangle
Tag None
E Function
Action Custom Report
Select Employees  False |1
Externally defined ~|
Report Definition DailySalesReport.cfg =
Reporit Type
Select whether the report was created in the Custom FOH
Reports applet or if it was created and is maintained extem...

Figure 21 Custom Report Button Properties (Externally Defined)

8. Type the name of the configuration file (with a .cfg extension), located in the Data directory, to

link to this button. If you do not link the button to a report configuration file, the button does not
generate a report.
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9. Type the text to identify the specific report you want to generate in ‘Name.” The text appears on
the button.

10. Complete the remaining options for the button, such as font, background color, and text
alignment.

11. Repeat this procedure for each custom report you want to add to the panel.

12. Select Panel > Save Panel and exit the Screen Designer function.
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NCR Voyix welcomes your feedback on this document. Your comments can be of great value in
helping us improve our information products. Please contact us using the following email address:
Documentation. HSR@NCRVoyix.com
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