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Revision Record

Date Version # Description

Prior to 
02/02/2023

QS v6.7+
EDC v6.7+

Supported Givex gift cards using NCR Aloha POS.

QS/TS v12.3+ Updated the Givex Gift Card Feature Focus Guide to reflect CFC and 
new AM, and added the ability to support gift card activation and query

QS/TS v15.1+ Added the ability to allow a guest to cash out a Givex gift card.

QS/TS v19.6+ Increased the gift card digits to 24.

02/02/2023 Converted document to use new templates. Updated the front cover and 
back page to reflect new NCR branding.

06/12/2024 Updated document to reflect NCR Voyix branding.
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About Givex gift cards  

Givex gift cards make great gifts for any occasion; they make it easy and convenient for your 
customers, and offer a valuable marketing opportunity for your restaurant. Remaining card balances 
bring customers back, and increase average ticket size. Small amounts that are never redeemed 
become pure profit to your restaurant. At the same time, you can track each Givex gift card, and you 
have direct access to information, such as how many cards were used, the average value spent, when 
and where the cards were used, and more.

Givex gift cards are plastic, magnetic-striped cards that replace the old-fashioned paper gift 
certificates, and operate very similarly to credit cards. You can purchase them from the vendor with a 
predetermined value, such as $10.00, or as an open value card. An open value gift card lets the 
guest purchasing the card determine the value of the card. Once activated, each of these can have 
additional value added to them, if configured to do so.

When you are selling and redeeming Givex gift cards, the Aloha® Point-of-Sale (POS) system 
connects to the host for verification and authorization. If you are selling a new card, it is activated at 
this time. If you are redeeming a gift card, an immediate adjustment is made to the card balance at 
the host location. Therefore, with gift cards, you are able to maintain a higher level of control, 
security, and tracking capabilities.

Effective with Aloha POS v12.3 and EDC v12.3 and later, using a plug-in, you can now support the 
Givex gift card as a full service gift and loyalty card provider. This feature supports the following 
transactions: 

● Activate card
● Add value
● Card balance 

You must work with Givex to configure the GCM.ini file.

Givex Gift Cards Procedures at a Glance

Core Product Aloha Quick Service, Aloha Table Service, Aloha EDC

Complementary Products No

Separate License Required? Yes, you must license your security key for Aloha EDC (Credit Card + 
MX under Software Packages) and Custom EDC (under Software 
Options).

Other References Aloha Quick Service Reference Guide, Aloha Quick Service Report 
Guide, Aloha EDC User Guide

Other Requirements The Givex Aloha driver installed on each terminal requires routable 
Internet. 



 Givex Gift Cards
About Givex gift cards

5

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

To support Givex gift cards, you must perform the following:

● Install the Givex Plug-In.
● Configure Givex/Private Label for Aloha EDC.

To accept 24-digit gift card numbers, you must update to the following:

● Aloha POS version to 19.6+.
● Aloha EDC to v19.4+.
● Givex plugin to v15.1.178+. 

Although no configuration is necessary, you may need to access Maintenance > Payments > 
Tenders > Identification tab and update the Givex gift card number to 24-digits under the 
‘Identification’ group bar.
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Installing Givex gift cards
This section details the installation requirements for Givex Gift Cards. If you are an experienced user, 
refer to Procedures at a Glance for abbreviated steps. If you prefer more detail, continue reading this 
document. 

Use the following procedure to install Aloha Givex. 

Givex requirements
There are requirements when using Givex gift cards. 

● You must be on Aloha POS v12.3 and later. 
● The terminals must be capable of sending traffic on port 50020 to the Internet.
● The terminals must have Service Pack 3 and C++ 2008; otherwise, the driver fails to install with 

error 1904.

Prerequisites: What you need to do before installing Givex
1. Install EDC v15.1 and later.

If you use Aloha Manager, select Uses Electronic Draft Capture under the Products installed 
group bar on the Global tab in Maintenance > Business > Installed Products. 
If you use Aloha Configuration Center, select Uses Electronic Draft Capture under the Products 
installed group bar on the Global tab in Maintenance > Business > Global Administration.

2. Stop EDC before installing Givex.
3. Verify the following EDC files are in the BIN folder:

AlohaUPI.Core.dll
EdcSvr.UpiClient.Interop.dll
Log4net.dll

4. Run GivexUPISetup.msi in the setup folder. Choose the install location same as the EDC.exe 
(%IBERDIR%/Aloha/BIN folder) 

Givex Gift Cards Procedures at a Glance:

If you are viewing this document using Adobe Acrobat Reader, click each link for detailed information 
regarding the task. 

1. Verify prerequisites are complete. See page 6.

2. Install the Givex UPI Plug-In. See page 7.

Note
Givex provides the Givex Aloha driver, and the user name and password. Access Aloha Update to 
download the Givex UPI plug-in. 
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The following files should be installed by setup in %IBERDIR%\BIN:
GivexAlohaUPI.dll
GCM.dll
GCM.ca
GCM.cert
GCM.ini

5. Copy Plugin.cfg from BIN folder to the same location as EDC.ini file (%IBERDIR%/Aloha/EDC 
folder). 

Installing the Givex UPI plug-in
You must install the Givex UPI Plug-In prior to any configuration. Access alohaupdates.com to 
download this file. You need GivexUPISetup.msi, which installs all necessary files for the initial 
installation of Givex; the remaining files install through the Aloha POS system and Aloha Electronic 
Draft Capture. 

1. Go to 
https://www.alohaupdates.com/RadiantUpdatePortal/SignIn.aspx?ReturnUrl=%2fRadiantUpdate
Portal%2fDefault.aspx.

2. Select NCR Customer or NCR Employee as the type of user and click Sign In.
3. If prompted, enter your user name and password and click LOG IN. 
4. Select Download Install CD.
5. Select Givex from the ‘Application Suite’ drop-down list, and select the most current version of 

the plugin from ‘Major Version.’
6. Click Download Now and save GivexUPISetup.msi to a staging folder.
7. Continue to the next procedure.
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Launching the Givex plug-in setup wizard

After downloading GivexUPISetup.msi, follow the prompts to complete installation.

1. Locate and launch GivexUPISetup.msi. 

2. Click Next.The End-User License Agreement screen appears. 

Figure 1  Givex UPI Setup Wizard 

Figure 2  Accept End-User License Agreement 
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3. Select I accept the terms in the License Agreement and click Next. The Givex UPI Plug-In for 
Aloha EDC Setup screen appears. 

4. Click Next. 

Figure 3  Givex UPI Plug-In for Aloha EDC Setup

Figure 4  Ready to Install 
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5. Click Install. The Progress status bar screen appears. 

6. Allow the installation to continue. 

7. Once the installation completes, click Finish to exit the Givex UPI Plug-In for Aloha EDC wizard. 

Figure 5  Installing the Givex UPI Plug-In for Aloha EDC 

Figure 6  Installation Complete 
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A file called GCM.ini, located in the BIN folder, contains the connection parameters needed by the 
Givex driver to communicate with the Givex processor. You must configure the timeout, IP address, 
and IP port.

1. Navigate to the %IberDir\BIN folder.
2. Open GCM.ini using Notepad.
3. Edit the following variables, as shown below: 

PRIMARY _MODE = 1
PRIMARY_TIMEOUT = 20 (Default)
PRIMARY_IP_ADDRESS = Enter the IP address provided by Givex. For example, 
‘dc-us1.givex.com.’ 
PRIMARY_IP_PORT = Enter the IP port provided by Givex. For example, ‘50019.’ 
PRIMARY_DIAL_COM =
PRIMARY_DIAL_BAUD =
PRIMARY_DIAL)INIT =
PRIMARY_DIAL_PHONE =
BACKUP_MODE = 1
BACKUP_TIMEOUT = 20
BACKUP_IP_ADDRESS = Enter the IP address provided by Givex. For example, 
‘dc-us1.givex.com.’
BACKUP_IP_PORT = Enter the IP port provided by Givex. For example, ‘50019.’
BACKUP_DIAL_COM =
BACKUP_DIAL_BAUD =
BACKUP_DIAL_INIT =
BACKUP_DIAL_PHONE =

If you are testing Givex, add the variables provided by Givex: 

○ [TEST_SECTION]
○ TEST_PARAMETER = 1

4. Close and save the file.
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Configuring Givex gift cards
This section details the configuration requirements within Aloha Manager and Aloha Configuration 
Center (CFC) for Givex Gift Cards. If you are an experienced user, refer to Procedures at a Glance 
for abbreviated steps. If you prefer more detail, continue reading this document. 

Givex Gift Cards Procedures at a Glance:

If you are viewing this document using Adobe Acrobat Reader, click each link for detailed information 
regarding the task. 

1. Access Maintenance > Business > Store > Store Settings tab > Gift Card/Certificate Sales 
group to configure the Givex gift card host. See page 14.

2. Access Maintenance > Menu > Items to configure items for selling Givex gift cards; one each for 
activation and adding value. 
To activate a Givex predefined amount gift card, see page 17.
To add value to a Givex predefined amount gift card, see page 18.
To activate a Givex open amount gift card, see page 20.
To add value to a Givex open amount gift card, see page 22.

3. Access Maintenance > Payments > Tenders to configure a tender for applying payment with a 
Givex gift card. 
To configure the Tender tab, see page 24.
To configure the Type tab, see page 27.
To configure the Authorization tab, see page 28.
To configure the Printers tab, see page 29.

4. Access Maintenance > Electronic Draft Capture > Cards to assign Givex to gift cards. See 
page 30.

5. Access Maintenance > Screen Designer > Quick Service Screen Designer or Table Service 
Screen Designer to add buttons for selling and redemption to the front-of-house (FOH).
Quick Service:
To add a predefined amount gift card button for activation in QS, see page 30.
To add a predefined amount gift card button to add value in QS, see page 31.
To add an open amount gift card button for activation in QS, see page 32.
To add an open amount gift card button to add value in QS, see page 33.
To add a Givex gift card redemption button in QS, see page 34.
Table Service:
To add a predefined amount gift card button for activation in TS, see page 36.
To add a predefined amount gift card button to add value in TS, see page 37.
To add an open amount gift card button for activation in TS, see page 38.
To add an open amount gift card button to add value in TS, see page 39.
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6. Access Maintenance > Labor > Pos Access Levels to allow an employee to cash out a Givex gift 
card. See page 40.

7. Select Utilities > Refresh POS & All Products to refresh the data. See page 44.

Givex Gift Cards Procedures at a Glance:
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Configuring Givex as the processor for gift cards
You configure Givex as the processor for your gift cards in Aloha EDC; however, you must stop EDC 
processing first.

To configure Givex:

1. Select Maintenance > Electronic Draft Capture > Processor.
2. Click the New drop-down arrow, select Independent, and click OK. 

3. Accept the system assigned number or click the ellipsis button (...) next to ‘Number’ to 
display the Number Assignment dialog box, from which you can choose an alternate number. 

4. Under the ‘Identification’ group bar, type Givex to identify the processor.
5. Select Active to activate the processor.
6. Under the ‘Independent’ group bar, select Givex from the ‘Plugin type’ drop-down list.
7. Type Givex as the file name.
8. Click Save and exit the Processor function.

Figure 7  Electronic Draft Capture - Processor
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Configuring the Givex gift card host
The Aloha POS system offers you the ability to prevent theft and abuse of gift cards; you can prevent 
the activation or redemption of a gift card on the same business day on which the card was activated 
and prevent the redemption of a gift card more than once in the same business day, unless with 
manager approval. Determine what you will allow or prevent for gift cards in Store Settings > Gift 
Card/Certificate Sales.

To configure the Givex gift card host:

1. Select Maintenance > Business > Store.
2. Select the Store Settings tab.
3. Select the Gift Card/Certificate Sales group located at the bottom of the screen. 

4. Under the ‘Gift sales’ group bar, select Private Label from the ‘Gift card/Certificate provider’ 
drop-down list.

Note
If the Gift Card/Certificate Sales group is not available, you must access Maintenance > 
Business > Additional Features and select ‘Display gift card.’ Or if using Aloha 
Configuration Center, log in as a corporate user and access Maintenance > Business > 
Corporate Administration. Log out and then log back in.

Figure 8  Store Settings Tab - Gift Card/Certificate Provider Group
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5. Under the ‘Printing properties’ group bar, select Show last 4 digits on all vouchers to 
determine the portion of the gift card number to print on the voucher.

6. Under the ‘Printing properties > Voucher’ group bar, select Print guest check message if you 
want a message to appear on the check.

7. Under the ‘Restrictions’ group bar, select Cannot redeem same gift card twice in a day to 
prevent the redemption of the same gift card more than once in the same business day. 

8. Select Cannot activate and redeem gift card on same day to prevent the redemption of a gift 
card on the same business day on which the card is activated. 

9. Select Allow refund transactions for activations and reload to allow you to perform a refund 
for a customer who wishes to return a private label gift card they have purchased or remove 
additional funds loaded on their private label gift card. 

10. Select Restrict multiple redemptions of the same gift card on a single check to prevent an 
employee from applying payments from the same gift card in increments to the same guest 
check. For example, you have a $20.00 check. With this feature selected, the employee must 
apply the entire card to the amount; not in $5.00 increments.

11. Select Restrict multiple add values of the same gift card on a single check to prevent an 
employee from adding multiple values to the same gift card on the same guest check.

12. Select Restrict activation of gift card until tendered to prevent the activation or reloading of a 
gift card until you receive payment and the guest check has a $0.00 balance. If activation or 
reload fails, the Aloha POS system sends an immediate reversal to the guest check, preventing 
over-payment.

13. Click Save and exit the Store function.

Note
To provide the ability to override these restrictions, select the appropriate access level in 
Maintenance > Labor > Pos Access Levels > Access Level tab and select ‘Override gift 
card restrictions’ under the ‘Financial’ group bar.

Note
You must select Private Label from the ‘Gift card/certificate provider’ drop-down list to enable 
this option. The system supports this functionality for Givex private label gift cards only.
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Configure items for selling Givex gift cards
You must configure items for selling Givex gift cards. Typically, you configure an item to sell the gift 
card and an item to add value to a gift card. If you sell gift cards with a predefined amount, create 
two items for each; one for activating and the other for adding value to the card.

To activate a Givex predefined amount gift card: 

1. Select Maintenance > Menu > Items.
2. Click the New drop-down arrow, select Gift card from the ‘Type’ list box, and click OK.
3. Accept the system assigned number or click the ellipsis button (...) next to ‘Number’ to 

display the Number Assignment dialog box, from which you can choose an alternate number. 

4. Under the ‘Settings’ group bar, type a Short name, such as ‘$10 GC Act.’
5. Type a Chit name, such as ‘$10 GC Act.’

Note
Make note of the item number; you will need it later.

Figure 9  Item Tab - Activate Predefined Gift Card
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6. Type a Long name, such as ‘$10 GC Activate.’ 
7. Select Activate card as the ‘Gift card action’ to activate the card upon approval.
8. Leave None as the ‘Tax group.’ Generally, gift cards are not taxable items.
9. Select the Sales/retail category, such as ‘Retail’
10. Select the Pricing tab.

11. Select Item Price as the pricing method. 
12. Type the default price.
13. Click Save and continue to the next procedure. 

To add value to a predefined amount gift card:

1. While still in the Items function, click the New drop-down arrow, select Gift card from the 
‘Type’ list box, and click OK.

2. Accept the system assigned number or click the ellipsis button (...) next to ‘Number’ to 
display the Number Assignment dialog box, from which you can choose an alternate number.

Figure 10  Pricing Tab - Activate Predefined Gift Card
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3. Under the ‘Settings’ group bar, type a Short name, such as ‘$10 GC Add.’
4. Type a Chit name, such as ‘$10 GC Add.’
5. Type a Long name, such as ‘$10 GC Add Value.’ 
6. Select Add value as the ‘Gift card action’ to activate the card upon approval.
7. Leave None as the ‘Tax group.’ Generally, gift cards are not taxable items.
8. Select the Sales/retail category, such as ‘Retail’
9. Select the Pricing tab.

Figure 11  Item Tab - Add Value Predefined Amount Gift Card
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10. Select Item Price as the pricing method. 
11. Type the default price.
12. Click Save and continue to the next procedure. 

To activate an open amount gift card: 

1. While still in the Items function, click the New drop-down arrow, select Gift card from the 
‘Type’ list box, and click OK.

2. Accept the system assigned number or click the ellipsis button (...) next to ‘Number’ to 
display the Number Assignment dialog box, from which you can choose an alternate number.

Figure 12  Pricing Tab - Add Value Predefined Amount Gift Card - Pricing Tab



 Givex Gift Cards
Configuring Givex gift cards

21

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

3. Under the ‘Settings’ group bar, type a Short name, such as ‘Open GC Act.’
4. Type a Chit name, such as ‘Open GC Act.’
5. Type a Long name, such as ‘Open GC Activate.’ 
6. Select Activate card as the ‘Gift card action’ to activate the card upon approval.
7. Leave None as the ‘Tax group.’ Generally, gift cards are not taxable items.
8. Select the Sales/retail category, such as ‘Retail’
9. Select the Pricing tab.

Figure 13  Item Tab - Activate Open Amount Gift Card - Item Tab



 Givex Gift Cards
Configuring Givex gift cards

22

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

10. Select Ask for Price as the pricing method. 
11. Click Save and continue to the next procedure. 

To add value to an open amount gift card:

1. While still in the Items function, click the New drop-down arrow, select Gift card from the 
‘Type’ list box, and click OK.

2. Accept the system assigned number or click the ellipsis button (...) next to ‘Number’ to 
display the Number Assignment dialog box, from which you can choose an alternate number.

Figure 14  Pricing Tab - Activate Open Amount Gift Card
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3. Under the ‘Settings’ group bar, type a Short name, such as ‘$10 GC Add.’
4. Type a Chit name, such as ‘$10 GC Add.’
5. Type a Long name, such as ‘$10 GC Add Value.’ 
6. Select Add value as the ‘Gift card action’ to activate the card upon approval.
7. Leave None as the ‘Tax group.’ Generally, gift cards are not taxable items.
8. Select the Sales/retail category, such as ‘Retail’
9. Select the Pricing tab.

Figure 15  Item Tab - Add Value Open Amount Gift Card - Item Tab
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10. Select Ask for Price as the pricing method. 
11. Click Save.

Configure a tender for applying a payment with a gift card
To redeem gift cards for purchases, you must define a gift card tender. You need only add one 
tender for gift cards. When you define the tender as a gift card, the options in the Tender function 
that do not pertain to gift cards become disabled. If your restaurant allows overpayment when 
redeeming a gift card, or refunding the full cash value of a gift card back to the guest without 
purchasing an item at the store, then you must define the tender to allow overpayment and provide 
cash back.

To configure the Tender tab of a Givex gift card tender:

1. Select Maintenance > Payments > Tenders.
2. Click the New drop-down arrow, select Gift card from the ‘Type’ list box, and click OK.
3. Accept the system assigned number or click the ellipsis button (...) next to ‘Number’ to 

display the Number Assignment dialog box, from which you can choose an alternate number.

Figure 16  Pricing Tab - Add Value Predefined Amount Gift Card
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4. Under the ‘Settings’ group bar, type a Short name, such as ‘$10 GC.’
5. For Table Service, select First available button position to allow the system to place the tender 

button in the first available position of the FOH Tender screen.
-OR-
Click the ellipsis (...) to display the Button Position dialog box and select an available position for 
the gift card tender.

6. Select an image, such as the gift card logo, to appear on the button in place of the name, from 
the ‘Button image’ drop-down list.

7. Select the tender under which you want the credit card to report, if you do not want it to report 
as itself, from the ‘Report as’ drop-down list.
-OR-
Leave the default value of Current if you want the credit card to report as itself.

8. Select how the tender behaves in the FOH when selected for payment from the 'Default amount 
behavior' drop-down list, if you want it to behave differently than the default choice of 'Ask for 

Figure 17  Tenders - Tender Tab 
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amount.' The other choices are 'Next highest amount,' 'Exact amount due,' and 'Specific 
amount.'

9. Select Active to make the tender available for use. If not active, an error message appears in the 
FOH when you select this tender for payment.

10. Clear Affect deposit since credit cards do not affect the total cash amount you have on hand for 
deposit.

11. Select Print check on close to print a copy of the guest check at the time you close the check 
using this tender. To save paper, clear this option to turn off printing of the guest check at close 
in environments where you provide a copy of the guest check to the guest prior to applying 
payment. The guest typically does not require another copy of the guest check after you tender 
and close the check.

12. Select Open drawer on close to open the drawer each time you apply payment and close a 
check to this tender.

13. Clear Print signature line. Use this option for non-cash tenders for which you require a 
signature from the guest, such as 'House account' and 'Property management' tender types. Do 
not confuse this option as one having to do with signature line rules that control when to print 
signature lines on gift card vouchers.

14. For Table Service, clear Combine on check.
15. For Table Service, select Close check upon payment to automatically close a check when the 

payments applied to the check meet or exceed the guest check amount.
16. For Table Service, clear or select Do not verify amount to determine the placement of the 

cursor on the FOH tender screen and whether you are able to change the amount to something 
less than the balance of the check. When you select this option, cursor focus is always just below 
the amount and you are unable to change the amount at all. When you clear this option, cursor 
focus is on the amount. You can change the amount to something less than the balance of the 
check but attempts to change the amount to something greater result in an error message. If the 
tender allows tips, you can change the amount to something greater than the balance of the 
check; however, the system calculates the difference and moves the excess amount to the tip 
amount

17. Under the 'Tips' group bar, select Allow tips to allow guests to add a tip to the guest check and 
pay it with this credit card.

18. Enter the maximum allowable tip percentage in 'Maximum tip %.' Enter the percentage as a 
number and two decimal places. For example, enter a percentage of 50% as 50.00.

19. For Table Service, type the percentage of tips to recover from employees for the cost of 
processing the transaction in 'Tip refund %.' Enter the percentage as a number and two decimal 
places. For example, enter a percentage of 50% as 50.00.

20. Select Remove tip line if auto gratuity to not print a tip line on guest checks paid with this 
tender, if you add an automatic gratuity.

21. Continue to the next procedure.
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To configure the Type tab of a Givex gift card tender:

1. Select the Type tab. 

2. Under the ‘Type settings’ group bar, select Private Label as the gift card provider. Selecting a 
provider also selects 'Expiration,' which requires the entry of the expiration date when manually 
entering a credit card number.

3. Under the 'Options settings' group bar, select Use magnetic card only to prevent an employee 
from manually entering a credit card number without manager approval when applying this 
tender as payment. To override this setting for a certain employee and allow them to enter the 
number manually without manager approval, select 'Manual credit card number' for the 
appropriate access level in Maintenance > Labor > Pos Access Levels, and then assign that 
access level to the employee.

4. Clear Expiration. Givex gift cards are ‘Track 2’ only; they do not support expiration dates.
5. Select Verify signature to display a prompt reminding the employee to verify the signature on 

the card matches the signature on the gift card voucher.
6. For Quick Service, select Display tender screen on card swipe if you want the employee to 

verify the amount, or allow them to change the amount, applied to the card. If cleared, the system 
automatically sends the full amount of the transaction as soon as you slide the card across the 
reader.

7. If using select Display ID field first on tender screen to allow the Display ID field to appear 
first.

8. Click Save and continue to the next procedure. 

Figure 18  Tenders - Type Tab
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To configure the Authorization tab of a Givex gift card tender:

1. Select the Authorization tab. 

2. Under the ‘Authorization’ group bar, select Print on check to print the authorization code on the 
guest check.

3. Clear Allow force authorization on Gift Cards, as this does not apply to Givex gift cards. If 
you select this option, the system initiates a forced redemption on the gift card. EDC does not 
transmit to the EDC processor and returns a ‘Not Supported’ error message.

4. Continue to the next procedure.

Figure 19  Tenders - Authorization Tab 
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To configure the Printers tab of a Givex gift card tender:

1. Select the Printers tab.

2. Select the printer from the ‘Available’ list box and click >> to move the printer to the ‘Included’ 
list box.

3. Click Save and exit the Tenders function.

Figure 20  Tenders - Printers Tab
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Designating Givex as gift card processor
You must designate Givex as the processor for private label gift cards.

To designate Givex as the gift card processor: 

1. Select Maintenance > Electronic Draft Capture > Cards. 

2. Under the ‘Gift Cards’ group bar, select Independent, from the ‘Private’ drop-down list.
3. Select Givex from the ‘Private independent processor drop-down list.
4. Click Save and exit the Cards function. 

Adding Givex gift card buttons to the FOH
This section details how to configure Givex buttons to display on the Front-of-House (FOH); it includes 
both Quick Service and Table Service instructions. 

Selling Givex Gift Cards in Quick Service

Create buttons and add them to the FOH for selling. For this section, you will use the gift card items 
that you created in Maintenance > Menu > Items.

To add a predefined amount gift card button for activation in QS:

1. Select Maintenance > Screen Designer > Quick Service Screen Designer.
2. Select Work with Panels.

Figure 21  Cards Function - Gift Cards Group Bar
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3. Select Panel > Open Panel, select the panel containing your retail items, or a similar panel, and 
click OK.

4. Select an available button or right-click the panel and select New Button. The Properties 
dialog box appears. 

5. Under the ‘Function’ group bar, select Order Item from the ‘Action’ drop-down list.
6. Select the predefined amount gift card item for activation you created earlier from the ‘Item’ 

drop-down list.
7. Under the ‘Appearance’ group bar, type a name for the button, such as ‘$10 Gift Card Activate.’ 

To display text on multiple lines, insert ‘\n’ without spaces for line breaks, such as ‘$10\nGift 
Card\nActivate.’

8. Configure the remaining options as you would for any other button function.
9. Select Panel > Save Panel.
10. Repeat this procedure for every predefined amount gift card for activation.
11. Select File > Exit to exit Quick Service Screen Designer. 

To add a predefined amount gift card button to add value in QS:

1. Select Maintenance > Screen Designer > Quick Service Screen Designer.
2. Select Work with Panels.
3. Select Panel > Open Panel, select the panel containing your retail items, or a similar panel, and 

click OK.

Figure 22  Predefined Amount for Activation Button
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4. Select an available button or right-click the panel and select New Button. The Properties 
dialog box appears. 

5. Under the ‘Function’ group bar, select Order Item from the ‘Action’ drop-down list.
6. Select the predefined amount gift card item to add value you created earlier from the ‘Item’ 

drop-down list.
7. Under the ‘Appearance’ group bar, type a name for the button, such as ‘$10 Gift Card Add 

Value.’ To display text on multiple lines, insert ‘\n’ without spaces for line breaks, such as 
‘$10\nGift Card\nAdd Value.’

8. Configure the remaining options as you would for any other button function.
9. Select Panel > Save Panel.
10. Repeat this procedure for every predefined amount gift card to add value.
11. Select File > Exit to exit Quick Service Screen Designer. 

To add an open amount gift card button for activation in QS:

1. Select Maintenance > Screen Designer > Quick Service Screen Designer.
2. Select Work with Panels.
3. Select Panel > Open Panel, select the panel containing your retail items, or a similar panel, and 

click OK.

Figure 23  Predefined Amount Add Value Button
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4. Select an available button or right-click the panel and select New Button. The Properties 
dialog box appears. 

5. Under the ‘Function’ group bar, select Order Item from the ‘Action’ drop-down list.
6. Select the open amount gift card item for activation you created earlier from the ‘Item’ 

drop-down list.
7. Under the ‘Appearance’ group bar, type a name for the button, such as ‘Open Amount Gift Card 

Activate.’ To display text on multiple lines, insert ‘\n’ without spaces for line breaks, such as 
‘Open Amt\nGift Card\nActivate.’ 

8. Configure the remaining options as you would for any other button function.
9. Select Panel > Save Panel.
10. Repeat this procedure for every open amount gift card to activate.
11. Select File> Exit to exit the Quick Service Screen Designer.

To add an open amount gift card button to add value in QS:

1. Select Maintenance > Screen Designer > Quick Service Screen Designer.
2. Select Work with Panels.
3. Select Panel > Open Panel, select the panel containing your retail items, or a similar panel, and 

click OK.

Figure 24  Open Amount Activation Button
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4. Select an available button or right-click the panel and select New Button. The Properties 
dialog box appears. 

5. Under the ‘Function’ group bar, select Order Item from the ‘Action’ drop-down list.
6. Select the open amount gift card item to add value you created earlier from the ‘Item’ 

drop-down list.
7. Under the ‘Appearance’ group bar, type a name for the button, such as ‘Open Amount Gift Card 

Activate.’ To display text on multiple lines, insert ‘\n’ without spaces for line breaks, such as 
‘Open Amt\nGift Card\nAdd Value.’

8. Configure the remaining options as you would for any other button function.
9. Select Panel > Save Panel.
10. Repeat this procedure for every open amount gift card to add value.
11. Select File> Exit to exit the Quick Service Screen Designer.

Redeeming Givex gift cards in QS
Create buttons and add them to the FOH for redemption. For this section, you will use tenders that 
you created in Maintenance > Payments > Tenders.

To add a Givex gift card redemption button in QS:

1. Select Maintenance > Screen Designer > Quick Service Screen Designer.
2. Select Work with Panels.
3. Select Panel > Open Panel, select the panel containing your tenders, and click OK.

Figure 25  Open Amount Add Value Button
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4. Select an available button or right-click the panel and select New Button. The Properties 
dialog box appears. 

5. Under the ‘Function’ group bar, select Tender from the ‘Action’ drop-down list.
6. Select Givex from the ‘Tender’ drop-down list.
7. Select True to allow the cash drawer to open or False to keep the cash drawer closed upon 

tender from the ‘Open Drawer’ drop-down list.
8. Under the ‘Appearance’ group bar, type a name for the button, such as ‘Givex Gift Card.’ To 

display text on multiple lines, insert ‘\n’ without spaces for line breaks, such as ‘Givex\nGift 
Card.’

9. Select Panel > Save Panel.
10. Select File> Exit to exit the Quick Service Screen Designer.

Figure 26  Redeeming Givex 
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Selling Givex gift cards in TS
Create buttons and add them to the FOH for selling. For this section, you will use the gift card items 
that you created in Maintenance > Menu > Items.

To add a predefined amount gift card button for activation in TS:

1. Select Maintenance > Menu > Submenus.
2. Select the submenu to contain the gift card item, such as ‘Retail.’ 
3. Click an available position. 

4. Under the ‘Item and pricing’ group bar, select Item Button from the ‘Type’ drop-down list.
5. Select the predefined amount gift card item for activation that you created earlier from the 

‘Item’ drop-down list.
6. Select Item price from the ‘Price method’ drop-down list.
7. Continue to the next procedure.

Figure 27  Predefined Amount Activate 
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To add a predefined amount gift card button to add value in TS:

1. While still in the Submenus function, click the an available position. 

2. Under the ‘Item and pricing’ group bar, select Item Button from the ‘Type’ drop-down list.
3. Select the predefined amount gift card item to add value that you created earlier from the 

‘Item’ drop-down list.
4. Select Item price from the ‘Price method’ drop-down list.
5. Continue to the next procedure.

Figure 28  Predefined Amount Add Value 
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To add an open amount gift card button for activation in TS:

1. While still in the Submenus function, click the an available position. 

2. Under the ‘Item and pricing’ group bar, select Item Button from the ‘Type’ drop-down list.
3. Select the open amount gift card item for activation that you created earlier from the ‘Item’ 

drop-down list.
4. Select Item price from the ‘Price method’ drop-down list.
5. Continue to the next procedure.

Figure 29  Open Amount Activate 
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To add an open amount gift card button to add value in TS:

1. While still in the Submenus function, click the an available position. 

2. Under the ‘Item and pricing’ group bar, select Item Button from the ‘Type’ drop-down list.
3. Select the open amount gift card item to add value that you created earlier from the ‘Item’ 

drop-down list.
4. Select Item price from the ‘Price method’ drop-down list.
5. Click Save and exit the Submenus function. 

Redeeming Givex gift cards in TS
When you created the Givex gift card tender in Maintenance > Payments > Tenders, you designated 
a button to display in the first available button position, or selected an available position on the 
Tender screen. Refer to “Configure a tender for applying a payment with a gift card” on page 24 for 
more information. 

Figure 30  Open Amount Add Value 



 Givex Gift Cards
Configuring Givex gift cards

40

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Supporting gift card activation and query by bar code scan
You can use a bar code scanner to scan a gift card for redemptions. To increase your 
speed-of-service, you can also use a bar code scanner to activate, add value to, and query the 
balance of, a gift card. Additionally, you can perform a refund using a bar code scanner for Givex 
gift cards. 

Allowing a guest to cash out a Givex gift card
In many states, you must allow a guest to receive the remaining funds on a gift card in the form of 
immediate cash out. You can configure your Givex processor to allow a guest to cash out their Givex 
gift card, upon request. This feature allows you to return the remaining card balance to the guest 
without opening a guest check, as long as the amount falls within regional restrictions. You can also 
control who can perform the cash out function. The Givex cash out information appears on the Audit 
Report, as well as the Employee Checkout report, the Drawer Paid Out report, the Drawer Payments 
report, and the Server Sales report. 

Note
There is no configuration needed for this enhancement

Note
Regional laws limit the amount of cash out a guest can receive back from a Givex gift card. There is 
no configuration required for this limitation; the Givex processor handles the regional laws limiting 
how much cash is approved for cash back on a gift card.
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Configuring Givex cash out
To configure the Givex cash out feature, you must provide an appropriate employee with the 
appropriate access level, create a ‘Gift card cash out’ petty cash account, and a ‘Gift card cash out’ 
button. 

To provide the ability to cash out a Givex gift card: 

1. Select Maintenance > Labor > Pos Access Levels.
2. Select the access level to which you want to allow the ability to cash out a Givex gift card. 

3. Under the ‘Financial’ group bar, select Enable cash out from gift card to allow employees 
assigned to this access level to use a ‘Gift card cash out’ button to provide cash back to a guest 
requesting the balance of a gift card in the form of cash; this feature does not require an open 
guest check.

4. Click Save.
5. Repeat this procedure for each access level requiring the ability to cash out a Givex gift card. 
6. Exit the Pos Access Levels function.

To assist with employee reporting at checkout of cash given to guests requesting the balance of a 
Givex gift card in cash back, create a petty cash account specific to Givex cash out. The button you 
create to provide the cash back ties back to this petty cash account.

Figure 31  Pos Access Level - Financial Group Bar 
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To create a petty cash account specifically for providing cash back on Givex gift cards:

1. Select Maintenance > System Settings > Petty Cash Account.
2. Click the New drop-down arrow, select Paid out from the ‘Type’ list box, and click OK.
3. Accept the system assigned number or click the ellipsis (...) next to ‘Number’ to display the 

Number Assignment dialog box, from which you can choose an alternate number. 

4. Type a name, such as ‘Givex Cash Out,’ for the petty cash account.
5. Configure the remaining options as you would for any other petty cash account.
6. Click Save and exit the Petty Cash Account function.

Create a Givex Cash Out button to provide a means for contacting the Givex processor to obtain the 
remaining balance on a gift card when a guest requests the balance back as cash out.

To add a Givex Cash Out button:

1. Select Maintenance > Screen Designer > Quick Service Screen Designer or Table 
Service Screen Designer.

2. Select Work with Panels. 
3. Select Panel > Open Panel.
4. If using Quick Service, select a panel of your choosing and click OK. 
5. If using Table Service, you must select a floor plan panel to edit, and click OK.

Figure 32  Givex Cash Out Petty Cash Account
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6. Select an available button or create a new button. The Properties dialog box appears. 

7. Under the ‘Function’ group bar, select Gift Card Cash Out from the ‘Action’ drop-down list.
8. Select Private Label from the ‘Processors’ drop-down list.
9. Select the petty cash account created specifically for Givex from the ‘Petty Cash Account’ 

drop-down list.
10. Under the ‘Appearance’ group bar, type a name for the button, such as ‘Givex\nCash\nOut;’ to 

display text on multiple lines, insert ‘\n’ without spaces for line breaks.
11. Configure the remaining options as you would for any other button.
12. Select Panel > Save All Panels.
13. Exit the Screen Designer function. 

Figure 33  Givex Cash Out Button
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Refreshing the data
Once you configure the necessary features for Givex, you must refresh the Aloha POS system, then 
stop, and restart EDC Service (EDCSvr). Select Utilities > POS > Refresh POS & All Installed Products 
to transfer the new information to the FOH terminals, or wait for the End-of-Day (EOD) process to 
accomplish the data refresh for you. Note: If you run the refresh prior to the EOD process, select 
‘Automatically restart all Aloha POS terminals’ and click OK to continue. After the data refresh is 
complete, all new settings become operational across the Aloha network. 

Go to Windows Services, select EDC Service to stop and then restart.

To stop POS processing in Aloha EDC:

1. Navigate and log in to Aloha EDC.
2. Select File > Stop POS Status Processing, or click the On toggle button to end the POS Status 

Processing. Note: Do not skip this step as it is necessary when making changes to Aloha EDC.
3. After the Aloha EDC has stopped, select File > Start POS Status Processing, or click the Off 

toggle button to restart the POS Status Processing. 

Caution
Refresh data with caution and never during peak hours of operation. All FOH terminals reboot 
during a refresh and are down for a short period of time.



 Givex Gift Cards
Using Givex gift cards

45

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Using Givex gift cards
You must use a gift card tender to accept a gift card as a form of payment for goods sold. You can 
add a tip to the payment only if the tender is set up as ‘tippable.’ 

If you are required to enter the gift card using a magnetic card reader, and the card is unreadable, 
someone with sufficient access must enter the card manually. 

Redeeming Givex gift cards
1. Enter items as usual.

Important
Givex does not allow offline transactions.

Figure 34  Tender Screen 
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2. Navigate to the Tenders screen containing Givex. 

3. Touch Givex. The Givex screen appears.

Figure 35  Tender Screen 
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4. To accept the amount, touch OK.
5. Enter a tip, if applicable.
6. Touch OK.
7. Enter the Givex gift card number, and touch OK. 

Figure 36  Givex Redemption Screen
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8. Close the check. 

Cashing out a Givex gift card
1. A guest hands you a Givex gift card, requesting the remaining balance of the gift card in cash 

back. 
2. Locate and touch the Givex Cash Out button. If your access level allows you to perform this 

function, the Please Enter Card screen appears; otherwise, the manager approval screen 
appears. 

3. Slide the gift card through the magnetic stripe reader or manually enter the gift card number 
and touch OK. The system sends a request to the Givex processor, which then provides the 
available cash back amount, or displays an error message if the amount is outside the regional 
restrictions.

4. If the balance remaining is within the regional restrictions, note the amount, touch the message 
to dismiss it, and hand an amount equal to the balance of the gift card to the guest.

Figure 37  Processing Givex Gift Card
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Activating a Givex gift card
1. Navigate to the screen where the Givex activation button exists.
2. Touch Givex Activate. An Open Item screen appears. 
3. Enter the amount and touch OK. The Givex Activate screen appears with the activation amount 

auto-populating. 

4. Slide the Givex gift card. The card is now activated. Depending upon the configuration, the 
system returns you to the WWT or main menu screen. 

Adding value to a Givex gift card
1. Navigate to the screen where the Givex add value button exists.
2. Touch Givex Add Value. An Open Item screen appears. 

Figure 38  Givex Activate Screen
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3. Enter the amount and touch OK. The Givex Add Value/Activate screen appears with the 
activation amount auto-populating. 

4. Slide the Givex gift card. The card has value added. Depending upon the configuration, the 
system returns you to the WWT or main menu screen.

Figure 39  Givex Activate Screen
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Determining the balance of a Givex gift card
Navigate to the screen where the Givex Balance button exists.

1. Touch Givex Balance. The Givex Balance Check screen appears. 

2. Slide the Givex gift card or manually enter the card number and then touch OK. The Aloha 
Givex Details screen appears. 

3. Provide the information to the guest and then touch OK to close the Aloha Givex dialog box.

Figure 40  Givex Balance Screen 

Figure 41  Aloha Givex Details Screen 
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Reporting Givex gift cards
Givex is available on the following reports: Payment Detail and Audit. See below for examples. 

Figure 42  Payment Detail Report Example

Figure 43  Audit Report Example
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Troubleshooting Givex gift cards
The following are helpful hints and troubleshooting tips for Givex gift cards.

If you have issues with Givex, check the GCM.log. 

If this error message appears, there is an issue with the Givex configuration. Touch to dismiss error 
message. 

If this error message appears, you must configure Givex as the gift card provider.

Figure 44  Gift Card Processor Not Responding

Figure 45  Processor Not Configured
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