
 

1

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Contents
About Global Payments ............................................................................................ 4
Configuring Global Payments ..................................................................................... 6

Preparing the Aloha POS system ............................................................................... 6
Configuring Aloha Payment solutions ...................................................................... 24
Configuring the Ingenico Desk/5000 payment terminal .............................................. 31
Using Global Payments .......................................................................................... 33

Troubleshooting Global Payments ............................................................................ 40

Feature Focus Guide:
Global Payments 

Core Product: Aloha Table Service, Aloha Quick Service, Aloha Payment Solutions
Last Updated: June 13, 2024



 Global Payments
Copyright and Trademark Information

2

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Copyright and Trademark Information
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instances, photographs are of equipment prototypes; therefore, before using this document, consult with your 
NCR Voyix representative or NCR Voyix office for the most current information.
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About Global Payments

Global Payments, a worldwide leader in payments technology and software solutions, is a payment 
solution that utilizes Aloha Payment Solutions (APS) to communicate with and pass electronic payment 
data to and from the Aloha Point-of-Sale (POS) system. This solution supports credit, debit, and gift 
card transaction types. Use this document to configure the Aloha POS system and APS with Global 
Payments.

Supported payment terminals 

Currently, the Global Payments solution supports only the Ingenico Desk/5000 payment terminal.  

Software requirements 

Following are the general prerequisites for installation and usage on Back-of-House (BOH) site 
controllers and Front-of-House (FOH) terminals. It is possible that a specific plug-in might have slightly 
different prerequisites listed in its installation document, in which case the prerequisites in the 
installation document have priority over this list.  

Global Payments at a Glance

Core Product Aloha® Quick Service, NCR Aloha Table Service, NCR Aloha 
Payment Gateway

Complementary Products

Separate License Required? Yes. Credit card + MX. Gift Card + MX, if using the Gift Card 
feature.

Other References Aloha Quick Service Reference Guide, Aloha Table Service 
Reference Guide

GENERAL PREREQUISITES BOH FOH

Windows 10 or Windows 10 POS Ready YES YES

Aloha POS v12.3, v15.1 or later YES YES

APS v18.7 or later

ATG v17.8 or later 

Microsoft .NET Framework 3.5 installed with latest service packs YES YES

* TLS support for .NET 3.5.1 on Windows 10 
(http://support.microsoft.com/kb/3154518)

YES YES

Microsoft .NET Framework 4.0 installed with latest service packs YES YES

Microsoft C++ 2008 redistributable installed with latest service packs YES YES

Microsoft Web Services Enhancement (WSE) 3.0
Available at http://www.microsoft.com/download/en/details.aspx?id=14089

YES NO
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Supported transactions

APS and Global Payments support credit and debit cards.  

Additionally, guests can redeem and reload gift cards.

Microsoft SQL Server 2005 or later (details at http://support.microsoft.com/kb/889615)
Requires installation in mixed mode with SQL Server Browser enabled

YES NO

Compatible version of Aloha Transaction Gateway (ATG) YES NO

Credit Card + MX (EDC) must be enabled on the HASP license key, and Gift Card + MX, 
if using the Gift Card feature. 

YES YES

TRANSACTION CREDIT CARD DEBIT CARD

Sale/Purchase X X

Pre-Authorization X

Increase Authorization X

Completion X X

Refund X X

Void Sale X X

Void Refund Sale X X

Batch Settlement
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Configuring Global Payments 
The Global Payments solution leverage Aloha Payment Solutions to support the passing of payment 
information between the Aloha POS and Global Payments.

Preparing the Aloha POS system
This section discusses the configuration requirements for the Aloha POS system to use the Global 
Payments solution. If you are an experienced user, refer to Procedures at a Glance for abbreviated 
steps. If you prefer more detail, continue reading this document. 

Aloha POS Procedures at a Glance:

If you are viewing this document using Adobe Acrobat Reader, click each link for detailed information 
regarding the task. 

1. Access Maintenance > Business > Additional Features if using Aloha Manager, or Maintenance 
> Business > Corporate Administration if using Aloha Configuration Center, to expose all options 
that relate to gift cards. See page 7.

2. Access Maintenance > Business > Store > Store Settings tab.
Select the Gift card/Certificate sales group to designate a gift card provider. See page 7.
Select the Credit Card group to enable Aloha Payment Solutions (See page 8) and configure 
pre-authorization amounts for credit cards (See page 9).

3. Access Maintenance > Menu > Items to create gift card items for:
● Selling a predetermined value gift card. See page 10.
● Adding a predetermined value to a gift card. See page 12.
● Selling an open amount gift card. See page 14.
● Adding an open amount value to a gift card. See page 15. 

4. Access Maintenance > Menu > Submenus to add gift card items to a Table Service submenu. See 
page 16. 
-OR-
Access Maintenance > Screen Designer > Quick Service Screen Designer to add gift card 
items to a menu panel in Quick Service. See page 17.

5. Access Maintenance > Payments > Tenders to create an APS tender for electronic payment 
processing. See page 19.
For QS only, access Maintenance > Screen Designer > Quick Service Screen Designer to add 
the credit card tender button to the FOH. See page 21.

6. Access Maintenance > Payments > Tenders to create a pre-authorization button to appear on the 
Close screen (TS only - Optional). See page 22.

7. Select Utilities > Refresh POS & All Products to refresh the data. See page 23.
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Exposing gift card options
You must expose all options in the user interface related to gift cards, if you plan to use gift cards with 
Global Payments.  

1. Select Maintenance > Business > Additional Features if you are using Aloha Manager.
-OR-
Select Maintenance > Business > Corporate Administration if you are using Aloha 
Configuration Center. 

2. Select Display gift card to expose all options that relate to gift cards.
3. Click Save and exit Additional Features. 
4. Log out of the CFC/Aloha Manager and then log in again to see the new options. 

Designating a gift card provider
You must designate the provider of the gift card program to implement at your restaurant, in this 
case, Stored Value Systems. 

To configure a gift card provider:

1. Select Maintenance > Business > Store.
2. Select the Store Settings tab. 
3. Select the Gift Card/Certificates Sales group located at the bottom of the screen.

Figure 1  Display Gift Card
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4. Under the ‘Gift sales’ group bar, select Stored Value Systems from the ‘Gift card/certificate 
provider’ drop-down list.

5. Click Save and exit the Store function. 

Enabling APS
To enable the Aloha Payment Solutions to pass electronic payment information between the Aloha 
POS system and Global Payments, you must first enable Electronic Draft Capture (EDC) and Chip N 
PIN functionality. 

1. Select Maintenance > Business > Store.
2. Select the Store Settings tab.
3. Select the Credit Card group located at the bottom of the screen.

Figure 2  Gift Card/Certificate Sales Group
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4. Under the ‘EDC Setup’ group bar, select Enable Electronic Draft Capture.
5. Select Use Aloha EDC.
6. Select Use Chip N Pin to enable the Chip and PIN functionality.
7. Continue to the next procedure.

Configuring pre-authorization amount
The POS system does not ask for amount on pre-authorization. You configure these amounts in 
CFC/Aloha Manager.

To configure pre-authorization amounts:

1. While still in Maintenance > Business > Store > Store Settings tab > Credit Card group, under 
the ‘Authorization’ group bar, type an amount, such as ‘50.00,’ for ‘Initial pre-authorization 
amount.’

Figure 3  Store Settings - Credit Card Group
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2. Type an amount, such as ‘25.00,’ for ‘Subsequent pre-authorization amount.’
3. Type an amount, such as ‘15.00,’ for ‘Threshold for subsequent pre-authorization.’
4. Click Save and exit the Store function.
5. Continue to the next procedure. 

Creating gift card items for selling
As with everything you sell in the Aloha system, you must create an item to add to the guest check 
when a guest wishes to purchase a gift card. The type of gift cards you sell determines the 
configuration required for the item. For example, if you sell gift cards with a predetermined amount, 
such as $20.00, $30.00, and $50.00, create an item for each denomination. If you sell open value 
gift cards that allow the customer to designate the value of the gift card, you only have to create one 
item and then enter the value at the time you sell the gift card. You also need to create an item for 
adding value to an existing gift card already in use.

To create an item for selling a predetermined value gift card:

1. Select Maintenance > Menu > Items.
2. Click the New drop-down arrow, select Gift card from the ‘Type’ list box, and click OK. 

Figure 4  Authorization Group Bar
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3. Accept the system assigned number or click the ellipsis button (...) next to ‘Number’ to 
display the Number Assignment dialog box, from which you can choose an alternate number.

4. Type a name, such as ‘$10 Gift Card.’ 
5. Select Activate card as the ‘Gift card action.’
6. Under the ‘Assignments’ group bar, select the appropriate tax group. 

7. Select Retail from the ‘Sales/retail category’ drop-down list.
8. Configure the remaining options for the gift card, as necessary.

Figure 5  Items - Item Tab 

Note
You must attach a tax record to all items. Generally, gift cards are not taxable items; therefore, 
select a tax record without a tax percentage. You may need to create a ‘no tax’ tax group, if one 
does not already exist. 
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9. Select the Pricing tab. 

10. Select Item Price as the ‘Pricing method.’
11. Type the predetermined amount to designate for this gift card item, such as 10.00, in ‘Default 

price.’
12. Click Save.
13. Repeat this procedure if you need to create additional gift cards with other predetermined 

values.
14. Exit the Items function or continue to the next procedure.

To create an item for adding a predetermined value to a gift card: 

1. Select Maintenance > Menu > Items.
2. Click the New drop-down arrow, select Gift card from the ‘Type’ list box, and click OK. 

Figure 6  Items - Pricing Tab 

Figure 7  Item Tab - Add Value
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3. Accept the system assigned number or click the ellipsis button (...) next to ‘Number’ to 
display the Number Assignment dialog box, from which you can choose an alternate number.

4. Type a name, such as ‘$10 GC Add.’
5. Select Add value as the ‘Gift card action.’
6. Under the ‘Assignments’ group bar, select the appropriate tax group. 

7. Select Retail from the ‘Sales/retail category’ drop-down list.
8. Configure the remaining options for the gift card, as necessary.
9. Select the Pricing tab. 

10. Select Item Price as the ‘Pricing method.’
11. Type the predetermined amount to designate for this gift card item, such as 10.00, in ‘Default 

price.’
12. Click Save.
13. Repeat this procedure if you need to create additional items for adding other predetermined 

values. 
14. Exit the Items function or continue to the next procedure.

Note
You must attach a tax record to all items. Generally, gift cards are not taxable items; therefore, 
select a tax record without a tax percentage. You may need to create a ‘no tax’ tax group, if one 
does not already exist. 

Figure 8  Pricing Tab - Add Value
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To create an item for selling an open value gift card:

1. Select Maintenance > Menu > Items.
2. Click the New drop-down arrow, select Gift card from the ‘Type’ list box, and click OK. 

3. Accept the system assigned number or click the ellipsis (...) next to ‘Number’ to display the 
Number Assignment dialog box, from which you can choose an alternate number.

4. Type a name, such as ‘Gift Card.’
5. Select Activate card as the ‘Gift card action.’
6. Under the ‘Assignments’ group bar, select the appropriate tax group. 

7. Select Retail from the ‘Sales/retail category’ drop-down list.
8. Configure the remaining options, as necessary.

Figure 9  Item Tab - Open Amount 

Note
You must attach a tax record to all items. Generally, gift cards are not taxable items; therefore, 
select a tax record without a tax percentage. You may need to create a ‘no tax’ tax group, if one 
does not already exist. 
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9. Select the Pricing tab. 

10. Select Ask for Price as the pricing method.
11. Click Save and exit the Items function or continue to the next procedure.

To create an item for adding an open value to a gift card:

1. Select Maintenance > Menu > Items.
2. Click the New drop-down arrow, select Gift card from the ‘Type’ list box, and click OK. 

3. Accept the system assigned number or click the ellipsis (...) next to ‘Number’ to display the 
Number Assignment dialog box, from which you can choose an alternate number.

4. Type a name, such as ‘Gift Card ADD.’
5. Select Add value as the ‘Gift card action.’

Figure 10  Pricing Tab - Open Amount - Ask for Price

Figure 11  Item Tab - Open Amount - Add Value
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6. Under the ‘Assignments’ group bar, select the appropriate tax group. 

7. Select Retail from the ‘Sales/retail category’ drop-down list.
8. Configure the remaining options, as necessary.
9. Select the Pricing tab. 

10. Select Ask for Price as the pricing method.
11. Click Save and exit the Items function.

Adding gift card items to FOH for selling
After you create the necessary gift card items, you must add a button to the Front-of-House for each 
gift card item you create to allow you to sell and add gift card items to a guest check. For example, if 
you create an open value gift card item and allow guests to add value to an existing gift card, you 
need to add two buttons to the FOH, one for each item. The procedure to do this is different based 
on whether you use Table Service or Quick Service. For Table Service, you add a button for each 
item to a submenu; for Quick Service, you add a button for each item to a panel containing menu 
items.

To add gift card items to a Table Service submenu:

1. Select Maintenance > Menu > Submenus.
2. Select a submenu on which to add the gift card items from the ‘Submenus’ drop-down list. For 

example, ‘Retail.’
3. Select the Layout tab.

Note
You must attach a tax record to all items. Generally, gift cards are not taxable items; therefore, 
select a tax record without a tax percentage. You may need to create a ‘no tax’ tax group, if one 
does not already exist. 

Figure 12  Pricing Tab - Open Amount - Ask for Price
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4. Double-click an available position.
5. Under the ‘Item and pricing’ group bar, select Item Button from the ‘Type’ drop-down list.
6. Select the gift card, such as ‘$10 Gift Card,’ from the ‘Item’ drop-down list.
7. Leave Item price selected in ‘Price method.’
8. Click Save.
9. Repeat this procedure until you add all necessary gift card items, including the ‘Add Value’ gift 

card item.
10. Exit the Submenus function.

To add gift card items to a menu panel in Quick Service:

1. Select Maintenance > Screen Designer > Quick Service Screen Designer.
2. Select Work with Panels.
3. Select Panel > Open Panel and select a panel onto which to add the gift card buttons and click 

OK.

Figure 13  Submenus - Layout Tab
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4. Select Panel > New Button. The Properties dialog box appears.
5. Under the ‘Function’ group bar, select Order Item from the ‘Action’ drop-down list.
6. Select a gift card item from the ‘Item’ drop-down list. The name of the item appears on the 

button.
7. Under the ‘Appearance’ group bar, type a name for the button, such as ‘$10 Gift Card.’ To 

display text on multiple lines, insert ‘\n’ without spaces for line breaks, such as ‘$10\nGift Card.’ 
8. Configure the remaining options as you would for any other button.
9. Click Save.
10. Repeat this procedure until you add all necessary gift card items, including the Add Value gift 

card item. 
11. Exit the Screen Designer function.

Figure 14  Quick Service Screen Designer
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Creating credit card tenders for electronic payment processing
When using Aloha Payment Solutions to pass electronic payment data to and from the Aloha POS 
system, you need to set up a credit card tender for use when processing payment at the POS 
terminal. In Table Service, it is not necessary to use Screen Designer to add a tender button to the 
FOH, as this screen is hard-coded and selecting a button position takes care of this for you; however, 
if you are using Quick Service, you must add a button to a panel containing your tenders.

To create a credit card tender for electronic payment processing:

1. Select Maintenance > Payments > Tenders.
2. Click the New drop-down arrow, select Credit card from the ‘Type’ list box, and click OK.
3. Under the ‘Settings’ group bar, accept the system assigned number or click the ellipsis (...) 

next to ‘Number’ to display the Number Assignment dialog box, from which you can choose an 
alternate number. 

4. Type a name for the tender, such as ‘GP CC.’ 
5. For Table Service, select First available button position to allow the system to place the tender 

button in the first available position of the FOH Tender screen.
-OR-

Figure 15  Tenders - Tender Tab
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Click the ellipsis (...) to display the Button Position dialog box and select an available position for 
the tender. 

6. Select the tender under which you want the credit card tender to report, if you do not want it to 
report as itself, from the ‘Report as’ drop-down list.
-OR-
Leave the default value of Current in ‘Report as.’

7. Select Ask for amount from the ‘Default amount behavior’ drop-down list.
8. Select Active to make the tender available for use. If not active, an error message appears in the 

FOH when you select this tender for payment.
9. Select Print check on close to print a copy of the guest check when you close a check using this 

tender.
10. Under the 'Tips' group bar, select Allow tips to allow guests to add a tip to the guest check.
11. Enter the maximum allowable tip percentage in 'Maximum tip %.' Enter the percentage as a 

number and two decimal places. For example, enter a percentage of 50% as 50.00.
12. Select the Type tab. 

13. Select Not Applicable from the ‘Credit card provider’ drop-down list.
14. Select the Authorization tab.

Note
In Table Service, it is not necessary to use Screen Designer to add a tender button to the FOH, 
as this screen is hard-coded and selecting a button position takes care of this for you; however, 
for Quick Service, you must add a button to a panel containing your tenders.

Figure 16  Tenders - Type Tab
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15. Select Require authorization to display additional options.
16. Select Authorize using EDC. (Required)
17. Configure the remaining options in the usual manner.
18. Click Save and exit the Tenders function. 

Adding the GP CC credit card button to a panel (QS only)
In Quick Service environments, you must configure the credit card button to appear on the Tender 
screen. We recommend you script the button to chain back to an open check.

1. Select Maintenance > Screen Designer > Quick Service Screen Designer.
2. Select Work with Panels.
3. Select Panel > Open Panel, select a panel containing your tenders, and click OK. 
4. Select an available button or right-click the panel and select New Button. The Properties 

dialog box appears. 

5. Under the ‘Function’ group bar, select Tender from the ‘Action’ drop-down list.
6. Select the credit card tender created for Global Payments from the ‘Tender’ drop-down list. 
7. Select True from the ‘Open Drawer’ drop-down list, if necessary.
8. Under the ‘Appearance’ group bar, type a name for the button, such as ‘GP CC.’ To display text 

on multiple lines, insert ‘\n’ without spaces for line breaks, such as ‘GP\nCC.’
9. Configure the remaining options as you would for any other button function.
10. Select Panel > Save Panel.
11. Select File > Exit to exit Quick Service Screen Designer.

Figure 17  Properties Dialog Box
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Adding a pre-authorization button to the close screen (TS only, optional) 
In Table Service environments, you can configure a pre-authorization button to appear on the ‘Close’ 
screen. If a bartender uses the pre-authorization button to begin a check, the ‘Close pre-auth’ button 
must be used to close the transaction.

To add a pre-authorization button to the Close screen:

1. Select Maintenance > Payments > Tenders.
2. Click the New drop-down arrow, select Credit card from the ‘Type’ list box, and click OK. 

3. Under the ‘Settings’ group bar, type a name to identify the tender, such as ‘GP PreAuth.’
4. Select Active to make the tender available for use. 
5. Leave the First available button position and Button position options cleared. If you select 

either choice, the tender acts as authorization and not as a pre-authorization.
6. Select the Type tab.

Figure 18  Tenders - Tender Tab
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7. Select Not Applicable from the ‘Credit card provider’ drop-down list.
8. Select the Authorization tab. 

9. Under the ‘Authorization’ group bar, select Require authorization.
10. Select Authorize using EDC to electronically return an authorization code.
11. Select Allow pre-auth with EDC to electronically return an authorization code for 

pre-authorizations.
12. Click Save and exit the Tenders function. 

Refreshing data
After all settings are in place in Aloha Manager, it is necessary to select Utilities > POS > Refresh All 
POS Data to transfer the new information to the FOH terminals, or wait for the End-of-Day (EOD) 
process to accomplish the data refresh for you. If you run the refresh prior to the EOD process, select 

Figure 19  Tenders - Type Tab

Figure 20  Tenders - Authorization Tab
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‘Automatically restart all POS terminals’ and click OK to continue. After the data refresh is complete, 
all new settings become operational across the Aloha network.

Configuring Aloha Payment solutions
This section details the configuration requirements for Aloha Payment Solutions (APS). If you are an 
experienced user, refer to Procedures at a Glance for abbreviated steps. If you prefer more detail, 
continue reading this document. 

Install and configure the Aloha Payment solutions
Downloading and installing the Aloha Payment Solutions is a multi-step process. Begin by using the 
Radiant Update website to download APS, and then install the APS service. After installation, 
configure APS, the plug-ins, and values.

To install Aloha Payment Solutions:

1. Access Aloha Update by logging in to the Radiant Update website (randiantupdate.com). 
2. Select Download Install CD.
3. Select Aloha Payment Solutions from the ‘Application Suite’ drop-down list.
4. Select the latest version available from the ‘Major Version’ drop-down list.
5. Click Download Now and save ApsExternalApiClients_Release_x.x.zip file to a staging folder of 

your choosing.
6. Use File Explorer to browse to the staging folder. 
7. Double-click APS_Release_x.x.x.zip to open the file. 

Caution
Refresh data with caution and never during peak hours of operation. All FOH terminals reboot 
during a refresh and are down for a short period of time.

Aloha Payment Solutions Procedures at a Glance:

If you are viewing this document using Adobe Acrobat Reader, click each link for detailed information 
regarding the task. 

1. Install and configure the Aloha Payment Solutions. See page 24.

2. Configure the Global Payments plugins for APS. See page 29. 

3. Configure the Ingenico Desk/5000 payment terminal. See page 31.
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8. Double-click AlohaPaymentSolutionssetup.exe.

9. Select Use SQL database. If you clear this option, (1) you must use the same terminal where the 
payment was applied to void the payment; (2) Preauthorization, incremental authorization, and 
preauthorization completion do not work properly; and (3) APS reporting functionality is limited. 
Contact the international team for more information. 

10. Select the BOH computer name from the ‘Database Server Address’ drop-down list.
11. Click Next. The ‘Select plugin’ window appears.

Figure 21  Use SQL Database 

Note
If the server has multiple Network Interface Cards (NICs), use the server name itself in 
‘Database Server Address.’
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12. Select Global Payments.
13. Click Install. The installation status window appears. 

14. Allow the installation to complete.

Figure 22  Select Plugin 

Figure 23  Installation Wizard Window
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15. Click Close to exit the installation. 

To configure Aloha Payment Solutions:

1. Go to Start > APS > NCR APS Configuration. The APS Management screen appears.

2. Double-click Configure APS.

Figure 24  Installation Complete Window

Figure 25  APS Management Screen
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3. Under the ‘Pos Integration Mode’ group bar, select Global Payments from the ‘Default credit 
card plugin’ drop-down list. 

4. Select Global Payments from the ‘Default gift card plugin’ drop-down list. 
5. Select FohRedundancy from the ‘POS Integration Mode’ drop-down list. 
6. Click OK to return to the APS Management screen. 

Figure 26  Aloha Payment Service Configuration 
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To configure the Global Payments plugin for APS:

1. With the APS Management screen active, double-click Configure Plugins. 

The Plugin Configuration screen appears. 

2. Select GlobalPayments [ACTIVE] from the ‘Plugin’ drop-down list. The Plugin properties 
populate, including the GUID.

3. Click Configure Plugin. The ‘GlobalPayments plugin configuration’ screen appears. 

Figure 27  APS Management Screen

Figure 28  Plugin Configuration Screen 
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4. Under the ‘Payment Configuration’ group bar, select True for ‘Use Invoice Numbers.’ The 
GlobalPaymentsPedConfiguration Collection Editor screen appears. 

5. Under ‘Members,’ click Add to add a terminal.
6. Under the ‘Payment terminal’ group bar, type the IP address of the payment terminal. 
7. Type the network port of the payment terminal.

Figure 29  GlobalPayments Plugin Configuration 

Figure 30  GlobalPaymentsPedConfiguration Collection Editor
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8. Under the ‘POS terminal’ group bar, select the terminal. 
9. Repeat this procedure for each payment device to configure. 
10. Click OK.
11. Click OK and exit the APS Management function. 

Configuring the Ingenico Desk/5000 payment terminal
The Ingenico Desk/5000 payment terminal allows you to select options either by using the keypad or 
the touch screen. 

To configure the Ingenico Desk/5000 payment terminal: 

1. Press the Admin button to access configurations.
2. Touch MISC Options > semi-integrated > enable semilnteg and touch or press ON.
3. Touch MISC Options > semin-integrated > communication type and touch or press 

Ethernet. When it asks for the port, use the same port as in the APS configuration section.
4. Touch MISC Options > semi-integrated > receipt options and touch or press Terminal.
5. Go to Setup Menu.
6. Select Communications > Ethernet > Ethernet Setup and touch or press either dynamic or 

static IP, depending upon your business needs.
7. Go to Setup Menu.
8. Select Trans Options > Credit > Fraud and select how to verify the card.

Note
You must obtain the user name and password from your provider.

Figure 31  Ingenico Desk/5000 Payment Terminal
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9. Go to Setup Menu.
10. Select Trans Options > Prompts > Invoice #. This should match APS plugin configuration.
11. Go to Setup Menu.
12. Select Trans Options > Tip Options and set up your tip options.
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Using Global Payments
The Ingenico Desk/5000 payment terminal allows your guests to slide, tap or insert the chip-enabled 
card.

Sale with tip included

1. Enter a sale. The guest check amount appears on the payment terminal. 

2. The guest touches 1 using the keypad or 1-Yes/Oui on the touch screen to confirm the amount of 
the guest check. 

Figure 32  Confirm Amount

Figure 33  Enter Tip Amount
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3. Using the keypad, the guest enters a tip amount, such as $0.10.
4. The guest touches 1-Accept or the green button on the keypad to accept the sale. 

5. The guest inserts, taps, or slides the debit, credit, or gift card into the Ingenico Desk/5000 
payment terminal. 

Figure 34  Accept Sale

Figure 35  Insert, Tap, or Slide Card
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The payment terminal connects, transmits, and then receives confirmation.

The guest receipt prints from the payment terminal. 

Refunds

This section shows you how to perform a refund. The server or cashier selects Refund. 

1. The guest inserts, taps, or slides the debit, credit, or gift card into the Ingenico Desk/5000 
payment terminal.
The payment terminal connects, transmits, and then receives confirmation, and then receives an 
approval and asks for a signature from the guest.

Figure 36  Print Guest Receipt

Figure 37  Insert, Tap, or Slide Card
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2. The guest presses Enter to complete the transaction.

Sale and void

This section show you how to perform a sale and void. The guest confirms the sale, enters a tip, and 
inserts their card. 

1. While the card is still in the Ingenico Desk/5000 payment terminal, touch 1-Yes to confirm the 
void or touch 2-No to cancel the void. 
The payment terminal transmits the request, and then approves the transaction. 

Figure 38  Press Enter Screen 

Figure 39  Void Screen 
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The guest receipt prints from the payment terminal.
2. The guest signs the receipt. 

Figure 40  Signature Required Screen 
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Settlement

Use the Ingenico Desk/5000 payment terminal to settle (close) a batch and deposit funds.

1. Touch 1-Yes to close the batch and deposit funds. Touch 2-No to cancel. 

2. Touch 1-Accept to continue, or touch 2-Cancel to cancel the settlement.

Figure 41  Close Batch - Deposit Funds 

Figure 42  Information Screen
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The Ingenico Desk/5000 payment terminal connects and accepts the settlement. 

3. Touch 1-Yes to print the reports or 2-No to cancel. 

Figure 43  Connected Screen 

Figure 44  Print Reports
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Troubleshooting Global Payments
The following are helpful hints and troubleshooting tips provided for Global Payments.

SQL installation errors

If a SQL Server 2005 installation fails, you must:

1. Navigate to Add/Remove Programs in Control Panel and uninstall all SQL-related components 
that may still be there from the previous installation. 

2. When that task is complete, open and log in to the website: https://www.radiantupdate.com. 

3. Click Download Install CD on the menu. 
4. Select Aloha Payment Solutions from the ‘Application Suite’ drop-down list.
5. Select Utils from the ‘Major Version’ drop-down list.
6. Click Download Now to download and save WMIFIX.zip to a staging directory on the machine 

running SQL server.
7. Navigate to the staging directory, double-click WMIFIX.zip, and run WMIFIX.bat on the 

target computer.
8. Attempt the SQL installation again.

Figure 45  WMIFIX.zip

https://www.radiantupdate.com
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SQL not configured properly

If the SQL error ‘26’ appears during the installation of Aloha Payment Solutions (APS), it could be 
one of two issues:

1) The SQL Server Browser Service is not started. Navigate to Services in Control Panel, locate and 
select SQL Server Browser in the list and click Start the service. 

2) The network protocols are not enabled. 

a. Navigate to the Control Panel and select Admin tools > Computer Management. 
b. At the Computer Management window, select Services and Applications. 
c. Under ‘Services and Applications,’ select SQL Server Configuration Manager.
d. Select Protocols for SQLEXPRESS. 

Figure 46  SQL Server Browser

Figure 47  SQL Server Configuration Manager
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e. Configure the network protocols as shown in Figure 47.
f. Exit Computer Management. 

SQL and opened ports 

If you need to connect to a remote MSSQL server that uses a firewall, you must define the following 
exceptions in the firewall configuration:

● Allow inbound connections on TCP port 1433, which is the default port for MSSQL. You can 
change this in MSSQL config.

● Allow inbound connections on UDP port 1434.
● Add exception for the SQL Server (SQLServr.exe) program.

Locate the binary, found in the %ProgramFiles%\Microsoft SQL Server\  folder.

The UDP port 1434 is required if the APS database is implemented as a named SQL instance (which 
is usually the case for SQL Express Server.) 

Reference
Refer to http://msdn.microsoft.com/en-us/library/ms175483(v=sql.90).aspx and 
http://technet.microsoft.com/en-us/library/ms165614(v=sql.90).aspx for more details.

http://msdn.microsoft.com/en-us/library/ms175483(v=sql.90).aspx
http://msdn.microsoft.com/en-us/library/ms175483(v=sql.90).aspx
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Global Payments, Feature Focus Guide

NCR Voyix welcomes your feedback on this document. Your comments can be of great value in 
helping us improve our information products. Please contact us using the following email address: 
Documentation.HSR@NCRVoyix.com

mailto:documentation.hsr@ncrvoyix.com
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